Subject: Re: [bess] About draft-dskc-bess-bgp-car

From: "Dhananjaya Rao (dhrao)" <[email-masked]>
Date: Thu, 25 Mar 2021 17:20:07 +0000

Hi Jorge,

Thank you once again for reviewing the draft and for your feedback.

We will update the security considerations in a newer version.

The use of transposition here is to be efficient in bytes consumed in each NLRI when multiple routes have shared information such as locator. It provides flexibility to encode the common locator portion of SRv6 SIDs in the attribute. We will clarify with an example in the newer version.

Regards,
-Dhananjaya

On 3/10/21, 7:03 AM, "BESS on behalf of Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked] on behalf of [email-masked]> wrote:

    DJ, Swadesh,
    
    Thanks for your time about these two drafts during the BESS session.
    I just wanted to follow up on the two comments I made:
    
    1) About this and the security section
    
       “The indication of the key length enables BGP Speakers to determine
       the key portion of the NLRI and use it along with the NLRI Type field
       in an opaque manner for handling of unknown or unsupported NLRI
       types.  This can help Route Reflectors (RR) to propagate NLRI types
       introduced in the future in a transparent manner.”
    
    As discussed, this brings a potential security risk, since, for unknown route types, the RR only validates the key length without understanding if the content is wrong or not for the route type. I think DJ agreed this has to be discussed into the Security section (which by the way does not exist in the document in rev 01 __).

    2) About the srv6 tlv and transposition:
    
    "o  SRv6 SID Information: field of size as indicated by the length
          that either carries the SRv6 SID(s) for the advertised color-aware
          route as one of the following:
    
          *  A single 128-bit SRv6 SID or a stack of 128-bit SRv6 SIDs
    
          *  A transposed portion (refer [I-D.ietf-bess-srv6-services]) of
             the SRv6 SID that MUST be of size in multiples of one octet and
             less than 16."
    
    @Swadesh, in the srv6-services draft, transposition is used for efficient packing, which *should not* be an issue here since the srv6 tlv is part of the NLRI (at least for 1 SID). I 'suspect' the use case here is to *save* some bytes when a stack of SIDs need to be advertised with the BGP CAR route, and those SIDs have a few common bytes in the locator part? it would be good if you can clarify please.
    
    Thank you!
    Jorge
    
    _______________________________________________
    BESS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bess

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 25 Mar 2021 18:44:39 +0000

Hi DJ,

Appreciate it.

Thx
Jorge
From: Dhananjaya Rao (dhrao) <[email-masked]>
Date: Thursday, March 25, 2021 at 6:20 PM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [bess] About draft-dskc-bess-bgp-car
Hi Jorge,

Regards,
-Dhananjaya

    DJ, Swadesh,

    Thank you!
    Jorge