Subject: Re: [bess] Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

From: Qin Wu <[email-masked]>
Date: Tue, 27 Apr 2021 06:38:17 +0000

Hi, Jeffrey:
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]] 
发送时间: 2021年4月27日 4:35
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

Thank you for your review and comments. Let me share a diff to see if it addresses the issues, before I post a revision.

Please see zzh> below.

-----Original Message-----
From: Qin Wu via Datatracker <[email-masked]>
Sent: Friday, April 23, 2021 11:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

[External Email. Be cautious of content]

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu
Review result: Ready with nits

I have reviewed this document as part of the Operational directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written with the intent of improving the operational aspects of the IETF drafts. Comments that are not addressed in last call may be included in AD reviews during the IESG review.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes how to convey the RP address information into the MVPN Source Active route using an Extended Community so this information can be shared with an existing MSDP infrastructure. It provides an update to RFC6514.

Major issues:
None

Minor issues:
I am wondering how MVPN and MSDP SA Interoperation is back compatible with existing source  discovery information dissemination methods? Is there any downside to make MVPN SA and MSDP SA work together.

Zzh> There is no downside. The RFC6514 specified MSDP SA -> MVPN SA but is missing the other direction (MVPN SA -> MSDP SA), which causes lots of headache. This document is to add the missing part, as explained in introduction section.
Zzh> The only backwards compatibility issue is with a scenario further explained at the end of this message - where PE2 is a legacy PE that does not attach the EC.

[Qin]: Thank for clarification, I am little bit worried about this, with the magic policy control, we can solve all the backward compatibility issues,:-)

Section 1:
Suggest to add term for GTM, RPT, C-Multicast

Zzh> Added.

Section 3
When we say MVPN Pes that have one or more MSDP session in a VPN, does this statement contradict with “VPN-specific MSDP sessions are not required among the PEs”?

zzh> The MSDP session that the PEs have are with other non-PE MSDP speakers but not among themselves, so it does not contradict with that quoted text.

[Qin]:Without your clarification, I feel MVPN PEs will only establish MSDP session with other PEs in a VPN, rather than non-PE MSDP speakers? Can you add text to make this clear?

Section 3
What do you mean other MSDP speaker? Do we assume there is one or only one MSDP speaker in the MSDP mesh group? How MSDP speaker is different from MSDP peer?
Do you mean there is no session to be established between MSDP peer?

Zzh> MSDP sessions are established among MSDP speakers/peers. The text here means that the MVPN PEs that are running MSDP (with sessions to other non-PEs)  form a mesh group and that group does not include other MSDP peers that are not PEs.

[Qin]:Confused, the first half sentence said the MSDP session is established between PE and non-PEs, the second half sentence said the group does not include non-PE as MSDP peers? Are you saying in the second half sentence that the group only include other MSDP peers that are not PEs?

Section 3, last paragraph:
When we say ” In that case, if the selected best MVPN SA route does not have the "MVPN SA RP-address EC" but another route for the same (C-S, C-G) does, then the best route with the EC SHOULD be chosen.”, which best route is selected? Selected best MVPN SA route without EC or normal route with the EC?
It looks you assume the normal route with the EC is the best selected route as well in this context?

Zzh> The BGP selected best route may not have the EC. In that case, for MSDP interop purpose, the next best route with the EC should be used.

[Qin]: Understood, thanks for clarification.

Section 3
Can you provide an example of fine grained policy control? Is this related to local policy? “accepted MSDP SA message when receiving PE’s RP for the C-G is MSDP peer to which the generated MSDP message is advertised”

Zzh> Yes I changed it to local policy. We probably don't need examples here - just whatever MSDP policies that can be used in an MSDP deployment.
Zzh> The quoted text is part of the following description: a receiving PE1 receives an SA route from another PE2 who does not attach the EC, so PE1 uses its own local RP address (say R1) to construct that MSDP SA message and advertise to its peer. If that peer happens to be R1, the peer will reject it because PE1 used R1 in constructing the message. To prevent this rejection, R1 should configure MSDP policy to accept the message.
Zzh> Thanks!
Zzh> Jeffrey

[Qin]: I found another inconsistency issue, section 2, 3rd paragraph said:
"
   unless blocked by
   policy control, PE2 would in turn advertise MVPN SA routes because of
   those MSDP SA messages that it receives from PE1, which are redundant
   and unnecessary.
"
Section 3 said:
"
In that case, it is possible
   that receiving PE's RP for the C-G is actually the MSDP peer to which
   the generated MSDP message is advertised, causing the peer to discard
   it due to RPF failure.  To get around that problem the peer SHOULD
   use local policy to accept the MSDP SA message.
"
I am wondering whether these two places are talking about the same policy control, but one policy control is to avoid redundant message while the other is accept the MSDP SA message. Please make sure they are consistent.

Juniper Business Use Only

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 27 Apr 2021 19:18:15 +0000

Hi Qin,

Please see zzh2> below for clarifications.

-----Original Message-----
From: Qin Wu <[email-masked]>
Sent: Tuesday, April 27, 2021 2:38 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi, Jeffrey:
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2021年4月27日 4:35
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

Please see zzh> below.

-----Original Message-----
From: Qin Wu via Datatracker <[email-masked]>
Sent: Friday, April 23, 2021 11:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu

Major issues:
None

Minor issues:

[Qin]: Thank for clarification, I am little bit worried about this, with the magic policy control, we can solve all the backward compatibility issues,:-)
Zzh2> Well at this time we don't foresee other issues 😊

Section 1:

Zzh> Added.

Section 3

Zzh2> Section 1 does say the following:

   ... One or more of the
   PEs, say PE1, either act as a C-RP and learn of (C-S,C-G) via PIM
   Register messages, or have MSDP sessions with some MSDP peers and <====
   learn (C-S,C-G) via MSDP SA messages...

   [RFC6514] only specifies that a PE receiving the MVPN SA routes, say
   PE2, will advertise (C-S,C-G) C-multicast routes if it has
   corresponding (C-*,C-G) state learnt from its CE.  PE2 may also have
   MSDP sessions with other C-RPs at its site,                                                  <====

Zzh2> MVPN PEs establishing MSDP sessions with other non-PE devices is a common practice in RFC6514, so we should not need to call it again.

Section 3

[Qin]:Confused, the first half sentence said the MSDP session is established between PE and non-PEs, the second half sentence said the group does not include non-PE as MSDP peers? Are you saying in the second half sentence that the group only include other MSDP peers that are not PEs?
Zzh2> Correct. The text says that the mesh group includes PEs "that act as customer RPs or have one or more MSDP sessions" and does not "include other MSDP speakers". Those other MSDP peers are just no in the same "PE mesh group".

Section 3

[Qin]: I found another inconsistency issue, section 2, 3rd paragraph said:
"
   unless blocked by
   policy control, PE2 would in turn advertise MVPN SA routes because of
   those MSDP SA messages that it receives from PE1, which are redundant
   and unnecessary.
"
Zzh2> That policy, if exists, is on PE2.

Section 3 said:
"
Zzh2> That is on the (non-PE) peer.

Zzh2> Indeed one is for the PE to block redundant message and the other is for the non-PE peer to accept message.
Zzh2> Thanks.
Zzh2> Jeffrey