Subject: [bess] Document shepherd review of draft-ietf-bess-srv6-services-06

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thu, 1 Apr 2021 10:45:27 +0000

Authors,

I am the document shepherd for this draft. As is customary, I have reviewed the document and have some comments below.

Please treat these as you would any other working group last call comments.

In general, the draft is clear and well written – thank you.

I have a few minor comments as follows.

  *   Terminology. The document is missing a terminology section. The introduction does define some terms e.g. SRv6 based BGP services, SRv6 SID, SRv6 Service SID, etc, and I think it would make sense to split these out into a terminology section.
  *   There are numerous cases where the definite article (‘a’, ‘the’ etc) is missing. Please go through the document carefully and insert as needed.
  *   Introduction: “SRv6 Service SID refers to an SRv6 SID associated with one of the service specific behaviors…” I think you mean ‘endpoint behaviors’ per RFC8986.
  *   Please expand all acronyms on first use, particularly ones specififc to SRv6 e.g. ‘SRH’.

If you can fix these, then I will proceed with the publication process.

Thanks

Matthew

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 1 Apr 2021 12:50:58 +0000

Hi Matthew,

Thanks for your review and your comments. We’ll work on addressing them and posting the draft update.

Thanks,
Ketan (on behalf of co-authors)

From: Bocci, Matthew (Nokia - GB) <[email-masked]>
Sent: 01 April 2021 16:15
To: [email-masked]
Cc: [email-masked]
Subject: Document shepherd review of draft-ietf-bess-srv6-services-06

Authors,

Thanks

Matthew

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 12 Apr 2021 04:26:20 +0000

Hi Matthew,

Thanks for your review and your comments/feedback. We’ve just posted an update to the draft to address your comments.

https://datatracker.ietf.org/doc/html/draft-ietf-bess-srv6-services-07

We’ve also adding clarification text related to the transposition scheme in this version in response to the discussion on the list : https://mailarchive.ietf.org/arch/msg/spring/PgmzeCB7APmfv8sizbGDs6ZqcrY/

Thanks,
Ketan

Authors,

Thanks

Matthew

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 13 Apr 2021 10:32:39 +0000

Thanks Ketan

This looks fine to me. Please watch out for the shepherd’s write up and publication request in the next few days.

Matthew

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Monday, 12 April 2021 at 05:26
To: "Bocci, Matthew (Nokia - GB)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Document shepherd review of draft-ietf-bess-srv6-services-06

Hi Matthew,

Thanks,
Ketan

Authors,

Thanks

Matthew