Subject: [bess] Fwd: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt

From: Gyan Mishra <[email-masked]>
Date: Tue, 27 Apr 2021 00:25:27 -0400

Dear BESS,

I have updated the draft in revision 4 from comments during the WG Adoption
poll.

https://datatracker.ietf.org/doc/draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh/04/

Please review.

Thank  you

Gyan
---------- Forwarded message ---------
From: Mishra, Gyan S <[email-masked]>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: Fwd: [E] New Version Notification for
draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Hayabusanew <[email-masked]>

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: [E] New Version Notification for
draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Adam Simpson <[email-masked]>, Gyan Mishra <
[email-masked]>, Jeff Tantsura <[email-masked]>, Lili
Wang <[email-masked]>, Mankamana Mishra <[email-masked]>, Qing Yang <
[email-masked]>, Shuanglong Chen <[email-masked]>

A new version of I-D,
draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
has been successfully submitted by Gyan Mishra and posted to the
IETF repository.

Name:           draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh
Revision:       04
Title:          Deployment Guidelines for Edge Peering IPv4-NLRI with
IPv6-NH
Document date:  2021-04-26
Group:          Individual Submission
Pages:          21
URL:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04.txt&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=GplhN6pbPFCDnWAFF0tqeVZjBX1nnF-nL6H8tLNAnsM&e=
Status:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh_&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=D9OyhTMLCDz9ZQc1mYku6nCUBg3VEiBBB_vSdfKR3Iw&e=
Htmlized:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=FKPcDJ5syMhYkZ55Xrx3JbK7hHhzHGzEtOTNimEwwRk&e=
Htmlized:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=HfbldNQkr40Wa4XsQ_E9e4HD0mLu7Sidk35DT6yG5fM&e=
Diff:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=Cho5i64yzsLbzTY75c5YIA7OGt1Vo03FteXhvw1XLJA&e=

Abstract:
   As Enterprises and Service Providers upgrade their brown field or
   green field MPLS/SR core to an IPv6 transport, Multiprotocol BGP (MP-
   BGP)now plays an important role in the transition of their Provider
   (P) core network as well as Provider Edge (PE) Edge network from IPv4
   to IPv6.  Operators must be able to continue to support IPv4
   customers when both the Core and Edge networks are IPv6-Only.

   This document details an important External BGP (eBGP) PE-CE Edge
   IPv6-Only peering design that leverages the MP-BGP capability
   exchange by using IPv6 peering as pure transport, allowing both IPv4
   Network Layer Reachability Information (NLRI) and IPv6 Network Layer
   Reachability Information (NLRI)to be carried over the same (Border
   Gateway Protocol) BGP TCP session.  The design change provides the
   same Dual Stacking functionality that exists today with separate IPv4
   and IPv6 BGP sessions as we have today.  With this design change from
   a control plane perspective a single IPv6 is required for both IPv4
   and IPv6 routing updates and from a data plane forwarindg perspective
   an IPv6 address need only be configured on the PE and CE interface
   for both IPv4 and IPv6 packet forwarding.

   This document provides a much needed solution for Internet Exchange
   Point (IXP) that are facing IPv4 address depletion at large peering
   points.  With this design, IXP can now deploy PE-CE IPv6-Only eBGP
   Edge peering design to eliminate IPv4 provisioning at the Edge.  This
   core and edge IPv6-Only peering design paradigm change can apply to
   any eBGP peering, public internet or private, which can be either
   Core networks, Data Center networks, Access networks or can be any
   eBGP peering scenario.  This document provides interoperability test
   cases for the IPv6-Only peering design as well as test results
   between five major vendors stakeholders in the routing and switching
   indusrty, Cisco, Juniper, Arista, Nokia and Huawei.  With the test
   results provided for the IPv6-Only Edge peering design, the goal is
   that all other vendors around the world that have not been tested
   will begin to adopt and implement this new Best Current Practice for
   eBGP IPv6-Only Edge peering.

   As this issue with IXP IPv4 address depletion is a critical issue
   around the world, it is imperative for an immediate solution that can
   be implemented quickly.  This Best Current Practice IPv6-only eBGP
   peering design specification will help proliferate IPv6-Only
   deployments at the eBGP Edge network peering points to starting
   immediately at a minimum with operators around the world using Cisco,
   Juniper, Arista, Nokia and Huawei.  As other vendors start to
   implement this Best Current Practice, the IXP IPv4 address depletion
   gap will eventually be eliminated.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect, SME & Protocol Design Expert*

*Data Center Planning | Common Core | Development & Engineering Lab
ServicesGlobal Technology Services | ITNUC*

*O 240 970-6287M 301 502-134713101 Columbia Pike Rm 304-D*Silver Spring, MD
20904

*IETF  & ISOC Member since 2015*

https://www.ietf.org/

https://www.internetsociety.org/

-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 27 Apr 2021 09:24:30 +0000

Authors

Please can you make sure you have all responded to the IPR poll on the BESS list for this draft? I think I am still missing responses from a couple of you.

Thanks

Matthew

From: Gyan Mishra <[email-masked]>
Date: Tuesday, 27 April 2021 at 07:23
To: BESS <[email-masked]>, "[email-masked]" <[email-masked]>, Mankamana Misra <[email-masked]>, Jeff Tantsura <[email-masked]>, Lili Wang <[email-masked]>, Chenshuanglong <[email-masked]>, "Simpson, Adam 1. (Nokia - US/Mountain View)" <[email-masked]>, Qing Yang <[email-masked]>, "[email-masked]" <[email-masked]>, "Bocci, Matthew (Nokia - GB)" <[email-masked]>, Stephane Litkowski <[email-masked]>
Subject: Fwd: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt

Dear BESS,

I have updated the draft in revision 4 from comments during the WG Adoption poll.

Please review.

Thank  you

Gyan
---------- Forwarded message ---------
From: Mishra, Gyan S <[email-masked]<mailto:[email-masked]>>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: Fwd: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Hayabusanew <[email-masked]<mailto:[email-masked]>>

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Adam Simpson <[email-masked]<mailto:[email-masked]>>, Gyan Mishra <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Lili Wang <[email-masked]<mailto:[email-masked]>>, Mankamana Mishra <[email-masked]<mailto:[email-masked]>>, Qing Yang <[email-masked]<mailto:[email-masked]>>, Shuanglong Chen <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
has been successfully submitted by Gyan Mishra and posted to the
IETF repository.

Name:           draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh
Revision:       04
Title:          Deployment Guidelines for Edge Peering IPv4-NLRI with IPv6-NH
Document date:  2021-04-26
Group:          Individual Submission
Pages:          21
URL:            https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04.txt&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=GplhN6pbPFCDnWAFF0tqeVZjBX1nnF-nL6H8tLNAnsM&e=
Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh_&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=D9OyhTMLCDz9ZQc1mYku6nCUBg3VEiBBB_vSdfKR3Iw&e=
Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=FKPcDJ5syMhYkZ55Xrx3JbK7hHhzHGzEtOTNimEwwRk&e=
Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=HfbldNQkr40Wa4XsQ_E9e4HD0mLu7Sidk35DT6yG5fM&e=
Diff:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dmishra-2Dbess-2Ddeployment-2Dguide-2Dipv4nlri-2Dipv6nh-2D04&d=DwICaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=DnUkF34wu4mqq0UY8nn2rxBBO7qOW_D-RfNVLML28ZU&m=bGS9O5KFA11j2hd9og9I-N5eBH-Xsiq62Ubp3ky1Kak&s=Cho5i64yzsLbzTY75c5YIA7OGt1Vo03FteXhvw1XLJA&e=

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

--

[Image removed by sender.]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect, SME & Protocol Design Expert

Data Center Planning | Common Core | Development & Engineering Lab Services
Global Technology Services | ITNUC

O 240 970-6287
M 301 502-1347
13101 Columbia Pike Rm 304-D
Silver Spring, MD 20904

IETF  & ISOC Member since 2015

https://www.ietf.org/

--

[Image removed by sender.]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: "Simpson, Adam 1. (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 27 Apr 2021 13:25:56 +0000

Sorry, I’m one of those missing responses. I’m not aware of any IPR.

From: Bocci, Matthew (Nokia - GB) <[email-masked]>
Date: Tuesday, April 27, 2021 at 2:24 AM
To: Gyan Mishra <[email-masked]>, BESS <[email-masked]>, [email-masked] <[email-masked]>, Mankamana Mishra (mankamis) <[email-masked]>, Jeff Tantsura <[email-masked]>, Lili Wang <[email-masked]>, Chenshuanglong <[email-masked]>, Simpson, Adam 1. (Nokia - US/Mountain View) <[email-masked]>, Qing Yang <[email-masked]>, [email-masked] <[email-masked]>, Stephane Litkowski (slitkows) <[email-masked]>
Subject: Re: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
Authors

Thanks

Matthew

Dear BESS,

Please review.

Thank  you

Gyan
---------- Forwarded message ---------
From: Mishra, Gyan S <[email-masked]<mailto:[email-masked]>>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: Fwd: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Hayabusanew <[email-masked]<mailto:[email-masked]>>

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Apr 27, 2021 at 2:16 AM
Subject: [E] New Version Notification for draft-mishra-bess-deployment-guide-ipv4nlri-ipv6nh-04.txt
To: Adam Simpson <[email-masked]<mailto:[email-masked]>>, Gyan Mishra <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Lili Wang <[email-masked]<mailto:[email-masked]>>, Mankamana Mishra <[email-masked]<mailto:[email-masked]>>, Qing Yang <[email-masked]<mailto:[email-masked]>>, Shuanglong Chen <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

--

Gyan Mishra

O 240 970-6287
M 301 502-1347

https://www.ietf.org/

--

Gyan Mishra

M 301 502-1347