Subject: [bess] Cross WG review request for draft-ietf-bier-evpn

From: <[email-masked]>
Date: Fri, 2 Apr 2021 08:46:59 +0200

HI folks,

The BIER WG is in the last mile of review for draft-ietf-bier-evpn and
requests our review on the document before progressing further.

Please have a deep look at it and provide your feedback or concerns.

Please close the review by April 20th.

Thanks in advance,

Stephane

https://datatracker.ietf.org/doc/draft-ietf-bier-evpn/

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Wed, 7 Apr 2021 07:20:05 +0000

Hi,

I have some comments on this draft.

1. There are 3 different encapsulations VXLAN/NVGRE/GENEVE defined in this draft, but it is not clear if there is a mandatory one for  interoperable implementation, or all are mandatory ?

The effort to make BIER-EVPN "unified" with Unicast-EVPN (by using 3 BIER proto values) doesn't seem to be convenient:
1) For implementation, the existing NVO3 VXLAN/NVGRE/GENEVE forwarding module (HW or SW) doesn't help much because the major gap is BIER.
2) For trouble-shooting like offline LAN analyzing (rfc8279), the existing NVO3 VXLAN/NVGRE/GENEVE header doesn't help much because the major part is BIER.

>From my point of view, one uniform encapsulation is better because it is used for one single purpose - to distinguish the tenant and still keep aligned with NVO3 style where "VNI" is used.

2. In section 2.1:
         A well-known IP multicast address (to be assigned by IANA) is used as
the destination address and the egress PEs MUST be set up to receive
and process packets addressed to the address.

It is not clear what are the "set up" and "process" implying. For example:
1) For implementation, does the "set up" mean an MFIB entry populated into forwarding table ? A packet with well-known IP multicast address as destination address (like 224.0.0.1) is usually sent to CPU in a multicast router in my opinion.
2) For error-handling, how to "process" if the TTL/Hop limit field in the IP header is 0/1/254/255 ?

>From my point of view, the cost to support BIER-PHP this way is fairly high. I am not sure if some words like "recommend" or "not recommend" can help to do the trade-off for implementation/deployment.

Thanks
Jingrong

From: BESS [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 2, 2021 2:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Cross WG review request for draft-ietf-bier-evpn

HI folks,

The BIER WG is in the last mile of review for draft-ietf-bier-evpn and requests our review on the document before progressing further.
Please have a deep look at it and provide your feedback or concerns.

Thanks in advance,

Stephane