Subject: Re: [bess] Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

From: Qin Wu <[email-masked]>
Date: Wed, 28 Apr 2021 01:53:03 +0000

Thanks Jeffrey for clarification, I have better understanding on your document.
I suggest to add clarity to the text from two perspectives:
1. Highlight the assumption difference between mechanism proposed in RFC6514 and one proposed in this draft, e.g., in this draft, it doesn't require MSDP session to be established between PEs while RFC6514 allows this, that is why we applied different policy on different network elements.
2. Clarify only one PE exist in the MSDP mesh group
See comments marked with [Qin2]
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]] 
发送时间: 2021年4月28日 3:18
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

Please see zzh2> below for clarifications.

-----Original Message-----
From: Qin Wu <[email-masked]>
Sent: Tuesday, April 27, 2021 2:38 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

[External Email. Be cautious of content]

Hi, Jeffrey:
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2021年4月27日 4:35
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

Thank you for your review and comments. Let me share a diff to see if it addresses the issues, before I post a revision.

Please see zzh> below.

-----Original Message-----
From: Qin Wu via Datatracker <[email-masked]>
Sent: Friday, April 23, 2021 11:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

[External Email. Be cautious of content]

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu
Review result: Ready with nits

I have reviewed this document as part of the Operational directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written with the intent of improving the operational aspects of the IETF drafts. Comments that are not addressed in last call may be included in AD reviews during the IESG review.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes how to convey the RP address information into the MVPN Source Active route using an Extended Community so this information can be shared with an existing MSDP infrastructure. It provides an update to RFC6514.

Major issues:
None

Minor issues:
I am wondering how MVPN and MSDP SA Interoperation is back compatible with existing source  discovery information dissemination methods? Is there any downside to make MVPN SA and MSDP SA work together.

Zzh> There is no downside. The RFC6514 specified MSDP SA -> MVPN SA but is missing the other direction (MVPN SA -> MSDP SA), which causes lots of headache. This document is to add the missing part, as explained in introduction section.
Zzh> The only backwards compatibility issue is with a scenario further explained at the end of this message - where PE2 is a legacy PE that does not attach the EC.

[Qin]: Thank for clarification, I am little bit worried about this, with the magic policy control, we can solve all the backward compatibility issues,:-)
Zzh2> Well at this time we don't foresee other issues 😊
[Qin2]:How about "rpt-spt" mode which is beyond scope of this document. I don't investigate this.
Section 1:
Suggest to add term for GTM, RPT, C-Multicast

Zzh> Added.

Section 3
When we say MVPN Pes that have one or more MSDP session in a VPN, does this statement contradict with “VPN-specific MSDP sessions are not required among the PEs”?

zzh> The MSDP session that the PEs have are with other non-PE MSDP speakers but not among themselves, so it does not contradict with that quoted text.

[Qin]:Without your clarification, I feel MVPN PEs will only establish MSDP session with other PEs in a VPN, rather than non-PE MSDP speakers? Can you add text to make this clear?

Zzh2> Section 1 does say the following:

   ... One or more of the
   PEs, say PE1, either act as a C-RP and learn of (C-S,C-G) via PIM
   Register messages, or have MSDP sessions with some MSDP peers and <====
   learn (C-S,C-G) via MSDP SA messages...
[Qin2]: without your clarification or familiar with the context of RFC6514, I will believe MSDP can be either PE2 or non PE elements.

   [RFC6514] only specifies that a PE receiving the MVPN SA routes, say
   PE2, will advertise (C-S,C-G) C-multicast routes if it has
   corresponding (C-*,C-G) state learnt from its CE.  PE2 may also have
   MSDP sessions with other C-RPs at its site,                                                  <====
[Qin2]: In the VPN membership context, I will assume C-RPs can be PE1, but of course I am wrong.
Zzh2> MVPN PEs establishing MSDP sessions with other non-PE devices is a common practice in RFC6514, so we should not need to call it again.
[Qin2]: I think having some text to clarify MSDP peers or C-RPS as MSDP speakers is non-PE elements will have no harm, e.g.,
OLD TEXT:
"
   The MVPN PEs that act as customer RPs or have one or more MSDP
   sessions in a VPN (or the global table in case of GTM) are treated as
   an MSDP mesh group for that VPN (or the global table).  In the rest
   of the document, it is referred to as the PE mesh group.  It MUST NOT
   include other MSDP speakers, and is integrated into the rest of MSDP
   infrastructure for the VPN (or the global table) following normal
   MSDP rules and practices.
"
NEW TEXT:
"
   The MVPN PEs that act as customer RPs or have one or more MSDP
   sessions with non-PE elements in a VPN (or the global table in case of GTM) are treated as
   an MSDP mesh group for that VPN (or the global table).  In the rest
   of the document, it is referred to as the PE mesh group.  It only have one PE and MUST NOT
   include other PEs as MSDP speakers, and is integrated into the rest of MSDP
   infrastructure for the VPN (or the global table) following normal
   MSDP rules and practices.
"

Section 3
What do you mean other MSDP speaker? Do we assume there is one or only one MSDP speaker in the MSDP mesh group? How MSDP speaker is different from MSDP peer?
Do you mean there is no session to be established between MSDP peer?

Zzh> MSDP sessions are established among MSDP speakers/peers. The text here means that the MVPN PEs that are running MSDP (with sessions to other non-PEs)  form a mesh group and that group does not include other MSDP peers that are not PEs.

[Qin]:Confused, the first half sentence said the MSDP session is established between PE and non-PEs, the second half sentence said the group does not include non-PE as MSDP peers? Are you saying in the second half sentence that the group only include other MSDP peers that are not PEs?
Zzh2> Correct. The text says that the mesh group includes PEs "that act as customer RPs or have one or more MSDP sessions" and does not "include other MSDP speakers". Those other MSDP peers are just no in the same "PE mesh group".

Section 3, last paragraph:
When we say ” In that case, if the selected best MVPN SA route does not have the "MVPN SA RP-address EC" but another route for the same (C-S, C-G) does, then the best route with the EC SHOULD be chosen.”, which best route is selected? Selected best MVPN SA route without EC or normal route with the EC?
It looks you assume the normal route with the EC is the best selected route as well in this context?

Zzh> The BGP selected best route may not have the EC. In that case, for MSDP interop purpose, the next best route with the EC should be used.

[Qin]: Understood, thanks for clarification.

Section 3
Can you provide an example of fine grained policy control? Is this related to local policy? “accepted MSDP SA message when receiving PE’s RP for the C-G is MSDP peer to which the generated MSDP message is advertised”

Zzh> Yes I changed it to local policy. We probably don't need examples here - just whatever MSDP policies that can be used in an MSDP deployment.
Zzh> The quoted text is part of the following description: a receiving PE1 receives an SA route from another PE2 who does not attach the EC, so PE1 uses its own local RP address (say R1) to construct that MSDP SA message and advertise to its peer. If that peer happens to be R1, the peer will reject it because PE1 used R1 in constructing the message. To prevent this rejection, R1 should configure MSDP policy to accept the message.
Zzh> Thanks!
Zzh> Jeffrey

[Qin]: I found another inconsistency issue, section 2, 3rd paragraph said:
"
   unless blocked by
   policy control, PE2 would in turn advertise MVPN SA routes because of
   those MSDP SA messages that it receives from PE1, which are redundant
   and unnecessary.
"
Zzh2> That policy, if exists, is on PE2.

Section 3 said:
"
In that case, it is possible
   that receiving PE's RP for the C-G is actually the MSDP peer to which
   the generated MSDP message is advertised, causing the peer to discard
   it due to RPF failure.  To get around that problem the peer SHOULD
   use local policy to accept the MSDP SA message.
"
Zzh2> That is on the (non-PE) peer.

I am wondering whether these two places are talking about the same policy control, but one policy control is to avoid redundant message while the other is accept the MSDP SA message. Please make sure they are consistent.

Zzh2> Indeed one is for the PE to block redundant message and the other is for the non-PE peer to accept message.
[Qin]:Thanks for your clarification, maybe we should further clarify in section 3 that the mechanism proposed in this draft doesn't require MSDP session to be established between PEs, this is something different from what RFC6514 is doing.
I know you clarify this in the introduction, but seems not reflect obviously in the section 3.

Zzh2> Thanks.
Zzh2> Jeffrey

Juniper Business Use Only

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 28 Apr 2021 16:25:58 +0000

Hi Qin,

Please see zzh3> below, and attached diff.

-----Original Message-----
From: Qin Wu <[email-masked]>
Sent: Tuesday, April 27, 2021 9:53 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Zzh3> The introduction section does clearly state the following:

   If a PE does advertise MSDP SA messages based on received MVPN SA
   routes, the VPN-specific MSDP sessions are no longer needed.

Zzh3> I added "with other PEs":

   If a PE does advertise MSDP SA messages based on received MVPN SA
   routes, the VPN-specific MSDP sessions with other PEs are no longer needed.

Zzh3> The policy difference is actually irrelevant here.

Zzh3> The "PE MSDP mesh group" actually includes all PEs that are either a C-RP or an MSDP peer. Please see below for further information.

Zzh3> more responses below.

-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2021年4月28日 3:18
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

-----Original Message-----
From: Qin Wu <[email-masked]>
Sent: Tuesday, April 27, 2021 2:38 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi, Jeffrey:
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2021年4月27日 4:35
收件人: Qin Wu <[email-masked]>; Lenny Giuliano <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: RE: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Hi Qin,

Please see zzh> below.

-----Original Message-----
From: Qin Wu via Datatracker <[email-masked]>
Sent: Friday, April 23, 2021 11:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu

Major issues:
None

Minor issues:

[Qin]: Thank for clarification, I am little bit worried about this, with the magic policy control, we can solve all the backward compatibility issues,:-)
Zzh2> Well at this time we don't foresee other issues 😊
[Qin2]:How about "rpt-spt" mode which is beyond scope of this document. I don't investigate this.
Zzh3> Because it is out of scope, it is irrelevant 😊 As the document already says, the MVPN SA routes in the rpt-spt mode are for a different purpose.

Section 1:

Zzh> Added.

Section 3

   ... One or more of the

Zzh3> Unfortunately the new text is not correct 😊
Zzh3> This document is about a PE treating incoming MVPN SA routes as MSDP SA messages (which triggers outgoing MSDP SA messages to MSDP peers). Therefore, the PEs originating the MVPN SA routes and PEs originating outgoing MSDP SA messages as a result are considered in the same MSDP mesh group (as if they were running MSDP among themselves). That mesh group, referred to as PE mesh group, includes all PEs that "act as customer RPs or have one or more MSDP sessions in a VPN".
Zzh3> A PE may have multiple MSDP sessions and mesh groups.
Zzh3> This document does assume "familiarity with MVPN and MSDP protocols and procedures", and adding more clarifications will pull in more and more concepts/procedures like a chain reaction, so I'd rather avoid that.
Zzh3> Thanks.
Zzh3> Jeffrey

Section 3

Section 3

Section 3 said:
"

Zzh2> Thanks.
Zzh2> Jeffrey