Subject: [bess] FW: New Version Notification for draft-ietf-bess-datacenter-gateway-11.txt

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 May 2021 22:31:15 +0100

Hi all,

This revision attempts to address John Scudder's Discuss and Comment including changes discussed by email and in person (by John Drake). It also addresses the updated version of Gyan's GenArt review comments, incorporating most of the changes he suggested in his most recent email. Thanks to John (S) and Gyan for the amount of time and effort they spent reaching resolutions with the authors - a long and somewhat bumpy road, but a better document as a result.

No changes are made for Roman's Discuss (see recent email).

I believe that Warren's Discuss is also addressed partly by answering John's Discuss, but also by the change of terminology to "site" from the incorrect "SR domain".

As noted in email, this revision fixes one grammar point (a missing comma) and fixes the two out-dated references pointed out in Lars' Comment.

Per email, Erik and Alvaro's Comments are addressed by the change in domain/site terminology.

I think the actionable parts of Eric's Comment is also handled with the text change suggested in email.

Lastly, I think Rob's Comment has been closed through email.

Please let us know if you think more action is needed.

Many thanks to you all for the time and effort you've put in to reviewing this document.

Adrian

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 19 May 2021 22:21
To: Adrian Farrel <[email-masked]>; Eric Rosen <[email-masked]>; John Drake <[email-masked]>; Keyur Patel <[email-masked]>; Luay Jalil <[email-masked]>
Subject: New Version Notification for draft-ietf-bess-datacenter-gateway-11.txt

A new version of I-D, draft-ietf-bess-datacenter-gateway-11.txt
has been successfully submitted by Adrian Farrel and posted to the
IETF repository.

Name:		draft-ietf-bess-datacenter-gateway
Revision:	11
Title:		Gateway Auto-Discovery and Route Advertisement for Segment Routing Enabled Site Interconnection
Document date:	2021-05-19
Group:		bess
Pages:		13
URL:            https://www.ietf.org/archive/id/draft-ietf-bess-datacenter-gateway-11.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-bess-datacenter-gateway/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-bess-datacenter-gateway
Htmlized:       https://tools.ietf.org/html/draft-ietf-bess-datacenter-gateway-11
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-datacenter-gateway-11

Abstract:
   Data centers are critical components of the infrastructure used by
   network operators to provide services to their customers.  Data
   centers are attached to the Internet or a backbone network by gateway
   routers.  One data center typically has more than one gateway for
   commercial, load balancing, and resiliency reasons.

   Segment Routing is a protocol mechanism that can be used within a
   data center, and also for steering traffic that flows between two
   data center sites.  In order that one data center site may load
   balance the traffic it sends to another data center site, it needs to
   know the complete set of gateway routers at the remote data center,
   the points of connection from those gateways to the backbone network,
   and the connectivity across the backbone network.

   Other sites, such as access networks, also need to be connected
   across backbone networks through gateways.

   This document defines a mechanism using the BGP Tunnel Encapsulation
   attribute to allow each gateway router to advertise the routes to the
   prefixes reachable in the site to which it provides access, including
   advertising them on behalf of each other gateway to the same site.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 May 2021 23:29:13 +0100

Dang! 
Now sending to the IESG not the Secretariat.
Adrian

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: 19 May 2021 22:31
To: [email-masked]
Cc: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; 'Gyan Mishra' <[email-masked]>; [email-masked]' <[email-masked]>
Subject: FW: New Version Notification for draft-ietf-bess-datacenter-gateway-11.txt

Hi all,

Adrian

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 19 May 2021 22:21
To: Adrian Farrel <[email-masked]>; Eric Rosen <[email-masked]>; John Drake <[email-masked]>; Keyur Patel <[email-masked]>; Luay Jalil <[email-masked]>
Subject: New Version Notification for draft-ietf-bess-datacenter-gateway-11.txt

Abstract:

The IETF Secretariat