Subject: [bess] SRv6 / (SR)MPLS co-existence for bess

From: Eduard Metz <[email-masked]>
Date: Mon, 17 May 2021 10:16:00 +0200

Hello,

Co-existence of multiple dataplane technologies to carry BESS services is
useful for among others migration of one dataplane technology to another
(e.g. (SR)MPLS to SRv6).

Can co-existence be achieved without changing current specifications, or
would it require extensions / changes? For example as proposed in
draft-ls-bess-srv6-mpls-coexisting-vpn.

I was thinking maybe the BGP ADD-PATH capability could be leveraged to
achieve co-existence.

Would it be of interest to document co-existence cases and solutions?

Thanks!

cheers,
  Eduard

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 18 May 2021 12:13:02 +0000

Hi Eduard,

I do believe that BGP ADD-PATH mechanism can be leveraged for co-existence. There are also other design approaches to achieve the same.

I am copying the authors of https://datatracker.ietf.org/doc/draft-agrawal-spring-srv6-mpls-interworking/ who were working to document these approaches.

Thanks,
Ketan

From: BESS <[email-masked]> On Behalf Of Eduard Metz
Sent: 17 May 2021 13:46
To: [email-masked]
Subject: [bess] SRv6 / (SR)MPLS co-existence for bess

Hello,

Co-existence of multiple dataplane technologies to carry BESS services is useful for among others migration of one dataplane technology to another (e.g. (SR)MPLS to SRv6).

Can co-existence be achieved without changing current specifications, or would it require extensions / changes? For example as proposed in draft-ls-bess-srv6-mpls-coexisting-vpn.

I was thinking maybe the BGP ADD-PATH capability could be leveraged to achieve co-existence.

Thanks!

cheers,
  Eduard

---

From: Eduard Metz <[email-masked]>
Date: Tue, 18 May 2021 14:50:11 +0200

Thanks!
I overlooked that this draft already has a placeholder for co-existence, no
specific approaches included yet.
Would be happy to contribute if needed.

cheers,
  Eduard

On Tue, May 18, 2021 at 2:13 PM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> Hi Eduard,
>
>
>
> I do believe that BGP ADD-PATH mechanism can be leveraged for
> co-existence. There are also other design approaches to achieve the same.
>
>
>
> I am copying the authors of
> https://datatracker.ietf.org/doc/draft-agrawal-spring-srv6-mpls-interworking/
> who were working to document these approaches.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* BESS <[email-masked]> *On Behalf Of *Eduard Metz
> *Sent:* 17 May 2021 13:46
> *To:* [email-masked]
> *Subject:* [bess] SRv6 / (SR)MPLS co-existence for bess
>
>
>
> Hello,
>
>
>