Subject: [bess] Robert Wilton's No Objection on draft-ietf-bess-datacenter-gateway-10: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Wed, 19 May 2021 06:19:55 -0700

Robert Wilton has entered the following ballot position for
draft-ietf-bess-datacenter-gateway-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-datacenter-gateway/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thanks for this document.

The draft has a manageability considerations section - thanks - but I would
like to check whether assignment of the SR domain identifier would expect to be
configured via YANG?  If so, is there a YANG data model in the works that will
cover this functionality?  Having an informational reference to the data model
may be helpful to readers.

Regards,
Rob

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 May 2021 15:03:09 +0100

Hi Rob,

Interesting question.

> COMMENT:
> -------------------------------------------------------------------
>

It is hard to predict the expectations in this regard.
CLI, TL/1, YANG, DHCP?

I think that in the fullness of time, if the approach described in this document takes off, then I would expect to see YANG management available.
At the moment, however, I'm not aware of any work (presumably to augment BGP and/or SR models), so nothing to point at.

Compare and contrast with how VPN IDs are configured, and how long we lived with VPNs before we had a "standard" way to configure them.

Cheers,
Adrian

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 19 May 2021 14:29:19 +0000

Hi Adrian,

> -----Original Message-----
> From: iesg <[email-masked]> On Behalf Of Adrian Farrel
> Sent: 19 May 2021 15:03
> To: Rob Wilton (rwilton) <[email-masked]>; 'The IESG' <[email-masked]>
> Cc: [email-masked]; 'Matthew Bocci'
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: RE: Robert Wilton's No Objection on draft-ietf-bess-datacenter-
> gateway-10: (with COMMENT)
> 
> Hi Rob,
> 
> Interesting question.
> 
> > COMMENT:
> I think that in the fullness of time, if the approach described in this
> document takes off, then I would expect to see YANG management available.
> At the moment, however, I'm not aware of any work (presumably to augment
> BGP and/or SR models), so nothing to point at.
> 
> Compare and contrast with how VPN IDs are configured, and how long we
> lived with VPNs before we had a "standard" way to configure them.
[RW] 

Thanks for the information.

The unfortunate downside to this approach is that it is much harder to get agreement on what the configuration & operational data model should look like if every vendor has created their own version ...

Regards,
Rob