Subject: [bess] RFC7432bis : Request for review

From: Luc André Burdet <[email-masked]>
Date: Wed, 26 May 2021 18:58:36 +0000

Hi,

The update to RFC7432 is an important draft for the WG - could you please review offline and provide feedback?
https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis

I would like to incorporate feedback into a new version published before IETF 111, or discuss then any substantive content

Regards,
Luc André Burdet |  Cisco  |  [email-masked]  |  Tel: +1 613 254 4814

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 27 May 2021 12:15:55 +0000

Hi authors and contributors of draft-ietf-bess-rfc7432bis.

I have started reading the draft in hope to find a section that describes the differences between the original RFC 7432 and the "bis" draft for this RFC.
AFAIK, such sections are quite customary when a "bis" revision of an already approved and published RFC is proposed.
Unfortunately, there seems to be no such section in the draft, and looking for the differences in a 64-page document is quite non-trivial.
This may be one of the reasons why no comments have appeared at the BESS WG mailing list in 5 months following the draft posting.

May I suggest that you add such a section (or Appendix) to the next revision of the draft?

Looking just at the tables of contents of RFC 7432 and of the draft I see that the following new sections have been added (could have missed some items)

    7.9<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-7.9>.  EVPN Layer 2 Attributes Extended Community

       7.9.1<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-7.9.1>.  EVPN Layer 2 Attributes Partitioning

    7.12<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-7.12>. Route Prioritization

       10.1.1<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-10.1.1>.  Best Path selection for Default Gateway

    15.2<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-15.2>.  Sticky MAC Addresses

    18.1<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-18.1>.  Flow Label

   19<https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-00#section-19>. Use of Domain-wide Common Block (DCB) Labels

There are also some changes in the text of the sections that have existed in RFC 743. E.g., I see reference to BIER in the draft that do not exist in RFC 7432.

Tracking such changes would be quite difficult without the authors' help in the form of a "Summary of changes from RFC 7432" section/Appendix.

Such a section, if added, would be also included in the resulting RFC.

Hopefully this comment will be useful.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: BESS <[email-masked]> On Behalf Of Luc Andr? Burdet
Sent: Wednesday, May 26, 2021 9:59 PM
To: [email-masked]
Subject: [EXTERNAL] [bess] RFC7432bis : Request for review

Hi,

The update to RFC7432 is an important draft for the WG - could you please review offline and provide feedback?
https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis<https://clicktime.symantec.com/3Hss71ZoqyYVo1fFGH3PvdW6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis>

Regards,
Luc André Burdet |  Cisco  |  [email-masked]<mailto:[email-masked]>  |  Tel: +1 613 254 4814

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 27 May 2021 13:10:55 +0000

Hi Sasha,

That is very helpful feedback, and adding a section about the changes makes sense to me.
Thanks.
Jorge

From: Alexander Vainshtein <[email-masked]>
Date: Thursday, May 27, 2021 at 5:16 AM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
Cc: [email-masked] <[email-masked]>, Michael Gorokhovsky <[email-masked]>, Alexander Ferdman <[email-masked]>, Luc André Burdet <[email-masked]>
Subject: RE: RFC7432bis : Request for review
Hi authors and contributors of draft-ietf-bess-rfc7432bis.

I have started reading the draft in hope to find a section that describes the differences between the original RFC 7432 and the “bis” draft for this RFC.
AFAIK, such sections are quite customary when a “bis” revision of an already approved and published RFC is proposed.
Unfortunately, there seems to be no such section in the draft, and looking for the differences in a 64-page document is quite non-trivial.
This may be one of the reasons why no comments have appeared at the BESS WG mailing list in 5 months following the draft posting.

Tracking such changes would be quite difficult without the authors’ help in the form of a “Summary of changes from RFC 7432” section/Appendix.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Hi,

Regards,

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 27 May 2021 13:15:18 +0000

Hi Jorge,
Glad to be useful, and will be using for the next revision to review the changes
Judging by the difference in the size of the two documents (RFC 7432 is 56 pages while the draft is 65 pages) the section that describes the changes would make such a review much more feasible for me.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
Sent: Thursday, May 27, 2021 4:11 PM
To: Alexander Vainshtein <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; Michael Gorokhovsky <[email-masked]>; Alexander Ferdman <[email-masked]>; Luc André Burdet <[email-masked]>
Subject: [EXTERNAL] Re: RFC7432bis : Request for review

Hi Sasha,

From: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 27, 2021 at 5:16 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>, Alexander Ferdman <[email-masked]<mailto:[email-masked]>>, Luc André Burdet <[email-masked]<mailto:[email-masked]>>
Subject: RE: RFC7432bis : Request for review
Hi authors and contributors of draft-ietf-bess-rfc7432bis.

    7.9<https://clicktime.symantec.com/3NxCNy2mxkGc6BKRi3JZ9r16H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-7.9>.  EVPN Layer 2 Attributes Extended Community

       7.9.1<https://clicktime.symantec.com/36d1PB75YAkaqe7nar6K3mi6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-7.9.1>.  EVPN Layer 2 Attributes Partitioning

    7.12<https://clicktime.symantec.com/35FxGTNaL4Yid6DfW1CxQXn6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-7.12>. Route Prioritization

       10.1.1<https://clicktime.symantec.com/3WZS1PJE1319p3ZCAdeGNwZ6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-10.1.1>.  Best Path selection for Default Gateway

    15.2<https://clicktime.symantec.com/39uEWVQWDBT6T5y6pmbRgGQ6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-15.2>.  Sticky MAC Addresses

    18.1<https://clicktime.symantec.com/3PBmbBk5XQMkaZzYdG5KbKf6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-18.1>.  Flow Label

   19<https://clicktime.symantec.com/3Hr2wMPrjec3vB4r4SnWjq66H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bess-rfc7432bis-00%23section-19>. Use of Domain-wide Common Block (DCB) Labels

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of Luc Andr? Burdet
Sent: Wednesday, May 26, 2021 9:59 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] [bess] RFC7432bis : Request for review

Hi,

Regards,

---

From: Luc André Burdet <[email-masked]>
Date: Thu, 27 May 2021 13:59:55 +0000

Extremely useful feedback, thanks Sasha.

In the interim, here’s a diff highlighting changes  (especially smaller additions which may otherwise go undetected like ‘normazlied’ )

https://tools.ietf.org//rfcdiff?url1=https://www.rfc-editor.org/rfc/rfc7432.txt&url2=https://www.ietf.org/archive/id/draft-ietf-bess-rfc7432bis-00.txt<https://tools.ietf.org/rfcdiff?url1=https://www.rfc-editor.org/rfc/rfc7432.txt&url2=https://www.ietf.org/archive/id/draft-ietf-bess-rfc7432bis-00.txt>

Regards,

From: Alexander Vainshtein <[email-masked]>
Date: Thursday, May 27, 2021 at 09:15
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Michael Gorokhovsky <[email-masked]>, Alexander Ferdman <[email-masked]>, Luc André Burdet <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] RFC7432bis : Request for review

Hi Jorge,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Hi Sasha,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Hi,

Regards,