Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 12 Oct 2021 08:46:45 +0000

Greg

Thank you

I am good to close the implementation poll, but I believe there may be some outstanding comments to address from Saumya on the other thread. Please can you look at that?

Thanks

Matthew

From: Greg Mirsky <[email-masked]>
Date: Friday, 3 September 2021 at 15:41
To: Bocci, Matthew (Nokia - GB) <[email-masked]>, BESS <[email-masked]>
Cc: John E Drake <jdrake=[email-masked]>, sajassi=[email-masked] <sajassi=[email-masked]>, [email-masked] <[email-masked]>, Greg Mirsky <[email-masked]>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
Hi Matthew and BESS WG,
I was informed that our product does support using most of the sub-TLVs defined in the draft. Please let me know if you have any further questions regarding the implementation.

Regards,
Greg

On Tue, Aug 31, 2021 at 2:36 PM <[email-masked]<mailto:[email-masked]>> wrote:

Hi Matthew,

my apologies for the belated response:

  1.  I am still awaiting a response from our product team on whether any part of the draft is supported.
  2.  I concur with Ali. LSP Ping is a broadly used OAM tool detecting and localizing failures, including discrepancies between the data and control planes. The document defines necessary Target FEC sub-TLVs for EVPN and MVPN cases.

Regards,

Greg Mirsky

Sr. Standardization Expert
预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product R&D Institute/Wireline Product Operation Division

E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<http://www.zte.com.cn/>
Original Mail
Sender: JohnEDrake
To: Ali Sajassi (sajassi);Bocci, Matthew (Nokia - GB);[email-masked]<mailto:[email-masked]>;[email-masked]<mailto:[email-masked]>;
Date: 2021/08/31 11:34
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess
Hi,

I agree with Ali.

Yours Irrespectively,

John

Juniper Business Use Only
From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, August 27, 2021 9:54 PM
To: Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

[External Email. Be cautious of content]

Hi Matthew,

Some of the co-authors are on PTO and I couldn’t reach them (typical of the month of August). So, I’d like to get a bit more extension.

Regarding the two questions below:

  1.  My company hasn’t implemented it.
  2.  I do think that we should process with the publication as it describes how LSP ping can be used to detect data-plane failures for various EVPN functionality including aliasing, split-horizon filtering using ESI label, multicast, l2-unicast, l3-unicast, IRB, etc. For MPLS transport tunnel, I am not aware of any other tool/draft that allows us to do data-plane failure detection. Thus, I think it is important to proceed with its publications.

Still I’d like to hear from other co-authors and other people in this community.

Regards,
Ali

From: Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>>
Date: Monday, August 9, 2021 at 6:25 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
WG and Authors

Unfortunately I have not seen any responses indicating that there are any known implementations of this draft. I also did not see any responses to Stephane's question if we should proceed regardless.

As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4v8nM3No$>), please can you respond to this email indicating either:

- That you are aware of any implementations (ideally providing some details)
- If you are not aware of any, if you think the WG should proceed with the draft's publication and why.

I will close this poll on 25th August 2021.

Regards

Matthew

On 14/06/2021, 17:38, "BESS on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the BGP Enabled ServiceS WG of the IETF.

            Title           : LSP-Ping Mechanisms for EVPN and PBB-EVPN
            Authors         : Parag Jain
                              Samer Salam
                              Ali Sajassi
                              Sami Boutros
                              Greg Mirsky
         Filename        : draft-ietf-bess-evpn-lsp-ping-05.txt
         Pages           : 15
         Date            : 2021-06-14

    Abstract:
       LSP-Ping is a widely deployed Operation, Administration, and
       Maintenance (OAM) mechanism in MPLS networks.  This document
       describes mechanisms for detecting data-plane failures using LSP Ping
       in MPLS based EVPN and PBB-EVPN networks.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4CFZvJAM$>

    There is also an htmlized version available at:
    https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4RLT2-5Q$>

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli44UwE5yg$>

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/<https://urldefense.com/v3/__ftp:/ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4trDqUTY$>

    _______________________________________________
    BESS mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bess<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bess__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4YoTqkAc$>

---

From: "Dikshit, Saumya" <[email-masked]>
Date: Wed, 13 Oct 2021 04:14:09 +0000

Hi Mathew,

+1 on going ahead with this draft.
As Greg suggested in the other thread, we can draft an extension to include the new proposal.

Thanks
Saumya.

From: BESS [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, October 12, 2021 2:17 PM
To: Greg Mirsky <[email-masked]>; BESS <[email-masked]>
Cc: Greg Mirsky <[email-masked]>; sajassi=[email-masked]; [email-masked]; John E Drake <jdrake=[email-masked]>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

Greg

Thank you

Thanks

Matthew

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Friday, 3 September 2021 at 15:41
To: Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>>, BESS <[email-masked]<mailto:[email-masked]>>
Cc: John E Drake <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>, sajassi=[email-masked]<mailto:sajassi=[email-masked]> <sajassi=[email-masked]<mailto:sajassi=[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
Hi Matthew and BESS WG,
I was informed that our product does support using most of the sub-TLVs defined in the draft. Please let me know if you have any further questions regarding the implementation.

Regards,
Greg

Hi Matthew,

Regards,

Greg Mirsky

https://www.ietf.org/mailman/listinfo/bess<https://www.ietf.org/mailman/listinfo/bess>
Hi,

I agree with Ali.

Yours Irrespectively,

John

Hi Matthew,

Regards,
Ali

As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/<https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/>), please can you respond to this email indicating either:

Regards

Matthew

    Abstract:

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/<https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/>

    There is also an htmlized version available at:
    https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05<https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05>

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05<https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05>

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/<ftp://ftp.ietf.org/internet-drafts/>

    _______________________________________________
    BESS mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bess<https://www.ietf.org/mailman/listinfo/bess>

---

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Wed, 13 Oct 2021 09:28:13 +0000

Thank you. I believe we have consensus to publish the document. Please look out for the document shepherd write-up and publication request.

Best regards

Matthew

From: Dikshit, Saumya <[email-masked]>
Date: Wednesday, 13 October 2021 at 05:14
To: Bocci, Matthew (Nokia - GB) <[email-masked]>, Greg Mirsky <[email-masked]>, BESS <[email-masked]>
Cc: Greg Mirsky <[email-masked]>, sajassi=[email-masked] <sajassi=[email-masked]>, [email-masked] <[email-masked]>, John E Drake <jdrake=[email-masked]>
Subject: RE: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
Hi Mathew,

Thanks
Saumya.

Greg

Thank you

Thanks

Matthew

Regards,
Greg

Hi Matthew,

Regards,

Greg Mirsky

I agree with Ali.

Yours Irrespectively,

John

Hi Matthew,

Regards,
Ali

As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/), please can you respond to this email indicating either:

Regards

Matthew

    Abstract:

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/

    There is also an htmlized version available at:
    https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/