Subject: [bess] A question to the Authors of draft-wang-bess-sbfd-discriminator

From: Greg Mirsky <[email-masked]>
Date: Thu, 28 Oct 2021 12:54:08 -0700

Dear Authors,
thank you for bringing your work to the BESS WG. I've read the draft and
couldn't find a reference to the IDR WG draft that, as it seems to me,
addresses the same problem - draft-ietf-idr-bgp-ls-sbfd-extensions
<https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-sbfd-extensions/>.
Could you take a look at the IDR draft and share your thoughts? Do you find
that anything is missing in the draft-ietf-idr-bgp-ls-sbfd-extensions?

Regards,
Greg

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Fri, 29 Oct 2021 02:24:35 +0000

Hi Greg,

Thanks for you comments.
I have read the draft-ietf-idr-bgp-ls-sbfd-extensions<https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-sbfd-extensions/>. The problems and scenarios he's trying to solve are different from the way we use them.
The extension of the bgp-ls-sbfd-extension is to report the information collected by IS-IS/OSPF to the controller. The controller collects the information and delivers configurations to devices based on service requirements.
For example, the SBFD session is configured between PEs based on this descriminator.

In our solution, service routes are used to directly establish S-BFD sessions, and no controller coordination is required, simplifying deployment in some scenarios.
The two scenarios are oriented to different scenarios.
The bgp-ls-sbfd-extension solution mainly used for reports information. Therefore, only the information carried by IS-IS/OSPF needs to be reported. Therefore, the current extension is sufficient.
As our draft needs to be service-driven. In our scenarios, intermediate routers may change nexthops. To ensure service consistency, nexthop information needs to be added to verify S-BFD the creation of redundant S-BFD sessions.

Regards,
Haibo

From: BESS [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Friday, October 29, 2021 3:54 AM
To: [email-masked]; BESS <[email-masked]>; idr wg <[email-masked]>
Subject: [bess] A question to the Authors of draft-wang-bess-sbfd-discriminator

Dear Authors,
thank you for bringing your work to the BESS WG. I've read the draft and couldn't find a reference to the IDR WG draft that, as it seems to me, addresses the same problem - draft-ietf-idr-bgp-ls-sbfd-extensions<https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-sbfd-extensions/>. Could you take a look at the IDR draft and share your thoughts? Do you find that anything is missing in the draft-ietf-idr-bgp-ls-sbfd-extensions?

Regards,
Greg