Subject: [bess] WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon

From: <[email-masked]>
Date: Wed, 26 Jan 2022 10:49:46 +0100

Hello Working Group,

This email starts a two weeks Working Group Last Call on
draft-ietf-bess-evpn-mh-split-horizon [1]. 

This poll runs until *the 9th of Feb*.

We are also polling for knowledge of any undisclosed IPR that applies to
this document, to ensure that IPR has been disclosed in compliance with IETF
IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an Author or a Contributor of this document please
respond to this email and indicate whether or not you are aware of any
relevant undisclosed IPR. The Document won't progress without answers from
all the Authors and Contributors.

There is no IPR currently disclosed.

If you are not listed as an Author or a Contributor, then please explicitly
respond only if you are aware of any IPR that has not yet been disclosed in
conformance with IETF rules.

We are also polling for any existing implementation as per [2]. 

    Thank you,

    Stephane & Matthew

    [1]
https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-mh-split-horizon/

    [2]
https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw

---

From: Luc André Burdet <[email-masked]>
Date: Wed, 26 Jan 2022 14:39:56 +0000

Hi,

I have a question concerning the IANA considerations section: IANA currently has no registry for the flags field of  EVPN ESI Label extended community to “request/allocate” SHT bits.

This has come up before for e.g. draft-ietf-bess-evpn-l2gw-proto which requests a 3-bit field for load-bal modes.

Should one or the other draft request an IANA registry ?

Ref:
https://www.iana.org/assignments/bgp-extended-communities/bgp-extended-communities.xhtml
https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-l2gw-proto#section-4

Regards,
Luc André

Luc André Burdet |  Cisco  |  [email-masked]  |  Tel: +1 613 254 4814

From: BESS <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, January 26, 2022 at 04:50
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [bess] WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon

Hello Working Group,

This email starts a two weeks Working Group Last Call on draft-ietf-bess-evpn-mh-split-horizon [1].

We are also polling for knowledge of any undisclosed IPR that applies to this document, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an Author or a Contributor of this document please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR. The Document won't progress without answers from all the Authors and Contributors.

If you are not listed as an Author or a Contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

    Thank you,

    Stephane & Matthew

    [1] https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-mh-split-horizon/

    [2] https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw

---

From: "Rabadan, Jorge (Nokia - US/Sunnyvale)" <[email-masked]>
Date: Fri, 28 Jan 2022 11:27:20 +0000

Hi Luc,

As usual, that is an excellent point.
One of the two draft should start a registry in the IANA section. Stephane, chairs, any preference where this should reside?

@Luc, about this:

“This has come up before for e.g. draft-ietf-bess-evpn-l2gw-proto which requests a 3-bit field for load-bal modes.”

Since the single-active bit (all-active if set to 0) is specified in RFC7432 and draft-7432bis, I assume the l2gw draft would only request one bit of the registry, and not a 3-bit field, right?

Thank you,
Jorge

From: Luc André Burdet <[email-masked]>
Date: Wednesday, January 26, 2022 at 6:40 AM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [bess] WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon
Hi,

Ref:

Regards,
Luc André

Hello Working Group,

    Thank you,

    Stephane & Matthew

---

From: "Rabadan, Jorge (Nokia - US/Sunnyvale)" <[email-masked]>
Date: Fri, 28 Jan 2022 11:29:56 +0000

Hi,

As a co-author, I’m not aware of any related IPR.

Nokia’s implementation follow the default aspects described in the document, and plans to add support for the full specification in the coming releases.

Thank you.
Jorge

From: [email-masked] <[email-masked]>
Date: Wednesday, January 26, 2022 at 1:50 AM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon

Hello Working Group,

    Thank you,

    Stephane & Matthew

---

From: Luc André Burdet <[email-masked]>
Date: Fri, 28 Jan 2022 16:26:17 +0000

Thanks Jorge.
I had defined 3 bits in L2-GW-Proto, in anticipation of more/many load-balancing modes... but that now seems somewhat aggressive. I don’t mind scaling back down to 2-bitfield or just a new SFA bit by itself.

Another suggestion could be to create the registry directly with draft-7432bis ?

Regards,
Luc André

From: "Rabadan, Jorge (Nokia - US/Sunnyvale)" <[email-masked]>
Date: Friday, January 28, 2022 at 06:27
To: Luc André Burdet <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bess] WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon

Hi Luc,

@Luc, about this:

Thank you,
Jorge

Ref:

Regards,
Luc André

Hello Working Group,

    Thank you,

    Stephane & Matthew

---

From: "Rabadan, Jorge (Nokia - US/Sunnyvale)" <[email-masked]>
Date: Sat, 29 Jan 2022 00:02:09 +0000

Thanks Luc. So you were planning to update RFC7432 *and* draft-7432-bis to convert the “single-active” bit into one of the possible values of a new three-bit field?

If that is so, I think indeed it makes more sense to create the registry in draft-7432-bis and reserve individual bits in the other two drafts. It would be bad to publish 7432-bis to have it updated immediately after.

Can we create the registry in 7432-bis then?

Thanks!
Jorge

From: Luc André Burdet <[email-masked]>
Date: Friday, January 28, 2022 at 11:26 AM
To: Rabadan, Jorge (Nokia - US/Sunnyvale) <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [bess] WGLC, IPR and implementation poll for draft-ietf-bess-evpn-mh-split-horizon
Thanks Jorge.
I had defined 3 bits in L2-GW-Proto, in anticipation of more/many load-balancing modes... but that now seems somewhat aggressive. I don’t mind scaling back down to 2-bitfield or just a new SFA bit by itself.

Regards,
Luc André

Hi Luc,

@Luc, about this:

Thank you,
Jorge

Ref:

Regards,
Luc André

Hello Working Group,

    Thank you,

    Stephane & Matthew