Subject: [bfcpbis] Misplaced text in draft-ietf-bfcpbis-rfc4582bis-03

From: "Horvath, Ernst" <[email-masked]>
Date: Mon, 25 Jun 2012 15:34:01 +0000

I think some text needs to be shifted into a different section, as detailed below.

Sections 10.1.2 and 10.2.2 both start with a sentence
  "When communicating over unreliable transport and upon receiving a
   [FloorRequest/FloorRelease] from a participant, the floor control server MUST
   respond with a FloorRequestStatus message within the transaction
   failure window to complete the transaction."
These statements put a normative requirement on the floor control server and should therefore go into section 13.1 and 13.4, respectively.

Similarly, the sentence
  "When communicating over unreliable transport and upon receiving a
   ChairAction from a participant, the floor control server MUST respond
   with a ChairActionAck message within the transaction failure window
   to complete the transaction."
from 11.2 belongs into section 13.6. In addition, "from a participant" should rather be "from a chair" in that sentence.

The same applies to
- 12.1.2, where the 1st sentence should go into 13.5;
- 12.2.2, where the 1st sentence should go into 13.2;
- 12.3.2, where the 1st sentence should go into 13.3;
- 12.4.2, where the 1st sentence should go into 13.7.

Furthermore, section 13.1.3 specifies participant behaviour and should be moved into section 10.1, possibly under the heading "Reception of a Subsequent FloorRequestStatus Message".
What could be covered in 13.1.3 (or as part of 13.1.2) instead is retransmission of a subsequent FloorRequestStatus message, which is currently not specified explicitly.

Simlarly for 13.5.3, which should go into 12.1; retransmission of subsequent FloorStatus messages could be covered in 13.5.3 instead.

13.9 is also in the wrong section, but this subsection will disappear anyway if ErrorAck is removed as a whole.

Regards,
Ernst

---

From: Tom Kristensen <[email-masked]>
Date: Tue, 26 Jun 2012 14:22:11 +0200

The changes you propose below seems to make sense and will keep the 
logic partitioning of the text with regards to requirements/behaviour 
for the different roles in the separate sections:

10.  Floor Participant Operations
11.  Chair Operations
12.  General Client Operations
13.  Floor Control Server Operations

I no objections are received, I'll proceed to shuffle the text across 
according to your comments; thank you very much!

-- Tom

On 06/25/2012 05:34 PM, Horvath, Ernst wrote:
> _______________________________________________
> bfcpbis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bfcpbis
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 26 Jun 2012 18:14:55 +0000

Works for me.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Tom Kristensen (tomkrist)
> Sent: Tuesday, June 26, 2012 5:22 AM
> To: Horvath, Ernst
> Cc: [email-masked]
> Subject: Re: [bfcpbis] Misplaced text in draft-ietf-bfcpbis-rfc4582bis-03
> 
> > These statements put a normative requirement on the floor control server
> and should therefore go into section 13.1 and 13.4, respectively.
> >
> > Similarly, the sentence
> > from 11.2 belongs into section 13.6. In addition, "from a participant"
> should rather be "from a chair" in that sentence.
> >
> > The same applies to
> > Furthermore, section 13.1.3 specifies participant behaviour and should be
> moved into section 10.1, possibly under the heading "Reception of a
> Subsequent FloorRequestStatus Message".
> > What could be covered in 13.1.3 (or as part of 13.1.2) instead is
> retransmission of a subsequent FloorRequestStatus message, which is
> currently not specified explicitly.
> >
> > Simlarly for 13.5.3, which should go into 12.1; retransmission of
> subsequent FloorStatus messages could be covered in 13.5.3 instead.
> >