Subject: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-23.txt

From: [email-masked]
Date: Mon, 21 May 2018 13:48:35 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Binary Floor Control Protocol Bis WG of the IETF.

        Title           : Session Description Protocol (SDP) Format for Binary Floor Control Protocol (BFCP) Streams
        Authors         : Gonzalo Camarillo
                          Tom Kristensen
                          Christer Holmberg
	Filename        : draft-ietf-bfcpbis-rfc4583bis-23.txt
	Pages           : 23
	Date            : 2018-05-21

Abstract:
   This document defines the Session Description Protocol (SDP) offer/
   answer procedures for negotiating and establishing Binary Floor
   Control Protocol (BFCP) streams.

   This document obsoletes RFC 4583.  Changes from RFC 4583 are
   summarized in Section 15.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-rfc4583bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-bfcpbis-rfc4583bis-23
https://datatracker.ietf.org/doc/html/draft-ietf-bfcpbis-rfc4583bis-23

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-rfc4583bis-23

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 21 May 2018 21:04:17 +0000

(As chair)

Hi Folks,

This version of the draft addresses comments provided by the SDP directorate review (thanks Paul). 
It includes changes to the ABNF and corresponding editorial clarifications. I realized only now that the working group was not included in the discussion of these changes. Please review closely and share your feedback with the list. Not much changed but it is critical that we got the changes right.

Thanks,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Monday, May 21, 2018 at 1:48 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-23.txt

    
    Abstract:

    

    
    
    _______________________________________________
    bfcpbis mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: Alan Ford <[email-masked]>
Date: Mon, 21 May 2018 22:55:53 +0100

Hi all,

So this is quite a significant change from 4583; the attributes confid, userid, floorid, and bfcpver have all changed from “token” to “DIGIT”. Only numeric values are now valid. In my opinion this seems fine, since the relevant fields in the protocol are defined as unsigned integers so in fact permitting tokens was not appropriate in the first place.

All these changes seem fine.

Regards,
Alan

> On 21 May 2018, at 22:04, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> (As chair)
> 
> Hi Folks,
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 May 2018 11:42:07 +0000

Thanks! So, I guess we can ship the document :)

Regards,

Christer

-----Original Message-----
From: bfcpbis [mailto:[email-masked]] On Behalf Of Alan Ford
Sent: 21 May 2018 23:56
To: Charles Eckel (eckelcu) <[email-masked]>
Cc: Roman Shpount <[email-masked]>; [email-masked]; Gonzalo Camarillo <[email-masked]>; Paul Kyzivat <[email-masked]>; Tom Kristensen (tomkrist) <[email-masked]>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-23.txt

Hi all,

Regards,
Alan

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 25 May 2018 14:51:07 +0000

Hi Christer,

I agree that the draft is ready to move forward. Mary is the document shepherd and is working on the write-up. Last I checked, she was still waiting for confirmation from your co-authors that any and all appropriate IPR disclosures required for full conformance with the provisions of BCP 78 and BCP 79 have already been filed. Tom and Gonzalo, please get back to Mary on this as soon as possible.

Cheers,
Charles

-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Thursday, May 24, 2018 at 4:42 AM
To: Alan Ford <[email-masked]>, Charles Eckel <[email-masked]>
Cc: Roman Shpount <[email-masked]>, "[email-masked]" <[email-masked]>, Gonzalo Camarillo <[email-masked]>, Paul Kyzivat <[email-masked]>, Tom Kristensen <[email-masked]>
Subject: RE: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-23.txt

    Regards,
    
    Christer
    
    -----Original Message-----
    From: bfcpbis [mailto:[email-masked]] On Behalf Of Alan Ford
    Sent: 21 May 2018 23:56
    To: Charles Eckel (eckelcu) <[email-masked]>
    Cc: Roman Shpount <[email-masked]>; [email-masked]; Gonzalo Camarillo <[email-masked]>; Paul Kyzivat <[email-masked]>; Tom Kristensen (tomkrist) <[email-masked]>
    Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-rfc4583bis-23.txt
    
    Hi all,

    
    Regards,
    Alan

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 25 May 2018 18:01:15 +0200

Hi Charles,

I have already gotten back to Mary. Thanks!

Cheers,

Gonzalo

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 31 May 2018 10:33:26 +0000

Mary?

On 25/05/18 19:01, "Gonzalo Camarillo" <[email-masked]>
wrote:

>> I agree that the draft is ready to move forward. Mary is the document
>>shepherd and is working on the write-up. Last I checked, she was still
>>waiting for confirmation from your co-authors that any and all
>>appropriate IPR disclosures required for full conformance with the
>>provisions of BCP 78 and BCP 79 have already been filed. Tom and
>>Gonzalo, please get back to Mary on this as soon as possible.
>> 
>> Cheers,
>> Charles
>> 
>> Cc: Roman Shpount <[email-masked]>, "[email-masked]"
>><[email-masked]>, Gonzalo Camarillo <[email-masked]>,
>>Paul Kyzivat <[email-masked]>, Tom Kristensen <[email-masked]>
>>     Cc: Roman Shpount <[email-masked]>; [email-masked]; Gonzalo
>>Camarillo <[email-masked]>; Paul Kyzivat
>><[email-masked]>; Tom Kristensen (tomkrist) <[email-masked]>
>>     So this is quite a significant change from 4583; the attributes
>>confid, userid, floorid, and bfcpver have all changed from ³token² to
>>³DIGIT². Only numeric values are now valid. In my opinion this seems
>>fine, since the relevant fields in the protocol are defined as unsigned
>>integers so in fact permitting tokens was not appropriate in the first
>>place.
>>     
>>     > It includes changes to the ABNF and corresponding editorial
>>clarifications. I realized only now that the working group was not
>>included in the discussion of these changes. Please review closely and
>>share your feedback with the list. Not much changed but it is critical
>>that we got the changes right.
>>     > 
>>     > Thanks,
>>     > Charles
>>     > 
>>     > 
>>     > From: bfcpbis <[email-masked]> on behalf of
>>"[email-masked]" <[email-masked]>
>>     >            Title           : Session Description Protocol (SDP)
>>Format for Binary Floor Control Protocol (BFCP) Streams