Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

From: Christer Holmberg <[email-masked]>
Date: Fri, 4 May 2018 12:59:11 +0000

Hi,

I have created a pull request based on Alan’s suggestion:

https://github.com/cdh4u/draft-bfcp-4583bis/pull/7

Regards,

Christer

From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Friday 4 May 2018 at 14:01
To: Alan Ford <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Charles Eckel <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi,

I can go other way, so I’d like to hear what others think.

Charles?

Regards,

Christer

From: Alan Ford <[email-masked]<mailto:[email-masked]>>
Date: Friday 4 May 2018 at 11:33
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Cc: Charles Eckel <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi,

On 4 May 2018, at 09:06, Christer Holmberg <christer.holmberg@ericsson..com<mailto:[email-masked]>> wrote:

> Ultimately the bfcpver attribute is informational; we do not specify any algorithms. Endpoints will
> decide what version to use based on what is shared and thus what is known about the peer’s capabilities.
> But it would remove any ambiguity to have this explicitly stated by both ends.

Regarding the algorithms, if the offerer indicates versions X, Y, Z, I think the answerer has to indicate a subset of those – it the answerer does not support any of the versions it should not accept the BFCP establishment. Sure, we could allow the answerer to also include versions not included by the offerer, for endpoints must use versions that both endpoints have indicated support of.

We could specify that, but as you say, there is no harm in an endpoint presenting more - the one which is used must be mutually supported. But I have no problem adding that to the 13.2 list, in order words:

 o  MUST associate a 'bfcpver' attribute with the 'm’ line, containing a subset of the versions presented in the offer.

Regards,
Alan

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 4 May 2018 14:55:32 +0000

(as an individual)
I agree with Alan’s point and the goal of the pull request. The changes for the offer look good. The changes for the answer would be clearer if the MUST statements were reorder as follows:

OLD:
When the answerer receives an offer, which contains an 'm' line describing a BFCP stream, if the answerer accepts the 'm' line it:

  *   MUST insert a corresponding 'm' line in the answer, with an identical 'm' line proto value <xref target="RFC3264"/>; and
  *   MUST, if the offer contained an SDP 'floorctrl' attribute, associate a 'floorctrl' attribute with the 'm' line; and
  *   MUST associate a 'bfcpver' attribute with the 'm' line. The answerer MUST only indcate support of BFCP versions also supported by the offerer. If the answerer does not support any of the versions supported by the offerer, the answerer MUST NOT accept the 'm' line.

NEW:
When the answerer receives an offer, which contains an 'm' line describing a BFCP stream, it MUST associate a 'bfcpver' attribute with the 'm' line. The answerer MUST only indicate support of BFCP versions also supported by the offerer. If the answerer does not support any of the versions supported by the offerer, the answerer MUST NOT accept the 'm' line.
If the answerer accepts the 'm' line it:

  *   MUST insert a corresponding 'm' line in the answer, with an identical 'm' line proto value <xref target="RFC3264"/>; and
  *   MUST, if the offer contained an SDP 'floorctrl' attribute, associate a 'floorctrl' attribute with the 'm' line.

Note, there is a typo that I fixes as well,
s/indcate/indicate

Cheers,
Charles

From: Christer Holmberg <[email-masked]>
Date: Friday, May 4, 2018 at 5:59 AM
To: Christer Holmberg <[email-masked]>, Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Charles Eckel <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

Hi,

Regards,

Christer

Hi,

Charles?

Regards,

Christer

Hi,

Regards,
Alan

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 4 May 2018 21:20:18 +0000

Hi Charles,

>(as an individual)
>I agree with Alan’s point and the goal of the pull request. The changes for the offer look good. 
>The changes for the answer would be clearer if the MUST statements were reorder as follows:
>
>OLD:
>• MUST insert a corresponding 'm' line in the answer, with an identical 'm' line proto value <xref target="RFC3264"/>; and
>• MUST, if the offer contained an SDP 'floorctrl' attribute, associate a 'floorctrl' attribute with the 'm' line; and
>• MUST associate a 'bfcpver' attribute with the 'm' line. The answerer MUST only indcate support of BFCP versions also supported by the offerer. If the answerer does not >support any of the versions supported by the offerer, the answerer MUST NOT accept the 'm' line.
>
>NEW:
>When the answerer receives an offer, which contains an 'm' line describing a BFCP stream, it MUST associate a 'bfcpver' attribute with the 'm' line. 

That doesn't work. The answerer cannot associated an attribute with the 'm' line in the offer.

However, perhaps something like:

When the answerer receives an offer, which contains an 'm' line describing a BFCP stream, the answerer MUST check whether it supports one or more of the BFCP versions supported by the offerer. If the answerer does not support any of the BFCP versions, it MUST NOT accept the 'm' line. Otherwise, if the answerer accepts the 'm' line, it: 
• MUST insert a corresponding 'm' line in the answer, with an identical 'm' line proto value <xref target="RFC3264"/>; and
• MUST, if the offer contained an SDP 'floorctrl' attribute, associate a 'floorctrl' attribute with the 'm' line; and
• MUST associate a 'bfcpver' attribute with the 'm' line. The answerer only indicates support of BFCP versions also supported by the offerer. 

>Note, there is a typo that I fixes as well,

Will be fixed.

Regards,

Christer

Hi,

Regards,

Christer

From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Friday 4 May 2018 at 14:01
To: Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Charles Eckel <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi,

Charles?

Regards,

Christer

From: Alan Ford <[email-masked]>
Date: Friday 4 May 2018 at 11:33
To: Christer Holmberg <[email-masked]>
Cc: Charles Eckel <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute

Hi, 

 

Regards,
Alan

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 4 May 2018 21:30:33 +0000

Hi Christer,

Your revised proposal works for me. One minor suggestion is to reorder the third bullet before the second, because the first and third are always required whereas the second is required only if there is a 'floorctrl' attribute.

Cheers,
Charles

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Friday, May 4, 2018 at 2:21 PM
To: Charles Eckel <[email-masked]>, Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

    Hi Charles,

    

    
    Will be fixed.
    
    Regards,
    
    Christer

    
    Hi,

    
    Regards,
    
    Christer

    Hi,

    Charles?
    
    Regards,
    
    Christer

    Hi, 

     

    
    Regards,
    Alan
    
    _______________________________________________
    bfcpbis mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 4 May 2018 21:32:23 +0000

Hi,

>Your revised proposal works for me. One minor suggestion is to reorder the third bullet >before the second, because the first and third are always required whereas the second is >required only if there is a 'floorctrl' attribute.

I can do that.

Regards,

Christer

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Friday, May 4, 2018 at 2:21 PM
To: Charles Eckel <[email-masked]>, Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

    Hi Charles,

    

    
    Will be fixed.
    
    Regards,
    
    Christer

    
    Hi,

    
    Regards,
    
    Christer

    Hi,

    Charles?
    
    Regards,
    
    Christer

    Hi, 

     

    
    Regards,
    Alan

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 4 May 2018 21:43:16 +0000

Pull request has been updated.

Regards,

Christer

-----Original Message-----
From: bfcpbis [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 04 May 2018 23:32
To: Charles Eckel (eckelcu) <[email-masked]>; Alan Ford <[email-masked]>
Cc: [email-masked]
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

Hi,

I can do that.

Regards,

Christer

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Friday, May 4, 2018 at 2:21 PM
To: Charles Eckel <[email-masked]>, Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

    Hi Charles,

    

    
    Will be fixed.
    
    Regards,
    
    Christer

    
    Hi,

    
    Regards,
    
    Christer

    Hi,

    Charles?
    
    Regards,
    
    Christer

    Hi, 

     

    
    Regards,
    Alan

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 4 May 2018 22:46:49 +0000

Looks good. Thanks.

Charles

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Friday, May 4, 2018 at 2:43 PM
To: Christer Holmberg <[email-masked]>, Charles Eckel <[email-masked]>, Alan Ford <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request

    Regards,
    
    Christer
    
    -----Original Message-----
    From: bfcpbis [mailto:[email-masked]] On Behalf Of Christer Holmberg
    Sent: 04 May 2018 23:32
    To: Charles Eckel (eckelcu) <[email-masked]>; Alan Ford <[email-masked]>
    Cc: [email-masked]
    Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request
    
    Hi,

    I can do that.
    
    Regards,
    
    Christer

    -----Original Message-----
    From: bfcpbis <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
    Date: Friday, May 4, 2018 at 2:21 PM
    To: Charles Eckel <[email-masked]>, Alan Ford <[email-masked]>
    Cc: "[email-masked]" <[email-masked]>
    Subject: Re: [bfcpbis] 4583bis: SDP bfcpver attribute - pull request
    
        Hi Charles,

        

        
        Will be fixed.
        
        Regards,
        
        Christer

        
        Hi,

        
        Regards,
        
        Christer

        Hi,

        Charles?
        
        Regards,
        
        Christer

        Hi, 

         

        
        Regards,
        Alan