Subject: [Bier] Updates to BIER MPLS Encapsulation document

From: Gregory Mirsky <[email-masked]>
Date: Mon, 18 May 2015 22:05:09 +0000

Dear Authors, et.al,
in Dallas we had good discussion of BIER Ping and Traceroute work. We, authors of the BIER Ping, believe that OAM payload definition is more in place in the draft-ietf-bier-mpls-encapsulation rather than in draft-kumarzheng-bier-ping. If you would kindly add OAM to list of Protocol values defined in the BIER Encapsulation draft, then we'll gladly reference it in BIER Ping and other BIER OAM docs.
And couple comments:

*         noticed that list of protocol values is not consecutive - 1, 2, 3, 4, ..., 6 (5 is not used);

*         I think that "This document has no actions for IANA." is not accurate as the BIER Encap draft does define set of Protocol values.

*         BIER Header has Reserved field of 16 bits long. Would you kindly consider splitting it and creating 8 bit-long Flags field, obviously maintained by IANA through a new sub-registry, and thus leaving 8 bits in the Reserved field for any possible use in the future? At least two-bit flags would be used by passive performance, loss and delay, measurement method known as marking.

Your comments, questions always greatly appreciated.

                Regards,
                                Greg

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 19 May 2015 10:30:19 +0200

Thanks Greg,

All good points.

I’ll work with Eric to get this incorporated into the MPLS encap doc.

Ice.

> On 19 May 2015, at 00:05, Gregory Mirsky <[email-masked]> wrote:
> 
> Dear Authors, et.al,
> in Dallas we had good discussion of BIER Ping and Traceroute work. We, authors of the BIER Ping, believe that OAM payload definition is more in place in the draft-ietf-bier-mpls-encapsulation rather than in draft-kumarzheng-bier-ping. If you would kindly add OAM to list of Protocol values defined in the BIER Encapsulation draft, then we’ll gladly reference it in BIER Ping and other BIER OAM docs.
> And couple comments:
> ·         noticed that list of protocol values is not consecutive – 1, 2, 3, 4, …, 6 (5 is not used);
> ·         I think that “This document has no actions for IANA.” is not accurate as the BIER Encap draft does define set of Protocol values.
> ·         BIER Header has Reserved field of 16 bits long. Would you kindly consider splitting it and creating 8 bit-long Flags field, obviously maintained by IANA through a new sub-registry, and thus leaving 8 bits in the Reserved field for any possible use in the future? At least two-bit flags would be used by passive performance, loss and delay, measurement method known as marking.
>  
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier