Subject: Re: [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

From: [email-masked]
Date: Tue, 13 Oct 2015 10:17:45 +0800

Dear all,

  A new draft about how to use BIER in data centers as well as how to 
extend IGP/BGP protocol to discovery remote NVEs in data centers to form 
the mapping between VXLAN network identifier and bitstring has been 
submitted. Wish you can pay attention to this draft and continue the 
discussion as the te-arch draft :)

  Any comments are welcome:)

Best Wishes,
Linda Wang

[email-masked] 写于 2015/10/12 17:03:30:

> [email-masked] 
> 2015/10/12 17:03
> 
> 收件人
> 
> "fangwei hu" <[email-masked]>, "Cui Wang" 
> <[email-masked]>, "Fangwei Hu" <[email-masked]>, "Zheng
> Zhang" <[email-masked]>, 
> 
> 抄送
> 
> 主题
> 
> New Version Notification for draft-wang-bier-vxlan-use-case-00.txt
> 
> 
> A new version of I-D, draft-wang-bier-vxlan-use-case-00.txt
> has been successfully submitted by Cui Wang and posted to the
> IETF repository.
> 
> Name:      draft-wang-bier-vxlan-use-case
> Revision:   00
> Title:      BIER Use Case in VxLAN
> Document date:   2015-10-11
> Group:      Individual Submission
> Pages:      16
> URL:            https://www.ietf.org/internet-drafts/draft-wang-
> bier-vxlan-use-case-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-wang-bier-
> vxlan-use-case/
> Htmlized:       
https://tools.ietf.org/html/draft-wang-bier-vxlan-use-case-00
> 
> 
> Abstract:
>    Bit Index Explicit Replication (BIER) is an architecture that
>    provides optimal multicast forwarding through a "BIER domain" without
>    requiring intermediate routers to maintain any multicast related per-
>    flow state.  BIER also does not require any explicit tree-building
>    protocol for its operation.  A multicast data packet enters a BIER
>    domain at a "Bit-Forwarding Ingress Router" (BFIR), and leaves the
>    BIER domain at one or more "Bit-Forwarding Egress Routers" (BFERs).
>    The BFIR router adds a BIER header to the packet.  The BIER header
>    contains a bit-string in which each bit represents exactly one BFER
>    to forward the packet to.  The set of BFERs to which the multicast
>    packet needs to be forwarded is expressed by setting the bits that
>    correspond to those routers in the BIER header.
> 
>    This document tries to describe the drawbacks of how BUM services are
>    deployed in current data centers, and proposes how to take full
>    advantage of BIER to implement BUM services in data centers.
> 
>  
> 
> 
> Please note that it may take a couple of minutes from the time of 
submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 13 Oct 2015 03:14:25 +0000

Hi Linda,

To form the mapping between VXLAN network identifier and bitstring, you could actually use the following two kinds of mappings: 1) the mapping between VNIs and NVEs; 2) the mapping between NVEs and BRF-ids. For the latter, there have been corresponding drafts as mentioned in your draft. As for the former (i.e., VPN/VN membership auto-discovery), it belongs to the scope of NVO3 WG. As for how to extend ISIS/OSPF for VPN/VN membership auto-discovery, there was a related draft (https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-00#page-4). Unfortunately, it seems that the NVo3 WG has no interest in defining ISIS/OSPF based distributed control plane protocols up till now.

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, October 13, 2015 10:18 AM
To: [email-masked]
Cc: Cui Wang; Zheng Zhang; fangwei hu
Subject: Re: [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Dear all,

  A new draft about how to use BIER in data centers as well as how to extend IGP/BGP protocol to discovery remote NVEs in data centers to form the mapping between VXLAN network identifier and bitstring has been submitted. Wish you can pay attention to this draft and continue the discussion as the te-arch draft :)

Best Wishes,
Linda Wang

[email-masked]<mailto:[email-masked]> 写于 2015/10/12 17:03:30:

> [email-masked]<mailto:[email-masked]>
> 2015/10/12 17:03
>
> 收件人
>
> "fangwei hu" <[email-masked]<mailto:[email-masked]>>, "Cui Wang"
> <[email-masked]<mailto:[email-masked]>>, "Fangwei Hu" <[email-masked]<mailto:[email-masked]>>, "Zheng
> Zhang" <[email-masked]<mailto:[email-masked]>>,
>
> 抄送
>
> 主题
>
> Htmlized:       https://tools.ietf.org/html/draft-wang-bier-vxlan-use-case-00
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of submission

---

From: Andrew Qu <[email-masked]>
Date: Tue, 13 Oct 2015 05:00:50 +0000

Hi Linda,

Thanks for writing up this draft.  As VxLAN/NvGRE/DOVE all dataplanes are using
similar technology to support L2 over L3,  how about using one draft to take care of all similar
data planes.

How about change the specific VxLAN network Identifier field into two sections:

1)      protocol [vxLAN/vxlanGPE/nvGRE/DOVE etc]

2)      BUM domain like VNI/TSI, but may be more general  term can be used.

Just my 2 cents!

Thanks,

Andrew

0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |    Type       |   Length      |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |           VXLAN Network Identifier            |     Res       |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, October 12, 2015 7:18 PM
To: [email-masked]
Cc: Cui Wang; Zheng Zhang; fangwei hu
Subject: Re: [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Dear all,

Best Wishes,
Linda Wang

---

From: [email-masked]
Date: Tue, 13 Oct 2015 15:16:10 +0800

Hi Xiaohu,

  Thanks very much for your comments and clarification.

  As mentioned in bier-use-cases, there is no doubt that BIER can be used 
in NVO3 efficiently to steer BUM traffic. As the foundation of BIER in 
NVO3, then extends the BIER control plane to carry VXLAN-specific 
information to form the mapping between VXLAN network identifier and 
bitstring. This stands to reason. 
 
  On the other hand, you mentioned a related draft and I read it, I find 
it is kind of differentiated from my draft. Your draft aims to extend 
IS-IS to support NVEs auto-discovery, after that, each NVE knows where the 
other NVEs are, then use ingress replication or other methods to forward 
the BUM traffic. 

  So we still would like to say IGP/BGP extension for VXLAN-specific 
information together with BIER-specific information is an interesting 
method in NVO3 :)

  Thanks,

Best Wishes,
Linda Wang

Hi Linda,
 
To form the mapping between VXLAN network identifier and bitstring, you 
could actually use the following two kinds of mappings: 1) the mapping 
between VNIs and NVEs; 2) the mapping between NVEs and BRF-ids. For the 
latter, there have been corresponding drafts as mentioned in your draft. 
As for the former (i.e., VPN/VN membership auto-discovery), it belongs to 
the scope of NVO3 WG. As for how to extend ISIS/OSPF for VPN/VN membership 
auto-discovery, there was a related draft (
https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-00#page-4). 
Unfortunately, it seems that the NVo3 WG has no interest in defining 
ISIS/OSPF based distributed control plane protocols up till now.
 
Best regards,
Xiaohu
 
From: BIER [mailto:[email-masked]] On Behalf Of 
[email-masked]
Sent: Tuesday, October 13, 2015 10:18 AM
To: [email-masked]
Cc: Cui Wang; Zheng Zhang; fangwei hu
Subject: Re: [Bier] New Version Notification for 
draft-wang-bier-vxlan-use-case-00.txt
 
Dear all, 

Best Wishes, 
Linda Wang

submission
> _______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier

---

From: [email-masked]
Date: Tue, 13 Oct 2015 15:19:33 +0800

Hi Andrew,

  Thanks very much for your appreciated comments. 

  I agree with your suggestions, as no matter what dataplanes are used to 
support L2 over L3, the control plane can use the same method in my draft 
to advertise these dataplanes informaiton. I would update your suggestions 
in the next version. 

  Thanks very much:)

Best,
Linda

Hi Linda,
 
Thanks for writing up this draft.  As VxLAN/NvGRE/DOVE all dataplanes are 
using
similar technology to support L2 over L3,  how about using one draft to 
take care of all similar
data planes.
 
How about change the specific VxLAN network Identifier field into two 
sections:
 
1)      protocol [vxLAN/vxlanGPE/nvGRE/DOVE etc]
2)      BUM domain like VNI/TSI, but may be more general  term can be 
used.
 
Just my 2 cents!
 
Thanks,
 
Andrew

 
Dear all, 

Best Wishes, 
Linda Wang

submission
> until the htmlized version and diff are available at tools.ietf.org.

************* Email Confidentiality Notice ********************
The information contained in this e-mail message (including any 
attachments) may be confidential, proprietary, privileged, or otherwise
exempt from disclosure under applicable laws. It is intended to be 
conveyed only to the designated recipient(s). Any use, dissemination, 
distribution, printing, retaining or copying of this e-mail (including its 

attachments) by unintended recipient(s) is strictly prohibited and may 
be unlawful. If you are not an intended recipient of this e-mail, or 
believe 
that you have received this e-mail in error, please notify the sender 
immediately (by replying to this e-mail), delete any and all copies of 
this e-mail (including any attachments) from your system, and do not
disclose the content of this e-mail to any other person. Thank you!

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 13 Oct 2015 07:45:57 +0000

Hi Linda,

You could piggyback the VN info on the BIER info. However, it would result in unnecessary data redundancy since there may be multiple <sub-domain, BFR-id> pairs for a given BFR/NVE.

Best regards,
Xiaohu

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 13, 2015 3:16 PM
To: Xuxiaohu
Cc: [email-masked]; BIER; fangwei hu; [email-masked]; Zheng Zhang
Subject: Re: [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Hi Xiaohu,

  As mentioned in bier-use-cases, there is no doubt that BIER can be used in NVO3 efficiently to steer BUM traffic. As the foundation of BIER in NVO3, then extends the BIER control plane to carry VXLAN-specific information to form the mapping between VXLAN network identifier and bitstring. This stands to reason.

  On the other hand, you mentioned a related draft and I read it, I find it is kind of differentiated from my draft. Your draft aims to extend IS-IS to support NVEs auto-discovery, after that, each NVE knows where the other NVEs are, then use ingress replication or other methods to forward the BUM traffic.

  So we still would like to say IGP/BGP extension for VXLAN-specific information together with BIER-specific information is an interesting method in NVO3 :)

  Thanks,

Best Wishes,
Linda Wang

Hi Linda,

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, October 13, 2015 10:18 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Cui Wang; Zheng Zhang; fangwei hu
Subject: Re: [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Dear all,

Best Wishes,
Linda Wang

> [email-masked]<mailto:[email-masked]>
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: [email-masked]
Date: Tue, 13 Oct 2015 16:09:34 +0800

Hi Xiaohu,
    If a given BFR/NVE is in multiple sub-domain, then the info that is 
carried
is necessary I think.

Best regards,
Sandy

Xuxiaohu <[email-masked]> 写于 2015/10/13 15:45:57:

> Hi Linda,
> 
> You could piggyback the VN info on the BIER info. However, it would 
> result in unnecessary data redundancy since there may be multiple 
> <sub-domain, BFR-id> pairs for a given BFR/NVE.
> 
> Best regards,
> Xiaohu
> 
>   As mentioned in bier-use-cases, there is no doubt that BIER can be
> used in NVO3 efficiently to steer BUM traffic. As the foundation of 
> BIER in NVO3, then extends the BIER control plane to carry VXLAN-
> specific information to form the mapping between VXLAN network 
> identifier and bitstring. This stands to reason. 
> 
>   On the other hand, you mentioned a related draft and I read it, I 
> find it is kind of differentiated from my draft. Your draft aims to 
> extend IS-IS to support NVEs auto-discovery, after that, each NVE 
> knows where the other NVEs are, then use ingress replication or 
> other methods to forward the BUM traffic. 
> 
> information together with BIER-specific information is an 
> interesting method in NVO3 :) 
> 
>   Thanks, 
> 
> Best Wishes, 
> Linda Wang
> 
> 
> 
> 
> 
> 
> Hi Linda, 
> 
> To form the mapping between VXLAN network identifier and bitstring, 
> you could actually use the following two kinds of mappings: 1) the 
> mapping between VNIs and NVEs; 2) the mapping between NVEs and BRF-
> ids. For the latter, there have been corresponding drafts as 
> mentioned in your draft. As for the former (i.e., VPN/VN membership 
> auto-discovery), it belongs to the scope of NVO3 WG. As for how to 
> extend ISIS/OSPF for VPN/VN membership auto-discovery, there was a 
> related draft 
(https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-00#page-4
> ). Unfortunately, it seems that the NVo3 WG has no interest in 
> defining ISIS/OSPF based distributed control plane protocols up till 
now. 
[email-masked]
> extend IGP/BGP protocol to discovery remote NVEs in data centers to 
> form the mapping between VXLAN network identifier and bitstring has 
> been submitted. Wish you can pay attention to this draft and 
> continue the discussion as the te-arch draft :) 
> 
submission

---

From: [email-masked]
Date: Tue, 13 Oct 2015 16:10:38 +0800

Hi Xiaohu,

Best regards,
Sandy

now. 
[email-masked]
submission
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 13 Oct 2015 09:01:29 +0000

Hi Sandy,

I agree that there should be a certain mapping between VN and sub-domain in order to keep replications of a given BUM packet as less as possible (i.e., try to assign the same sub-domain ID to all NVEs of a given VN). However, wouldn’t it be better to attach the sub-domain info to the VN info TLV as a sub-TLV? In this way, the above VN info is useful not only to BIER mode but also to ingress replication mode. Of course, in the ingress replication mode, there is no need to attach the sub-domain info to the VN info TLV anymore.

Best regards,
Xiaohu

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 13, 2015 4:11 PM
To: Xuxiaohu
Cc: [email-masked]; BIER; fangwei hu; [email-masked]; nvo3; [email-masked]
Subject: 答复: Re: [nvo3] [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Hi Xiaohu,
    If a given BFR/NVE is in multiple sub-domain, then the info that is carried
is necessary I think.

Best regards,
Sandy

"nvo3" <[email-masked]<mailto:[email-masked]>> 写于 2015/10/13 15:45:57:

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
> Cc: [email-masked]<mailto:[email-masked]>; BIER; fangwei hu; [email-masked]<mailto:[email-masked]>; Zheng Zhang
> related draft (https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-00#page-4
> defining ISIS/OSPF based distributed control plane protocols up till now.
>
> Best regards,
> Xiaohu
>
> [email-masked]<mailto:[email-masked]>

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 13 Oct 2015 09:17:24 +0000

By the way, the VN info could be carried as a new sub-TLV of the Extended Prefix TLV as defined in [I-D.ietf-ospf-prefix-link-attr<https://tools.ietf.org/html/draft-ietf-bier-ospf-bier-extensions-00#ref-I-D.ietf-ospf-prefix-link-attr>]) in the OSPF case or a new sub-TLV of the Extended Reachability TLVs in the ISIS case, or a sub-TLV of the ISIS Route Capability TLV or a TLV of the OSPF RI LSA.

Best regards,
Xiaohu

From: Xuxiaohu
Sent: Tuesday, October 13, 2015 5:01 PM
To: [email-masked]'
Cc: [email-masked]; BIER; fangwei hu; [email-masked]; nvo3; [email-masked]
Subject: RE: Re: [nvo3] [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Hi Sandy,

Best regards,
Xiaohu

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 13, 2015 4:11 PM
To: Xuxiaohu
Cc: [email-masked]<mailto:[email-masked]>; BIER; fangwei hu; [email-masked]<mailto:[email-masked]>; nvo3; [email-masked]<mailto:[email-masked]>
Subject: 答复: Re: [nvo3] [Bier] New Version Notification for draft-wang-bier-vxlan-use-case-00.txt

Hi Xiaohu,

Best regards,
Sandy

---

From: [email-masked]
Date: Wed, 14 Oct 2015 14:07:46 +0800

Hi Xiaohu,

  As mentioned in draft(
http://tools.ietf.org/id/draft-wang-bier-vxlan-use-case-00.txt), BUM 
traffic in data center virtualization is one significant use case of BIER. 
So focusing on how to extend BIER to support BUM in data centers seems 
more reasonable for me :) 
 
  Thanks,

Best wishes,
Linda

By the way, the VN info could be carried as a new sub-TLV of the Extended 
Prefix TLV as defined in [I-D.ietf-ospf-prefix-link-attr]) in the OSPF 
case or a new sub-TLV of the Extended Reachability TLVs in the ISIS case, 
or a sub-TLV of the ISIS Route Capability TLV or a TLV of the OSPF RI LSA.
 
Best regards,
Xiaohu
 
From: Xuxiaohu 
Sent: Tuesday, October 13, 2015 5:01 PM
To: [email-masked]'
Cc: [email-masked]; BIER; fangwei hu; [email-masked]; nvo3; 
[email-masked]
Subject: RE: Re: [nvo3] [Bier] New Version Notification for 
draft-wang-bier-vxlan-use-case-00.txt
 
Hi Sandy,
 
I agree that there should be a certain mapping between VN and sub-domain 
in order to keep replications of a given BUM packet as less as possible 
(i.e., try to assign the same sub-domain ID to all NVEs of a given VN). 
However, wouldn’t it be better to attach the sub-domain info to the VN 
info TLV as a sub-TLV? In this way, the above VN info is useful not only 
to BIER mode but also to ingress replication mode. Of course, in the 
ingress replication mode, there is no need to attach the sub-domain info 
to the VN info TLV anymore.
 
Best regards,
Xiaohu
 
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 13, 2015 4:11 PM
To: Xuxiaohu
Cc: [email-masked]; BIER; fangwei hu; [email-masked]; nvo3; 
[email-masked]
Subject: 答复: Re: [nvo3] [Bier] New Version Notification for 
draft-wang-bier-vxlan-use-case-00.txt

Hi Xiaohu, 

Best regards, 
Sandy

"nvo3" <[email-masked]> 写于 2015/10/13 15:45:57:

> related draft (
https://tools.ietf.org/html/draft-xu-nvo3-isis-cp-00#page-4
now. 
[email-masked]
submission