Subject: [Bier] comments on draft-prz-bier-bfrid-assignment-00

From: [email-masked]
Date: Mon, 26 Oct 2015 15:03:01 +0800

Hi Tony,

    The BFR-id allocation of IGP is efficient and reasonable. For
the uniformation with BIER-Arch, I have a suggestion:

    In the new version of BIER-Arch, section 6.10, for different 
BFR may use different BitStringLength, there are two types of BSL,
Imposition BSL and Disposition BSL. In general the Disposition BSL 
is a combination, and include the Imposition BSL. 

    In my opinion, in one sub-domain, the more unified of BSL, 
the more efficient forwarding there will be. So the BSL of 
forwarding should be uniform as much as possible.

    Since DR of IGP collects all the information of BIER nodes, DR
can also collect the Disposition BSLs of every node. The DR selects 
the most resonable and popular BSL in one domain, and notifies every 
node the BSL value. Then the major nodes will all use the negotiatory 
BSL to forward multicast flow.

Best regards,
Sandy

---

From: Antoni Przygienda <[email-masked]>
Date: Mon, 26 Oct 2015 17:53:43 +0000

Hi Tony,

    The BFR-id allocation of IGP is efficient and reasonable.

[Tony saiz:] thanks, I let the draft expire but I see already multiple parties asking for automatic BFR-id assignment and beside a centralized approach such an IGP election has its charm so I guess it will revive in its time.

For the uniformation with BIER-Arch, I have a suggestion:

[Tony saiz:] a 'most reasonable and popular' is not much of a criteria to ever get consensus in anything from my experience ;-)

The stuff I wrote was picking the largest supported by e'one since those will be always most efficient in terms of minimizing copies

n  Tony