Subject: [Bier] comment on draft-anish-bier-overlay-pim-00

From: Tony Przygienda <[email-masked]>
Date: Wed, 21 Oct 2015 15:52:34 +0300

Read that up quickly and two observations:

a) I don't see a need for the E-bit, either the BFR-ID is visible in the
routing underlay (IGP) or not. Setting the E bit if there is none doesn't
help, not setting it when present seems to serve no purpose ?
b) sub-domains are forgotten unless the draft supports only a single,
well-known sub-domain (to be specified in the draft). BFR-id is per
sub-domain and so on.

--- tony

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: Anish Peter <[email-masked]>
Date: Wed, 21 Oct 2015 21:44:36 +0530

Hi Tony,
  Thanks for sharing you observations. Please see inline for response.

On 10/21/15 6:22 PM, Tony Przygienda wrote:
> a) I don't see a need for the E-bit, either the BFR-ID is visible in 
> the routing underlay (IGP) or not. Setting the E bit if there is none 
> doesn't help, not setting it when present seems to serve no purpose ?
AP> The field in the hello tlv is BIER-prefix and not BIER-ID. A router 
participating in BIER forwarding but is not egress may not have a 
BIER-ID, but will have BIER-prefix. Hence this flag helps.
> well-known sub-domain (to be specified in the draft). BFR-id is per 
AP> This overlay model uses BIER-prefix alone which is unique across all 
the bier domains. Resolving BIER-prefix to sub-domain and BIER-ID is 
considered as a functionality to be achieved with the information from 
underlay.

Thanks,
Anish
>
> --- tony
>
> -- 
> /We’ve heard that a million monkeys at a million keyboards could 
> produce the complete works of Shakespeare; now, thanks to the 
> Internet, we know that is not true.//
> /
> —Robert Wilensky
>
>
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 22 Oct 2015 07:34:33 +0000

a) I don't see a need for the E-bit, either the BFR-ID is visible in the routing underlay (IGP) or not. Setting the E bit if there is none doesn't help, not setting it when present seems to serve no purpose ?
AP> The field in the hello tlv is BIER-prefix and not BIER-ID. A router participating in BIER forwarding but is not egress may not have a BIER-ID, but will have BIER-prefix. Hence this flag helps.
[Tony saiz:] I don't see how those two things relate to each other. You always have a prefix, yes, under that you have BFR-id per sub-domain and that  is basically your 'e' bit you can derive from underlay. The bit seems redundant and may contradict the underlay easily

b) sub-domains are forgotten unless the draft supports only a single, well-known sub-domain (to be specified in the draft). BFR-id is per sub-domain and so on.
AP> This overlay model uses BIER-prefix alone which is unique across all the bier domains. Resolving BIER-prefix to sub-domain and BIER-ID is considered as a functionality to be achieved with the information from underlay.
[Tony saiz:] This does not compute. Different sub-domains will have different BFER-IDs for the _same_ prefix.

I suggest to look @ TLV encodings in ISIS closely & think how you'll translate per sub-domain (unless you reserve a well-known sub-domain for this work but then you run a very limited overlay and that needs spelling out in the spec)

n  Tony