Subject: [Bier] draft-kumarzheng-bier-ping-03

From: Xuxiaohu <[email-masked]>
Date: Sat, 24 Sep 2016 03:21:23 +0000

Hi co-authors of this draft,

I'm curious to know the rationale of the choice that " BIER OAM is defined in a way that it stays within BIER layer by following directly the BIER header without mandating the need for IP header." In other words, what's the real benefit of eliminating the IP header? Anyway, you would need IP protocol stack on each BFR, especially for reply mode 2 (i.e., Reply via IPv4/IPv6 UDP packet). In addition, I'm also wondering the necessity of Reply mode 3 (i.e., Reply via BIER packet). In other words, why does "the Initiator intend to validate the return BIER path" since the forward and return BIER paths between two BFRs may be totally asymmetric?

Best regards,
Xiaohu

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 23 Sep 2016 20:41:55 -0700

Hi Xiaohu,
thank you for your thoughtful questions.
Ensuring that active OAM is in-band with data, i.e. is fate-sharing, being
monitored significantly simplifies defect localization.
For the case of MPLS encapsulation preserving IP header has no apparent
benefit as BIER header carries BFIR ID.
As RFC 7110 demonstrated, there are benefits of controlling path used for
Echo Reply. I think that in the future version we'll provide more details
regarding use of different Reply modes.

Regards,
Greg

On Fri, Sep 23, 2016 at 8:21 PM, Xuxiaohu <[email-masked]> wrote:

> I’m curious to know the rationale of the choice that “ BIER OAM is defined
> in a way that it stays within BIER layer by following directly the BIER
> header without mandating the need for IP header.” In other words, what’s
> the real benefit of eliminating the IP header? Anyway, you would need IP
> protocol stack on each BFR, especially for reply mode 2 (i.e., Reply via
> IPv4/IPv6 UDP packet). In addition, I’m also wondering the necessity of
> Reply mode 3 (i.e., Reply via BIER packet). In other words, why does “the
> Initiator intend to validate the return BIER path” since the forward and
> return BIER paths between two BFRs may be totally asymmetric?
>
>
>
> Best regards,
>
> Xiaohu
>
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 24 Sep 2016 03:49:08 +0000

BTW, I’m also wondering the real value of the BIER traceroute functionality in real BIER networks.

It said in the draft that

“In trace route mode, Initiator MAY
   include Target SI-Bitstring TLV to control the path trace towards any
   specific BFER or set of BFERs.”

When initiator performs traceroute towards more than one BFER, how could it construct a trace path of a tree? When initiator performs traceroute towards a single BFER, the trace path may be totally different from the real path of a BIER packet could containing that BFER and other BFERs, so what’s the real value of BIER traceroute in practice?

Best regards,
Xiaohu

发件人: BIER [mailto:[email-masked]] 代表 Xuxiaohu
发送时间: 2016年9月24日 11:21
收件人: [email-masked]
主题: [Bier] draft-kumarzheng-bier-ping-03

I’m curious to know the rationale of the choice that “ BIER OAM is defined in a way that it stays within BIER layer by following directly the BIER header without mandating the need for IP header.” In other words, what’s the real benefit of eliminating the IP header? Anyway, you would need IP protocol stack on each BFR, especially for reply mode 2 (i.e., Reply via IPv4/IPv6 UDP packet). In addition, I’m also wondering the necessity of Reply mode 3 (i.e., Reply via BIER packet). In other words, why does “the Initiator intend to validate the return BIER path” since the forward and return BIER paths between two BFRs may be totally asymmetric?

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 24 Sep 2016 04:08:29 +0000

Hi Greg,

Thanks for your response.

Although BIER has the BFIR-id, it seems much simpler and consistent to keep the request and reply message within the same format.

If I understand RFC7110 correctly, it’s only applicable in the directional LSP case. However, is there any directional path concept in the BIER case?

Best regards,
Xiaohu

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2016年9月24日 11:42
收件人: Xuxiaohu
抄送: [email-masked]
主题: Re: [Bier] draft-kumarzheng-bier-ping-03

Hi Xiaohu,
thank you for your thoughtful questions.
Ensuring that active OAM is in-band with data, i.e. is fate-sharing, being monitored significantly simplifies defect localization.
For the case of MPLS encapsulation preserving IP header has no apparent benefit as BIER header carries BFIR ID.
As RFC 7110 demonstrated, there are benefits of controlling path used for Echo Reply. I think that in the future version we'll provide more details regarding use of different Reply modes.

Regards,
Greg

On Fri, Sep 23, 2016 at 8:21 PM, Xuxiaohu <[email-masked]<mailto:[email-masked]>> wrote:
Hi co-authors of this draft,

Best regards,
Xiaohu

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 24 Sep 2016 06:42:17 +0000

s/ directional/bidirectional.

发件人: BIER [mailto:[email-masked]] 代表 Xuxiaohu
发送时间: 2016年9月24日 12:08
收件人: Greg Mirsky
抄送: [email-masked]
主题: [Bier] 答复: draft-kumarzheng-bier-ping-03

Hi Greg,

Best regards,
Xiaohu

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2016年9月24日 11:42
收件人: Xuxiaohu
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [Bier] draft-kumarzheng-bier-ping-03

Hi Xiaohu,

Regards,
Greg

Best regards,
Xiaohu

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Sat, 24 Sep 2016 12:26:06 +0000

HI Xuxiaho,

As Greg mentioned, the basic intention is to have it in-band to data traffic and avoid any other layer dependency if and when BIER layer in itself can handle it. BIER header carries sufficient information that can be used for OAM request/response and so we leveraged it and avoid depending on other layer.

Thanks,
Nagendra

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Xuxiaohu <[email-masked]<mailto:[email-masked]>>
Date: Saturday, September 24, 2016 at 12:08 AM
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Bier] 答复: draft-kumarzheng-bier-ping-03

Hi Greg,

Best regards,
Xiaohu

Hi Xiaohu,

Regards,
Greg

Best regards,
Xiaohu