Subject: [Bier] Interim WG Day 1 minutes

From: Greg Shepherd <[email-masked]>
Date: Wed, 28 Sep 2016 08:19:11 -0700

shep: Agenda
 linda: add draft-wang-bier-ethernet
all: accepted

shep: status
 tony: encaps must stand the test of time.
 shep: new encaps can be added
 shep: separate; arch, encap, encode.
  tony: orthogonal
  tony: encode is important for HW.

shep: charter - one more encap because it's experimental. push back on
charter for another?
justify going to standards, then
what is the encap that gives us customer uptake and path to standards track.

shep: current status
 MPLS:
 use-cases covered:
  mvpn. DETNET, EVPM, IPTV. MLDP-in-band signalling.

 use-cases not covered.
   DC:(storage, VXLAN).
   Enterprise
   homenet - (Dino,Tony:mcast DV in babel)

stig: should we force deployments to have MPLS?
shep: not about forcing it's about finding another encap to meet as
many deployments as possible.

UDP: dst-port=BIER, src-port:entropy. equivalent to BIER
ehtertype. imposed hop-by-hop => no check-sums. BIER hdr not too deep
in pkt.

Dino: DC is 4 and 6 only.
Dino. BIER server to server in DC. leafs do BIER, spoine does
not. does that require BIER over IP. tunnels are evil.
shep: dynamic overlay.
tony: arch supports auto tunneling through non-supported node.

lunch break

Sandy: presents VXLAN.
ice: draft for MLD membership. good for samll deployments
dino: overlay signalling must scale.
ice: use BGP for scale.
shep: BIER does not dictate membership signalling.
shep: Ice and Sandy to collaborate on future MLD draft.

Linda: BIER-ethernet draft.
 shep: consider draft-xu-bier
 dino: many fields same as IP header
 tony: BS,SD, BSL, should not be in the packet - it's CP
 info. don't couple them.
 dino: in BIER unicast is a special case of multicast.
 all: agree new next-hop proto registry.
 tony & Ice; same capabilities as BIER-MPLS plus 6-bit DS.
 toerless: is there a technical argument for I and SD in the header
 .... silence.

Pierre: IPv6 Encap.
 dino: can you reconstruct a v6 mcast addr at the BFER?
   pierre: yes, mcast addr only few sig-bits. copy them to the end.
alia: what are the reasons for this IPv6 mechanism over others.

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 28 Sep 2016 09:14:31 -0700

Blue sheet Day 1:

Greg S/CSCO
Tony P/JNPR
Linda, Sandy/ZTE
Pierre Pfister/CSCO
Stig Venaas/CSCO
Nagendra Kumar/CSCO
Mahesh Shivkumar
Jeffrey Z./JNPR
Ice/CSCO
Greg Mirsky/?
Alia/JNPR
Jeff T/?
Toerless/?
Dino/?
Neale Ranns/CSCO

On Wed, Sep 28, 2016 at 8:19 AM, Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky