Subject: [Bier] encap in DC

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 27 Sep 2016 19:55:18 +0000

Hi Dino,

What to follow up on the discussion in this morning's interim meeting whether/why BIER-ether may not be liked by DC operators.

You mentioned that DC operators may only want to work with IP (v4/v6) and they want to be able to continue to use IP tools like ping/traceroute.

To clarify, with BIER-ether it'd still be IP based: the payload is IP (with IP mcast header) enclosed in BIER enclosed in Ether. IP ping/traceroute will still work, and there will be BIER specific ping/traceroute extensions to figure out the reachability/paths at BIER layer.

Even if we use BIER-ipv6, there will still be need for BIER specific ping/traceroute tools.

Jeffrey

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 27 Sep 2016 14:17:10 -0700

> You mentioned that DC operators may only want to work with IP (v4/v6) and they want to be able to continue to use IP tools like ping/traceroute.

Right.

> To clarify, with BIER-ether it'd still be IP based: the payload is IP (with IP mcast header) enclosed in 

"IP based" means that a BIER message would be *inside* an IP header that was inside an ethertype of 0x0800 or 0x86dd. “BIER-ether” means that an ethertype would be allocated for a BIER header.

I think from a hardware point of view, and for vendor efficiency, an ethertype would probably be a good way to go. But the message to customers is that Bier is a layer-3 protocol and is not subject to the same forwarding behavior as an L2 switch would perform.

That is “Bier is routable”, meaning it is hop by hop forwarding.

> BIER enclosed in Ether. IP ping/traceroute will still work, and there will be BIER specific ping/traceroute extensions to figure out the reachability/paths at BIER layer.

If Bier, using this header definition:

was run over its own ethertype, would NOT allow traceroute to work. Since traceroute uses TTL decrement as a procedure to invoke return ICMP messages. The above Bier header has no TTL.

So you could only use existing traceroute if there was a IP protocol codepoint for Bier and it run over IPv4 and IPv6.

Dino

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 27 Sep 2016 14:33:35 -0700

MPLS carrying this encaps has TTL ...

On Tue, Sep 27, 2016 at 2:17 PM, Dino Farinacci <[email-masked]> wrote:

> Hi Dino,
>
>
> What to follow up on the discussion in this morning's interim meeting
> whether/why BIER-ether may not be liked by DC operators.
>
> You mentioned that DC operators may only want to work with IP (v4/v6) and
> they want to be able to continue to use IP tools like ping/traceroute.
>
>
> Right.
>
> "IP based" means that a BIER message would be *inside* an IP header that
> was inside an ethertype of 0x0800 or 0x86dd. “BIER-ether” means that an
> ethertype would be allocated for a BIER header.
>
> I think from a hardware point of view, and for vendor efficiency, an
> ethertype would probably be a good way to go. But the message to customers
> is that Bier is a layer-3 protocol and is not subject to the same
> forwarding behavior as an L2 switch would perform.
>
> BIER enclosed in Ether. IP ping/traceroute will still work, and there will
> be BIER specific ping/traceroute extensions to figure out the
> reachability/paths at BIER layer.
>
>
> was run over its own ethertype, would NOT allow traceroute to work. Since
> traceroute uses TTL decrement as a procedure to invoke return ICMP
> messages. The above Bier header has no TTL.
>
> So you could only use existing traceroute if there was a IP protocol
> codepoint for Bier and it run over IPv4 and IPv6.
>
> Dino
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 27 Sep 2016 21:34:25 +0000

Hi Dino,

Please see zzh> below.

From: Dino Farinacci [mailto:[email-masked]]
Sent: Tuesday, September 27, 2016 5:17 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] encap in DC

Hi Dino,

Right.

Zzh> To clarify, when I said “IP based” I meant that the payload is still IP (enclosed in BIER then in Ether). With that, existing IP tools can still be used, and BIER tools will handle BIER specific things.

Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is that it does not require MPLS signaling and forwarding. BIER signaling/forwarding infrastructure is required regardless whether it’s BIER-mpls or BIER-ipv6 or BIER-ether.

Zzh> Yes; and tunneling can still be used.

Zzh> That is BIER-mpls, and the BIER-label preceding the header has TTL. There is already a draft on how BIER ping/traceroute is done.

Zzh> For BIER-ether, both draft-xu-bier-encapsulation and draft-wang-bier-ethernet has TTL in the BIER header, and the BIER ping/traceroute draft based on BIER-mpls can be adapted to BIER-ether as well.

Jeffrey

Dino

Jeffrey

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 27 Sep 2016 14:36:23 -0700

Yes, but Jeff was comparing Bier in IP or Bier in Ethernet only.

Dino

> On Sep 27, 2016, at 2:33 PM, Tony Przygienda <[email-masked]> wrote:
> 
> We’ve heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true.
> —Robert Wilensky

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 27 Sep 2016 14:38:06 -0700

Data centers will have the same reaction to adding another ethertype forwarding plane, if it is a Bier ethertype or an MPLS ethertype, it will react the same way. 

Putting Bier in IP, allows them to keep their core running with two substrates, a dual-stack substrate, IPv4 and IPv6.

Dino

> On Sep 27, 2016, at 2:34 PM, Jeffrey (Zhaohui) Zhang <[email-masked]> wrote:
> 
> Hi Dino,
>  
> Please see zzh> below.
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 27 Sep 2016 21:58:47 +0000

Hi Dino,

Not sure if they'd react the same as to MPLS, which requires its own forwarding infrastructure. As I mentioned below:

> > Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is that it
> does not require MPLS signaling and forwarding. BIER signaling/forwarding
> infrastructure is required regardless whether it’s BIER-mpls or BIER-ipv6
> or BIER-ether.

Notice that BIER-either does not require additional signaling/forwarding compared to BIER-ipv6. If an operator does not like another ethertype, he might also not like having to turn on IPv6 just to do BIER?

Jeffrey

> -----Original Message-----
> Sent: Tuesday, September 27, 2016 5:38 PM
> Data centers will have the same reaction to adding another ethertype
> forwarding plane, if it is a Bier ethertype or an MPLS ethertype, it will
> react the same way.
> 
> Putting Bier in IP, allows them to keep their core running with two
> substrates, a dual-stack substrate, IPv4 and IPv6.
> 
> Dino
> 
> > You mentioned that DC operators may only want to work with IP (v4/v6)
> and they want to be able to continue to use IP tools like ping/traceroute.
> >
> > Right.
> >
> >
> > Zzh> To clarify, when I said “IP based” I meant that the payload is
> still IP (enclosed in BIER then in Ether). With that, existing IP tools
> can still be used, and BIER tools will handle BIER specific things.
> >
> > Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is that it
> does not require MPLS signaling and forwarding. BIER signaling/forwarding
> infrastructure is required regardless whether it’s BIER-mpls or BIER-ipv6
> or BIER-ether.
> >
> > BIER enclosed in Ether. IP ping/traceroute will still work, and there
> will be BIER specific ping/traceroute extensions to figure out the
> > was run over its own ethertype, would NOT allow traceroute to work.
> Since traceroute uses TTL decrement as a procedure to invoke return ICMP
> > Zzh> That is BIER-mpls, and the BIER-label preceding the header has TTL.
> There is already a draft on how BIER ping/traceroute is done.
> >
> > Zzh> For BIER-ether, both draft-xu-bier-encapsulation and draft-wang-
> bier-ethernet has TTL in the BIER header, and the BIER ping/traceroute
> draft based on BIER-mpls can be adapted to BIER-ether as well.
> >
> > Jeffrey
> >
> > Dino
> >
> >

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 27 Sep 2016 15:04:59 -0700

The problem is simple from a data center operator point of view. And it would be stated like this:

“I already run IPv4/IPv6 in my network. I want Bier for efficient replication and state reduction but I want it on top of IPv4 and IPv6”.

The above data center operator IS NOT running MPLS. And doesn’t want to add it to their network.

Dino

> On Sep 27, 2016, at 2:58 PM, Jeffrey (Zhaohui) Zhang <[email-masked]> wrote:
> 
> Hi Dino,
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 27 Sep 2016 22:08:12 +0000

I am not saying adding MPLS to their network.
I am saying adding BIER-ether encap, which does NOT require additional signaling/forwarding semantics compared to BIER-ipv6.

Jeffrey

> Sent: Tuesday, September 27, 2016 6:05 PM
> “I already run IPv4/IPv6 in my network. I want Bier for efficient
> replication and state reduction but I want it on top of IPv4 and IPv6”.
> 
> > Not sure if they'd react the same as to MPLS, which requires its own
> forwarding infrastructure. As I mentioned below:
> >
> > Notice that BIER-either does not require additional signaling/forwarding
> compared to BIER-ipv6. If an operator does not like another ethertype, he
> might also not like having to turn on IPv6 just to do BIER?
> >
> > Jeffrey
> >
> >>> On Sep 27, 2016, at 2:34 PM, Jeffrey (Zhaohui) Zhang
> <[email-masked]>
> >> wrote:
> >>>
> >>> Hi Dino,
> >>>
> >>> Please see zzh> below.
> >>>

---

From: David Mozes <[email-masked]>
Date: Wed, 28 Sep 2016 07:02:58 +0000

Also we found that the minimum 256 bits  bitsring is not that easy from flex HW point of view  
More flexible option will help on that as well  

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of Jeffrey (Zhaohui) Zhang
Sent: Wednesday, September 28, 2016 1:08 AM
To: Dino Farinacci <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] encap in DC

Jeffrey

> > On Sep 27, 2016, at 2:58 PM, Jeffrey (Zhaohui) Zhang 
> > <[email-masked]>
> wrote:
> >
> > Hi Dino,
> >
> >>> Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is 
> >>> Zzh> that it
> >> infrastructure is required regardless whether it’s BIER-mpls or 
> >> BIER-
> ipv6
> >> or BIER-ether.
> >
> compared to BIER-ipv6. If an operator does not like another ethertype, 
> he might also not like having to turn on IPv6 just to do BIER?
> >
> > Jeffrey
> >
> >> Data centers will have the same reaction to adding another 
> >> ethertype forwarding plane, if it is a Bier ethertype or an MPLS 
> >> ethertype, it
> will
> >> react the same way.
> >>
> >>> To clarify, with BIER-ether it'd still be IP based: the payload is 
> >>> IP
> >> (with IP mcast header) enclosed in
> >>>
> >>> "IP based" means that a BIER message would be *inside* an IP 
> >>> header
> that
> >> was inside an ethertype of 0x0800 or 0x86dd. “BIER-ether” means 
> >> that an ethertype would be allocated for a BIER header.
> >>>
> >>> Zzh> To clarify, when I said “IP based” I meant that the payload 
> >>> Zzh> is
> >> still IP (enclosed in BIER then in Ether). With that, existing IP 
> >> tools can still be used, and BIER tools will handle BIER specific things.
> >>>
> >>> Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is 
> >>> Zzh> that it
> >> infrastructure is required regardless whether it’s BIER-mpls or 
> >> BIER-
> ipv6
> >> or BIER-ether.
> >>>
> >>> Zzh> That is BIER-mpls, and the BIER-label preceding the header 
> >>> Zzh> has
> TTL.
> >>> Zzh> For BIER-ether, both draft-xu-bier-encapsulation and 
> >>> Zzh> draft-wang-
> >> bier-ethernet has TTL in the BIER header, and the BIER 
> >> ping/traceroute draft based on BIER-mpls can be adapted to BIER-ether as well.
> >>>
> >>> Jeffrey
> >>>
> >>> Dino
> >>>
> >>>
> >>> Even if we use BIER-ipv6, there will still be need for BIER 
> >>> specific
> >> ping/traceroute tools.
> >>>
> >>> Jeffrey
> >>>

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 28 Sep 2016 07:18:23 +0000

Hi Dino,

> -----邮件原件-----
> 发件人: BIER [mailto:[email-masked]] 代表 Dino Farinacci
> 发送时间: 2016年9月28日 6:05
> 收件人: Jeffrey Zhang
> 抄送: [email-masked]
> 主题: Re: [Bier] encap in DC
> 
> “I already run IPv4/IPv6 in my network. I want Bier for efficient replication and
> state reduction but I want it on top of IPv4 and IPv6”.

I'm curious about how to achieve efficient replication and state reduction while running BIER on top of vanilla IPv4 and IPv6.

Best regards,
Xiaohu 

> >>> Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is that
> >>> Zzh> it
> >> does not require MPLS signaling and forwarding. BIER
> >> signaling/forwarding infrastructure is required regardless whether
> >> it’s BIER-mpls or BIER-ipv6 or BIER-ether.
> >
> compared to BIER-ipv6. If an operator does not like another ethertype, he might
> also not like having to turn on IPv6 just to do BIER?
> >
> > Jeffrey
> >
> >> forwarding plane, if it is a Bier ethertype or an MPLS ethertype, it
> >> will react the same way.
> >>
> >> was inside an ethertype of 0x0800 or 0x86dd. “BIER-ether” means that
> >> an ethertype would be allocated for a BIER header.
> >>>
> >> ethertype would probably be a good way to go. But the message to
> >> customers is that Bier is a layer-3 protocol and is not subject to
> >> the same forwarding behavior as an L2 switch would perform.
> >>>
> >>> Zzh> Layer-2.5, sort of like MPLS. The difference from MPLS is that
> >>> Zzh> it
> >> does not require MPLS signaling and forwarding. BIER
> >> signaling/forwarding infrastructure is required regardless whether
> >> it’s BIER-mpls or BIER-ipv6 or BIER-ether.
> >>>
> >> Since traceroute uses TTL decrement as a procedure to invoke return
> >> ICMP messages. The above Bier header has no TTL.
> >>>

---

From: Eric C Rosen <[email-masked]>
Date: Wed, 28 Sep 2016 10:30:48 -0400

> I'm curious about how to achieve efficient replication and state reduction while running BIER on top of vanilla IPv4 and IPv6.

Yes, it would be interesting to know how you get the advantages of BIER 
if you don't deploy BFRs that provide the BIER forwarding plane.  
Encapsulating BIER in IPv6 doesn't eliminate the need for the BIER 
forwarding plane, as Jeffrey has pointed out.

Of course, if someone were to insist that IP is the only encapsulation 
they would consider, one could always put the encapsulation from Figure 
1 of draft-xu into an IP packet.  The plethora of issues raised by the 
IPv6 proposal stems from the misguided attempt to carry the BitString in 
the IP destination address field.  Obviously that does not eliminate the 
need for the BIER forwarding plane and the BIER signaling procedures; in 
fact it only makes things more complicated.  Presumably, making things 
more complicated is not one of the DC operators' goals.

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 28 Sep 2016 12:08:55 -0700

> Yes, it would be interesting to know how you get the advantages of BIER if you don't deploy BFRs that provide the BIER forwarding plane.  Encapsulating BIER in IPv6 doesn't eliminate the need for the BIER forwarding plane, as Jeffrey has pointed out.

Yes, you have to deploy BFRs. The question is what header should be used to convey BitString info.

> Of course, if someone were to insist that IP is the only encapsulation they would consider, one could always put the encapsulation from Figure 1 of draft-xu into an IP packet.  The plethora of issues raised by the IPv6 proposal stems from the misguided attempt to carry the BitString in the IP destination address field.  Obviously that does not eliminate the need for the BIER forwarding plane and the BIER signaling procedures; in fact it only makes things more complicated.  Presumably, making things more complicated is not one of the DC operators' goals.

Agree 100%.

Dino