Subject: [Bier] Comments on Montreal IETF 105 BIER Agenda

From: Xiejingrong <[email-masked]>
Date: Mon, 22 Jul 2019 12:40:11 +0000

Dear Greg & Chairs,
I have sent my concerns days ago but haven't got any response, so I have to use a new title on the mail.
I request now to have a *guaranteed* time slot about 10 minutes for <draft-xie-bier-ipv6-encapsulation-03> draft, and give up the requested time slot for the other 3 drafts.
I have the following reasons:
(1) It is the time now to discuss encapsulation proposals, to help making the <bier-ipv6-requirements> more clear.
(2) the <bierin6> draft is on the agenda with guaranteed time. Obviously it is an encapsulation draft. It even has many open questions on the list which I think is serious.
(3) as a cmpromise, I ack to give up the time slot request on other 3 drafts. Does that work for you ?
(4) I have given many comments on the drafts, which I think can shorten the presentation time. Maybe each for 2 minutes?

Please let me know your thoughts.

Thanks
Jingrong

________________________________
From: BIER [[email-masked]] on behalf of Greg Shepherd [[email-masked]]
Sent: Wednesday, July 17, 2019 23:08
To: BIER WG
Subject: Re: [Bier] BIER WG, Call For Agenda, Montreal IETF 105

Just updated the agenda:.

IETF 105, Montreal
BIER WG Agenda

WG Status Update 15mins, chairs
draft-zzhang-bier-tether-02, 15 minutes, Jeffrey Zhang
draft-hb-bier-mldp-signaling-over-bier, 10 mins Hooman Bidgoli
draft-ietf-bier-multicast-http-response-01, 10 mins, Dirk Trossen
draft-ietf-bier-pmmm-oam 10min, Greg Mirsky
draft-ietf-bier-te-arch 10min, Toerless Eckert
draft-ietf-bier-mld-02, 10min, Stig Venaas
draft-zhang-bier-bierin6-03
 draft-zhang-bier-source-protection-00, 15min, Sandy Zhang
draft-ietf-bier-ipv6-requirements, 15min, Mike McBride
- additional drafts to be discussed if room decides, based on the above
- requirements draft.
  draft-xie-bier-ipv6-encapsulation-02
  draft-xie-bier-ipv6-isis-extension-00
  draft-xie-bier-ipv6-mvpn-01
  draft-geng-bier-ipv6-inter-domain-00

On Tue, Jul 16, 2019 at 12:59 PM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
I just uploaded the first draft agenda. Here it is for your review (below). Please send corrects here, and slides to me directly (unicast to this gmail address).

IETF 105, Montreal
BIER WG Agenda

WG Status Update 15mins, chairs
draft-zzhang-bier-tether-02, 15 minutes, Jeffrey Zhang
draft-hb-bier-mldp-signaling-over-bier, 10 mins Hooman Bidgoli
draft-ietf-bier-multicast-http-response-01, 10 mins, Dirk Trossen
draft-ietf-bier-pmmm-oam 10min, Greg Mirsky
draft-ietf-bier-te-arch 10min, Toerless Eckert
draft-ietf-bier-mld-02, 10min, Stig Venaas
draft-ietf-bier-ipv6-requirements, 10min, Mike McBride
- additional drafts to be discussed if room decides, based on the above
- requirements draft.
  draft-xie-bier-ipv6-encapsulation-02
  draft-xie-bier-ipv6-isis-extension-00
  draft-xie-bier-ipv6-mvpn-01
  draft-geng-bier-ipv6-inter-domain-00

On Mon, Jul 8, 2019 at 12:37 PM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Please send agenda items with title, draft, speaker name, and requested time to this thread.

Thanks,
Shep
(chairs)

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 22 Jul 2019 11:30:02 -0700

Jingrong,

The agenda stands as a reflection of the decisions of the WG according to
our procedures and charter. From the charter:

https://datatracker.ietf.org/wg/bier/about/

7) BIER in IPv6 : A mechanism to use BIER natively in IPv6 may be
standardized if coordinated with the 6MAN WG and with understood
applicability.

As of now, the WG has decided that modifying the v6 header to encode BIER
is no longer native v6

Please review the minutes from IETF 104 in Prague:

https://datatracker.ietf.org/doc/minutes-104-bier/

There was a productive discussion in the room. The consensus in the room,
which was confirmed from the list, was that this work will focus on the
problem statement first. If one or more unique use-cases are presented that
require a new encoding or encapsulation then we can address solutions to
these use-case in the associated drafts. If these solutions are out of
scope of our charter, we can propose changing the charter to include this
work at that time, as necessary.

I'm sorry the WG is not moving as fast as you like. I agree with you. :) We
have more than a handful of active drafts ready for WGLC and we can't get
volunteers for Doc Shepherds. Some WGLC email responses were so
depressingly low it can't be considered much of a consensus. But it's what
we have and where we are at this time.

I look forward getting deeper into the use-cases draft this week. Thanks
for you help and patience.

- Shep
(chairs)

On Mon, Jul 22, 2019 at 5:40 AM Xiejingrong <[email-masked]> wrote:

> I request now to have a *guaranteed* time slot about 10 minutes for
> <draft-xie-bier-ipv6-encapsulation-03> draft, and give up the requested
> time slot for the other 3 drafts.
> (2) the <bierin6> draft is on the agenda with guaranteed time. Obviously
> it is an encapsulation draft. It even has many open questions on the list
> which I think is serious.
> (4) I have given many comments on the drafts, which I think can shorten
> the presentation time. Maybe each for 2 minutes?
>
> ------------------------------
> *From:* BIER [[email-masked]] on behalf of Greg Shepherd [
> [email-masked]]
> *Sent:* Wednesday, July 17, 2019 23:08
> *To:* BIER WG
> *Subject:* Re: [Bier] BIER WG, Call For Agenda, Montreal IETF 105
>
> On Tue, Jul 16, 2019 at 12:59 PM Greg Shepherd <[email-masked]> wrote:
>
>> I just uploaded the first draft agenda. Here it is for your review
>> (below). Please send corrects here, and slides to me directly (unicast to
>> this gmail address).
>>
>> IETF 105, Montreal
>> BIER WG Agenda
>>
>> On Mon, Jul 8, 2019 at 12:37 PM Greg Shepherd <[email-masked]> wrote:
>>

---

From: Xiejingrong <[email-masked]>
Date: Mon, 22 Jul 2019 20:39:54 +0000

Dear Greg,

As of now, the WG has decided that modifying the v6 header to encode BIER
is no longer native v6
[XJR]
Maybe the "natively" in the charter is subjective. Let's think about "BIER in IPv6".
BIERv6 is BIER in IPv6 extension header, and BIERin6 is BIER in IPv6 payload.
Which one do you think is more "native" ? say one is 50% native and one is 60% native?
It's clear when this charter text was discussing, we want to have a useful BIER IPv6, instead of limiting ourselves by "native" or not.
This can be refered to https://mailarchive.ietf.org/arch/msg/bier/Zd8mcNc_UoHBrxza7iar8jMjYJg
This conclusion above will unnecessarily kill the work we have done on BIERv6 so far, and discourage the work later.

Please review the minutes from IETF 104 in Prague:
https://datatracker.ietf.org/doc/minutes-104-bier/
[XJR]
I have read the minutes many times. Maybe we went wrong to judge native or not from this. For example here is one of the discussion about native:
Because bier uses its own header, no matter how you do it, we cannot call it ipv6 native.
>From this, the "native" does not really exist. How do we explain the charter text then ?

If these solutions are out of scope of our charter, we can propose changing the charter to include this
work at that time, as necessary.
[XJR]
I don't think the BIERv6 is out of our current charter.
Quite the contrary, it is the reason why we gether here, thinking, discussion, arguing and producing.
The current charter is not a far thing, just a year approximately.
Maybe the current AD Alvaro can give us the guidence.

Thanks
Jingrong

________________________________
From: Greg Shepherd [[email-masked]]
Sent: Tuesday, July 23, 2019 2:30
To: Xiejingrong
Cc: BIER WG; [email-masked]; [email-masked]
Subject: Re: Comments on Montreal IETF 105 BIER Agenda

Jingrong,

The agenda stands as a reflection of the decisions of the WG according to our procedures and charter. From the charter:

As of now, the WG has decided that modifying the v6 header to encode BIER is no longer native v6

There was a productive discussion in the room. The consensus in the room, which was confirmed from the list, was that this work will focus on the problem statement first. If one or more unique use-cases are presented that require a new encoding or encapsulation then we can address solutions to these use-case in the associated drafts. If these solutions are out of scope of our charter, we can propose changing the charter to include this work at that time, as necessary.

I'm sorry the WG is not moving as fast as you like. I agree with you. :) We have more than a handful of active drafts ready for WGLC and we can't get volunteers for Doc Shepherds. Some WGLC email responses were so depressingly low it can't be considered much of a consensus. But it's what we have and where we are at this time.

I look forward getting deeper into the use-cases draft this week. Thanks for you help and patience.

- Shep
(chairs)

On Mon, Jul 22, 2019 at 5:40 AM Xiejingrong <[email-masked]<mailto:[email-masked]>> wrote:
Dear Greg & Chairs,

Thanks
Jingrong

________________________________
From: BIER [[email-masked]<mailto:[email-masked]>] on behalf of Greg Shepherd [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 17, 2019 23:08
To: BIER WG
Subject: Re: [Bier] BIER WG, Call For Agenda, Montreal IETF 105

IETF 105, Montreal
BIER WG Agenda

IETF 105, Montreal
BIER WG Agenda

Thanks,
Shep
(chairs)

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 22 Jul 2019 14:04:56 -0700

Thank you for your input. The fact that draft-ietf-bier-ipv6-requirements
is an adopted WG document should be confirmation that this work is being
seriously fconsidered by the WG regardless of current charter
interpretation, just as I've outlined in email here more than once. Seems
the only remaining concern is the pace of the IETF WG process. Sorry. I too
wish things move more quickly. I look forward to further discussions on
Thurs.

Cheers,
Greg
(chairs)

On Mon, Jul 22, 2019 at 1:40 PM Xiejingrong <[email-masked]> wrote:

> It's clear when this charter text was discussing, we want to have a useful
> BIER IPv6, instead of limiting ourselves by "native" or not.
> This can be refered to
> https://mailarchive.ietf.org/arch/msg/bier/Zd8mcNc_UoHBrxza7iar8jMjYJg
> This conclusion above will unnecessarily kill the work we have done on
> BIERv6 so far, and discourage the work later.
>
> I have read the minutes many times. Maybe we went wrong to judge native or
> not from this. For example here is one of the discussion about native:
> *From:* Greg Shepherd [[email-masked]]
> *Sent:* Tuesday, July 23, 2019 2:30
> *To:* Xiejingrong
> *Cc:* BIER WG; [email-masked]; [email-masked]
> *Subject:* Re: Comments on Montreal IETF 105 BIER Agenda
>
> Jingrong,
>
> I'm sorry the WG is not moving as fast as you like. I agree with you. :)
> We have more than a handful of active drafts ready for WGLC and we can't
> get volunteers for Doc Shepherds. Some WGLC email responses were so
>> (1) It is the time now to discuss encapsulation proposals, to help
>> making the <bier-ipv6-requirements> more clear.

---

From: Alia Atlas <[email-masked]>
Date: Mon, 22 Jul 2019 17:07:19 -0400

I only meant natively - as opposed to over MPLS or Ethernet.
There were a couple drafts discussing options at the time.

Of course, Alvaro has the current state and interpretation!

Regards,
Alia

On Mon, Jul 22, 2019 at 5:05 PM Greg Shepherd <[email-masked]> wrote:

>> It's clear when this charter text was discussing, we want to have a
>> useful BIER IPv6, instead of limiting ourselves by "native" or not.
>> This can be refered to
>> I have read the minutes many times.. Maybe we went wrong to judge native
>> or not from this. For example here is one of the discussion about native:
>>>> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>

---

From: Xiejingrong <[email-masked]>
Date: Mon, 22 Jul 2019 21:36:05 +0000

Thanks Alia very much for the explanation! That's what I understand about "natively" word too.

to Greg:
The fact that draft-ietf-bier-ipv6-requirements is an adopted WG document should be confirmation that this work is being seriously fconsidered by the WG regardless of current charter interpretation, just as I've outlined in email here more than once.
[XJR] That's good!
I apologize if I misunderstand the "the WG has decided that modifying the v6 header to encode BIER is no longer native v6".
We should have agreed on the work and drafts, regardless of the "native" interpretation.
And there is no concerns "If these solutions are out of scope of our charter" for me now.
Thanks for the carification.

Seems the only remaining concern is the pace of the IETF WG process.
[XJR] I have no objection to the pace of WG that the chairs think the best.
So I clear the comments on the agenda now.
I would like to discuss only if room decides based on the requirements draft.

Thanks
Jingrong

________________________________
From: Alia Atlas [[email-masked]]
Sent: Tuesday, July 23, 2019 5:07
To: Greg Shepherd
Cc: Xiejingrong; BIER WG; [email-masked]; [email-masked]
Subject: Re: [Bier] Comments on Montreal IETF 105 BIER Agenda

Regards,
Alia

On Mon, Jul 22, 2019 at 5:05 PM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Thank you for your input. The fact that draft-ietf-bier-ipv6-requirements is an adopted WG document should be confirmation that this work is being seriously fconsidered by the WG regardless of current charter interpretation, just as I've outlined in email here more than once. Seems the only remaining concern is the pace of the IETF WG process. Sorry. I too wish things move more quickly. I look forward to further discussions on Thurs.

Cheers,
Greg
(chairs)

On Mon, Jul 22, 2019 at 1:40 PM Xiejingrong <[email-masked]<mailto:[email-masked]>> wrote:
Dear Greg,

Please review the minutes from IETF 104 in Prague:
https://datatracker.ietf.org/doc/minutes-104-bier/
[XJR]
I have read the minutes many times.. Maybe we went wrong to judge native or not from this. For example here is one of the discussion about native:
Because bier uses its own header, no matter how you do it, we cannot call it ipv6 native.

Thanks
Jingrong

________________________________
From: Greg Shepherd [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, July 23, 2019 2:30
To: Xiejingrong
Cc: BIER WG; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Comments on Montreal IETF 105 BIER Agenda

Jingrong,

- Shep
(chairs)

Thanks
Jingrong

IETF 105, Montreal
BIER WG Agenda

IETF 105, Montreal
BIER WG Agenda

Thanks,
Shep
(chairs)
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier