Subject: [Bier] The offline talk about BIERin6 and BIER-ipv6-requirements drafts

From: Xiejingrong <[email-masked]>
Date: Sat, 27 Jul 2019 11:24:19 +0000

Thanks Jeffrey and Sandy for the patient talk offline about the BIERin6 and BIER-ipv6-requirements yesterday.
I summarized the talk afterwards, and have the following points.

(1) BIERin6 is a Layer-4 solution, which has its special advantages and disadvantages in different scenarios, comparing to Layer-3 solution (the solution using IPv6 Extension Header).

(2) The <bier-ipv6-requirements> can be more inclusive to include Layer-3, Layer-4, and Layer-5 solution, so that many of the interests, Layer-3/4/5, in the WG can be all considered.

What's your opinion ?

Thanks
Jingrong

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 29 Jul 2019 13:25:30 +0000

Hi Jingrong,

We emphasized several times it is not layer-4, just like you would not consider IPinIP/IPinWhatever as layer-4.

Jeffrey

Juniper Business Use Only
From: BIER <[email-masked]> On Behalf Of Xiejingrong
Sent: Saturday, July 27, 2019 7:24 AM
To: BIER WG <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [Bier] The offline talk about BIERin6 and BIER-ipv6-requirements drafts

What's your opinion ?

Thanks
Jingrong

---

From: Xiejingrong <[email-masked]>
Date: Tue, 30 Jul 2019 02:21:15 +0000

Hi Jeffrey,

The IPinIP (as a comparison to BIERin6) you mentioned in the discussion really confused me then without a word.

But afterwards, I convinced myself it is definitely a Layer-4, and the problems we had talked about are the hints of Layer-4:

(1)     In Fragmentation, BIER is payload, and will be fragmented.  (BIER-header + payload-1-to-1xxx bytes) in one packet, and (payload-1xxx-to-2xxx) in another packet.

Thus, when BFR B receive a packet from BFR A, BFR B has to assembly the fragmented packets before sending to BFR C and BFR D.

(2)     In AH, BIER is payload, and will be seen as immutable for Integrity Check Value (ICV) calculation.

Thus, when BFR B receive a packet with AH ICV from BFR A, BFR B has to do the AH verification before sending to BFR C and BFR D.

(3)     In SRH, BIER is payload, and will be reached only after the SRH is processed.

Thus, when BFR B receive a packet with SRH from BFR A, BFR B has to process the SRH first, and then the Upper-layer BIER header at last.

Make sense ?

Thanks
Jingrong

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Monday, July 29, 2019 9:26 PM
To: Xiejingrong <[email-masked]>; BIER WG <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: The offline talk about BIERin6 and BIER-ipv6-requirements drafts

Hi Jingrong,

Jeffrey

Juniper Business Use Only
From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Xiejingrong
Sent: Saturday, July 27, 2019 7:24 AM
To: BIER WG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Bier] The offline talk about BIERin6 and BIER-ipv6-requirements drafts

What's your opinion ?

Thanks
Jingrong