Subject: Re: [Bier] draft-ietf-bier-ipv6-requirements-04

From: Michael McBride <[email-masked]>
Date: Thu, 16 Jan 2020 00:27:44 +0000

Hello team bier,

We've updated the bier-ipv6-req's draft, per our discussion in Singapore, and will ask for wglc in Vancouver. This gives us time to fine tune it with your additional feedback.

The purpose of this draft is to list the requirements which will help steer us towards a solution(s). There are currently two active drafts (xie-bier-ipv6-encapsulation & zhang-bier-bierin6). Both are summarized in the appendix of bier-ipv6-requirements along with several other solutions. Both have been discussed at great length and meet the majority of the req's. IMHO the bier chairs/wg should discuss adopting both of these solutions as each provide a good (yes I'm biased) unique bierv6 solution. We could either let one of the solutions prevail in the end or allow both to progress and allow the market decide. 

Your further opinions appreciated.

Thanks,
mike

-----Original Message-----
From: BIER <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, January 15, 2020 3:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Bier] I-D Action: draft-ietf-bier-ipv6-requirements-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Bit Indexed Explicit Replication WG of the IETF.

        Title           : BIER IPv6 Requirements
        Authors         : Mike McBride
                          Jingrong Xie
                          Senthil Dhanaraj
                          Rajiv Asati
                          Yongqing Zhu
	Filename        : draft-ietf-bier-ipv6-requirements-04.txt
	Pages           : 14
	Date            : 2020-01-15

Abstract:
   The BIER WG includes, in its charter, work on developing mechanisms
   to transport BIER natively in IPv6.  This document is intended to
   help the WG with this effort by specifying requirements for
   transporting packets, with Bit Index Explicit Replication (BIER)
   headers, in an IPv6 environment.  There will be a need to send IPv6
   payloads, to multiple IPv6 destinations, using BIER.  There have been
   several proposed solutions in this area.  But there hasn't been a
   document which describes the problem and lists the requirements.  The
   goal of this document is to describe the BIER IPv6 requirements,
   summarize the proposed solutions, and guide the working group in
   understanding the benefits, and drawbacks, of the various solutions
   and to help in the development of acceptable solutions.

The IETF datatracker status page for this draft is:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-bier-ipv6-requirements%2F&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C39abd8b485ae4a68976f08d79a153493%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637147288203952108&amp;sdata=%2Fm5KusjR4rw11mg%2BXfWfFJX6BXiylDFYcVoZB52ZF9M%3D&amp;reserved=0

There are also htmlized versions available at:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-bier-ipv6-requirements-04&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C39abd8b485ae4a68976f08d79a153493%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637147288203952108&amp;sdata=ZldLMIS%2F6gMM9Ri%2BNQnjCEp%2BrkSMSBdC6kB1UKeQ7Io%3D&amp;reserved=0
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-bier-ipv6-requirements-04&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C39abd8b485ae4a68976f08d79a153493%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637147288203952108&amp;sdata=dmHX8vqvD5KJOLJS1%2BXKoty779GtqN6QjWTM76Ha9OA%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-bier-ipv6-requirements-04&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C39abd8b485ae4a68976f08d79a153493%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637147288203952108&amp;sdata=yKlkqpf0pYttYiahrVAeQ%2BG%2Ft4ihZdAKvSs17g8ToLo%3D&amp;reserved=0

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
BIER mailing list
[email-masked]
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fbier&amp;data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C39abd8b485ae4a68976f08d79a153493%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637147288203952108&amp;sdata=qxLhqTIeKd1cH4kMGyxrLDeJx%2BEYTww8jcWm%2FxWYeHo%3D&amp;reserved=0

---

From: Loa Andersson <[email-masked]>
Date: Thu, 23 Jan 2020 12:42:46 +0800

Working Group,

I gone over the mails and drafts that Mike mention.

Even though the first option for an SDO is to aim for a single
specification the path to reach that goal might be too adopt two
documents and use the wg process to see if it is possible to
merge the documents into a single specification, or demonstrate
that one solution is superior to the other.

In the event this is not possible there is quite often technical
or operational reasons. For example in the case of L2VPN we spent
quite an effort to try agree on a single signaling protocol, it
turned out that we couldn't. There were at that time quite a bit
of talked about "let the market decide", well it turned out that
the market decided that there was applicability for two solutions.

Therefore I think Mike's proposal is well founded and will give
us the time needed to come up with the correct decision or even
see what the market decide.

/Loa

On 16/01/2020 08:27, Michael McBride wrote:
> https://www.ietf.org/mailman/listinfo/bier
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64