Subject: [Bier] Comments on draft-ietf-bier-evpn-02

From: <[email-masked]>
Date: Mon, 6 Jan 2020 11:33:28 +0800 (CST)

Hi authors,

Happy New Year!

I am reading the "draft-ietf-bier-evpn-02" draft. I have a question on section 2.1 in "draft-ietf-bier-evpn-02", there is the description: The tunnel endpoint MUST be an IP multicast address and the receiving egress PE MUST be set up to receive and process packets addressed to the address.

The IP multicast address can simplify the forwarding procedure on PHP routers. But I am wondering how the PHP routers will do when it's hard to get a consistent multicast address among the BFERs which can not support BIER forwarding. 

And if unicast tunnel can be used here too?

Thanks,

Sandy

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sat, 25 Jan 2020 19:06:44 +0000

Hi Sandy,

Sorry for the late response.
It’s not the PH router that gets a multicast address used to send traffic to the PE. The ingress PE must already use a multicast address known to all PEs.

Jeffrey

From: [email-masked] <[email-masked]>
Sent: Sunday, January 5, 2020 10:33 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Antoni Przygienda <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Bier] Comments on draft-ietf-bier-evpn-02

Hi authors,

Happy New Year!

Thanks,

Sandy

---

From: <[email-masked]>
Date: Sun, 26 Jan 2020 16:33:55 +0800 (CST)

Hi Jeffrey,

Thank you for your respond!

I may misunderstand about the procedure. 

Is the multicast known to all PEs overlay?

Is the tunnel between PH router and BFER built in core network? 

If there is only one hop between PH router and BFER, and the tunnel is bound to a VPN, then the BFER can decapsulate the packet and forward it correctly.

But if there are multiple hops between PH router and BFER, does the router between PH router and BFER forward the packet correctly according to the multicast address in the tunnel encapsulation? 

Thanks,

Sandy

原始邮件

发件人：Jeffrey(Zhaohui)Zhang <[email-masked]>
收件人：张征00007940;Antoni Przygienda <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年01月26日 03:07
主 题 ：RE: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Sandy,

 

Jeffrey

 

Hi authors,

Happy New Year!

I am reading the "draft-ietf-bier-evpn-02" draft. I have a question on section 2.1 in "draft-ietf-bier-evpn-02", there is the description: The tunnel endpoint MUST be an IP multicast address and the receiving egress PE MUST be set up to receive and process
 packets addressed to the address.

Thanks,

Sandy

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sun, 26 Jan 2020 13:20:10 +0000

Hi Sandy,

The PH pop the BIER header and forward the inner packet to the BFER, either natively or over an underlay tunnel depending on whether the BFER is directly connected or not.

In case of vxlan, the inner encapsulation (after the popped BIER header) would be vxlan including its IP/UDP header. The IP destination address would be a multicast address advertised in the Auxiliary Information. The reason for including IP/UDP header is that in case of PHP, the BFER may not be able to know that incoming header is vxlan w/o IP/UDP (when PHP is not used, the BIER header’s proto field can indicate the inner header type).

Having said that, we’re thinking of allocating a dedicated IP multicast address for this purpose, instead of advertising it in the Auxiliary Information.

Jeffrey

From: BIER <[email-masked]> On Behalf Of [email-masked]
Sent: Sunday, January 26, 2020 3:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Antoni Przygienda <[email-masked]>; [email-masked]
Subject: Re: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Jeffrey,

Thanks,

Sandy

<https://urldefense.com/v3/__http:/www.zte.com.cn/__;!!NEt6yMaO-gk!RCRjdBs6i4aIH7MqB5HkTqklj3_srnCvrlB5RycB9p6R83N6-20FvyKtJaETXdVL$>
原始邮件
发件人：Jeffrey(Zhaohui)Zhang <[email-masked]<mailto:[email-masked]>>
收件人：张征00007940;Antoni Przygienda <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年01月26日 03:07
主 题 ：RE: [Bier] Comments on draft-ietf-bier-evpn-02
Hi Sandy,

Jeffrey

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, January 5, 2020 10:33 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; Antoni Przygienda <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Bier] Comments on draft-ietf-bier-evpn-02

Hi authors,

Happy New Year!

Thanks,

Sandy

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sun, 26 Jan 2020 13:25:14 +0000

Forgot to say that, if the PH tunnel the packet to an indirectly connected BFER, then there is a tunnel header before the IP/UDP/vxlan header.

From: Jeffrey (Zhaohui) Zhang
Sent: Sunday, January 26, 2020 8:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Antoni Przygienda <[email-masked]>; [email-masked]
Subject: RE: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Sandy,

Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Sunday, January 26, 2020 3:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Antoni Przygienda <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Jeffrey,

Thanks,

Sandy

Jeffrey

Hi authors,

Happy New Year!

Thanks,

Sandy

---

From: <[email-masked]>
Date: Mon, 27 Jan 2020 16:36:51 +0800 (CST)

Hi Jeffrey,

Thank you very much for your explaining!

I got it. The multicast destination is in the inner packet, like the overlay multicast address, right?

If there are multiple BFERs need to advertise the multicast address as Auxiliary information, 

they may advertise different addresses, then it's hard to encapsulate the inner packet.

A dedicated IP multicast address or some other unified methods are more reasonable. :-)

Thanks,

Sandy

原始邮件

发件人：Jeffrey(Zhaohui)Zhang <[email-masked]>
收件人：张征00007940;
抄送人：[email-masked]' <[email-masked]>;[email-masked]' <[email-masked]>;[email-masked]' <[email-masked]>;AntoniPrzygienda <[email-masked]>;[email-masked]' <[email-masked]>;
日 期 ：2020年01月26日 21:25
主 题 ：RE: [Bier] Comments on draft-ietf-bier-evpn-02

 

 

Hi Sandy,

 

In case of vxlan, the inner encapsulation (after the popped BIER header) would be vxlan including its IP/UDP header. The IP destination address would be a multicast address advertised in the Auxiliary Information. The reason for including
 IP/UDP header is that in case of PHP, the BFER may not be able to know that incoming header is vxlan w/o IP/UDP (when PHP is not used, the BIER header’s proto field can indicate the inner header type).

 

Jeffrey

From: BIER <[email-masked]>On Behalf Of [email-masked]
Sent: Sunday, January 26, 2020 3:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Antoni Przygienda <[email-masked]>;[email-masked]
Subject: Re: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Jeffrey,

Thanks,

Sandy

原始邮件

收件人：张征00007940;Antoni
 Przygienda <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;

抄送人：[email-masked] <[email-masked]>;[email-masked]
 <[email-masked]>;

日期：2020年01月26日
 03:07

主题：RE: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Sandy,

 

Jeffrey

From:[email-masked] <[email-masked]>
Sent: Sunday, January 5, 2020 10:33 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Antoni Przygienda <[email-masked]>;[email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Bier] Comments on draft-ietf-bier-evpn-02

Hi authors,

Happy New Year!

Thanks,

Sandy

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 27 Jan 2020 13:44:20 +0000

Hi Sandy,

It is an underlay multicast address (It’s like all Rosen MDT tunnels are using the same group address – it works because we’re not using group but using vxlan VNI to demultiplex traffic into different VPNs/BDs).

Different PEs advertising different address is still fine – it’s the ingress PE’s own decision - just that egress PEs need to be prepared to accept traffic with multiple addresses.

Still, allocating a well-known address is better.

Jeffrey

From: [email-masked] <[email-masked]>
Sent: Monday, January 27, 2020 3:37 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Antoni Przygienda <[email-masked]>; [email-masked]
Subject: Re:[Bier] Comments on draft-ietf-bier-evpn-02

Hi Jeffrey,

Thanks,

Sandy

原始邮件
发件人：Jeffrey(Zhaohui)Zhang <[email-masked]<mailto:[email-masked]>>
收件人：张征00007940;
抄送人：[email-masked]' <[email-masked]<mailto:[email-masked]>>;[email-masked]' <[email-masked]<mailto:[email-masked]>>;[email-masked]' <[email-masked]<mailto:[email-masked]>>;AntoniPrzygienda <[email-masked]<mailto:[email-masked]>>;[email-masked]' <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年01月26日 21:25
主 题 ：RE: [Bier] Comments on draft-ietf-bier-evpn-02
Forgot to say that, if the PH tunnel the packet to an indirectly connected BFER, then there is a tunnel header before the IP/UDP/vxlan header.

To: [email-masked]<mailto:[email-masked]>

Hi Sandy,

Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>>On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Sunday, January 26, 2020 3:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Antoni Przygienda <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] Comments on draft-ietf-bier-evpn-02

Hi Jeffrey,

Thanks,

Sandy

日期：2020年01月26日 03:07

Jeffrey

From:[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, January 5, 2020 10:33 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; Antoni Przygienda <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Bier] Comments on draft-ietf-bier-evpn-02

Hi authors,

Happy New Year!

Thanks,

Sandy