Subject: [Bier] FW: New Version Notification for draft-xie-bier-ipv6-encapsulation-07.txt

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 29 Jun 2020 09:29:08 +0000

Hi 6MAN people,

We have updated draft-xie-bier-ipv6-encapsulation-07. This draft defines a multicast solution which enables BIER (RFC 8279 & 8296) forwarding in an IPv6 domain.
The BIER architecture (RFC 8279 & 8296) is maximum reused, with the following 2 additional IPv6 extensions in this document:

   Define IPv6 address indicating BIERv6 forwarding, which is called End.BIER.

   Define new Destination Options Header, used for carrying BIER Header(bitstring included), which is called BIERv6 DOH.
In the new version of the draft:
   Terminologies like “BIERv6 domain” are added or updated.
   The use of “Proto” field in BIER header and IPv6 “Next Header” field is revised (main technical improvement in this document).
   Editorial changes including wording in security considerations.
   Issues raised by IDnits tool are fixed.
   Co-authors are added.
It will be great that 6man people could review the document and provide feedback/guidance from IPv6 expert perspective. Particularly:
1) If this document conforms to IPv6 core rule and IPv6 EH mechanism.
2) if this document has any security impacts from the view of IPv6.

Thanks!
Xuesong

> -----Original Message-----

> From: [email-masked] [mailto:[email-masked]]

> Sent: Monday, June 29, 2020 5:23 PM

> To: Mike McBride <[email-masked]>; Yongqing Zhu

> <[email-masked]>; Zhuangzhuang Qin

> <[email-masked]>; Senthil Dhanaraj

> <[email-masked]>; Gengxuesong (Geng Xuesong)

> <[email-masked]>; Xiejingrong (Jingrong)

> <[email-masked]>; Liang Geng <[email-masked]>;

> MooChang Shin <[email-masked]>; Rajiv Asati <[email-masked]>

> Subject: New Version Notification for draft-xie-bier-ipv6-encapsulation-07.txt

> A new version of I-D, draft-xie-bier-ipv6-encapsulation-07.txt

> has been successfully submitted by Xuesong Geng and posted to the IETF

> repository.

> Name:            draft-xie-bier-ipv6-encapsulation

> Revision:        07

> Title:               Encapsulation for BIER in Non-MPLS IPv6 Networks

> Document date:   2020-06-29

> Group:            Individual Submission

> Pages:            19

> URL:

> https://www.ietf.org/internet-drafts/draft-xie-bier-ipv6-encapsulation-07.txt

> Status:

> https://datatracker.ietf.org/doc/draft-xie-bier-ipv6-encapsulation/

> Htmlized:

> https://tools.ietf.org/html/draft-xie-bier-ipv6-encapsulation-07

> Htmlized:

> https://datatracker.ietf.org/doc/html/draft-xie-bier-ipv6-encapsulation

> Diff:

> https://www.ietf.org/rfcdiff?url2=draft-xie-bier-ipv6-encapsulation-07

> Abstract:

>    This document proposes a BIER IPv6 (BIERv6) encapsulation for Non-

>    MPLS IPv6 Networks using the IPv6 Destination Option extension

>    header.  This document updates RFC 8296.

> Please note that it may take a couple of minutes from the time of submission

> until the htmlized version and diff are available at tools.ietf.org.

> The IETF Secretariat

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 29 Jun 2020 09:33:06 +0000

Hi BIER WG,

There have been a lot of discussions in BIER WG about BIERv6 and we have received a lot of useful comments from WG.

In this version, we updated the draft based on these comments. Here are some progress:

1.      A main concern about BIERv6 is the use of BIER proto field and IPv6 next header when considering BIERv6-OAM functioning.

We think this update addressed this problem, using IPv6 next header solely in BIERv6, and thus makes the solution far more clear.

2.      Another concern is security. We’ve improve the security considerations since rev-04. In this version , we has added more descriptions.

3.      IPv6 issues will be fully discussed in 6MAN hopefully.

Please let us know if the above change solve your problem. And any other comments are welcome.

Best Regards

Xuesong