Subject: Re: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

From: Tianran Zhou <[email-masked]>
Date: Thu, 26 Nov 2020 13:20:30 +0000

Hi Jeffrey,

Be more clear, Bierv6 is a simple and nice solution that only requires a code point to encode the Bier header into the IPv6 layer extension header.
It leverages the IPv6 merits because of the IPv6 native.
In the previous discussions, Jingrong has pointed out many issues wrt Bier in 6.
Compared with Bierv6, we do not need Bier in 6 for IPv6.
Given we have a better solution, working on Bier in 6 is a wrong direction.

Cheers,
Tianran

发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2020年11月26日 20:20
收件人: Tianran Zhou <[email-masked]>; [email-masked]; Xiejingrong (Jingrong) <[email-masked]>
抄送: BIER WG <[email-masked]>; Gyan Mishra <[email-masked]>
主题: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Hi Tianran,

I did not see your argument why BIERin6 is “just a wrong solution and direction”.

Additionally, BIERin6 is existing RFC8296 solution with a new code point. Both from solution history and document timeline, BIERin6 comes *before* BIERv6 and it works with a nice clean layering. BIERv6 on the other hand has its issues (will expand on those in separate threads).

Therefore, the question should be flipped around – why BIERv6?

Jeffrey

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, November 25, 2020 10:50 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

[External Email. Be cautious of content]

Hi Jeffrey,

Bierv6 is a nice design. It works very well in IPv6 scenario.
Given we already have Bierv6, I do not understand why we are still arguing the requirement for Bier in 6.
I just see no need for Bier in 6.

Cheers,
Tianran

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Wednesday, November 25, 2020 10:14 PM
To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Hi Tianran,

I had answered/countered every question/comment that Gyan/Jingrong raised, some repeatedly.

Ø  Bier in 6 is just a wrong solution and direction.

Love to hear your arguments for the above.

Jeffrey

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, November 25, 2020 1:01 AM
To: [email-masked]<mailto:[email-masked]>; Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

[External Email. Be cautious of content]

Why do you want to stop valid comments and valid discussions?
I think both Gyan and Jingrong just raised the key technique points.
Bier in 6 is just a wrong solution and direction.

Tianran

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Wednesday, November 25, 2020 1:16 PM
To: Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
Cc: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Please try to keep comments on track and in-line with the thread. Stand-alone questions like this are just digging up ground we've already sowed.

Thanks,
Shep

On Tue, Nov 24, 2020 at 7:27 PM Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>> wrote:
(to make clean, raise a new topic)

I am confused too by the claiming a solution can do everything and it is an "existing" solution, while requesting allocation of IPv6 Next Header / IPv4 Protocol value which is non-trivial.

We need to know, what does *the* BIERin6 draft propose, and how does *the* BIERin6 draft satisfy the bier-ipv6-requirements.
Take req-1 as an example, suppose there are PPP-over-SONET(POS, RFC2615) links in an IPv6 network, can the existing RFC8296 solve ? What does *the* BIERin6 draft propose to solve ?

Please note in my question the word *the* does not include anything that RFC8296 can solve. Any existing RFC8296 solution is not belonging to *the* BIERin6 proposal. Please tell us *the* BIERin6 proposal.

Thanks
Jingrong

-----Original Message-----
From: Gyan Mishra [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, November 25, 2020 9:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: Alvaro Retana <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; draft-ietf-bier-ipv6-requirements <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: draft-ietf-bier-ipv6-requirements-09

Jeffrey

About the two lingering points it does shed light on something that has been disturbing me with the BIERin6 solution.

I thought about this some more and I think what creates a lot of confusion in my mind with BIERin6 solution is the L2/tunnel component.

As the main reason is that the L2/tunnel exists today with RFC 8296 “Non MPLS BIER Ethernet” with the special allocated next header code point to account for BIER next header 0xAB37.

I honestly think the L2 should be removed from the BIERin6 draft so that the optional IPV6 encapsulation is no longer “optional” in the draft as that now is the draft.

This also provides the “IPv6 encapsulation” commonality with BIERv6 at least showing clearly that their is a strive for commonality and parity between the two solutions.

Also the “muddying” of the water is eliminated by removing L2 making the solution crystal clear to operators.

Kind Regards

Gyan

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!Si-OI7n2KWZpZrAUn6G14gDTm6ICWah6GxBVRm00DTGFWCb0rs1cnBoFCUdkIsCQ$>

Juniper Business Use Only

Juniper Business Use Only

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 26 Nov 2020 15:12:06 +0000

Hi Tianran,

From: BIER <[email-masked]> On Behalf Of Tianran Zhou
Sent: Thursday, November 26, 2020 8:21 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]; Xiejingrong (Jingrong) <[email-masked]>
Cc: BIER WG <[email-masked]>; Gyan Mishra <[email-masked]>
Subject: Re: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Hi Jeffrey,

Zzh> It’s not just a new code point. It’s a new extension header with new procedures both in IPv6/BIER layer itself and in overlay like MVPN. For the complications in the IPv6/BIER layer itself, I’ve seen detailed analysis on its issues and complications (to be discussed separately). On the MVPN side, please see https://mailarchive.ietf.org/arch/msg/bier/4muFX1U9XrGf4nLGFDaZ-kcJxt0/.

Zzh> Would appreciate pointers to those.

Zzh> I would say it is the other way around.
Zzh> Jeffrey

Cheers,
Tianran

发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
发送时间: 2020年11月26日 20:20
收件人: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Xiejingrong (Jingrong) <[email-masked]<mailto:[email-masked]>>
抄送: BIER WG <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>
主题: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Hi Tianran,

Jeffrey

Hi Jeffrey,

Cheers,
Tianran

Hi Tianran,

  *   Bier in 6 is just a wrong solution and direction.

Jeffrey

Tianran

Thanks,
Shep

Thanks
Jingrong

-----Original Message-----
From: Gyan Mishra [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, November 25, 2020 9:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: Alvaro Retana <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; draft-ietf-bier-ipv6-requirements <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: draft-ietf-bier-ipv6-requirements-09

Jeffrey

Kind Regards

Gyan

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 27 Nov 2020 04:18:30 +0000

Hi Jeffrey,

Firstly, Bierv6 is encoded as an option in IPv6 extension header. There is no need for a new extension header.
We have already implemented bierv6, which is easy and nice. Do not have the complexity and issues you mentioned, or have been resolved.
For details, please see Jingrong’s reply on your pointer.
For the many Bier in 6 issues, complexity, we will also pointed out again.

Cheers,
Tianran

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Thursday, November 26, 2020 11:12 PM
To: Tianran Zhou <[email-masked]>; [email-masked]; Xiejingrong (Jingrong) <[email-masked]>
Cc: BIER WG <[email-masked]>; Gyan Mishra <[email-masked]>
Subject: RE: [Bier] What does BIERin6 propose to satisfy the requirements? //RE: draft-ietf-bier-ipv6-requirements-09

Hi Tianran,

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Tianran Zhou

Hi Jeffrey,

Cheers,
Tianran

Hi Tianran,

Jeffrey

Hi Jeffrey,

Cheers,
Tianran

Hi Tianran,

Jeffrey

Tianran

Thanks,
Shep

Thanks
Jingrong

-----Original Message-----
From: Gyan Mishra [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, November 25, 2020 9:34 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: Alvaro Retana <[email-masked]<mailto:[email-masked]>>; BIER WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Tony Przygienda <[email-masked]<mailto:[email-masked]>>; draft-ietf-bier-ipv6-requirements <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: draft-ietf-bier-ipv6-requirements-09

Jeffrey

Kind Regards

Gyan