Subject: [BLISS] draft-ietf-bliss-call-completion-04 Recommendation for retention time?

From: Mark Michelson <[email-masked]>
Date: Tue, 04 Aug 2009 18:51:45 -0500

Hi group,

I've been reading through draft-ietf-bliss-call-completion-04, and there is a 
piece of information that I have been having difficulty locating. When a cc 
monitor sends a final response to an INVITE that indicates that CCBS/CCNR/CCNL 
may be requested, is there a way that an expiration time may be indicated in 
this response?

I realize that as a cc monitor, I don't necessarily have to remember the 
original failed call forever, but I would think that it would be possible to 
indicate to an upstream element that its opportunity to request call completion 
services has expired. I did not see such a capability mentioned in the latest 
call completion draft, so I was wondering if such a facility may be considered. 
Or was this sort of facility left out of the draft for a specific reason?

I apologize in advance if this topic has surfaced in previous discussions, but 
looking through the list archives, google, and the draft itself did not give me 
an answer to my question.

Thanks for your time,
Mark Michelson

---

From: <[email-masked]>
Date: Wed, 5 Aug 2009 17:35:29 +0200

Hi Mark,

until now such a retention indication was not discussed. It's clear that there will be a temporal relationship between failed call and CC request, but the question is if we really have to indicate this via SIP?

If we say that about 20 s should be enough to activate CC, incl. time for signalling and user interaction, the definition of a 20 s retention timer at the CC agent should be sufficient to prevent the expiry of the possibility for CC. 

BR, Martin

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von Mark Michelson
> Gesendet: Mittwoch, 5. August 2009 01:52
> An: [email-masked]
> Betreff: [BLISS] draft-ietf-bliss-call-completion-04 
> Recommendation for retention time?
> 
> Hi group,
> 
> I've been reading through 
> draft-ietf-bliss-call-completion-04, and there is a piece of 
> information that I have been having difficulty locating. When 
> a cc monitor sends a final response to an INVITE that 
> indicates that CCBS/CCNR/CCNL may be requested, is there a 
> way that an expiration time may be indicated in this response?
> 
> I realize that as a cc monitor, I don't necessarily have to 
> remember the original failed call forever, but I would think 
> that it would be possible to indicate to an upstream element 
> that its opportunity to request call completion services has 
> expired. I did not see such a capability mentioned in the 
> latest call completion draft, so I was wondering if such a 
> facility may be considered. 
> I apologize in advance if this topic has surfaced in previous 
> discussions, but looking through the list archives, google, 
> and the draft itself did not give me an answer to my question.
> 
> Thanks for your time,
> Mark Michelson
> _______________________________________________
> BLISS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bliss
>

---

From: Mark Michelson <[email-masked]>
Date: Thu, 06 Aug 2009 11:01:39 -0500

> If we say that about 20 s should be enough to activate CC, incl. time for signalling and user interaction, the definition of a 20 s retention timer at the CC agent should be sufficient to prevent t…

Thank you for the response, Martin, and sorry for not replying sooner, myself.

I'm not too concerned about what a reasonable default expiry for the CC offer 
should be. What I am concerned about is whether this may be expressed in some 
way. For instance, could an expires= parameter be added to the Call-Info header 
sent by the CC monitor in cases where call completion services are available?

Mark Michelson

---

From: <[email-masked]>
Date: Mon, 10 Aug 2009 17:53:10 +0200

Hi Mark,

of course we could specify how to indicate the retention time to the agent.

But again the question is if we really need it, because CC has to be requested as soon as possible anyway. If you wait much longer than 20 to 30 seconds, the more probable it becomes that someone else calls and activates CC to the callee.

So from my point of view the definition of a retention timer which is known to agent and monitor will be sufficient.

BR, Martin

> Von: Mark Michelson [mailto:[email-masked]] 
> Gesendet: Donnerstag, 6. August 2009 18:02
> An: Hülsemann, Martin
> Cc: [email-masked]
> Betreff: Re: AW: [BLISS] draft-ietf-bliss-call-completion-04 
> > until now such a retention indication was not discussed. 
> It's clear that there will be a temporal relationship between 
> failed call and CC request, but the question is if we really 
> have to indicate this via SIP?
> > 
> > If we say that about 20 s should be enough to activate CC, 
> incl. time for signalling and user interaction, the 
> definition of a 20 s retention timer at the CC agent should 
> be sufficient to prevent the expiry of the possibility for CC. 
> > 
> > 
> > BR, Martin
> > 
> 
> I'm not too concerned about what a reasonable default expiry 
> for the CC offer should be. What I am concerned about is 
> whether this may be expressed in some way. For instance, 
> could an expires= parameter be added to the Call-Info header