Subject: [Blockchain-interop] Discussion on Asset Profiles

From: Thomas Hardjono <[email-masked]>
Date: Mon, 7 Dec 2020 14:20:26 +0000

Folks,

At the SecDispatch presentation at IETF109 there was a bullet point about the need for gateways to be able to point to an authoritative profile JSON file that defines clearly the asset in question.

This JSON file is a kind of prospectus document that states the aspects/attributes of the virtual asset. It's not the asset itself, but a description of it.

I think a standardized asset profile will be needed, given that different jurisdictions around the world may have its own regulatory perspectives on what/which virtual assets are recognized in a given jurisdiction. This become important if one of the gateways (e.g. origin-gateway G1) is operating in a different jurisdiction than the destination-gateway G2.

The assets-types will have some common fields (e.g. Issuer, Code, Date, signature), but other assets types may have sub-fields that are specific to that asset-type.

Below is a compiled list of the fields of information for the asset-profile that we have so far:

•	Issuer: is the LEI or name of the entity/company that is issuing the Asset Profile JSON file or N/A.

•	Asset Code: is any officially recognized asset code (e.g. CH0008742519).

•	Asset Code Type: is the code type to which the Asset Code belongs (e.g. ISIN or "other" if none exists).

•	Keywords: is a list of keywords to make the Asset Profiles easily searchable.

•	Prospectus Link: is the link to any officially approved prospectus or N/A.

•	Key Information Link: is the link to any Key Information Document (KID) or N/A.

•	Transfer Restriction: is any information about transfer restrictions (e.g. banned jurisdictions etc.), such that the sender and recipient gateways can assess the validity of the transfer or N/A.

•	Ledger Requirements: is any information about the specific ledger requirements, such that the sender and recipient gateway can assess the appropriateness of the "receiving ledger" or N/A.

•	Original Asset Location: is the information about the original asset location L0 ("home ledger" and address), such that the receiving gateway can notify L0 that the asset has been transferred to a potentially new DLT.

•	Previous Asset Location: is the information about the previous asset location (ledger and address) from where the sender gateway DLT has received the asset, such that the recipient gateway can check that the received quantity doesn't exceed the disposable amount on the sender gateway DLT. This is N/A if the sender gateway DLT is the Original Asset Location.

•	Issuance: is the issuance date of the Asset Profile JSON file.

•	Expiration: is the expiration of the Asset Profile JSON file in terms of months or years (comparable to the TLS X.509 certificate).

•	Verification Endpoint: is the URL endpoint where anyone can check the current validity status of the Asset Profile JSON file.

•	Signature Value: is the signature of the Issuer of the Asset Profile.

Thoughts?

-- thomas --

---

From: Luke Riley <[email-masked]>
Date: Tue, 8 Dec 2020 18:41:27 +0000

Hi Thomas,

A couple of parameters that may be useful for describing distributed ledger based digital assets are*:

SupplyType, with options

  *   Limited Deterministic. - ongoing with a fixed supply, e.g. BTC
  *   Unlimited Deterministic - ongoing with no fixed limit but fixed rules on when more will be created, e.g. ETH
  *   Unlimited Deterministic - ongoing with no fixed limit and no fixed rules on when more will be created, e.g. some DL tokens that can be created in an ongoing basis.
  *   Premined - All assets created at the distributed ledger or smart contract genesis, e.g. XRP or ERC20 tokens.

GenerationMethod, with options:

  *   Ad Hoc - more of the asset can be created whenever required
  *   Smart Contract Logic - More of the asset can only be created if some smart contract conditions have been met
  *   Genesis - All of the asset was created at either distributed ledger or smart contract genesis
  *   Block Creator - More of the asset is automatically assigned to the block creator (i.e. accounts-based blockchain block reward)
  *   Coinbase - More of the asset is created via a UTXO (with no input) in a newly created block (i.e. UTXO-based blockchain block reward)

Regards,

Luke

* Section VI of the following discussed some of the above and more:
Paolo Tasca[https://dblp.org/img/orcid-mark.12x12.png], Claudio J. Tessone<https://dblp.org/pid/46/8194.html>:
A Taxonomy of Blockchain Technologies: Principles of Identification and Classification. Ledger 4<https://dblp.org/db/journals/ledger/ledger4.html#TascaT19> (2019)
________________________________
From: Blockchain-interop <[email-masked]> on behalf of Thomas Hardjono <[email-masked]>
Sent: 07 December 2020 14:20
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [Blockchain-interop] Discussion on Asset Profiles

CAUTION: This email originated from outside of the organisation. Do not click links or open attachments unless you recognise the sender and know the content is safe.

Folks,

Thoughts?

-- thomas --

--
Blockchain-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/blockchain-interop
This message is intended solely for the addressee and may contain privileged and confidential information. If you have received this message in error, please send it back to us, and immediately and permanently delete it. Do not use, copy or disclose the information contained in this message or in any attachment. Quant Network does not guarantee that this email has not been intercepted and amended or that it is virus free.