Subject: Re: [Blockchain-interop] ODAP-2PC (crash recovery for gateways) call for feedback

From: Rafael Belchior <[email-masked]>
Date: Tue, 11 May 2021 20:36:03 +0100

Hello All,
We have updated the crash recovery mechanism draft [1] - feedback is
greatly appreciated! 

Changes:
-Major restructuring.  
-Changes to Log Format (ODAP's updated data model insights were taken
into account - thanks @Luke!) 
-Updated Log Storage API

On a separate topic - is anyone familiarized with  ISO 20022 data model?
It looks like ISO is also trying to solve the interoperability problem. 

Cheers, 
Rafael 

A 2021-03-03 11:45, Rafael Belchior escreveu: 

> Hello All,
> 
> We've written an academic paper on ODAP-2PC (also covering ODAP and a
> use case on digital promissory notes) - feedback is very welcomed:
> https://www.techrxiv.org/articles/preprint/HERMES_Fault-Tolerant_Middleware_for_Blockchain_Interoperability/14120291/1
> 
> The crash recovery mechanism draft is available at Github:
> https://github.com/CxSci/blockchain-gateway/blob/main/crash/draft-belchior-blockchain-gateway-recovery-01.md
> 
> Feel free to open a GitHub issue to suggest changes.
> 
> Cheers,

-- 
Rafael Belchior
Ph.D. student in Computer Science and Engineering, Blockchain - Técnico
Lisboa
https://rafaelapb.github.io/
https://www.linkedin.com/in/rafaelpbelchior/ 

Links:
------
[1]
https://github.com/CxSci/blockchain-gateway/blob/main/docs/crash/draft-belchior-blockchain-gateway-recovery-02.md

---

From: Rafael Belchior <[email-masked]>
Date: Tue, 25 May 2021 14:47:48 +0100

Dear All, 

Revision 02 of the crash recovery mechanism draft has been published:
https://www.ietf.org/archive/id/draft-belchior-gateway-recovery-02.txt 

Cheers, 

Rafael 

A 2021-05-11 20:36, Rafael Belchior escreveu:

> Hello All,
> We have updated the crash recovery mechanism draft [1] - feedback is greatly appreciated! 
> 
> Changes:
> -Major restructuring.  
> -Changes to Log Format (ODAP's updated data model insights were taken into account - thanks @Luke!) 
> -Updated Log Storage API
> 
> On a separate topic - is anyone familiarized with  ISO 20022 data model? It looks like ISO is also trying to solve the interoperability problem. 
> 
> Cheers, 
> Rafael 
> 
> Ph.D. student in Computer Science and Engineering, Blockchain - Técnico Lisboa

Links:
------
[1]