Subject: RE: [bmwg] OSPF convergence terminology

From: "Manral, Vishwas" <[email-masked]>
Date: Wed, 19 Dec 2001 12:39:32 -0500

Randy,

>i am used to 'convergence' being a matter of MANY routers coming to the
same
>view of the routing universe.  as the bmwg's scope is a single device, i
>don't think we should be using the term 'convergence' at all.
May be you are right, but what could be a more appropriate term for it?

>and be specific.  do you mean the rib 'settling' or the fib?
OSPF 'convergence' draft talks about rib 'settling' and not the fib, guess
it is the same with BGP convergence.

>randy
Thanks,
Vishwas

_______________________________________________
bmwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/bmwg

---

From: Randy Bush <[email-masked]>
Date: Wed, 19 Dec 2001 11:51:22 -0800

> May be you are right, but what could be a more appropriate term for

i was hinting 'settling'

> OSPF 'convergence' draft talks about rib 'settling' and not the fib,
> guess it is the same with BGP convergence.

greenberg's recent paper at isma showed that the biggest chunk of ospf
settling time was updating the fib from the rib, an unexpected result.

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 19 Dec 2001 11:51:22 -0800

i was hinting 'settling'

randy

---

From: Andrew Frame <[email-masked]>
Date: Wed, 19 Dec 2001 12:00:38 -0800

> > May be you are right, but what could be a more appropriate term for

you want to call single router convergence 'settling'? you are possibly
alone in the world on this one...

> settling time was updating the fib from the rib, an unexpected result.

which is why we need standards for both control plane and forwarding
plane convergence.

-andrew

---

From: Andrew Frame <[email-masked]>
Date: Wed, 19 Dec 2001 12:00:38 -0800

-andrew

---

From: Randy Bush <[email-masked]>
Date: Wed, 19 Dec 2001 12:49:21 -0800

> alone in the world on this one...

'possibly' maybe, really not.  but i really don't care what we call it as
long as we don't misuse 'convergence' (or any other well-defined/used term).

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 19 Dec 2001 12:49:21 -0800

randy