Subject: [bmwg] WGLC: draft-ietf-bmwg-2544-as-01

From: Al Morton <[email-masked]>
Date: Fri, 17 Feb 2012 11:55:24 -0500

BMWG,

This message begins a Last call on the draft titled:

RFC 2544 Applicability Statement:
Use on Production Networks Considered Harmful

http://tools.ietf.org/html/draft-ietf-bmwg-2544-as-01

The Last Call will end on March 12, 2012 (coincident with
the revised draft submission deadline for IETF-83).

We've been discussing this topic in BMWG for over a year.

As agreed when taking this draft as a BMWG chartered item,
AD Advisor Ron Bonica will call consensus on this WGLC
(since the current chair is a co-author).

Please weigh-in on whether or not this Internet-Draft
should be given to the Area Directors and IESG for consideration and
publication as an Informational RFC.  Send your comments
to this list and/or Ronald Bonica <[email-masked]>.

Al
bmwg chair

---

From: David Newman <[email-masked]>
Date: Fri, 17 Feb 2012 11:24:09 -0800

> to this list and/or Ronald Bonica <[email-masked]>.

I support the advancement of this document to the ADs and IESG.

dn

---

From: Bill Cerveny <[email-masked]>
Date: Sun, 19 Feb 2012 21:33:46 -0500

Most (all) comments below are grammatical in nature:

Phrase "device under test" and acronymn "DUT" used interchangeably and "DUT" not defined on first usage: " … it is clearly desirable to contain all DUT traffic within the ITE." in section 5 Actually come to think of it, what is "DUT traffic"? Maybe use a more generic "test traffic" here instead of "DUT traffic"?

1) Introduction: 

When I first saw statement, "can only be reliably produced" I wanted to change it to "can only be reliably replicated" or even to something like "can only be reliably produced (and reproduced)". But original usage may be OK (open for comment).

Text '… the term "real-world" to refer production …' should probably be '… the term "real-world" to refer to production …' (added second "to")

5) Advisory on RFC 2544 Methods in Real-world Networks

Minor tweak: "It is possible that some of the tests may prove to be valid …": Possibly change to "It is possible that some of the tests may prove valid …" 

6) What to do without RFC 2544

The paragraph:

"   Other standards may help to fill gaps in telecommunication service
   testing.  For example, the IETF has many standards intended to assist
   with network operation, administration and maintenance (OAM), the
   ITU-T Study Group 12 has a recommendation on service activation test
   methodology
"

The comma after "(OAM)" seems like it should be least be a semi-colon and perhaps a period followed by 'The ITU-T …' as a new sentence.

7) Security Considerations

Minor, minor tweak: Add "a" between "to testing in" and  "laboratory ITE" as such "to testing in a laboratory ITE", since I think "ITE" is singular.

Otherwise, looks good,

Bill Cerveny

On Feb 17, 2012, at 11:55 AM, Al Morton wrote:

> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: Kenneth Green <[email-masked]>
Date: Mon, 20 Feb 2012 05:24:43 +0000

There still seems to be some mixed usage of the phrases "production", "active" and "real-world".

My recollection was that earlier discussion resolved to replace "real-world" with "production". I see no explanation given of the differences amongst these three adjectives and if indeed there is none, then using only one will improve clarity.

Suggested edits:

5. Advisory...

OLD: And as discussed above, the tests will never produce a reliable or accurate benchmarking result.
NEW: And as discussed above, the tests will never produce a reliable or accurate benchmarking result on a production (?real-world? ?active?) network.

Regards,
Kenneth

Kenneth Green
Solution Architect
Ixia

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Al Morton
Sent: Saturday, 18 February 2012 3:55 AM
To: [email-masked]
Cc: Ronald Bonica
Subject: [bmwg] WGLC: draft-ietf-bmwg-2544-as-01

BMWG,

The Last Call will end on March 12, 2012 (coincident with the revised draft submission deadline for IETF-83).

As agreed when taking this draft as a BMWG chartered item, AD Advisor Ron Bonica will call consensus on this WGLC (since the current chair is a co-author).

Please weigh-in on whether or not this Internet-Draft should be given to the Area Directors and IESG for consideration and publication as an Informational RFC.  Send your comments to this list and/or Ronald Bonica <[email-masked]>.

Al
bmwg chair