Subject: Re: [bmwg] draft-morton-bmwg-virtual-net-00

From: ramki Krishnan <[email-masked]>
Date: Wed, 9 Apr 2014 07:12:05 -0700

Additionally, it would be worthwhile to discuss the common energy efficiency aspects across all VNFs. These would include discussing the tradeoffs between CPU energy efficiency/latency/throughput for various packet processing schemes such as

-        Fixed polling

-        Adaptive polling

-        Changing processor P-states (this could be platform specific)

Thanks,

Ramki

-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of Muhammad Durrani
Sent: Wednesday, March 19, 2014 12:27 AM
To: Bhavani Parise; [email-masked]
Subject: Re: [bmwg] draft-morton-bmwg-virtual-net-00

Hi Bhavani,

- do we need to consider or compare performance with the real/physical network vs. the virtual network

- in 3.2 do we need Virtual Switch

[MD] We do need to provide methodologies to benchmark for three architectures vSwitch/SR-IOV and PCI bypass.

Regarding comparing performance only PCI bypass can be compared with physical world.  Again we are not benchmarking networks here but the virtual appliance and wherever needed comparison will be laid out for both Physical and virtual appliance.

for 3.2 how about load balancers, firewalls - do we need to consider, what kind of DPI

    - firewalls - stateful vs stateless

[MD] Virtual appliance is broader term - it means virtual Load balancer  and firewalls (both state full and stateless) We won't be suggesting "kind of DPI" - Standard method will be provided to qualify appliance for any type of DPI

Regards,

Muhammad

-----Original Message-----

From: bmwg [mailto:[email-masked]] On Behalf Of Bhavani Parise

Sent: Wednesday, March 19, 2014 12:03 AM

To: [email-masked]<mailto:[email-masked]>

Subject: [bmwg] draft-morton-bmwg-virtual-net-00

Al,

    including the WG list also for my comments/Qs for this draft. These are a few things which we can look into including as considerations for this draft.

- also for 3.2 - for VNF itself, do we need location of the VNF - guest VM,separate process, appliance etc

-

    - what kind of considerations we need to note when testing a Virtual Firewall Function

- how many Tenants can a VNF support?

- for 3.3 - how about VM mobility or VNF mobility itself

thanks,

Bhavani

________________________________________

_______________________________________________

bmwg mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/bmwg

_______________________________________________

bmwg mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/bmwg

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 9 Apr 2014 11:06:45 -0400

Hi Ramki,

If you search our past work proposals,  draft-manral-...
proposed energy efficiency metrics and benchmarking.
There is some controversy and complexity on making power
measurements, we need to collect these issues and see what
can be done.

Al 
________________________________________
From: bmwg [[email-masked]] On Behalf Of ramki Krishnan [[email-masked]]
Sent: Wednesday, April 09, 2014 10:12 AM
To: Muhammad Durrani; Bhavani Parise; [email-masked]
Subject: Re: [bmwg] draft-morton-bmwg-virtual-net-00

-        Fixed polling

-        Adaptive polling

Thanks,

Ramki

-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of Muhammad Durrani
Sent: Wednesday, March 19, 2014 12:27 AM
To: Bhavani Parise; [email-masked]
Subject: Re: [bmwg] draft-morton-bmwg-virtual-net-00

Hi Bhavani,

Regards,

Muhammad

-----Original Message-----

Al,

-

thanks,

Bhavani

bmwg mailing list

bmwg mailing list

---

From: ramki Krishnan <[email-masked]>
Date: Wed, 9 Apr 2014 22:11:54 -0700

Hi Al,

There are some important and interesting differences between energy efficiency in switches/routers vs VNFs (which runs on servers).

Energy efficiency in Switches/Routers

-        Powering off switch/router components for energy efficiency could have a detrimental effect on the applications unless the servers (sourcing the applications) are also turned off

-        There are no open standards for this

Energy efficiency in VNFs

-        The NFV requirements (high level) for energy efficiency are well defined in the NFV Virtualization Requirements document (http://www.etsi.org/deliver/etsi_gs/NFV/001_099/004/01.01.01_60/gs_NFV004v010101p.pdf)

-        A number of standard interfaces have been developed to support the need to manage workloads across individual/multiple servers to achieve the desired performance and power consumption. Notable established standards are:

*     Intelligent Platform Management Interface (IPMI 2.0)

*     Data Center Management Interface (DCMI 1.5)

*     DMTF Systems Management Architecture for Server Hardware (SMASH)

As you pointed out, we need to take closer look, but I don't see a big problem in coming to consensus on topic in a reasonable amount of time.

Thanks,

Ramki

-----Original Message-----
From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
Sent: Wednesday, April 09, 2014 8:07 AM
To: ramki Krishnan; Muhammad Durrani; Bhavani Parise; [email-masked]
Subject: RE: [bmwg] draft-morton-bmwg-virtual-net-00

Hi Ramki,

There is some controversy and complexity on making power measurements, we need to collect these issues and see what can be done.

Al

To: Muhammad Durrani; Bhavani Parise; [email-masked]<mailto:[email-masked]>

-        Fixed polling

-        Adaptive polling

Thanks,

Ramki

-----Original Message-----

To: Bhavani Parise; [email-masked]<mailto:[email-masked]>

Hi Bhavani,

Regards,

Muhammad

-----Original Message-----

To: [email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>

Al,

-

thanks,

Bhavani

bmwg mailing list

[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>

bmwg mailing list

[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>