Subject: Please comment on draft-ietf-bmwg-fib-term-00.txt

From: [email-masked]
Date: Mon, 6 Nov 2000 17:46:51 -0700

Hi All,

I'd like to solicit your comments on draft-ietf-bmwg-fib-term-00.txt - the
terminology document for measuring the forwarding performance of a router on
the basis of it's forwarding table size and composition.

A copy of this draft can be found at:

	http://www.ietf.org/internet-drafts/draft-ietf-bmwg-fib-term-00.txt

Thanks!

Guy

-----------------------------------------------------------------------
Guy Trotter
Agilent Technologies         phone: +1 604 454 3516
Advanced Networks Division   fax:   +1 604 454 3401
#2500 4710 Kingsway          mailto:[email-masked]
Burnaby, British Columbia    page:  mailto:[email-masked]
V5H 4M2                      yahoo IM: guytrotter
CANADA                       http://www.agilent.com

> -----Original Message-----
> From: Kevin Dubray [mailto:[email-masked]]
> Sent: July 11, 2000 3:19 PM
> To: [email-masked]
> Subject: I-D ACTION:draft-ietf-bmwg-fib-term-00.txt
> 
> 
> 
> Subject: I-D ACTION:draft-ietf-bmwg-fib-term-00.txt
> Date: Tue, 11 Jul 2000 06:29:23 -0400
> From: [email-masked]
> Reply-To: [email-masked]
> To: IETF-Announce: 
> 
> --NextPart
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Border Gateway Multicast 
> Protocol Working Group
> of the IETF.
> 
> 	Title		: Terminology for Forwarding 
> Information Base (FIB) 
>                           based Router Performance Benchmarking
> 	Author(s)	: G. Trotter
> 	Filename	: draft-ietf-bmwg-fib-term-00.txt
> 	Pages		: 12
> 	Date		: 10-Jul-00
> 	
> This document defines terms that are to be used in a methodology
> that determines the IP packet forwarding performance of IP routers
> as a function of the forwarding information base installed within
> the router.
> The objective of this methodology is to evaluate the performance
> levels of IP routers as forwarding information bases continue to
> grow in size and complexity of structure.
> This methodology utilizes the packet forwarding performance
> measurements described in [2]; reference will also be made to the
> associated terminology document [3] for these terms.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-bmwg-fib-term-00.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-bmwg-fib-term-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-bmwg-fib-term-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> --NextPart
> Content-Type: Multipart/Alternative; Boundary="OtherAccess"
> 
> --OtherAccess
> Content-Type: Message/External-body;
> 	access-type="mail-server";
> 	server="[email-masked]"
> 
> Content-Type: text/plain
> Content-ID:	<[email-masked]>
> 
> ENCODING mime
> FILE /internet-drafts/draft-ietf-bmwg-fib-term-00.txt
> 
> --OtherAccess
> Content-Type: Message/External-body;
> 	name="draft-ietf-bmwg-fib-term-00.txt";
> 	site="ftp.ietf.org";
> 	access-type="anon-ftp";
> 	directory="internet-drafts"
> 
> Content-Type: text/plain
> Content-ID:	<[email-masked]>
> 
> --OtherAccess--
> 
> --NextPart--
>

---

From: Gabe Heininger <[email-masked]>
Date: Tue, 07 Nov 2000 15:16:00 -0800

Guy,

   Section 5.6 FIB Prefix Distribution

   Overall this section is complete. But there is one issue with your selection
of Measurement Units.
   In a situation where we are calculating Prefix Distribution for an existing
FIB, this will suffice. However, if we were trying to build a FIB (for
benchmarking purposes of course) to match a given Prefix Distribution specified
in this format, due to the math involved and the chosen inputs we can end up
with a fractional route. These must be accounted for. This is best illustrated
by example:

Build the following routing table:

10,240 Routes
[/8, 16%], [/10, 16%], [/19, 16%], [/22, 16%], [/23 16%], [/24, 16%], [/29, 4%]

1638.40 /8 Routes
1638.40 /10 Routes
1638.40 /19 Routes
1638.40 /22 Routes
1638.40 /23 Routes
1638.40 /24 Routes
409.60 /29 Routes

Using standard rounding, total number of routes = 10,238. If we are testing BGP
aggregation, or if a stream of traffic is configured to all destination
networks, it is possible that two networks would be missing (in the given
example), possibly invalidating the test. How do we account for the missing
routes when specifying prefix distribution in this fashion?

Gabe Heininger
Senior Engineer
Ixia