Subject: [Bridge-mib] VlanID and VlanIDOrAny

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 5 Sep 2003 00:47:33 +0200

So... nobody has reacted to my request for
writeup. So I am preparing to do an ID myself.

This is what I think the discussion boiled down to.

    VlanId            ::= TEXTUAL CONVENTION
        DISPLAY-HINT "d"
        STATUS        current
        DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN."
        SYNTAX        Integer32 (1..4094)

    VlanIdOrAny       ::= TEXTUAL CONVENTION
        DISPLAY-HINT "d"
        STATUS        current
        DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
                      The value of 4095 is used to indicate a wildcard,
                      i.e. any value.
                     "
        SYNTAX        Integer32 (1..4094 | 4095)

Any comments?

Bert

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 5 Sep 2003 11:05:03 +0200

>>>>> Wijnen, Bert (Bert) writes:

Bert> So... nobody has reacted to my request for writeup. So I am
Bert> preparing to do an ID myself.

Bert> This is what I think the discussion boiled down to.

:    VlanIdOrAny       ::= TEXTUAL CONVENTION
:        DISPLAY-HINT "d"
:        STATUS        current
:        DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
:                      The value of 4095 is used to indicate a wildcard,
:                      i.e. any value.
:                     "
:        SYNTAX        Integer32 (1..4094 | 4095)

Bert> Any comments?

Perhaps it makes sense to explain somewhere why 0 is not being used
for the wildcard value.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany