Subject: Re: [Bridge-mib] VlanID and VlanIDOrAny

From: "Les Bell" <[email-masked]>
Date: Fri, 5 Sep 2003 15:20:01 +0100

This looks okay to me.

Les...

"Wijnen, Bert (Bert)" <[email-masked]>@ietf.org on 04/09/2003 23:47:33

Sent by:  [email-masked]

To:   "Bridge-Mib
cc:
Subject:  [Bridge-mib] VlanID and VlanIDOrAny

So... nobody has reacted to my request for
writeup. So I am preparing to do an ID myself.

This is what I think the discussion boiled down to.

   VlanId            ::= TEXTUAL CONVENTION
       DISPLAY-HINT "d"
       STATUS        current
       DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN."
       SYNTAX        Integer32 (1..4094)

   VlanIdOrAny       ::= TEXTUAL CONVENTION
       DISPLAY-HINT "d"
       STATUS        current
       DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
                   The value of 4095 is used to indicate a wildcard,
                   i.e. any value.
                  "
       SYNTAX        Integer32 (1..4094 | 4095)

Any comments?

Bert

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 7 Sep 2003 09:29:03 +0200

It seems that in IPCDN, some people would like
to see yet another TC, namely:

    VlanIdOrZero      ::= TEXTUAL CONVENTION
        DISPLAY-HINT "d"
        STATUS        current
        DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.

                      The value zero is NOT a valid VLAN ID. 
                      
                      When this textual convention is used as the
                      syntax of an object, the object definition
                      MUST specify in the DESCRIPTION clause what
                      the value zero means.
                     "
        SYNTAX        Integer32 (0 | 1..4094)

Does anyone see a problem with that?

Thanks,
Bert 

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: vrijdag 5 september 2003 0:48
To: Bridge-Mib (E-mail)
Subject: [Bridge-mib] VlanID and VlanIDOrAny

Any comments?

Bert

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 7 Sep 2003 11:54:51 +0300

So, I guess that the IPCDN people do not need 4095. 

Otherwise, it looks OK to me. 

Dan

> Sent: 07 September, 2003 10:29 AM
> To: Bridge-Mib (E-mail)
> Subject: FW: [Bridge-mib] VlanID and VlanIDOrAny
> 
>

---

From: "Les Bell" <[email-masked]>
Date: Mon, 8 Sep 2003 09:03:59 +0100

I agree with Andrew on this.  You should define the semantics of the TC more
explicitly, otherwise there seems no value in defining it at all.  One concern I
have here is that VlanIdOrZero, as defined below, could be misused in place of
the VlanIdOrAny.

I can see a possible need for a VlanIdOrNone TC defining the value 0 as
indicating that no VLAN is used; or for the VlanIdOrPriorityOnly, as Andrew
mentions below.  In either of these cases I would accept the value 0 indicating
'No VLAN' or 'Priority Tagged Frame', respectively, as long as it is explicitly
defined as such in the TC.

Les...

"Andrew Smith" <[email-masked]>@ietf.org on 07/09/2003 21:39:45

To:   "'Wijnen, Bert \, "'Bridge-Mib \
cc:
Subject:  RE: [Bridge-mib] VlanID and VlanIDOrAny

Bert,

It seems pointless to me to define a TC where any module that uses it
MUST (or even MAY) add special semantics to one or more of the values.
Why then bother defining the TC at all? We should either define what the
special "none" value is, including its semantics, in the TC definition
or else not define any such TC. I also don't think that the name
"...OrZero" is very helpful: the name should give a hint as to the
semantics, not the syntax, even for a TC name.

N.B. if what IPCDN wants to do is identify the "priority-tagged" frames
permitted by 802.1D/802.1Q (that is frames that carry user_priority
information but no relevant VLAN information) then that should be
handled in one of 2 ways: (a) add 0 as a valid value for VlanId or
VlanIdOrAny or (b) define separate VlanIdOrPriorityOnly and/or
VlanIdOrAnyOrPriorityOnly TCs with ranges (0 | 1..4094) and/or (0 |
1..4094 | 4095) respectively [but I thought in the bridge-mib list
discussions previously, we'd decided that there was no requirement for
the priority-tagged semantics, no?].

Andrew

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Wijnen, Bert (Bert)
Sent: Sunday, September 07, 2003 11:14 AM
To: 'Romascanu, Dan (Dan)'; Bridge-Mib (E-mail)
Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny

Not sure if they need it or not, but it would be to
indicate "wildcard", not "none"

Thanks,
Bert

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: zondag 7 september 2003 10:55
> To: Wijnen, Bert (Bert); Bridge-Mib (E-mail)
> Subject: RE: [Bridge-mib] VlanID and VlanIDOrAny
>
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 8 Sep 2003 16:01:06 +0200

There are quite a bundle of TCs that have this sort of
xxxOrZero behaviour where the user of the TC has to specify
some additional semantics. 

I am fine to be more specific, and to even add a few more
TCs as indicated below. I am writing up an I-D that will
contain them, so we can review.

Thanks,
Bert 

> From: Les Bell [mailto:[email-masked]]
> Sent: maandag 8 september 2003 10:04
> To: [email-masked]

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 21 Sep 2003 23:44:04 +0200

> Bert> So... nobody has reacted to my request for writeup. So I am
> Bert> preparing to do an ID myself.
> 
> Bert> This is what I think the discussion boiled down to.
> 
> :    VlanIdOrAny       ::= TEXTUAL CONVENTION
> :        DISPLAY-HINT "d"
> :        STATUS        current
> :        DESCRIPTION  "The VLAN ID that uniquely identifies a VLAN.
> :                      The value of 4095 is used to indicate 
> a wildcard,
> :                      i.e. any value.
> :                     "
> :        SYNTAX        Integer32 (1..4094 | 4095)
> 
> Bert> Any comments?
> 
> Perhaps it makes sense to explain somewhere why 0 is not being used
> for the wildcard value.
> 
So we're adding anotehr TC where zero value means NONE.
SO then it has become self-explanatory, don't you agree?

Bert