Subject: [Bridge-mib] FW: [802.1] [802.1AB]: Problem with the lldpXdot1RemProtoVlanEntry table inde x

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 20 Jan 2005 15:08:00 +0200

The following question was asked on the IEEE 802.1 e-mail list. The referred index object lldpXdot1RemProtoVlanId has a syntax of Integer32(0|1..4094) - kind of similar to the TC once proposed by Bert. 

Regards,

Dan

-----Original Message-----
From: IEEE 802.1 [mailto:[email-masked]]On Behalf Of Eelco Chaudron
Sent: 20 January, 2005 9:35 AM
To: [email-masked]
Subject: [802.1] [802.1AB]: Problem with the lldpXdot1RemProtoVlanEntry table inde x

Hi All,

When implementing the dot1 extension MIB I was running into a problem with
the lldpXdot1RemProtoVlanTable.
The table has the following indexes:
  - lldpRemTimeMark
  - lldpRemLocalPortNum
  - lldpRemIndex
  - lldpXdot1RemProtoVlanId

The problem lies within the last index, lldpXdot1RemProtoVlanId. This can
have a value of zero, and would be causing an infinite loop when doing SNMP
getnext operations.

To my understanding a SNMP index can never have a value of zero, as it
indicates to SNMP to get the first value.

How would we hande this? For example not returning entries in the
lldpXdot1RemProtoVlanTable wich have a vlanid of zero? Or report the zero
values as 4096?

Regards,

Eelco

IEEE 802.1 list info: http://www.ieee802.org/1/email-pages/etkg1204.html

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "C. M. Heard" <[email-masked]>
Date: Thu, 20 Jan 2005 07:24:38 -0800 (PST)

On Thu, 20 Jan 2005, Eelco Chaudron wrote:
> When implementing the dot1 extension MIB I was running into a
> problem with the lldpXdot1RemProtoVlanTable.
> The problem lies within the last index, lldpXdot1RemProtoVlanId.
> This can have a value of zero, and would be causing an infinite
> loop when doing SNMP getnext operations.
> 
> To my understanding a SNMP index can never have a value of zero,
> as it indicates to SNMP to get the first value.

That is a misconception.  For the purpose of instance selection,
zero is a perfectly valid index value, and it is not treated
differently than any other value.

RFC 2578 recommends that index values be to 1 or greater except in
special situations.  However, it is acceptable to include zero in
the range of index values when it is semantically significant or
when it is used as the index value for a unique row with special
properties.

//cmh