Subject: Re: [Bridge-mib] Review comments on draft-ietf-bridge-bridgemib-smiv2-07.txt

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 6 Jan 2005 23:28:00 +0100

On Fri, Dec 31, 2004 at 10:48:40AM -0800, C. M. Heard wrote:
 
> > If we can do this, it would move the mib up under mib-2, and eliminate
> > the forward reference (issue #757). 
> > It would also place the object and notification subtrees under the
> > dot1dBridge MODULE-IDENTITY, approximating the recommended practices
> > from draft-ietf-ops-mib-review-guidelines Suggested OID layout. 
> 
> All of these sound to me like Good Things.

I have applied the changes. Here is the current tree structure:

  --dot1dBridge(1.3.6.1.2.1.17)		# MODULE-IDENTITY
    +--dot1dNotifications(0)
    +--dot1dBase(1)
    +--dot1dStp(2)
    +--dot1dSr(3)
    +--dot1dTp(4)
    +--dot1dStatic(5)
    +--dot1dConformance(8)
       +--dot1dGroups(1)
       +--dot1dCompliances(2)

And this is the relevant part of the MIB module:

  -- ---------------------------------------------------------- --
  -- subtrees in the Bridge MIB
  -- ---------------------------------------------------------- --

  dot1dNotifications  OBJECT IDENTIFIER ::= { dot1dBridge 0 }

  dot1dBase           OBJECT IDENTIFIER ::= { dot1dBridge 1 }
  dot1dStp            OBJECT IDENTIFIER ::= { dot1dBridge 2 }

  dot1dSr             OBJECT IDENTIFIER ::= { dot1dBridge 3 }
  -- documented in RFC 1525

  dot1dTp             OBJECT IDENTIFIER ::= { dot1dBridge 4 }
  dot1dStatic         OBJECT IDENTIFIER ::= { dot1dBridge 5 }

  -- Subtrees used by Bridge MIB Extensions:
  --      pBridgeMIB  MODULE-IDENTITY   ::= { dot1dBridge 6 }
  --      qBridgeMIB  MODULE-IDENTITY   ::= { dot1dBridge 7 }
  -- Note that the practice of registering related MIB modules
  -- below dot1dBridge has been discouraged since there is no
  -- robust mechanism to track such registrations.
  
  dot1dConformance    OBJECT IDENTIFIER ::= { dot1dBridge 8 }

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 7 Jan 2005 12:18:39 -0500

Hi,

I recommend that the RSTP-MIB be positioned directly under mib-2 as
well, rather than under dot1dbridge. 

David Harrington
[email-masked]
co-chair, IETF Bridge WG

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juergen 
> Schoenwaelder
> Sent: Thursday, January 06, 2005 5:28 PM
> To: [email-masked]
> Subject: Re: [Bridge-mib] Review comments 
> ondraft-ietf-bridge-bridgemib-smiv2-07.txt
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 7 Jan 2005 21:02:15 +0100

> well, rather than under dot1dbridge. 

Yes. In fact, I hacked some code into libsmi yesterday so that it will 
warn in cases where a module identity is somewhere in the internet.mgmt
subtree and not directly below mib-2, transmission or snmpModules. The
idea is that MIB authors get a warning early in the process.

/js