Subject: [Bridge-mib] RE: draft-ietf-bridge-bridgemib-smiv2-10.txt

From: "David B Harrington" <[email-masked]>
Date: Tue, 1 Mar 2005 14:54:47 -0500

Hi,

In doing my recent review of the RSTP-MIB I tried to look up a
reference to 802.1w so I could understand the purpose of a managed
object, where the Description seemed lacking. I couldn't find an
802.1w document easily in IEEE; the [802.1w] link points to
GetIEEE802, and 802.1w is no longer available there, since it has been
incorporated into 802.1D-2004. I found a copy I had saved to my
computer and finally used that to lookup the referenced section of the
802.1 spec.  

I think this is a real problem. I do want to avoid opening up the
debate about whether to update our documents to support other stuff in
802.1D-2004 besides changing the references.

I have been thinking about providing text to incorporate as an IESG
NOTE that says the preferred document is 802.1D-2004 rather than
802.1t and 802.1w. However, the numbering between 802.1t and 802.1w
and the 802.1D-2004 spec doesn't match up, so the reference clause for
an object isn't much help.

If it was likely that IEEE 802.1 would be doing a revision soon, I'd
say leave it to them to update the references, but I suspect it may be
another three or more years before they do another 802.1D merge and
the 802.1t and 802.1w documents are already obsolete and unavailable.

I think we should update the reference clauses in the mib to point to
the appropriate 802.1D-2004 clauses, or provide an appendix that shows
the mapping between 802.1t/w clauses and 802.1D-2004 clauses. I think
we can do this as part of the IETF Last Call process since it is
purely editorial.

Can anybody offer some cycles to provide the mapping between the MIB
module references and the appropriate 802.1D-2004 clauses for each of
the WG documents?

Thanks,
David Harrington
[email-masked]
co-chair, IETF Bridge WG

> -----Original Message-----
> From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> Sent: Tuesday, March 01, 2005 2:02 PM
> To: Mike Geipel
> Cc: J?rgen Sch?nw?lder; KC Norseth; Les Bell; Dave Harrington
> Subject: RE: draft-ietf-bridge-bridgemib-smiv2-10.txt
> 
> Mike,
> 
> Thanks for looking at this. 
> 
> Everybody's swamped...
> 
> The issue is about using obsolete or updated references. The 
> problem is that it took about three years to bring this 
> document where it is, and meanwhile 802.1t was incorporated 
> into 802.1D - 2004. 
> 
> As Juergen mentioned, we do not plan to do a full update to 
> 802.1D - 2004. RSTP for example will be covered by a 
> different document. 
> 
> Do you believe that it is a very bad thing to use 802.1D - 
> 1998 and 802.1t as a reference? How would you define the 
> differences between 802.1D - 1998 and 802.1D - 2004 while 
> avoiding mentioning 802.1t?
> 
> Regards,
> 
> Dan
> 
> 
> 
> > -----Original Message-----
> > From: Mike Geipel [mailto:[email-masked]]
> > Sent: 01 March, 2005 8:29 PM
> > To: Romascanu, Dan (Dan)
> > Cc: 'J?rgen Sch?nw?lder'; 'KC Norseth'; 'Les Bell'; Dave
Harrington
> > Subject: FW: draft-ietf-bridge-bridgemib-smiv2-10.txt
> > 
> > 
> > Hi Dan,
> > 
> > You had recently sent a message to the 802.1 list, informing 
> > folks about the new bridge-mib.  (Thanks!)
> > I notice you're listed as one of the chairs of this group.
> > 
> > Jürgen sent the enclosed reply to my comment.
> > (BTW, that was a quick reply.  Thanks!)
> > 
> > Is it really out-of-scope for a draft 802.1D MIB definition to 
> > refer to the most recent version of the spec it is intended to 
> > manage?  If so, I'll drop it.
> > 
> > 
> > I suppose there wouldn't be much harm done if the list of 
> > managed objects hasn't changed from the obsolete version.
> > If I get a chance later this week, I hope to take a look at 
> > just what the differences are...
> > 
> > I'm kind-of swamped at the moment, though.
> > 
> > -- 
> > Mike Geipel
> > Axxcelera Broadband Wireless
> > 
> > 
> > -----Original Message-----
> > From: Jürgen Schönwälder [mailto:[email-masked]] 
> > Sent: Tuesday, March 01, 2005 12:59 PM
> > To: Mike Geipel
> > Cc: 'KC Norseth'; 'Les Bell'; Dave Harrington
> > Subject: Re: draft-ietf-bridge-bridgemib-smiv2-10.txt
> > 
> > On Tue, Mar 01, 2005 at 12:08:11PM -0500, Mike Geipel wrote:
> > 
> > > I am new to the IETF, although I have been active in IEEE 
> standards.
> > > Taking a quick look at the new Bridge MIB, I just noticed 
> > something...
> > >  
> > > It references the obsoleted 802.1D-1998 spec, 802.1t and 802.1w.
> > > These should be changed to use the 802.1D-2004 
> > specification, approved
> > last
> > > June to include all three.
> > >  
> > > I have not looked to see if they have defined new managed 
> > objects to the
> > > PICS pro forma.
> > 
> > (1) This document has passed WG last call. So your comment 
> > should be posted
> >     as IETF last call comment to the appropriate mailing list 
> > if you think
> >     this is a serious issue to consider.
> > 
> > (2) I have no clue what the differences between the various 
> specs are
> >     so I am pretty reluctant to change references.
> > 
> > (3) Note that it was specifically decided that this WG does 
> not try to
> >     track all the latest IEEE changes since this seems a 
> > rather difficult
> >     thing to do which should actually be done by the IEEE. 
> > (Note that the
> >     control of all these IEEE MIB modules is supposed to be 
> > moved to the
> >     IEEE.
> > 
> > /js
> > 
> > -- 
> > Juergen Schoenwaelder		    International 
> University Bremen
> > <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> > 28725 Bremen, Germany
> > 
> > 
> 

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "Tom Petch" <[email-masked]>
Date: Mon, 7 Mar 2005 16:45:01 +0100

I am inclined to leave well alone.

For me, the root problem is the IEEE system of identifying standards.  I find
that being up-to-date causes endless misunderstandings and arguments with people
who 'know' that they are talking about 802.1az (or some such) and will never
update their knowledge no matter how long ago that was superseded.  In fact, it
is hard to find an equipment manufacturer which does not use obsolete
references.  IEEE may declare them superseded but they now have a life
independent of the IEEE.

Have 802.1t and 802.1w reached that status?  I think so.

 (The hard copy sits on my desk along with 802.1D-1998 etc)

In passing, I see we have
dot1dStpPathCostDefault OBJECT-TYPE
    SYNTAX      INTEGER {
                    stp8021d1998(1),
                    stp8021t2001(2)
                }
which enshrines 802.1t for all time.  (But then it should be stp8021D1998).

Tom Petch

----- Original Message -----
From: "David B Harrington" <[email-masked]>
To: "'Bridge-Mib (E-mail)'" <[email-masked]>
Cc: "'Dan Romascanu'" <[email-masked]>; "'David Kessens'"
<[email-masked]>; <[email-masked]>; "'Wijnen,Bert
(Bert)'" <[email-masked]>
Sent: Tuesday, March 01, 2005 8:54 PM
Subject: [Bridge-mib] RE: draft-ietf-bridge-bridgemib-smiv2-10.txt

Hi,

Thanks,
David Harrington
[email-masked]
co-chair, IETF Bridge WG

Harrington