Subject: [Bridge-mib] problems with dot1dStpPortDesignatedPort

From: Michael MacFaden <[email-masked]>
Date: Thu, 28 Mar 2002 16:24:23 -0800

Hi,

In draft-ietf-bridge-bridgemib-smiv2-02.txt,
the managed object:

    dot1dStpPortDesignatedPort OBJECT-TYPE
     SYNTAX      OCTET STRING (SIZE (2))
     MAX-ACCESS  read-only
     STATUS      current
     DESCRIPTION
      "The Port Identifier of
       the port on the Designated
       Bridge for this port's segment."
     REFERENCE "IEEE 802.1D-1990: Section 4.5.5.7"
    ::= { dot1dStpPortEntry 9 }

has not been updated with text to 
say what one should do if the bridge
has greater than 255 ports. 

I understand 802.1T has modified how these 16 bits are
being divided up, however I don't think this
object can be reused and must only report 
on the range it is capable of reporting on. 

A new object would have to be added to represent
the new interpretation of the 16 bits in a port identifer.

Testing with existing fielded products 
has shown that the priority bits often just
get shifted out which strikes me as rather broken.

So is is possible that some prose be added to 
the front matter about what a conforming application 
should expect from a device implementing the BRIDGE-MIB 
when it device has > 255 ports?

Thanks,
Mike MacFaden

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "K.C. Norseth" <[email-masked]>
Date: Thu, 28 Mar 2002 18:10:14 -0700

Hi Mike,

We depricated dot1dStpPortPathCost for dot1dStpPortPathCost32   I can see
the value of doing a new object dot1dStpPortDesignatedPort.  We don't want
to add new objects if possible, but this does make sense.

What should a conforming application expect from a device implementing the
BRIDGE-MIB when it device has > 255 ports?

K.C.

----- Original Message -----
From: "Michael MacFaden" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 28, 2002 5:24 PM
Subject: [Bridge-mib] problems with dot1dStpPortDesignatedPort

| Hi,
|
| In draft-ietf-bridge-bridgemib-smiv2-02.txt,
| the managed object:
|
|     dot1dStpPortDesignatedPort OBJECT-TYPE
|      SYNTAX      OCTET STRING (SIZE (2))
|      MAX-ACCESS  read-only
|      STATUS      current
|      DESCRIPTION
|       "The Port Identifier of
|        the port on the Designated
|        Bridge for this port's segment."
|      REFERENCE "IEEE 802.1D-1990: Section 4.5.5.7"
|     ::= { dot1dStpPortEntry 9 }
|
| has not been updated with text to
| say what one should do if the bridge
| has greater than 255 ports.
|
| I understand 802.1T has modified how these 16 bits are
| being divided up, however I don't think this
| object can be reused and must only report
| on the range it is capable of reporting on.
|
| A new object would have to be added to represent
| the new interpretation of the 16 bits in a port identifer.
|
| Testing with existing fielded products
| has shown that the priority bits often just
| get shifted out which strikes me as rather broken.
|
| So is is possible that some prose be added to
| the front matter about what a conforming application
| should expect from a device implementing the BRIDGE-MIB
| when it device has > 255 ports?
|
| Thanks,
| Mike MacFaden
|
| _______________________________________________
| Bridge-mib mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/bridge-mib
|

---

From: Michael MacFaden <[email-masked]>
Date: Fri, 29 Mar 2002 12:04:24 -0800

>to add new objects if possible, but this does make sense.

Great.

>BRIDGE-MIB when it device has > 255 ports?

I would think a conforming agent would return noSuchInstance for this
managed object for ports > 255.

Regards,
Mike