Subject: [Bridge-mib] Re: FW: 802.1x and TimeTicks

From: "Les Bell" <[email-masked]>
Date: Mon, 25 Mar 2002 08:53:25 +0000

Bruno,

The intention for dot1xAuthSessionTime was to report it in hundredths of
seconds, as the TimeTicks TC says.  The description is wrong.

The question we have to ask now is:
How do people think we should fix this bug?

Option 1:
    Fix the description to say "hundredths of seconds".

Option 2:
    Fix the syntax as Integer32 (I think IETF rules do not permit this).

Option 3:
    Deprecate dot1xAuthSessionTime and
        a) define a new item using TimeTicks, or
        b) define a new item using Integer32.

This bug highlights one of the problems of developing MIBs in IEEE 802 groups:
lack of peer review.  The MIB experts are all at the IETF, so we need to get
IETF involvement in the MIB development at an early stage, so the MIB is
released at the same time as the IEEE 802 standard it addresses.  I think the
current approach with the hubmib WG development of the Power Over Ethernet MIB
is a good example of this.

Les...

"Pape, Bruno" <[email-masked]> on 22/03/2002 19:21:02

Sent by:  "Pape, Bruno" <[email-masked]>

To:   "'stds-802-1 @ieee.org'" <[email-masked]>
cc:    (Les Bell/GB/3Com)
Subject:  FW: 802.1x and TimeTicks

-----Original Message-----
From: Laurence, Francis (Joe)
Sent: Friday, March 22, 2002 2:21 PM
To: Pape, Bruno
Subject: RE: 802.1x and TimeTicks

Bruno,
   You might want to forward your message to the standards mailer for the
IEEE802.1
   group that created the standard. They are pretty good at answering
questions regarding
   the standards that they create.

The address is :
            [email-masked] <mailto:[email-masked]>

Joe L.

-----Original Message-----
From: Pape, Bruno
Sent: Friday, March 22, 2002 1:48 PM
To: mibcommittee
Subject: 802.1x and TimeTicks

It looks like the IEEE8021-PAE-MIB attempts to redefine TimeTicks in
its definition of dot1xAuthSessionTime.  The Net-SNMP code interprets
TimeTicks as per SNMPv2-SMI.  I would propose that we resolve the
conflict in favor of the SNMPv2-SMI definition of TimeTicks.  This would
apply to etsysDot1xAuthSessionTime in enterasys-8021x-extensions-mib.txt
as well.

Anyone feel like taking this up with the IEEE?

Thanks,

Bruno

From http://cvsmibs/cgi-bin/cvsweb.cgi/standards/ieee/IEEE8021-PAE-MIB
<http://cvsmibs/cgi-bin/cvsweb.cgi/standards/ieee/IEEE8021-PAE-MIB>

dot1xAuthSessionTime OBJECT-TYPE
    SYNTAX TimeTicks
    MAX-ACCESS read-only
    STATUS current
    DESCRIPTION
               "The duration of the session in seconds."
    REFERENCE  "9.4.4, Session Time"
    ::= { dot1xAuthSessionStatsEntry 7 }

And from http://cvsmibs/cgi-bin/cvsweb.cgi/standards/ietf/SNMPv2-SMI
<http://cvsmibs/cgi-bin/cvsweb.cgi/standards/ietf/SNMPv2-SMI>

-- hundredths of seconds since an epoch
TimeTicks ::=
    [APPLICATION 3]
        IMPLICIT INTEGER (0..4294967295)

---

From: "Ayers, Mike" <[email-masked]>
Date: Mon, 25 Mar 2002 10:27:15 -0600

> From: Les Bell [mailto:[email-masked]] 
> Sent: Monday, March 25, 2002 12:53 AM

>     Fix the syntax as Integer32 (I think IETF rules do not 

	They don't.

>         b) define a new item using Integer32.

	If the MIB has production field implementations, then (3) should be
chosen, else (1) will do nicely.

/|/|ike

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib