Subject: Re: Transport data mixed with Application data?

From: Doug Royer <[email-masked]>
Date: Mon, 2 Aug 1999 14:31:40 -0700 (PDT)

Sure  - SENDDATA

	CUA SENDDATA
	CUS <MIME-DATA>
	CS <TRANSPORT-PROTOCOL-REPLY>
	CS <iCAL-MIME-REPLY>
	CS ...application data...
	CS <CRLF>
	CS .
	CS <CRLF>

> Date: Mon, 02 Aug 1999 13:31:59 -0700
> From: [email-masked] (Steve Mansour)
> X-Accept-Language: en
> To: CalSched IETF <[email-masked]>
> Subject: Transport data mixed with Application data?
> List-Archive: <http://www.imc.org/ietf-calendar/mail-archive/>
> List-Unsubscribe: <mailto:[email-masked]?body=unsubscribe>
> 
> Can anyone come up with an example of a CAP command that returns both
> transport AND application level data? I don't think we have one yet.
> 
> Several of you spoke with me after the Oslo meeting and indicated that
> the "capabilities" information we returned in the example we covered was
> really all application-level data. I tend to agree with that.
> 
> The response to a CAP command currently has this general form:
> 
>      <replycode> ; text ;  more text  <CRLF>
>      [<application-level-data>] <CRLF>.<CRLF>
> 
> If there's really a need to return transport level stuff in the same
> reply, then we'll need to change it.
> 
> Please respond if you see a problem with this.
> 
> -Steve

-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: [email-masked] (Steve Mansour)
Date: Mon, 02 Aug 1999 15:24:04 -0700

Doug,

I don't understand your reply. We currently use this form of reply:

     <replycode> ; text ;  more text
     [<CRLF><application-level-data>]
     <CRLF>.<CRLF>

This has no place for transport-level data. It only allows the transport to
provide a reply code and optional human-readable comment data.

Below is an example reply from the draft. What is the transport-level data in
this reply? The first line has the reply code and the text. The <CRLF>.<CRLF>
is at the end. Everything in between is application-level data.  Is there any
reply that has transport-level data?

S: 2.0 ; got the request OK
S: Content-type:text/calendar; Method=RESPONSE;
S:   Optinfo=VERSION:2.1
S: Content-Transfer-Encoding: 7bit
S:
S: BEGIN:VCALENDAR
S: VERSION:2.1
S: METHOD:RESPONSE
S: TARGET:cap://cal.example.com/opaqueid99
S: CMDID:xyz12345
S: RESPONSE-STATUS:2.0
S: BEGIN:VEVENT
S: DTSTART:19990714T200000Z
S: DTEND:19990714T210000Z
S: UID:000444888929922
S: SUMMARY:Blah bla
S: END:VEVENT
S: BEGIN:VEVENT
S: UID:0034848098038888989443
S: SUMMARY:meeting
S: DTEND:19990714T233000Z
S: DTSTART:19990714T223000Z
S: END:VEVENT
S: END:VCALENDAR
S: .

-Steve