Subject: Re: W-7 CAP Auto-logout Timer

From: Doug Royer <[email-masked]>
Date: Thu, 19 Aug 1999 09:51:24 -0700 (PDT)

Pat - can we call for an e-humm?

I suggest (based on my memory of the issues as discussed in Oslo
or the mailing list):
	
  Give everyone until the end of August to e-humm on:

	W-7.1	Do we have an auto logout timer?

	If they humm YES, then:
		
		W-7.2 	Do we mandate a minimum value? As in
			it can not be less than XX minutes. A
			'no' humm means that you ~could~ be dropped
			right after a command - zero idle time allowed.
		
		W-7.3	Do we mandate a maximum value? As in
			it can not be more than YY minutes. A 'no'
			humm means that the CS might never hang up.
		
		W-7.4	Can the value be variable so the CS
			can decide based on load?
			
		W-7.5	Is the CS's default timeout value returned
			with the CAPABILITY command? Which would
			make W-7.4 just a hint.

		W-7.6	MUST the CS send something to the CUA
			when the connection is dropped? (Except
			a CS could just hang up on a spammer/hacker
			without any message.)

I e-humm:

	W-7.1	YES
	W-7.2	NO
	W-7.3	NO
	W-7.4	YES
	W-7.5	NO
	W-7.6	YES
	
-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: John Stracke <[email-masked]>
Date: Thu, 19 Aug 1999 13:24:30 -0400

> Pat - can we call for an e-humm?

I think you just did.  :-)

>         W-7.6   YES

I agree on all of these except 7.5: I think it could be useful for the CUA
to be able to tell the user how much idle time the CS permits.  For
example, if I find that I'm getting dropped frequently, I might like to be
able to see what the timeout was set to, so I can ask the admin about
increasing it.

--
/=============================================================\
|John Stracke    | My opinions are my own | S/MIME & HTML OK  |
[email-masked]|============================================|
|Chief Scientist | NT's lack of reliability is only surpassed |
|eCal Corp.      |  by its lack of scalability. -- John Kirch |
\=============================================================/

---

From: Alexander Taler <[email-masked]>
Date: Tue, 24 Aug 1999 11:33:02 -0400

> able to see what the timeout was set to, so I can ask the admin about

I'm with Doug on all of these.

I seem to recall that IMAP (?) clients would issue NOOP commands in 
order to prevent the server from closing a connection.    We don't 
have NOOP, but CAPABILITIES could serve the purpose.  Providing 
default timeout information (W-7.5) just makes this sort of 
behaviour easier, and I'm sure that we don't want to encourage it.

I can find that I'm getting dropped frequently when the server sends
timeout notices, and my client displays a 'The server timed-out your 
connection' message.

Alex