Subject: RRULE Question: How to specify weird pattern

From: [email-masked] (John Sun)
Date: Fri, 20 Jul 2001 11:21:52 -0700

I would like to know if you can tell me the RRULE for the following
recurrence pattern.

Repeat every 30th of the month.
However, if the month does not have 30 days, set the meeting to the last
day of the month.

Combining 2 RRULES like this might work:

BYMONTHDAY=30;FREQ=MONTHLY
BYMONTH=2,FREQ=YEARLY,BYMONTHDAY=-1

Is there a way to specify this in one RRULE?

---

From: Alan Davies <[email-masked]>
Date: Fri, 20 Jul 2001 14:33:57 -0400

You could use bysetpos:

FREQ=MONTHLY;BYMONTHDAY=28,29,30;BYSETPOS=-1

--Alan