Subject: Server replies to CREATE

From: Doug Royer <[email-masked]>
Date: Wed, 14 Nov 2001 16:02:17 -0700

The restriction tables for CREATE server replies, needs
to include UID (or ALARMID for VALARM) with the replies.
Otherwise you could not discern which REQUEST-STATUS is for
which object?

VEVENT Example:

       . . . VEVENT           0+
add    . . . . UID               1    The UID for which this
add                                   REQUEST-STATUS applies.
       . . . . REQUEST-STATUS    1+
       . . . . *              0        No other VEVENT properties
                                       are present

And it is needed for VTODO, VJOURNAL, and VALARM (with ALARMID).

-Doug

---

From: [email-masked] (Steve Mansour)
Date: Fri, 16 Nov 2001 08:55:43 -0800

Additionally, won't we need to supply the RECURRENCE-ID if the create
was for a new instance?  Or do people see that as a MODIFY operation?

> add                                   REQUEST-STATUS applies.

done!

> And it is needed for VTODO, VJOURNAL, and VALARM (with ALARMID).

done!

-Steve

---

From: Doug Royer <[email-masked]>
Date: Fri, 16 Nov 2001 14:58:51 -0700

> was for a new instance?  Or do people see that as a MODIFY operation?

Yes - if you created multiple with the same UID, each of which
was a METHOD:ADD - add byCAP METHOD:CREATE.

If you MODIFY more than one instance, but not all instances - yes.

And likewise QUERYNAME should be returned for CREATE VQUERYs.
And TZ<whatever> when CREATing a VTIMEZONEs.
And CARID when CREATing VCARs.
Any others?

---

From: George Babics <[email-masked]>
Date: Tue, 20 Nov 2001 13:55:34 -0500

Added recurrence id to the server's response.

George