Subject: CAP TODO: disconnect

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 12:37:52 -0700

> - DISCONNECT: should the client now wait for a response
>  from the server before disconnecting?

YES!!

For two reasons:

	1) To make sure the CS got the request.

	2) To keep the CS from hanging open that connection for
	   a while in TCP-WAIT state when:

		CUA:	sends - goodbye
		CS:	sends - goodbye reply
		CUA:	physical hang-up before it gets the CS reply.
		CS:	TCP waiting for the ill-mannered CUA's
			TCP stack to say 'got message'

This was discussed in a SMTP IETF meeting. It can cause
the server side to hang for a while in TCP-WAIT state while
the TCP stack determines if the connection died or is just slow.

SPANNERS loved the fact you could fire off junk to an smtp-server
and disconnect without waiting for the spam target system to reply,
sometimes resulting in possibly a HUGE NUMBER of sessions hung for
a couple of minutes while the TCP-stack determining if they hung up
or are slow. I think that on most Unix systems the default is a 2 minute
wait per connection.

-Doug

---

From: George Babics <[email-masked]>
Date: Tue, 20 Nov 2001 13:41:19 -0500

By doing CAP's transport layer with BEEP, disconnect
will be out of the scope of CAP.

George