Subject: RE: MIME Multiple body parts (Was Re: uid...)

From: "John Stracke" <[email-masked]>
Date: Fri, 9 Nov 2001 11:55:31 -0500

>Unicode is a solution - but may have difficulties for certain Asian
>languages, specifically there appear to be commonly used Japanese 
character
>sets that are not in UTF8.

There is nothing in Unicode that is not in UTF-8.  That's what 
"transformation format" means.  See RFC-2279.

Unicode has had difficulties with some Asian languages in the past (the 
whole "Han unification" mess), but I believe that was fixed this year.

/========================================================\
|John Stracke                    |Principal Engineer     |
[email-masked]   |Incentive Systems, Inc.|
|http://www.incentivesystems.com |My opinions are my own.|
|========================================================|
|This is the .sig that says... Ni!                       |
\========================================================/

---

From: "John Stracke" <[email-masked]>
Date: Mon, 12 Nov 2001 09:53:21 -0500

>I agree. I am NOT saying it is a must for MUA's. I am saying
>lets not limit ourselves to what MUA's can do today. 

OK, then we're in agreement: I just said it was risky.  Probably that'll 
change.

/===========================================================\
|John Stracke                    |Principal Engineer        |
[email-masked]   |Incentive Systems, Inc.   |
|http://www.incentivesystems.com |My opinions are my own.   |
|===========================================================|
|A computer without Windows is like a chocolate cake without|
|mustard.                                                   |
\===========================================================/

---

From: [email-masked]
Date: Mon, 12 Nov 2001 14:25:11 -0500

----- Forwarded by Robert Ransdell/Westford/IBM on 11/12/2001 02:19 PM -----

Steve Mansour <[email-masked]>
Sent by: [email-masked] (Steve Mansour)
11/12/2001 01:49 PM

        To:     [email-masked]
        cc: 
        Subject:        Re: MIME Multiple body parts (Was Re: uid...)

I absolutely agree that we *should* have allowed for multiple UIDs in
iTIP messages.  As I said, I was overruled :-)

Why did you not post this to the group?

-STeve

[email-masked] wrote:
> 
> The one that would cause you a problem is posting a conference.  For
> example all the events at Lotussphere;    In this case each event is a
> different uid.  The .ics stream is all the possible events at the
> conference.
> 
>   sman
>                            To:        Robert Ransdell/Westford/IBM
>   11/12/2001 12:37 <[email-masked]>
>   PM                       cc:
>                            Subject:        Re: MIME Multiple body
>                    parts (Was Re: uid...)
> 
> That should be no problem, right?  The UID will still be the same.  So
> that doesn't violate the RFC as I read it.
> 
> -Steve
> 
> Robert Ransdell/Westford/IBM wrote:
> 
> > You have to allow, at least,  an iCalendar stream with multiple
> VEvents to
> > handle the case of an additional invitee to an already existing
> repeating
> > event where some of the individual events have been modified.
> >
> >
> 
|---------+--------------------------------+----------------------------------------------------------------------------------->
> > |         |           sman                 |
>                                                           |
> > |         |           Sent by:             |       To:
> [email-masked]                                             |
> > |         |           owner-ietf-calendar@m|       cc:       (bcc:
> Robert Ransdell/Westford/IBM)                               |
> > |         |           ail.imc.org          |       Subject:  Re:
> MIME Multiple body parts (Was Re: uid...)                     |
> > |         |                                |
>                                                           |
> > |         |                                |
>                                                           |
> > |         |           11/10/2001 12:35 AM  |
>                                                           |
> > |         |                                |
>                                                           |
> >
> 
|---------+--------------------------------+----------------------------------------------------------------------------------->
> >   >------------------------|
> >   |                        |
> >   >------------------------|
> >
> > Doug Royer wrote:
> >
> > > (I think Steve was sleeping when he sent his reply :-)
> >
> > that could be true, but see below...
> >
> > > Steve Mansour wrote:
> > > >
> > > > "Shannon J. Clark" wrote:
> > > > >
> > > > > There is a common trend to associate ONE MIME object holding
> an
> > iCalendar
> > > > > object with ONE vEVENT (and perhaps a vTimezone object). In
> fact I
> > think
> > > > > some vendors may ONLY deal with iCalendar objects that contain
> only
> > one
> > > > > vEVENT.
> > > > >
> > > > > However it is clearly valid to have a vCalendar with multiple
> vEVENT
> > objects
> > > > > (or else what are we doing here???)
> > > >
> > > > you'd think it would be clearly valid wouldnt you?  Actually,
> there was
> > > > a very persuasive group of folks that wanted text/calendar mime
> parts
> > to
> > > > only contain components with a single UID.  And they won :-)
>  Have a
> > > > look at the restriction tables in iTIP. For VEVENTs, where the
> presence
> > > > value is 1+, the text specifies that all components must have
> the same
> > > > UID.
> > >
> > > No:  You can have multiple VEVENTS in one VCALENDAR each with
> > > its own UID.
> > >
> > >         BEGIN:VCALENDAR
> > >         ...
> > >         BEGIN:VEVENT
> > >         UID:1
> > >         ...
> > >         END:VEVENT
> > >         BEGIN:EVENT
> > >         UID:2
> > >         ...
> > >         END:VEVENT
> > >         END:VCALENDAR
> > >
> > > The restriction is per VEVENT, not PER VCALENDAR.
> >
> > Hmm... that's not the way I read RFC2446.  Have a look at 3.2.2
> REQUEST.
> > The
> > restriction table says
> >
> >     VEVENT              1+      All components MUST have the same
> UID
> >
> > I take this to mean that in a REQUEST you can have 1 or more VEVENTs
> but
> > they all
> > must have the same UID.  How do others read this?
> >
> > -Steve
> > (See attached file: sman.vcf)

---

From: [email-masked]
Date: Mon, 12 Nov 2001 14:41:03 -0500

I think your code has to  allow this because that was the most common use 
for vCalendar objects on the web.  IE public events such as band 
schedules.

-STeve

---

From: "John Stracke" <[email-masked]>
Date: Mon, 12 Nov 2001 15:39:23 -0500

I suspect you're talking about raw iCalendar objects, not iTIP messages.

|The plural of mongoose is polygoose.                    |