Subject: Re: CAP TODO: single threaded

From: "John Stracke" <[email-masked]>
Date: Fri, 9 Nov 2001 18:01:26 -0500

>> - Problems with a single threaded server?
>> If yes, then will need to change some things.
>> See post "CAP: Bounded latency"
>
>(1) What do you mean by 'single threaded'? Do you mean OS threads?
>    If so - I don't know of any issues.

The post referred to explains.  Basically, bounded latency is usually not 
implementable in a single-threaded process (unless you start messing with 
alarm signals, and signals are the spawn of Satan), because the APIs used 
to access the backend database are typically blocking calls.  If CAP 
requires the bounded-latency features, then it is mandating that servers 
be designed with multiple threads.

/========================================================\
|John Stracke                    |Principal Engineer     |
[email-masked]   |Incentive Systems, Inc.|
|http://www.incentivesystems.com |My opinions are my own.|
|========================================================|
|"Time is money, and price is information." --Russ Nelson|
\========================================================/

---

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 17:07:30 -0700

> be designed with multiple threads.

Multi-threaded - no not required. I can do that on a Palm Pilot,
Unix, any of the MS-dos's, and using many single threaded OS's
and languages.

I was never a fan of bound latency. I always said if the CUA
does not want to wait, it can cancel the request.  However
the WG overrode me by a huge majority. Any system that can
handle iCalendar/CAP can handle this.

Yes - you have to use alarms. But even the Palm Pilot and MS-Dos's
can do that. And I don't know of any Unix that can not do alarms well.

I really don't see this as an issue.

The API's to backend databases - from mSQL, MySQL, the GNU-SQL,
Oracle, and MANY others have nothing to-do with alarms. Many (all these?)
allow for submitting the query and going back later for the answer.

If your OS can't do OS alarms - then how will it ever handle iCal alarms?
Is it going to block all request until all iCal-alarms are sent?

Pain - yes - that's why I did not want it. The WG said yes.
Closed issue - lets get CAP out. :-)
-Doug