Subject: Re: ALARMID to VALARM after stored?

From: "John Stracke" <[email-masked]>
Date: Tue, 20 Nov 2001 14:37:54 -0500

>We could generate a UID instead of using an ALARMID.
>It will be one less property to define, and UIDs are
>used as unique ids for many other components: VEVENT,
>VTODO, VJOURNAL, etc.

Yes, but those are all top-level components; a VALARM is contained within 
a VEVENT or VTODO.

Myself, I took the original suggestion to mean that the UID returned by 
GENERATEUID could be used as the value for an ALARMID, not that we would 
actually rename ALARMID.

/=============================================================\
|John Stracke                   |Principal Engineer           |
[email-masked]  |Incentive Systems, Inc.      |
|http://www.incentivesystems.com|My opinions are my own.      |
|=============================================================|
|"I think we'd get fewer bug reports if we stopped selling our|
|software off planet."                                        |
\=============================================================/

---

From: Bernard Desruisseaux <[email-masked]>
Date: Tue, 20 Nov 2001 16:50:55 -0500

> Yes, but those are all top-level components; a VALARM is contained within

Actually, it would be useful to allow VALARMs contained
within VEVENT and VTODO to make reference to VALARMs
contained in VAGENDAs to allow calendar users to easily
manage their preferred alarm properties (e.g., alarm lead
time) in few VALARMs.

For instance, I could store the following VALARM in a
VAGENDA:

   BEGIN:VALARM
   UID:[email-masked]
   TRIGGER:-PT30M
   REPEAT:2
   DURATION:PT15M
   ACTION:DISPLAY
   END:VALARM

and make reference to it in a VALARM contained within a
VEVENT as follows:

   BEGIN:VEVENT
   UID:[email-masked]
   DTSTART:20011121T220000Z
   DTEND:20011121T230000Z
   SUMMARY:Important Meeting
   BEGIN:VALARM
   ALARMREF:[email-masked]
   END:VALARM
   END:VEVENT

To make this possible we need unique identifiers (UID)
for VALARMs.

> GENERATEUID could be used as the value for an ALARMID, not that we would

I meant to rename ALARMID to UID.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878