Subject: Re: What should the xCal tag names case be?

From: Gary Frederick <[email-masked]>
Date: Fri, 02 Nov 2001 12:03:15 -0600

argh--- so many interesting projects - 24 hours in a day...

I also 'vote' for lower case. It looks better.

I have done a lot of hand coding of xcal (my version) and it is a real 
handy thing to have. However, I like the idea of all lower case because 
it is 'easy' to do in a program. If we have mixed case, we have to have 
a bit of code for each tag's case.

My original post was trying (and failing due to my inability to 'type' 
English) to say that an original in iCalendar can have whatever case the 
XML will have for example lower-case. We will not be able to recreate 
the original iCalendar from xcal without saving info about the 
original's case. I see NO <comment>note the upper case</coment> reason 
to save info on the case of the original.

 >For whose "ease of use" do we make this decision?
If it's easy to read, it's a bit easier to work with when doing XSLT 
stylesheets. A BIG <coment>did it again...</comment> plus.

My wife uses my version of xcal to enter events. She enters them by 
hand. We can generate iCalendar and xcal once we have something in xcal. 
She finds it easy to work with xcal. I think there will be a small but 
measureable number of people editing xcal by hand.

Gary

NITSCH,FRANK (HP-Germany,ex1) wrote:
>>>I believe
>>>research has shown that mixed case is easier to read.
>>>
> 
> Well, reading a book is of course easier than reading
> C code... ;-)
> 
> 
>>That certainly accords with my own experience.  People who 
>>SHOUT, or who 
>>type everything in lower case, are harder to read.  Mixed 
>>case gives your 
>>eyes clues as they parse along.
>>
> 
> You should take into account that coding XML by hand will
> be much less error-prone if everything is either lower or
> upper case. However I agree that upper case is not really
> a desired option... It looks just annoying and using Shift
> or Caps Lock all the time is also a hassle for those who type
> xCal by hand.
> 
> If you now think that coding xCal by hand is not an important
> use-case I'd like to ask you: who do you think should read
> raw XML? What's the most important issue the decision
> should be based on? Is it a developer who want's to verify
> the output of his GUI by inspecting the XML source or a
> developer who constructs a test xCal event in XML in his
> ASCII editor? For whose "ease of use" do we make this decision?
> 
> BTW: I'd vote for all lower case! ;-)
> 
> Regards
> 
> 	Frank
>

---

From: "John Stracke" <[email-masked]>
Date: Fri, 2 Nov 2001 13:20:34 -0500

> If we have mixed case, we have to have 

True--it would mean the script to convert text/calendar to 
application/icalendar+xml would need to know properties and parameters, 
and would have to be updated for extensions, just as if the names didn't 
match at all.

So, yes, I think we should go for all lowercase (or all uppercase, if 
anybody really wants to argue that), and identical names.

John Stracke
Principal Engineer
Incentive Systems, Inc.
[email-masked]