Subject: CAP DODO: VQUERY - partial access

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 13:03:04 -0700

> - VQUERY: if the user does not have access to some, but not 
> all of properties that were specified
> should the acessible properties be returned along with an error code

This is already described in CAP.

They do not return the properties that the UPN does
not have access to. If you ask for ATTENDEEs and you
don't have permission, the results are returned without
the ATTENDEE property:

If you send:

	BEGIN:VQUERY
	QUERY:SELECT DTSTART,DTEND,ATTENDEE FROM VEVENT WHERE UID="123"
	END:VQUERY

and get back:

	BEGIN:VCALENDAR
	DTSTART:<valid...>
	DTEND:<valid...>
	END:VCALENDAR

Is a valid reply that means you have access to the calendar,
but not all the properties you requested. (It could return and empty
set with nothing between the BEGIN/END.

-Doug

---

From: George Babics <[email-masked]>
Date: Tue, 20 Nov 2001 12:51:29 -0500

I'll remove it from the to-do list.
We should add an example of such a search.

George