Subject: Re: CAP TODO - CRISP

From: "John Stracke" <[email-masked]>
Date: Fri, 9 Nov 2001 17:57:14 -0500

>>  section 7.1.5, CAPVERSION, CAR, and QUERYLEVEL all need to be able to 
>>  have values of NONE.)
>
>Why MUST these be NONE?
>
>Why can't a CRISP server send out a CAPABILITY of CRISP,

Mmm, that's an option.  However, I think I'd rather make it explicit to 
clients that they're not going to get CAR or QUERYLEVEL features.  That 
way, if a CAP client accidentally gets configured to use a CRISP server, 
it will be told so clearly, even if it doesn't check the CRISP capability.

Perhaps CAPVERSION could be "CRISP" and the other two could be "NONE", and 
we can specify that NONE is a legal value if, and only if, CAPVERSION is 
CRISP.  How's that?

/========================================================\
|John Stracke                    |Principal Engineer     |
[email-masked]   |Incentive Systems, Inc.|
|http://www.incentivesystems.com |My opinions are my own.|
|========================================================|
|Earth: love it or leave it.                             |
\========================================================/

---

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 16:55:32 -0700

> it will be told so clearly, even if it doesn't check the CRISP capability.

How about if a server sends out CRISP and not CAPVERSION, then
it is a CRISP server and not a CAP server.

If a server were NOT to send CAPVERSION, then it is NOT a CAP server.
So it would be out of scope for CAP.

However a LONG debate resolved to SQL-MIN, that is not optional for
a CAP server.

> we can specify that NONE is a legal value if, and only if, CAPVERSION is

I don't see what the conflict is. If you don't want to use SQL-MIN,
don't use it. The CS will not cram one up the pipe to a CUA.

If CAPVERSION is not present or its value is not "1.0" (as specified
in the current draft) --> then it is not a CAP server.
So out of scope for CAP.

Sending NONE to CAPVERSION and NONE to SQL-MIN takes away a lot
of CAP. It's not a CAP server.

Why can't you say a CRISP server is a CAP server,except: no CAPVERSION
and no SQL-MIN, ... ?

-Doug