Subject: ALARMID to VALARM after stored?

From: Doug Royer <[email-masked]>
Date: Wed, 14 Nov 2001 15:53:52 -0700

In the restriction table for METHOD:CREATE

       . . . . ALARMID        0 or 1   MUST be 1 if multiple
                                       VALARMs are present in
                                       same component.

Issue?

If a VEVENT is created with a VALARM that DOES NOT contain
a ALARMID, what is the procedure for adding a new VALARM
to that VEVENT? You just can't add one, you have for first
modify the existing VALARM and add a ALARMID for it, so...

I think we should declare that this is a '1' and not
a '0 or 1'.  Any CUA that gets a non-CAP object can
easily add a ALARMID, but it would be a pain to add
one later.

-Doug

---

From: [email-masked] (Steve Mansour)
Date: Wed, 14 Nov 2001 21:01:44 -0800

> easily add a ALARMID, but it would be a pain to add

I agree.  I think it is far simpler to just always add the alarmid.
I'll make the update. If anyone has any objections let's go through it
on the list.  (we can always pull it out later if someone comes up with
a good reason for NOT having an alarm id).

For people who are concerned about small-footprint devices not being
able to generate guids, remember that is why we added the GENERATEUID
command. You can always ask the server to generate them for you.

-Steve

---

From: Doug Royer <[email-masked]>
Date: Thu, 15 Nov 2001 14:01:50 -0700

> command. You can always ask the server to generate them for you.

ALARMID != UID, but you could use it for that I guess.

And in I can not find the definition of ALARMID in CAP.

NEW TODO - add definition if ALARMID to CAP?

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 15 Nov 2001 16:42:57 -0500

> ALARMID != UID, but you could use it for that I guess.

Why can't we simply use UID in VALARM?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 15 Nov 2001 16:02:13 -0700

> Why can't we simply use UID in VALARM?

It could make a VQUERY command a mess to read.
ALARMID's are unique per component and UIDs are unique.

No other reasons that I can think of.

---

From: [email-masked] (Steve Mansour)
Date: Thu, 15 Nov 2001 15:20:34 -0800

> Why can't we simply use UID in VALARM?

what if there are multiple valarms?

-Steve

---

From: George Babics <[email-masked]>
Date: Tue, 20 Nov 2001 13:25:56 -0500

We could generate a UID instead of using an ALARMID.
It will be one less property to define, and UIDs are
used as unique ids for many other components: VEVENT,
VTODO, VJOURNAL, etc.

George