Subject: Re: Last Call: Date and Time on the Internet: Timestamps to Proposed Standard

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 16:35:59 -0700

Why not just specify that dates/times are RFC2445 compliant?
The calsch WG spent a long time debating these issues.

In addition the date-time format used in RFC2445 is also
ISO-8601 based.

In addition the calsch WG has a plan (don't laugh too hard)
for the usage of time zones. This draft only mentions they exist.

Why does there need to be another date-time standard?
Why did this not go through the calsch working group (at least
cc the working group before final proposal?). This draft 
acknowledges the calsch WG, but the chairs (I called Pat) never
saw this - nor did I. Was it sent and debated as assumed by
reading the acknowledgements?

   6. Acknowledgements

      ... Thanks are also due
      to participants of the IETF Calendaring/Scheduling working group
      mailing list, and participants of the time zone mailing list.

The iCalendar date-time format is restricted to exactly one
representation of date-time (not optional spaces, dashes, ...).
There was a large debate on this before rfc2445 came out.
We decided on ONE format for date time based on ISO-8601

	YYYYMMDDTHHMMSS [+/- ...]

If the intent is to be human readable - both loose.
If the intent is to be machine readable - why another similar format?

-Doug

---

From: Doug Royer <[email-masked]>
Date: Fri, 09 Nov 2001 16:38:59 -0700

Joe Abley wrote:
> 
> On Fri, Nov 09, 2001 at 05:16:09PM -0500, Keith Moore wrote:
> > However, many events are actually specified relative to a particular
> > timezone, and timezone offsets occasionally change with little advance
> > warning.  As such, this representation may not be sufficient for
> > specifying dates and times of some kinds of events, particularly
> > future events.
> >
> > In such cases it is necessary to include a representation of the timezone
> > (not merely the GMT offset) along with the date of the event.  This
> > specification does not provide such a facility, and is therefore
> > inappropriate for representation of (for example) events on a calendar.
> 
> Is this not covered in section 1?
>
>   o  All times expressed have a stated relationship (offset) to
>  ....

No - not at all.

This is a BIG issue - if you want to understand it, go
to the calsch archives. Or send email to the [email-masked]
mailing list.

-Doug