Subject: Re: VCARs - any other specific proposals?

From: [email-masked]
Date: Thu, 31 Jan 2002 13:07:48 -0500

While I wade thru the immense flood of recent postings and try to stay 
abreast of the discussions I have one simple sugestion.  WRT:

   The "CARID" property specifies the local identifier for the "VCAR"
   calendar component.  The "NAME" property specifies a localizable
   display name.

Given the ABNF and the prose it appears as if I can have a NAME but no 
CARID.  Since the CARID is what is used to find the definition of the 
rights, but NAME is not, why not follow the same approach we took for 
ATTENDEE and CN.  Make NAME a property parameter of CARID.  Better still, 
you can reuse the CN property parameter name since its essentially the 
same thing, just in another property now.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 14:02:50 -0500

[email-masked] wrote:
> ATTENDEE and CN.  Make NAME a property parameter of CARID.  Better
> still, you can reuse the CN property parameter name since its
> essentially the same thing, just in another property now.

What about localization? :-(

In my last post (CAP: LANGUAGE parameter), I requested
that we allow NAME to occur more than once to be able
to specify this property in different languages in the
same VCAR.

I for one would not have any objection to make CARID
mandatory.  

I did propose to use UID instead of CARID, but this
proposition was not well received.  Apparently, using
UID in VCAR would cause us problems.  That is, problems
that we already have to deal with in VEVENT.  UID is ok
for VEVENT but not for VCAR, or so it seems.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 12:46:20 -0700

[email-masked] wrote:
> CARID. 

bug!

> Since the CARID is what is used to find the definition of the

I thought of the same thing, however a CN (2445) is:

	4.2.2 Common Name

	   Parameter Name: CN

	   Purpose: To specify the common name to be associated
           with the calendar user specified by the property.

It's not a calendar user.

BUT - It could be a paramater to CARID - yes.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 15:26:39 -0500

> > Given the ABNF and the prose it appears as if I can have a NAME but no

As I said to Bruce let's make CARID mandatory
(i.e., MUST occur once).

> BUT - It could be a paramater to CARID - yes.

Can't be done because of localization.  See my reply to Bruce.

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 15:38:51 -0700

> What about localization? :-(

Your right.

> to specify this property in different languages in the

As we are inventing VCARs and VQUERYs (2445 did not), it is
not too late to do that. I am okay with multiple NAME's
per VCAR, but only if they have unique LANGUAGE parameters.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 19:09:13 -0500

> per VCAR, but only if they have unique LANGUAGE parameters.

I agree.

Where should we specify that multiple instances of the NAME
property, within a given component, MUST NOT have the same
value for their LANGUAGE parameter?  In the text?  In a
comment in the ABFN?  TZNAME didn't have this restriction
in RFC 2445.  But yes we should specify it.

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 17:31:34 -0700

Bernard Desruisseaux wrote:
> comment in the ABFN?

As long as it is documented I don't think it matters.

>  TZNAME didn't have this restriction

True - but TZNAME needed to as is valid to have multiple
copies with the same data - and that is bogus.