Subject: Consistant naming of tags

From: [email-masked]
Date: Thu, 31 Jan 2002 14:09:27 -0500

In looking at the versions of CAP Ive noticed that we are somewhat 
arbitrary in how we name multiword properties and parameters.  For example 
we have properties like:

DEFAULT_VCARS  CURRENT_DATETIME  RECUR_ACCEPTED  RECUR_EXPAND 

as well as some like:

ALLOW-CONFLICT  LAST-MODIFIED 

etc.

For those less observant the difference is a '_' vs a '-'.  We should be 
consistanly using one or the other.  Since iCalendar opt'd for '-' I 
propose that all '_' in properties be changed to '-' in the draft for 
consistancy reasons.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 14:15:01 -0500

[email-masked] wrote:
> 
> I propose that all '_' in properties be changed to '-' in the draft
> for consistancy reasons.

I agree.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 15:40:46 -0700

[email-masked] wrote:
> arbitrary in how we name multiword properties and parameters.  For
> example we have properties like:
> 
> For those less observant the difference is a '_' vs a '-'.  We should
> be consistanly using one or the other.  Since iCalendar opt'd for '-'

I agree, I think they sneaked in when I had a buggy version
of my text processor, it printed '_' instead of '-', then
when I fixed the text, I missed many of them.