Subject: Re: VCAR question

From: Bernard Desruisseaux <[email-masked]>
Date: Mon, 14 Jan 2002 17:38:25 -0500

Bernard Desruisseaux wrote:
> 
> Doug Royer wrote:
> >
> > > > > The relationship between the CAP commands (i.e.,
> > > > > create, delete, modify, move, search and schedule)
> > > > > and the CAP actions should be clarified.  Renaming
> > > > > the ACTION CREATE to WRITE would probably help
> > > > > reducing the confusion.
> > > >
> > > > OR we could rename the command to CREATE as WRITE implies
> > > > modify as you pointed out above.
> > >
> > > You lost me.  Rename which command?
> >
> > Rename the WRITE command to CREATE
> 
> There is no WRITE command in CAP.
> 
> > (or is that a BXXP thing?).
> 
> I don't know what you mean by that.
> 
> I proposed to rename the ACTION CREATE (not the "create"
> command) to WRITE (i.e., ACTION=WRITE) to make it clear
> that is doesn't only apply to the "create" command.
> 
> Is that okay with you?

I would like to close this issue by proposing some changes to the
text that was put back in the last interim draft which is available
at the following URL: http://www.calsch.org/ietf/drafts.html.

IS (Section 11.2, RIGHTS Value Type):

>   act-type     = ("CREATE" / "MODIFY" / "DELETE" / "READ" / all)

>   ...

>   The ACTION rule part defines one or more CAP actions that are allowed
>   for the UPN.  The valid values are CREATE, DELETE, MODIFY, MOVE,
>   READ, and all of the [iTIP] scheduling commands; PUBLISH, REQUEST,
>   REPLY, ADD, CANCEL, REFRESH, COUNTER, DECLINECOUNTER, corresponding
>   to the scheduling commands; and '*', meaning all of calendaring
>   commands and scheduling commands.  Multiple ACTION enumerations can
>   be specified as a COMMA character (US-ASCII decimal 44) separated
>   list of ACTION enumerated values.  The text '*' is the same as
>   specifying the enumerated values "CREATE,MODIFY,DELETE,READ,MOVE".

PROPOSAL:

act-type     = ("WRITE" / "MODIFY" / "DELETE" / "READ" / all)

...

The ACTION rule part defines one or more CAP actions that are allowed
for the UPN.  The valid values are WRITE, DELETE, MODIFY, READ, and
'*', meaning all actions.  Multiple ACTION enumerations can be specified
as a COMMA character (US-ASCII decimal 44) separated list of ACTION
enumerated values.  The text '*' is the same as specifying the
enumerated
values "WRITE,MODIFY,DELETE,READ".

In brief, the iTIP METHODs as well as MOVE are no longer listed
as valid ACTIONs in the text (they never were in the ABNF).  The
ACTION CREATE was renamed to WRITE to reduce confusion, which is
consistent with the READ ACTION.

The following table shows my understanding of the relationship
between the commands and the ACTIONs.

   +----------+--------+---------------+
   | Command  | Target | Source        |
   +----------+--------+---------------+
   | create   | WRITE  | n/a           |
   | delete   | n/a    | DELETE        |
   | modify   | n/a    | MODIFY        |
   | move     | WRITE  | READ + DELETE |
   | search   | n/a    | READ          |
   | schedule | WRITE  | n/a           |
   +----------+--------+---------------+

Comments?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Mon, 14 Jan 2002 16:19:00 -0700

> consistent with the READ ACTION.

The ACTIONS applies to the commands, when the commands were
renamed the ACTIONS were not - thus some of the confusion.
So you could grant or deny commands to a UPN.

The METHOD:<value> (or any other identifiable object) 
was specified with:

	...OBJECT=METHOD;VALUE=<a-value>;...

I would like the ACTION values to be exactly the same as
the commands as they were before these changes. And I don't
care what their name is as long as they are the same, otherwise
what are they?

AND that would mean that act-type would be expanded to
mean ALL actions a CUA could take (as in ALL commands).

> between the commands and the ACTIONs.

Sorry, I don't understand the table at all.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 17 Jan 2002 10:04:40 -0500

> mean ALL actions a CUA could take (as in ALL commands).

The mapping between commands and ACTIONS is not 1:1.

To be able to "move" a component from VAGENDA "a" to
VAGENDA "b", I should be granted 

  "READ" ACTION from VAGENDA "a",
  "WRITE" ACTION from VAGENDA "b",
  "DELETE" ACTION from VAGENDA "a".

That is, all the actions that needs to happen whenever
a "move" command is executed.

> Sorry, I don't understand the table at all.

Here's how this table was meant to be read:

You can execute the command "create" only if you have
the "WRITE" ACTION granted in the specified target.

You can execute the command "delete" only if you have
the "DELETE" ACTION granted in the specified source.

You can execute the command "modify" only if you have
the "MODIFY" ACTION granted in the specified source.

You can execute the command "move" only if you have
the "WRITE" ACTION granted in the specified target
and the "READ" and "DELETE" ACTIONs granted in the
specified source.

You can execute the command "search" only if you have
the "READ" ACTION granted in the specified source.

You can execute the command "schedule" only if you have
the "WRITE" ACTION granted in the specified target.

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Thu, 17 Jan 2002 09:39:39 -0700

> The mapping between commands and ACTIONS is not 1:1.

Well it used to be :-)

>   "DELETE" ACTION from VAGENDA "a".

Why not just have a MOVE ACTION?

And then there is no mapping?

---

From: "Shannon J. Clark" <[email-masked]>
Date: Thu, 17 Jan 2002 12:03:57 -0600

Doug,

One reason might be that a "Move action" would really be "move from VAGENDA
A to VAGENDA B" - so you would need to have a factorial number of actions
assigned to you if you are to manage multiple VAGENDAs.

i.e. in the case of VAGENDA "a" and "b" only two MOVE ACTIONS are required
(Move from A to B - and Move from B to A) - note that they are not the same.

but in the case of VAGENDA "a", "b", "c", "d", "f" ... "z" you would require
26! Move actions were you required to be able to move from each to each...
this seems like a recipe for confusion and/or error.

READ/WRITE/DELETE are far more general (and it could be argued whether
DELETE is simply a limited sub-set of WRITE).

Just an observation - apologies if I have missed something.

Shannon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Doug Royer
Sent: Thursday, January 17, 2002 10:40 AM
To: [email-masked]
Subject: Re: VCAR question

Well it used to be :-)

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 17 Jan 2002 13:12:21 -0500

> Why not just have a MOVE ACTION?

Because to be allowed to move components from "a" to "b"
you would need to have the ACTION MOVE granted in both "a"
and "b", which would imply that you would also be allowed
to move components from "b" to "a".  But what if you only
want to allow someone to move from "a" to "b" but not from
"b" to "a"?

Furthermore, it wouldn't make sense to have the ACTION
MOVE granted in a VAGENDA but the ACTION DELETE denied.
To delete a component I would simply have to move it
into some other VAGENDA in which I'm granted the ACTION
DELETE.

Regards,
Bernard

---

From: "Shannon J. Clark" <[email-masked]>
Date: Thu, 17 Jan 2002 12:09:05 -0600

Bernard,

A question that I raised in a recent post - what is the difference between

DELETE

and

WRITE

i.e. is DELETE simply a limited sub-set of WRITE? - different security
schemes consider the act of "negative" writing - i.e. deleting as being
included or not in having "write" permissions (in Unix if you have write to
a file or directory you can delete the file.

So should all instances of "if only you have DELETE" be replaced with "if
only you have DELETE or WRITE permissions to the target"?

Shannon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Bernard
Desruisseaux
Sent: Thursday, January 17, 2002 9:05 AM
To: [email-masked]
Subject: Re: VCAR question

Regards,
Bernard

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 17 Jan 2002 13:34:53 -0500

> A question that I raised in a recent post - what is the difference between

I might want to grant you the right to DELETE components for
which you are the OWNER, but not necessarily grant you the
right to WRITE new components.

Regards,
Bernard