Subject: CAP (why 'select'?)

From: Doug Royer <[email-masked]>
Date: Tue, 08 Jan 2002 17:17:57 -0700

> 6.2.3.2 "select" Element
>
>  Many calendaring commands can target several components stored on the
>  CS (e.g., "search", "delete", "modify" and "move").  The "select"
>  element is used to identify the targeted components.

That is what TAGET does, why do we need 'select' ?

---

From: Patrice Lapierre <[email-masked]>
Date: Tue, 08 Jan 2002 19:49:17 -0500

A problem with using only an iCalendar property 
like TARGET would be to express the "move" operation.

 There are source target(s) needed to identify 
the VAGENDA where to search for components
and a single destination target to identify the 
destination.

  It would be possible to extend iCalendar to express
this (e.g, add new components/property, impose 
restriction of the ordering of the TARGET properties, ...). 
But it seems (at least to me) that the use the <select> 
construct is much cleaner.

---

From: Doug Royer <[email-masked]>
Date: Tue, 08 Jan 2002 18:32:18 -0700

> like TARGET would be to express the "move" operation.

That was covered in the old (and removed without debate)
modify operation. There is no need for an external tag.

I believe the old MODIFY is coming back as it had already
reached consensus and there have been no debate or even
WG proposals to change it. There was a *LOT* of work put
into the modify command, throwing it away without any
debate is unacceptable.

I ask the chairs now for a statement. I would really
like them state that we have closed the CAP-REQUIREMENTs
over a year ago, and we reached consensus to change
the TRANSPORT ONLY - Not everything someone wants to change.

> and a single destination target to identify the

I don't understand. You VQUERY given a qualified CALID
or a relative CALID. What can't you do with TARGET?
You can name multiple TARGETS in a VQUERY - nothing new.

> construct is much cleaner.

Cleaner or not, we can't keep re-inventing the wheel. 
TARGET reached consensus and we moved on. We can NOT
just keep inventing things because we think of better
ways to do it (an I still don't see that it is better).