Subject: [Fwd: Returned mail: Host unknown (Name server: imc.or: host not found)]

From: Doug Royer <[email-masked]>
Date: Tue, 29 Jan 2002 15:05:34 -0700

Bernard Desruisseaux wrote:
> 
> Doug Royer wrote:
> >
> > In previous proposals:
> >
> > SELF    - was a tag that meant 'currently authenticated UPN'
> >          in VCAR and VQUERY
> >
> > OWNER   - Was a tag that meant 'currently authenticated UPN
> >         - IF they are the owner'.
> >           In both VCAR and VQUERY.
> >
> > NONOWNER- Was a tag that meant 'currently authenticated UPN'
> >         - IF they are NOT the owner of the calendar.
> >           In both VCAR and VQUERY.
> >
> > *       - stood for 'any currently authenticated UPN.
> >           In both VCAR and VQUERY.
> 
> Which proposals are you referring to?  I've looked in the
> archive and I could not find any proposal for VQUERY that
> made mention of these tags.

They were in CAP, you added it to VQUERY. We don't need
two ways to do the same thing. If we add one, lets add them all.
If we rename one to a function, lets rename them all to functions.

> > > In my proposal I assumed that CAP-QL would also have a way to
> > > express SELF, and I used a function for that (i.e., SELF()).
> > > I've simply transposed this concept in my proposal.
> >
> > So my question is, do we want to change OWNER -> OWNER(),
> > and NONOWNER() to NONOWNER() and so on?
> 
> OWNER no.
> 
> NONOWNER no.
> 
> SELF okay since it is used in CAP-QL.

I'll add them to CAP-QL - as functions - any objections?.
They all need to be the same, function or non-function. Which?

> >
> > If not, lets make them all the same format. (All as
> > functions, or all not as functions).
> 
> Again, as I said, the only change I did, as part of my
> proposal, was to bring SELF in the CAP-QL vocabulary.
> Whether we make SELF a function or not in CAP-QL should
> not have any impact on the tags OWNER and NONOWNER for
> the GRANT and DENY properties.  Don't mix apples with
> oranges as my old math teacher used to say!

They are NOT apples and oranges. SELF means the currently
authenticed user in both VQUERY and VCAR? What is the 
other meaning?

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 30 Jan 2002 14:49:45 -0500

Doug Royer wrote:
> They were in CAP, you added it to VQUERY. 

Not true.  Again, I only added SELF() to CAP-QL. OWNER
and NONOWNER have never been part of the query language,
and I most certainly did not add them to VQUERY myself.

> We don't need

They are not the same thing.

Beside, show me how you would use OWNER and NONOWNER
in CAP-QL.

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Wed, 30 Jan 2002 14:39:33 -0700

Bernard Desruisseaux wrote:

> Not true.  Again, I only added SELF() to CAP-QL.

SELF was in CAP, it was in the SQL-MIN, you renamed it.

   self           = "SELF"        ; Only valid for ATTENDEE value.
                                  ; When OBJECT=ATTENDEE;VALUE=SELF.

> Beside, show me how you would use OWNER and NONOWNER

VCARs?

Get all VCARs where UPN is {calendar OWNER, non calendar NONOWNER}
by UPN value and not by 'tag' name.

	GRANT:UPN=OWNER
	GRANT:UPN=doug

Now if 'doug' is the calendar owner,

   Get where UPN is calendar owner/non-owner.

	...WHERE UPN = OWNER()

   will return both, and

	... WHERE UPN = 'OWNER'

   will only get the first.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 30 Jan 2002 17:15:01 -0500

>                                   ; When OBJECT=ATTENDEE;VALUE=SELF.

This is not true.   Indeed, SELF was in CAP but only
in the ABFN of RIGHTS value type.  NOT in the ABNF
of SQL-MIN.  What you are quoting is from the ABNF
of RIGHTS value type.

> > Beside, show me how you would use OWNER and NONOWNER

In a VCAR or a VQUERY.  CAP-QL is used by the SCOPE property
of VCAR and by the QUERY property of VQUERY.

> by UPN value and not by 'tag' name.

Actually, that would we :

   GRANT:OWNER
   GRANT:doug

>    Get where UPN is calendar owner/non-owner.

There is no such thing as a UPN property.  Your example
is not valid.  Plus, how the CS is supposed to guess that
"'doug' is the calendar owner".  What is the context?

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Wed, 30 Jan 2002 15:58:32 -0700

> of SQL-MIN.  What you are quoting is from the ABNF

What? It was in CAP. What's the differance?

There are now two ways to say 'SELF' - UN-ACCEPTABLE.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Wed, 30 Jan 2002 19:23:18 -0500

> There are now two ways to say 'SELF' - UN-ACCEPTABLE.

This is not true.  With my proposals SELF is only
defined in CAP-QL as 'SELF()' and nowhere else.

The property SCOPE of VCAR   makes use of CAP-QL.
The property QUERY of VQUERY makes use of CAP-QL.

There is only one way to say 'SELF' and it is defined
as 'SELF()' in CAP-QL.

Regards,
Bernard