Subject: Re: CAP (schedul command - redundent?) latest interm draft

From: [email-masked]
Date: Wed, 9 Jan 2002 16:39:04 -0500

Doug pondered:
>As the CREATE command can create any object including iTIP object.
>It looks to me if the 'schedule' command is redundant. Did I
>missing something?

They can be distinguished by context where you find them in the draft.

The former is used when doing "direct book" kinds of actions.  That is,
actions where the CU has the rights to directly put entries into a calendar
(ie: they become 'booked' on the TARGET calendar).  Notice that no METHOD
property is in the table in 6.2.4.1 so I suspect that iTIP messages are NOT
creatable (but this is an assumption based on interpreting the table).

The latter is used when doing C&S workflow (over iTIP or not).  That is,
actions where the CU has insufficient rights to directly put entries into a
calendar and must rely on the CU associated w/each TARGET to take action on
the entry.

Bruce
===========================================================================
Bruce Kahn
INet: [email-masked]

---

From: Doug Royer <[email-masked]>
Date: Thu, 10 Jan 2002 13:23:06 -0700

> They can be distinguished by context where you find them in the draft.

My point is that CREATE can create any object. I would agree
that someone added that command. However it is new and not
needed as you have always been able to create any kind
of object with CREATE. This is one of those 'new' things
that was already covered and has appeared into CAP without
any real debate. Other than someone saying something like,
it sure would be nice. 

> actions where the CU has the rights to directly put entries into a
> calendar (ie: they become 'booked' on the TARGET calendar). Notice
> that no METHOD property is in the table in 6.2.4.1 so I suspect that
> iTIP messages are NOT creatable (but this is an assumption based on
> interpreting the table).

I agree that is what it says. However that is not what it should
say. And - In a previous email from me a month or so ago I
pointed out that METHOD was missing from those restriction
tables - and as I recall *all* that responded said that 'yes
it is missing'.

Also, in the previous email sent by you and this one you
state that the METHOD is booked and that there is no METHOD?
I am confused on how you can think that both are and should
be true.

> The latter is used when doing C&S workflow (over iTIP or not). That
> is, actions where the CU has insufficient rights to directly put
> entries into a calendar and must rely on the CU associated w/each
> TARGET to take action on the entry.

Those differences are conceptional only. The CS does the
same thing for iTIP and non-iTIP messages. It stores them
for a CUA to do something later. And the CUA does not ask
the CS 'what command was that stored with', it just gets
the data with a VQUERY.

The authenticated UPN will or will not have sufficient
rights to store any object as defined by the VCARs into TARGET. 
Even if it is a CREATE or any iTIP method. That is not 
related to this issue.

There is NO need for an additional 'store this object' command.
Once the data is stored more modified, it simply exists
in its latest state - no matter what command caused that
data to be stored.