Subject: Re: 05 sendata -> beep.

From: [email-masked]
Date: Wed, 23 Jan 2002 17:10:38 -0500

Hi George, point of clarification here.  I'm not sure if what I say is the 
same as what you stated - if so, slap me down.  I thought what we were 
told to do was remove transport from CAP and to use BEEP instead.  That 
does not sound the same as "was to change CAP into a BEEP profile."  I may be wrong.

George Babics <[email-masked]>
Sent by: [email-masked]
01/23/02 15:47

        To:     [email-masked]
        cc: 
        Subject:        Re: 05 sendata -> beep.

Doug Royer wrote:
> 
> Bernard Desruisseaux wrote:
> >
> > Doug Royer wrote:
> > >
> > > In order to get things back to the way they were in 05, PLUS add 
BEEP.
> > >
> > > I propose we replace the beep-cap-commands with <senddata/>
> > > then restore all of the existing agreed on objects. Where
> > > <senddata/> has an optional argument of 'letency' who's value
> > > is in seconds.
> > >
> > > Example:
> > >
> > > C: MSG 1 8 . 124 234
> > > C: Content-Type: application/cap+xml
> > > C:
> > > C: <senddata/>
> > > C: <![CDATA[
> > > C: BEGIN:VCALENDAR
> > > C: METHOD:CREATE
> > > C: TARGET:target...
> > > C: ...
> > > C: END:VCALENDAR
> > > C: />]]>
> >
> > Which problems in the current draft are you trying
> > to address?
> 
> The task for 06 was to move the old CAP transport commands to
> BEEP. However more than that was done. The problem I am addressing
> is fixing that so that is all that was done. So the objects
> are again 2445 compliant and can again (as was in 05) be sent
> via iMIP.

  The task for draft-06 was to change CAP into a BEEP profile.

  And it is what was done. Certainly there are many ways of doing it.
The way that was chosen is in line with most of the BEEP profiles that
we looked at, that is, they all separate the commands from the data.

George

---

From: George Babics <[email-masked]>
Date: Wed, 23 Jan 2002 23:38:08 -0500

When an application protocol, e.g., CAP, uses BEEP for transport,
it becomes a BEEP profile.

George

[email-masked] wrote:
> 
> Hi George, point of clarification here.  I'm not sure if what I say is the same as what you stated
> - if so, slap me down.  I thought what we were told to do was remove transport from CAP and to use
> BEEP instead.  That does not sound the same as "was to change CAP into a BEEP profile."  I may be
> wrong.
> 
>   Sent by: [email-masked]            To:        [email-masked]
>                                                        cc:
>   01/23/02 15:47                                       Subject:        Re: 05 sendata -> beep.
> 
> Doug Royer wrote:
> >
> > > > In order to get things back to the way they were in 05, PLUS add BEEP.
> > > >