Subject: Re: CAP by Minneapolis

From: [email-masked]
Date: Tue, 29 Jan 2002 17:24:35 -0500

Hi Alan.  Doug is right.  We need to keep all notes on the list.  I don't 
think Doug was saying anything bad about Steltor - he was making sure 
Bruce knew who was making a case for the topic.  Bruce's email has been 
sort of "mucked up" and he may not have seen all the threads.  I believe 
Doug wanted to make sure Bruce knew the context.

And yes, we did get our hands slapped for notes off the list.  But, we're 
better now.  So, all of the rest of you who are annoyed at the traffic - 
well, this is a discussion on calendar standards efforts. This is how we 
try to figure out what to do.  Keep those cards and letters coming.

And play nice!
___________________
Patricia Egen Consulting
www.egenconsulting.com
423-875-2652

---

From: Gary Frederick <[email-masked]>
Date: Wed, 30 Jan 2002 05:19:42 -0600

Patricia Egen mentioned:
 >Keep those cards and letters
 > coming.

I have been wondering if anything is going on with the XML version of 
iCalendar. I was waiting for CAP conversation to slow down...

...

Is anything going on with the XML version of iCalendar?

Gary

[email-masked] wrote:

> 
> Hi Alan.  Doug is right.  We need to keep all notes on the list.  I 
> don't think Doug was saying anything bad about Steltor - he was making 
> sure Bruce knew who was making a case for the topic.  Bruce's email has 
> been sort of "mucked up" and he may not have seen all the threads.  I 
> believe Doug wanted to make sure Bruce knew the context.
> 
> And yes, we did get our hands slapped for notes off the list.  But, 
> we're better now.  So, all of the rest of you who are annoyed at the 
> traffic - well, this is a discussion on calendar standards efforts. This 
> is how we try to figure out what to do.  Keep those cards and letters 
> coming.
> 
> And play nice!
> ___________________
> Patricia Egen Consulting
> www.egenconsulting.com
> 423-875-2652

---

From: "ericp" <[email-masked]>
Date: Wed, 30 Jan 2002 08:19:04 -0500

Good Morning Gary,

The XML iCalendar has been pretty quite, due to the
CAP work and the focus on completing the draft.

I will be sending out a updated issues list soon.
The XML draft will expire on Feb 16 2002, so I hope
to have an update of the draft. There may not be
too many significant changes to it, with another 
update to follow in the spring.

Eric

-------------------------------
Eric R. Plamondon
Steltor - Chief Web Architect
2000 Peel Street, 4th Floor
Montreal, Quebec
mailto:[email-masked]
http://www.steltor.com

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gary Frederick
> Sent: Wednesday, January 30, 2002 6:20 AM
> To: ietf-calendar
> Subject: Re: CAP by Minneapolis
> 
> 
> 
> Patricia Egen mentioned:

---

From: Doug Royer <[email-masked]>
Date: Wed, 30 Jan 2002 09:55:05 -0700

> Is anything going on with the XML version of iCalendar?

As soon as CAP is out, I hope we go full steam ahead with XML.

---

From: Gary Frederick <[email-masked]>
Date: Wed, 30 Jan 2002 12:36:38 -0600

I would guess that when CAP is out, there will be a 'bit' of follow up 
as people digest.

I would like to see a reference CS so people could test. There is 
interest (OpenOffice, PHPGroupware, Mozilla, ...) (or is a server 
different from a Calendar Store? :-) )

My needs are pretty simple. For example, I will probably get calendar 
info into XML and do my queries using XMLish queries, rather than the 
SQLesque language in CAP. That lets me get up and searching right away.

Now back to my 9-5 as you all get ready for Minneapolis :-)

Gary

---

From: Doug Royer <[email-masked]>
Date: Wed, 30 Jan 2002 14:17:31 -0700

> SQLesque language in CAP. That lets me get up and searching right away.

It's not going to be that simple.  First you have to get
the data from a CS - and that is CAP. When XML is out, then
CAP can serve up XML objects, but it's still CAP.

Plus if you think about synchronization issues with resources
you are just going to be wasting bandwidth. If you get everything,
query the local XML data then attempt to book a resource, discover
it is taken, ask again for everyone, XML search everything, discover
....

That is why this WG invented iTIP, and why you need a real-time
(whatever that really means) connection protocol to reserve
resources where the CS determines who gets what booked items.

I don't see any need to invent another get stuff from a CS
language. We will have to add a capability to CAP that
says that the CS can dish out XML objects, and a way for
the CUA to ask for them. But you will still need CAP.

Think of CAP as IMAP or POP. You can have any kind
of MIME objects that you fetch with IMAP and POP, but you still
have to get he MIME object using IMAP or POP (or CAP).

---

From: Gary Frederick <[email-masked]>
Date: Wed, 30 Jan 2002 15:41:10 -0600

Yep.

My needs (currently) are simple. When CAP is out, I'll get the objects 
in iCal or xcs, doesn't matter to me, and then work with the XML 
version. I'm not doing any scheduling, synchronization whatever..., just 
displaying events. simple... (currently)

 > the CUA to ask for them. But you will still need CAP.

No argument there. I was trying to say that I was waiting for after CAP 
to see if someone comes up with a simple server to test against.

Gary

---

From: Doug Royer <[email-masked]>
Date: Wed, 30 Jan 2002 14:52:43 -0700

> SQLesque language in CAP. That lets me get up and searching right away.

Plus - I have been saving my calendar data for over 10 years. Using
the Unix 'calendar' versions of 'cm' and 'dtcm'. Each time I
upgrade, I convert the data to the new format. I have over 17 MB of
10 years of calendar data. So do you really want to download 17 MB
of data to see if I am available at 2pm tomorrow?

I think you want CAP-QL.

Currently there is NO tool that I have to find the data.
I have to remember where it was and start searching.