Subject: CAP: LANGUAGE parameter

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 13:44:24 -0500

As a French speaker I'm concerned by the fact that we
don't allow properties that make use of the LANGUAGE
parameter to occur more than once in our components.

For instance, how am I supposed to specify my home town
in both French and English as the location of a VEVENT,
given that LOCATION is only allowed to occur once in a
VEVENT?  That is, the following is not legal:

  LOCATION;LANGUAGE=en:Montreal
  LOCATION;LANGUAGE=fr-CA:MontrÃ©al  <-- Montréal in UTF-8

Can we change our restriction tables to allow LOCATION,
SUMMARY, CATEGORIES, NAME, etc. to occur more than once
in our components?

Regards,
Bernard
-- 
Bernard Desruisseaux                    mailto:[email-masked]
Research & Development                  Tel.  : +1 514 733-8500 x4213
Steltor                                 Fax   : +1 514 733-8878

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 15:33:35 -0700

> SUMMARY, CATEGORIES, NAME, etc. to occur more than once

The SkiCal people pointed that out a couple of years ago.
They also had an issue with what the language spoken
at the event would be:

	LOCATION;LANGUAGE=en:Montreal
	LOCATION;LANGUAGE=fr-CA:MontrÃ©al 
	
But that did not say if English or French would be
the language spoken at the event.

Have you looked at the SkiCaL proposals to see how they
solved this?

And would you agree this is a separate issue from CAP?
I don't think that CAP cares, so this would be a separate
draft on making 2445 more L18N'able.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 18:33:51 -0500

> draft on making 2445 more L18N'able.

We still need to make sure that extensions to iCalendar
part of the CAP draft are localiz............able! :-)

The restriction tables should be changed to specify 0+
for the following properties:

   COMMENT
   CATEGORIES
   NAME

I'll change the ABFN of VCAR to allow multiples instances
of the NAME property.

Regards,
Bernard

---

From: Doug Royer <[email-masked]>
Date: Thu, 31 Jan 2002 17:28:19 -0700

> part of the CAP draft are localiz............able! :-)

True, but that is ADDING a new feature.  There is no requierment
that CAP allow for multiple instances of LANGUAGE in one
component. Just adding it would break an existing iTIP
implementation. We can't just add them at this point.

So you can't just add them in CAP. 

AND - CAP does currently allow for any component in any ONE
language. So we are I18N and I10N ready.

> for the following properties:

That would have to be an update to iTIP and is out of scope
for CAP - and expect LOTS of resistance on that. I think it
would be better to add new property names for alternate 
LANGUAGE representations so that existing implementations
would not break.

---

From: Bernard Desruisseaux <[email-masked]>
Date: Thu, 31 Jan 2002 20:33:58 -0500

> LANGUAGE representations so that existing implementations

I agree.  It is out of scope for CAP to fix/improve old
properties.

Regards,
Bernard