Subject: CREATE command definition in draft-08

From: Mark Davidson <[email-masked]>
Date: Mon, 15 Jul 2002 14:45:49 +0100

In section 9.1.4

           create-vreply  = "BEGIN" ":" "VREPLY" CRLF
                             created-id
                             request-status
                            *(x-prop)
                            "END" ":" "VREPLY" CRLF

                            ; Where the id is appropriate for the
                            ; type of object created:
                            ;
                            ; VAGENDA = calid
                            ; VCAR = carid
                            ; VEVENT, VFREEBUSY, VJOURNAL, VTODO = uid
                            ; VQUERY = queryid
                            ; ALARM = sequence
                            ; x-component = x-id
                            ;

I think the comments should be as I don't think you can create ALARMS 
with CREATE, you would use MODIFY (If I am wrong about creating ALARMS, 
then some different changes need to be made around what a TARGET can be):

                            ; VAGENDA = calid
                            ; VCAR = carid
                            ; VEVENT, VFREEBUSY, VJOURNAL, VTODO = uid
                            ; VQUERY = queryid
                            ; VTIMEZONE = tzid
                            ; x-component = x-id

Just under that:

            created-id    = ( calid / carid / uid / uid dtstamp
                              / queryid / tzid / sequence / x-id)

When would "uid timestamp" be used? Is it "uid" space "timestamp"?

A bit further down in this section:

               create-reply = "BEGIN" ":" "VCALENDAR" CRLF
                               calprops
                               *(iana-prop)
                               *(x-prop)
                               1*(create-comp-vreply)
                               "END" ":" "VCALENDAR" CRLF

create-comp-vreply is not defined. I am also unsure of what the 
restrictions table for a create reply is telling me, that the Responce: 
section did not (apart from it is possible to send an iTIP response).

Also a small typo in the same section (page 95)
    The CS would sends the REPLY in separate MIME objects, one per
    TARGET.

Should be:
    The CS would send the REPLY in separate MIME objects, one per
    TARGET.

Mark Davidson

---

From: Doug Royer <[email-masked]>
Date: Sat, 20 Jul 2002 14:33:20 -0600

Mark Davidson wrote:
> I think the comments should be as I don't think you can create
> ALARMS ...

(by them selves - your right ).  Removed from draft.

> ...with CREATE, you would use MODIFY (If I am wrong about creating
> ALARMS, then some different changes need to be made around what a
> TARGET can be):

I just removed VALARM from the 'create-reply'.
Thanks!

> ...

It must be a typo - removed.

> section did not (apart from it is possible to send an iTIP response).

Your right, it was in there twice - I removed the 2nd copy.

>     The CS would send the REPLY in separate MIME objects, one per

Fixed - thanks.