Subject: Re: Follow up to BEEP and CAP - one-to-many

From: "Preston Stephenson" <[email-masked]>
Date: Mon, 19 May 2003 12:39:34 -0600

I understand the multipart. I just wanted to verify that a single BEEP
reply message can't have two mime entities at the outermost level.

RPY 5 0 . 0 842
Content-Type: text/calendar

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//someone's prodid
CMD;ID=creation02:REPLY
TARGET:relcalz1    <- 1st TARGET listed.
BEGIN:REPLY        <- Reply for 1st VEVENT create in 1st TARGET.
UID:FirstInThisExample-1
REQUEST-STATUS:2.0
END:VREPLY
BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 1st TARGET.
UID:SecondInThisExample-2
REQUEST-STATUS:2.0
END:VREPLY
END:VCALENDAR
Content-Type: text/calendar

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//someone's prodid
CMD;ID=creation02:REPLY
TARGET:relcalz2    <- 2nd TARGET listed
BEGIN:REPLY        <- Reply for 1st VEVENT create in 2nd TARGET.
UID:FirstInThisExample-1
REQUEST-STATUS:2.0
END:VREPLY
BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 2nd TARGET.
UID:SecondInThisExample-2
REQUEST-STATUS:2.0
END:VREPLY
END:VCALENDAR
END

The above should be invalid, but the following would be valid.

RPY 5 0 . 0 811
Content-Type: text/calendar

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//someone's prodid
CMD;ID=creation02:REPLY
TARGET:relcalz1    <- 1st TARGET listed.
BEGIN:REPLY        <- Reply for 1st VEVENT create in 1st TARGET.
UID:FirstInThisExample-1
REQUEST-STATUS:2.0
END:VREPLY
BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 1st TARGET.
UID:SecondInThisExample-2
REQUEST-STATUS:2.0
END:VREPLY
END:VCALENDAR
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//someone's prodid
CMD;ID=creation02:REPLY
TARGET:relcalz2    <- 2nd TARGET listed
BEGIN:REPLY        <- Reply for 1st VEVENT create in 2nd TARGET.
UID:FirstInThisExample-1
REQUEST-STATUS:2.0
END:VREPLY
BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 2nd TARGET.
UID:SecondInThisExample-2
REQUEST-STATUS:2.0
END:VREPLY
END:VCALENDAR
END

Thanks.
Preston

>>> [email-masked] 5/19/2003 12:11:10 PM >>>

Preston Stephenson wrote:
> I just need a little clarification on some postings from last year.
> 
> Section 10.1.4 CREATE Command
> The replies from the different targets.
> 
> Is this an example of a BEEP MSG/ANS,ANS,NUL exchange?
> 
> In the case of a BEEP MSG/RPY exchange, would the two VCALENDAR
objects
> be in one text/calendar mime?

Yes it could be.

You can have multiple VCALENDARS in each MIME object.

You can have multiple MIME objects, each with any valid
MIME object using MULTIPART/<whatever> and possibly nested.
However as the topic is CAP, it is assumed that at least one
of the MIME objects will be an iCalendar object.

-- 

  Doug Royer                     |   http://INET-Consulting.com 
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: Doug Royer <[email-masked]>
Date: Mon, 19 May 2003 13:23:21 -0600

> reply message can't have two mime entities at the outermost level.

If MIME allows it, it can.

--