Subject: Follow up to BEEP and CAP - one-to-many

From: "Preston Stephenson" <[email-masked]>
Date: Mon, 19 May 2003 09:51:34 -0600

I just need a little clarification on some postings from last year.

Section 10.1.4 CREATE Command
The replies from the different targets.

Is this an example of a BEEP MSG/ANS,ANS,NUL exchange?

In the case of a BEEP MSG/RPY exchange, would the two VCALENDAR objects
be in one text/calendar mime?

   S: Content-Type: text/calendar
   S:
   S: BEGIN:VCALENDAR
   S: VERSION:2.0
   S: PRODID:-//someone's prodid
   S: CMD;ID=creation02:REPLY
   S: TARGET:relcalz1    <- 1st TARGET listed.
   S: BEGIN:REPLY        <- Reply for 1st VEVENT create in 1st TARGET.
   S: UID:FirstInThisExample-1
   S: REQUEST-STATUS:2.0
   S: END:VREPLY
   S: BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 1st TARGET.
   S: UID:SecondInThisExample-2
   S: REQUEST-STATUS:2.0
   S: END:VREPLY
   S: END:VCALENDAR
   S: BEGIN:VCALENDAR
   S: VERSION:2.0
   S: PRODID:-//someone's prodid
   S: CMD;ID=creation02:REPLY
   S: TARGET:relcalz2    <- 2nd TARGET listed
   S: BEGIN:REPLY        <- Reply for 1st VEVENT create in 2nd TARGET.
   S: UID:FirstInThisExample-1
   S: REQUEST-STATUS:2.0
   S: END:VREPLY
   S: BEGIN:REPLY        <- Reply for 2nd VEVENT crate in 2nd TARGET.
   S: UID:SecondInThisExample-2
   S: REQUEST-STATUS:2.0
   S: END:VREPLY
   S: END:VCALENDAR

Thanks.
Preston

---

From: Doug Royer <[email-masked]>
Date: Mon, 19 May 2003 12:11:10 -0600

> be in one text/calendar mime?

Yes it could be.

You can have multiple VCALENDARS in each MIME object.

You can have multiple MIME objects, each with any valid
MIME object using MULTIPART/<whatever> and possibly nested.
However as the topic is CAP, it is assumed that at least one
of the MIME objects will be an iCalendar object.

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards