Subject: CAP-QUERY ABNF disagrees with examples

From: Andrea Campi <[email-masked]>
Date: Thu, 29 May 2003 17:39:07 +0200

Hi,

a colleague just noticed the ABNF for CAL-QUERY (6.1.1) doesn't
agree with examples elsewhere in the draft. In most (all?) cases
the examples are right.

 -      cap-factor = cap-colval SP cap-oper SP col-value
   	     / cap-colval SP "NOT LIKE" SP col-value
   	     / cap-colval SP "LIKE" SP col-value
   	     / cap-colval SP "IS NULL"
   	     / cap-colval SP "IS NOT NULL"
   	     / col-value SP "NOT IN" cap-colval"
   	     / col-value SP "IN" cap-colval"
   	     / "STATE()" "=" ( "BOOKED"
   			      / "UNPROCESSED"
   			      / "DELETED" )

But we always use STATE()='BOOKED' etc. (note the quotes around
BOOKED.

 -      cap-col    = comp-name
                / comp-name "." cap-prop

Shouldn't this be:

	cap-col    = comp-name
                / comp-name "." cap-prop
		/ cap-prop

as the former forbids basic queries like:

   QUERY:SELECT * FROM VEVENT WHERE UID = 'uid123'
   END:VQUERY

 - the last example in 6.1.1.18 uses DELETE instead of DELETED:

   BEGIN:VQUERY
   QUERYID:Fetch UIDs of marked for delete VEVENTs and VTODOs
   QUERY:SELECT UID FROM VEVENT WHERE STATE() = 'DELETE'
   QUERY:SELECT UID FROM VTODO WHERE STATE() = 'DELETE'
   END:VQUERY

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A. - BT Ignite                  http://www.inet.it
Technical Dept. - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Thu, 29 May 2003 10:34:02 -0600

Yes - thanks.

I have updated the source and it will be in the next release of the draft.

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards