Subject: CAP-12-e: 6.1.1.15 Query by Date-Time range

From: [email-masked]
Date: Thu, 11 Dec 2003 13:57:58 -0500

In revistiing some sections of CAP 12-e for snippets for other postings I 
ran across what appears to be an incorrect example for the section. 
Section 6.1.1.15 Query by Date-Time range should have an example for 
getting "every booked "VEVENT" component that has an instance greater than 
or equal to July 1st, 2000 00:00:00 UTC and less than or equal to July 
30st, 2000 23:59:59 UTC."

However the query is using RECURRENCE-ID which is an instance identifier 
and NOT the acutal entry occuring in that time range.  I believe the 
correct example should be:

   BEGIN:VQUERY
   QUERY:SELECT * FROM VEVENT
   WHERE DTSTART >= '20000701T000000Z'
   AND DTEND <= '20000730T235959Z'
   AND STATE() = 'BOOKED'
   END:VQUERY

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Mark Smith <[email-masked]>
Date: Thu, 11 Dec 2003 13:08:43 -0700

Is this not the current discussion?

[email-masked] wrote:
> 
> In revistiing some sections of CAP 12-e for snippets for other
> postings I ran across what appears to be an incorrect example for the
> section.  Section 6.1.1.15 Query by Date-Time range should have an
> example for getting "every booked "VEVENT" component that has an
> instance greater than or equal to July 1st, 2000 00:00:00 UTC and less
> than or equal to July 30st, 2000 23:59:59 UTC."
> 
> However the query is using RECURRENCE-ID which is an instance
> identifier and NOT the acutal entry occuring in that time range.  I
> believe the correct example should be:
> 
>    BEGIN:VQUERY

---

From: Arnaud Quillaud <[email-masked]>
Date: Thu, 11 Dec 2003 13:14:56 -0800

I posted the same question a few days ago:

http://www.imc.org/ietf-calendar/mail-archive/msg11342.html

Doug replied to this thread but I must confess I was still confused after reading it and I didn't get a chance to reply back.

Arnaud

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 11, 2003 10:58 AM
To: [email-masked]
Subject: CAP-12-e: 6.1.1.15 Query by Date-Time range

In revistiing some sections of CAP 12-e for snippets for other postings I ran across what appears to be an incorrect example for the section.  Section 6.1.1.15 Query by Date-Time range should have an example for getting "every booked "VEVENT" component that has an instance greater than or equal to July 1st, 2000 00:00:00 UTC and less than or equal to July 30st, 2000 23:59:59 UTC." 

However the query is using RECURRENCE-ID which is an instance identifier and NOT the acutal entry occuring in that time range.  I believe the correct example should be: 

   BEGIN:VQUERY

Bruce 
Bruce Kahn                                INet: [email-masked]