Subject: Re: CAP BEEP profile

From: "Preston Stephenson" <[email-masked]>
Date: Mon, 01 Mar 2004 11:45:39 -0700

I think it was when the client sent the start message for the cap
profile channel, it wasn't expecting a response from the server.
It would want to send the start message, then immediately start sending
CAP messages.
It didn't know how to handle the response from the start message.

C: Content-Type: application/beep+XL
C:
C: <start number='3'>
C:   <profile Uri='HTTP://iana.org/beep/cap/1.0'/>
C: </start

( the client wasn't able to handle this response from the server)
S: Content-Type: application/beep+xml
S:
S: <profile uri='http://iana.org/beep/cap/1.0'>
S:   <![CDATA[<blob status='complete'/>]]>
S: </profile>

Is that what you are asking?
Preston

>>> [email-masked] 3/1/2004 11:20:12 AM >>>

Preston Stephenson wrote:

>The other implementation was Novell's NetMail client trying to talk
to
>Novell's GroupWise server.
>
Sorry, I mean: "HOW" are the two implementations different?

>
>>>      
>>>
>Did you mean starting a new channel? (As you have a <start> message
>below)
>
>Or did to mean to show a <greeting> message? (you said starting the
CAP
>
>BEEP profile).
>
>As I understand BEEP, you send the CAP uri in the greeting message
>and then the authentication profile in the start messages.
>
>What was the 'other' format you tested against?
>
>  
>
-- 

Doug Royer                     |   http://INET-Consulting.com 
-------------------------------|-----------------------------
[email-masked]                 | Office: (208)520-4044
http://Royer.com/People/Doug   | Fax:    (866)594-8574
                               | Cell:   (208)520-4044

              We Do Standards - You Need Standards

---

From: Doug Royer <[email-masked]>
Date: Mon, 01 Mar 2004 12:12:11 -0700

Yes. I thought you were saying that the profile information
was being sent in different sequences or something by
the two implementations.

So far I have not tried to interoperate with any other CAP
implementation. And I would not call myself a BEEP expert.

So do you have proposed text to solve the cap-bug you filed? :-)
I am still trying to figure out if I got BEEP right.

--