Subject: Re: CAP BEEP profile

From: "Preston Stephenson" <[email-masked]>
Date: Mon, 01 Mar 2004 05:28:51 -0700

I was talking about starting a BEEP channel for the CAP protocol.
As I understand the Greeting message, the client sends an empty
greeting and the server sends its greeting with the profiles it can
support.

The exchanged we enforce as a server is to:
1) Send the greeting message.
    Depending on the settings on the server, we either reply saying we
support SASL TLS only or SASL TLS and SASL PLAIN profiles.
2) If the server only returns the SASL TLS, the client has to start the
SASL TLS channel..
    After the client successfully starts the SASL TLS profile, the
server will allow the SASL PLAIN profile.
3) After the client successfully starts the SASL PLAIN channel, the
server will allow the CAP profile.
4) The client will then start the CAP profile.
     Only after the CAP profile channel successfully starts, do we
allow CAP messages.

The other implementation was Novell's NetMail client trying to talk to
Novell's GroupWise server.

Thanks.
Preston

>>> [email-masked] 2/28/2004 12:14:36 PM >>>

Preston Stephenson wrote:

>I posted a query about the CAP BEEP profile back in October but
didn't
>get a response.
>I went ahead and put a bug in bugzilla (657)
>It's the only thing I remember that I need resolved.
>
>Thanks.
>Preston
>
>  
>
>>Sorry if I missed this.
>>
>>Is there an example of starting the CAP BEEP profile?
>>
Did you mean starting a new channel? (As you have a <start> message
below)

Or did to mean to show a <greeting> message? (you said starting the CAP

BEEP profile).

As I understand BEEP, you send the CAP uri in the greeting message
and then the authentication profile in the start messages.

What was the 'other' format you tested against?

>>When I initially wrote my CAP server, I think I patterned my start
>>exchange after the SASL profiles. Thus:
>>
>>C: Content-Type: application/beep+xml
>>C:
>>C: <start number='3'>
>>C:   <profile uri='http://iana.org/beep/cap/1.0'/>
>>C: </start
>>
>>S: Content-Type: application/beep+xml
>>S:
>>S: <profile uri='http://iana.org/beep/cap/1.0'>
>>S:   <![CDATA[<blob status='complete'/>]]>
>>S: </profile>
>>
>>In section 12.1 BEEP Profile Registration, it talks about the
>>    
>>
>initial
>  
>
>>message must be the GET-CAPABILITY command.
>>It doesn't talk about the BEEP Start message exchange.
>>
>>In section 12.1 there is also a "URI[10]" reference. The "[10]"
>>reference seems to have been taken from rfc3080.
>>The reference should probably be changed to "[URI]" to be
>>    
>>
>consistent.
>  
>
>>Thanks.
>>Preston
>>    
>>

-- 

Doug Royer                     |   http://INET-Consulting.com 
-------------------------------|-----------------------------
[email-masked]                 | Office: (208)520-4044
http://Royer.com/People/Doug   | Fax:    (866)594-8574
                               | Cell:   (208)520-4044

              We Do Standards - You Need Standards

---

From: Doug Royer <[email-masked]>
Date: Mon, 01 Mar 2004 11:20:12 -0700

>Novell's GroupWise server.
Sorry, I mean: "HOW" are the two implementations different?

--