Subject: dtend removed? (Re: draft-royer-ical-basic-01.txt - sent to IETF)

From: Sam Roberts <[email-masked]>
Date: Sat, 2 Apr 2005 21:27:15 -0500

Quoting [email-masked], on Sun, Jan 16, 2005 at 02:11:43PM -0700:
> I send -01 of iCal-Basis to the IETF. It fixed some problems and
> typos that were sent to me and the lists. It also deprecates DTEND and
> replaced the examples and ABNF with DURATION.

dtstart/dtend and dtstart/duration are equivalent ONLY for single
non-recurring events.

A yearly event on that starts at april second   3PM, and goes until
april 3 6PM will have different durations. This year it falls on
DST. The duration will be different next year.

Anything starting on the 25th and going to the "-1th"/last day of the
month will have a different duration every month. Etc.

It's also trivial to support doing the calculation of duration/dtend for
a specific event.

Do you ever intend to support recurring events again?

I just hours ago wrote a little server that publishes all the birthdays
in my address book as text/calendar over http, which is handy because my
calendar program now subscribes to it. Those birthdays recur!

Sam

> Copy at:
> 
> 	http://inet-consulting.com/draft-royer-ical-basic-01.txt
> 
> And HTML version at:
> 
> 	http://inet-consulting.com/draft-royer-ical-basic-01.html
> 	
> -- 
> 
> Doug Royer                     | http://INET-Consulting.com
> -------------------------------|-----------------------------
> [email-masked]                 | Office: (208)612-4638
> http://Royer.com               | Fax:    (866)594-8574
>                                | Cell:   (208)520-4044
> 
>               We Do Standards - You Need Standards
>

---

From: Doug Royer <[email-masked]>
Date: Sun, 03 Apr 2005 15:17:05 -0600

This discussion belongs in CALSIFY - not CALDAV.

> _______________________________________________
> Ietf-caldav mailing list -- [email-masked]
> See http://ietf.webdav.org/caldav/ for more CalDAV resources
> http://lists.osafoundation.org/mailman/listinfo/ietf-caldav

--