Subject: [Ietf-calsify] One last comment on exact vs. nominal durations

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Fri Sep 14 10:49:42 2007

Jonathan is right.  I wouldn't mind addressing this issue if
someone wants to propose text.

Cheers,
Bernard

Eliot Lear wrote:
> Jonathan Lennox wrote:
>> One other issue occured to me on exact vs. nominal durations.
>>
>> The definition of RRULE says:
>>
>>       If the duration of the recurring component is specified with the
>>       "DTEND" or "DUE" property, then the same exact duration will apply
>>       to all the members of the generated recurrence set.
>>
>> This is correct for DTEND or DUE specified with VALUE=DATE-TIME, but I 
>> think
>> it's wrong for DTEND or DUE (and thus also DTSTART) with VALUE=DATE.  In
>> this latter case, I think it's clear that the desired outcome is always
>> for the event to last a nominal number of days, not the exact duration of
>> time of the first instance of the recurrence set.
>>
>> Is this worth addressing?
>>
>>   
> 
> Substantial
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify
>

---

From: cyrus at daboo.name (Cyrus Daboo)
Date: Thu Sep 27 08:07:35 2007

Hi Jonathan,

--On August 13, 2007 11:56:40 AM -0400 Jonathan Lennox 
<[email-masked]> wrote:

> Add the text (wordsmithing as appropriate):
>
> +      If the local time when a nominal duration would end does not exist,
> +      or occurs more than once, in the duration's timezone, it is
> +      interpreted in the same manner as an explicit DATE-TIME value
> +      describing that date and time, as specified in section 3.3.5.

Wordsmithed alternative that I think is clearer:

    If the local time determined by adding a nominal duration to a
    DATE-TIME value does not exist, or occurs more than once, in the
    timezone of the DATE-TIME value used, it is interpreted in the same
    manner as an explicit DATE-TIME value describing that date and time, as
    specified in section 3.3.5.

Other than that, I agree adding this would be good.

-- 
Cyrus Daboo

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Thu Sep 27 08:15:30 2007

> Other than that, I agree adding this would be good.

I'm proposing a slight change to cover the case where DTSTART
is a date in local time (not UTC, no TZID):

    timezone being used, it is interpreted in the same

Cheers,
Bernard

---

From: cyrus at daboo.name (Cyrus Daboo)
Date: Thu Sep 27 08:22:27 2007

Hi Bernard,

>     specified in section 3.3.5.

+1

-- 
Cyrus Daboo

---

From: bernard.desruisseaux at oracle.com (Bernard Desruisseaux)
Date: Thu Sep 27 10:06:58 2007

I take my words back!

-1

If one always want a nominal duration of 1 day (or N days)
then one should use DURATION instead.

Cheers,
Bernard

Bernard Desruisseaux wrote:
>>> This is correct for DTEND or DUE specified with VALUE=DATE-TIME, but 
>>> I think

---

From: lennox at cs.columbia.edu (Jonathan Lennox)
Date: Thu Sep 27 11:25:26 2007

> Other than that, I agree adding this would be good.

Well, this rule needs to apply not only when a nominal duration is added to
an explicit DATE-TIME, but also when a nominal duration is added to the
start time of a recurring event.

I can't think of a good, short way of saying "a date and time value, whether
calculated or explicitly specified", though.  Anyone?

-- 
Jonathan Lennox
[email-masked]