Subject: [calsify] jscalendar: Vendor specific names and overrides

From: Michael Douglass <[email-masked]>
Date: Sun, 2 Aug 2020 00:19:58 -0400

Doesn't the construct

"example.com/customprop"

make it difficult to process overrides?

{...

   "example.com/customprop": 12345

...

   "recurrenceOverrides": {
     "2018-01-05T14:00:00": {
       "example.com/customprop": 56789
    },

...}

Where's the "example.com" property?

A different delimiter perhaps?

---

From: "Neil Jenkins" <[email-masked]>
Date: Mon, 03 Aug 2020 09:46:26 +1000

> make it difficult to process overrides?

It's possible (as per RFC6901 <https://tools.ietf.org/html/rfc6901> you can use ~1 to represent a literal forward slash), but that does mean you have to escape a top-level property and can't just use it verbatim, which seems awkward. Good point.

> A different delimiter perhaps?

Yes, I think colon will work better; I'll change it.

Neil.