Subject: [calsify] Barry Leiba's Discuss on draft-ietf-calext-eventpub-extensions-17: (with DISCUSS)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Mon, 04 Jan 2021 13:55:35 -0800

Barry Leiba has entered the following ballot position for
draft-ietf-calext-eventpub-extensions-17: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-calext-eventpub-extensions/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thanks very much for the changes in Section 9.1, and I think we're now at the
best place we can reasonable be here.  Well done.

Thanks also for the changes to clarify the ABNF.  They're mostly good, and we
should be able to clean these last bits up pretty easily:

— Section 6.6 —

The new ABNF doesn’t correctly specify what the old was trying to say.  I think
this is correct and concise, but please check it over:

NEW

sdataprop    = "STRUCTURED-DATA" sdataparam ":"
                     sdataval CRLF

      sdataparam     = ; all parameter elements may appear in any order,
                       ; and the order is not significant.
                       (sdataparamtext / sdataparambin / sdataparamuri)
                       *(";" other-param)

      sdataparamtext = ";VALUE=TEXT"
                       ";" fmttypeparam
                       ";" schemaparam

      sdataparambin  = ";VALUE=BINARY"
                       ";ENCODING=BASE64"
                       ";" fmttypeparam
                       ";" schemaparam

      sdataparamuri  = ";VALUE=URI"
                       [";" fmttypeparam]
                       [";" schemaparam]

      sdataval       = ( binary / text /uri )
                       ; value MUST match value type

END

— Section 7.1 —

      participantc = "BEGIN" ":" "PARTICIPANT" CRLF
                     *( partprop / locationc / resourcec )
                     "END" ":" "PARTICIPANT" CRLF

This allows multiple instances of partprop (or none), which is not what you
mean.  The “*” isn’t right.  Also, do you really mean to have locationc and
resourcec here?  Those are blocks that are peers of participantc within eventc,
todoc, journalc, and freebusyc… are they also meant to be nested within
participantc?  If so, it would be good to have an example or two that shows
that.  In any case, that bit of ABNF still needs some work.

                     (calendaraddress)
                     (created)
                     (description)
                     (dtstamp)
                     (geo)
                     (last-mod)
                     (priority)
                     (seq)
                     (status)
                     (summary)
                     (url)

All of these are meant to be optional, so they should be in square brackets,
rather than in parentheses.  The same is true in Sections 7.2 and 7.3.

---

From: Michael Douglass <[email-masked]>
Date: Wed, 13 Jan 2021 15:53:55 -0500

Thanks for this,

Comments below - just posted a version 18

On 1/4/21 16:55, Barry Leiba via Datatracker wrote:
> Please refer tohttps://www.ietf.org/iesg/statement/discuss-criteria.html
Thanks - that seems much better.
> that.  In any case, that bit of ABNF still needs some work.

Replaced with

participantc = "BEGIN" ":" "PARTICIPANT" CRLF
                partprop *locationc *resourcec
                "END" ":" "PARTICIPANT" CRLF

location and resources are allowed as properties, locationc and 
resourcec allow the eventpub style components. I'll add an example

> rather than in parentheses.  The same is true in Sections 7.2 and 7.3.
All fixed.
>
>
>
>
>
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify