Subject: Re: [calsify] Call for adoption of jscalendar alignment plan

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 11 Apr 2022 15:42:34 +1000

There was no feedback of any kind on the list or directly to the chairs.  On top of everybody having been in favour during the IETF113 meeting, I'm going to take this to be consensus in favour of the plan.

Thanks everybody!

Those who offered to author, please go ahead and start work on your documents :)

Cheers,

Bron.

On Thu, Mar 24, 2022, at 02:05, Bron Gondwana wrote:
> Hi All,
> 
> Rather than doing a separate series of "call for adoption" on documents, I'm doing a call for adoption of an entire plan here.  The plan was discussed during the CALEXT session at IETF113 and received support there.  Here's the plan.
> 
> *Intent:***
> 
> Fully align jscalendar and icalendar formats, to allow lossless conversion between them, with the mapping document being changed from informational to standards track.  The end result will be jscalendar and icalendar being aligned, and all future specs will be updates to BOTH RFC5545 and jscalendar-bis.
> 
> *Steps:*
>  * new doc: icalendar extension for subsecond support (separate document so only those who care need implement it)
>  * new doc: updates to RFC5545, for the fields that are needed to represent non-subsecond things from jscalendar.
>  * new doc: jscalendar-bis, roll in technical eratta and ensure alignment with everything else needed by the mapping document.
>  * changed status: jscalendar-icalendar changes from information to proposed-standard.  Publish as a group with jscalendar-bis and the icalendar updates.
> 
> If you have any objections to this plan, or questions you wanted answered before all these documents are adopted and updated, please reply to this message by Friday April 8th.  Feel free to reply with support and offers to author/review parts of this too!
> 
> Thanks,
> 
> Bron.
> 
> --
>   Bron Gondwana, CEO, Fastmail Pty Ltd
>   [email-masked]
> 
> 
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Daniel Migault <[email-masked]>
Date: Mon, 11 Apr 2022 12:39:08 -0400

+1

On Mon, Apr 11, 2022 at 1:43 AM Bron Gondwana <[email-masked]>
wrote:

> There was no feedback of any kind on the list or directly to the chairs.
> On top of everybody having been in favour during the IETF113 meeting, I'm
> going to take this to be consensus in favour of the plan.
>
> Thanks everybody!
>
> Rather than doing a separate series of "call for adoption" on documents,
> I'm doing a call for adoption of an entire plan here.  The plan was
> discussed during the CALEXT session at IETF113 and received support there.
> Here's the plan.
>
> *Intent:*
>
> Fully align jscalendar and icalendar formats, to allow lossless conversion
> between them, with the mapping document being changed from informational to
> standards track.  The end result will be jscalendar and icalendar being
> aligned, and all future specs will be updates to BOTH RFC5545 and
> jscalendar-bis.
>
> *Steps:*
>
>    - new doc: icalendar extension for subsecond support (separate
>    document so only those who care need implement it)
>    - new doc: updates to RFC5545, for the fields that are needed to
>    represent non-subsecond things from jscalendar.
>    - new doc: jscalendar-bis, roll in technical eratta and ensure
>    alignment with everything else needed by the mapping document.
>    - changed status: jscalendar-icalendar changes from information to
>    proposed-standard.  Publish as a group with jscalendar-bis and the
>    icalendar updates.
>
>
> If you have any objections to this plan, or questions you wanted answered
> before all these documents are adopted and updated, please reply to this
> message by Friday April 8th.  Feel free to reply with support and offers to
> author/review parts of this too!
>
> Thanks,
>
> Bron.
>
> --

-- 
Daniel Migault
Ericsson