Subject: RE: [Capwap] Comments on objectives draft

From: "Partha Narasimhan" <[email-masked]>
Date: Thu, 7 Apr 2005 07:31:48 -0700

> I will try once more, and hopefully this time in a way that is clearer.
> The SLAPP protocol does not define a control protocol, it simply defines
> a discovery mechanism and then a method to download firmware from the
> AC to the AP. So there's a clear statement that there will be multiple
> control protocols (one per AC vendor), as well as an assumption that
> every AC vendor will keep the control protocol close to its chest.

Pat,

Maybe you havent had a chance to read the text in the draft and are basing your above opinion on prior (possibly outdated) information. The SLAPP proposal defines discovery and authentication mechanisms between a WTP and an AC and a way to negotiate a control protocol that will get executed after this process. The Image download option is one of the many possible ones (others to be defined) that can be negotiated and used. The draft explicitly states that the image download proposal is NOT mandatory and one SLAPP implementation MUST NOT assume that another supports it. 

Thanks
partha

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun" <[email-masked]>
Date: Thu, 7 Apr 2005 07:43:33 -0700

> Maybe you havent had a chance to read the text in the draft 
> and are basing your above opinion on prior (possibly 
> outdated) information. The SLAPP proposal defines discovery 
> and authentication mechanisms between a WTP and an AC and a 
> way to negotiate a control protocol that will get executed 
> after this process. The Image download option is one of the 
> many possible ones (others to be defined) that can be 
> negotiated and used. The draft explicitly states that the 
> image download proposal is NOT mandatory and one SLAPP 
> implementation MUST NOT assume that another supports it. 

Thanks for that clarification. However, as I understand it, there
is still no control protocol that is defined. Therefore 
how does an AP vendor interoperate with an AC?

PatC