Subject: RE: [Capwap] Proposed new requirements

From: "Saravanan Govindan" <[email-masked]>
Date: Tue, 12 Apr 2005 11:47:39 +0800

Dan,

As far as I know, REQ 4 did not go from "rejected" to "mandatory" when I
posted the text proposals in the Objectives format. Actually, I do not
think we had WG consensus on the priorities for any of the four
requirements at that time. It may have been a misunderstanding that all
the text proposals were "mandatory". This was not the case. 

My post was intended to start a discussion to decide the priorities for
the proposals in addition to any editorial changes. I do not know if my
post was not clear. 

As editor, I wanted to put out the proposals in the proper format and
get feedback from the WG.  

I hope this helps clarify the issue. 

Saravanan

> -----Original Message-----
> From: Dan Harkins [mailto:[email-masked]] 
> Sent: Tuesday, April 12, 2005 11:22 AM
> To: Saravanan Govindan
> Cc: Pat Calhoun; [email-masked]; [email-masked]
> Subject: Re: [Capwap] Proposed new requirements 
> 
>   Saravanan,
> 
>   That still sounds redundant to me. And furthermore, I still 
> would like to know where these "others" decided that REQ 4 
> contributed anything of value to the objectives draft. This 
> well-intentioned suggestion attempts to meet a perceived 
> disagreement over the wording of REQ 4 but does not address 
> the fundamental issue of how "rejected" became "mandatory" 
> without any substantive discussion.
> 
>   Dan.
> 
> On Tue, 12 Apr 2005 10:02:02 +0800 you wrote
> > I think we can overcome this issue if we can go back to the actual 
> > requirements proposed. REQ 1 says that the CAPWAP 
> specifications alone 
> > should be sufficient to realize compatibility between WTPs 
> and an AC.
> > REQ 4 says that compatibility between WTPs and an AC should not 
> > require vendors to exchange technical specifications. I 
> think they are 
> > very closely related.
> > 
> > So what if we were to include the following sentence after the 
> > description in REQ 1 and leave out REQ 4?
> > 
> > "Equipment vendors should therefore not be required to refer to any 
> > additional specifications to realize compatibility."
> > 
> > Would this is be acceptable?
> > 
> > Saravanan
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Dan Harkins [mailto:[email-masked]]
> > > Sent: Tuesday, April 12, 2005 3:51 AM
> > > To: Pat Calhoun
> > > Cc: [email-masked]; Saravanan Govindan; 
> > > [email-masked]
> > > Subject: Re: [Capwap] Proposed new requirements
> > > 
> > >   You didn't object further? So after your original objection you 
> > > did not further object. I agree. My point is that between your 
> > > original objection and the retraction of that objection 
> there were 
> > > no discussions on the topic and there were no folks that 
> stated it 
> > > provided any value. There was nothing for you to further object.
> > > 
> > >   I saw an objection to duplicate requirements. A discussion of 
> > > which of the duplicates to reject. A statement that a 
> particular one 
> > > would be rejected.
> > > Then all of a sudden there is agreement that that particular one 
> > > should not be rejected. If there are no other places where CAPWAP 
> > > business is discussed (note that I didn't specifically ask about 
> > > lists but more generally about, oh say, ad-hoc meetings, 
> conference 
> > > calls, etc) then I don't understand how this agreement to 
> resurrect 
> > > REQ 4 came about.
> > > 
> > >   Who are these "folks", why did their statements not 
> show up on the 
> > > list, and how can any agreement on a topic be arrived at if 
> > > discussion of it does not take place on this list?
> > > 
> > >   Dan.
> > > 
> > > On Mon, 11 Apr 2005 12:11:50 PDT you wrote
> > > > I did initially. My point below was that some folks thought it 
> > > > provided some value, and I didn't object further.
> > > > 
> > > > No, there are no additional mailing lists that I am aware of.
> > > > 
> > > > Pat Calhoun
> > > > CTO, Wireless Networking Business Unit Cisco Systems
> > > > 
> > > >  
> > > > 
> > > > > -----Original Message-----
> > > > > From: Dan Harkins [mailto:[email-masked]]
> > > > > Sent: Monday, April 11, 2005 10:45 AM
> > > > > To: Pat Calhoun
> > > > > Cc: [email-masked]; [email-masked]; 
> > > > > [email-masked]
> > > > > Subject: Re: [Capwap] Proposed new requirements
> > > > > 
> > > > >   Really? You were the one who brought up the idea of
> > > removing it in
> > > > > the first place! You said,
> > > > > 
> > > > > "Dorothy, I think that (1) and (4) are one and the same. We 
> > > > > could trim down to 3."
> > > > > 
> > > > > Dorothy and I then discussed which one made sense to reject 
> > > > > culminating in her statement below that REQ4 would be 
> the one to 
> > > > > reject. I was unable to find any others who subsequently
> > > stated that
> > > > > it was beneficial to include it. Who are these others? 
> > > And why did
> > > > > you change your mind?
> > > > > 
> > > > >   I get the distinct feeling that not all CAPWAP-related
> > > discussion
> > > > > are happening on this list. Is there some other place where 
> > > > > discussions are held that result in people changing opinions 
> > > > > they had previously stated in this forum?
> > > > > 
> > > > >   Dan.
> > > > > 
> > > > > On Mon, 11 Apr 2005 10:25:49 PDT you wrote
> > > > > > But others felt that it was beneficial to include, which is
> > > > > probably
> > > > > > why Saravanan included it. I am ok with leaving it in, as
> > > > > were others.
> > > > > > 
> > > > > > Pat Calhoun
> > > > > > CTO, Wireless Networking Business Unit Cisco Systems
> > > > > > 
> > > > > >  
> > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked] 
> > > > > > > [mailto:[email-masked]] On Behalf Of 
> Dan Harkins
> > > > > > > Sent: Monday, April 11, 2005 10:00 AM
> > > > > > > To: [email-masked]
> > > > > > > Cc: [email-masked]; [email-masked]
> > > > > > > Subject: Re: [Capwap] Proposed new requirements
> > > > > > > 
> > > > > > >   You previously said, "I agree to move REQ 4 to the 
> > > > > > > rejected category in the Objectives draft, since its been 
> > > > > > > pointed out that this is a duplicate of REQ 1."
> > > > > > > 
> > > > > > >   Dan.
> > > > > > > 
> > > > > > > On Mon, 11 Apr 2005 05:51:36 PDT you wrote
> > > > > > > > My opinion on this is that these are mandatory since
> > > > > > > interoperability
> > > > > > > > is specified in the charter.
> > > > > > > > 
> > > > > > > > -Dorothy
> > > > > > > > 
> > > > > > > > 
> > > > > > > > -----Original Message-----
> > > > > > > > From: [email-masked] 
> > > > > > > > [mailto:[email-masked]]On
> > > > > > > > Behalf Of ext Saravanan Govindan
> > > > > > > > Sent: Saturday, April 09, 2005 11:07 PM
> > > > > > > > To: [email-masked]
> > > > > > > > Subject: [Capwap] Proposed new requirements
> > > > > > > > 
> > > > > > > > 
> > > > > > > > Following Dorothy's summary of the new requirements,
> > > > > the following
> > > > > > > > posts contain text for them corresponding to the
> > > format of the
> > > > > > > > Objectives draft. The requirements have been 
> classified as
> > > > > > > 'General'. 
> > > > > > > > We now need to confirm priorities for them (Mandatory,
> > > > > > > Desirable or Rejected).
> > > > > > > > 
> > > > > > > > Please advise if there are any changes to be made to
> > > > > the proposed
> > > > > > > > formats.
> > > > > > > > 
> > > > > > > > Saravanan
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: [email-masked] 
> > > > > > > > > [mailto:[email-masked]] On Behalf Of 
> > > > > > > > > [email-masked]
> > > > > > > > > Sent: Friday, April 08, 2005 5:19 AM
> > > > > > > > > To: [email-masked]; [email-masked]; 
> > > > > > > > > [email-masked]
> > > > > > > > > Cc: [email-masked]; [email-masked]; 
> > > > > > > > > [email-masked]
> > > > > > > > > Subject: [Capwap] Interoperability reqs into 
> Objectives 
> > > > > > > > > draft
> > > > > > > > > (was: Comments on objectives draft)
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > I agree with James and Bert's proposal for
> > > Interoperability
> > > > > > > > > requirements in the CAPWAP Objectives draft.
> > > > > > > > > 
> > > > > > > > > We have some modest consensus on this point, and I'd 
> > > > > > > > > like
> > > > > > > to close
> > > > > > > > > this issue in order to incorporate these requirements
> > > > > into the
> > > > > > > > > Objectives draft.
> > > > > > > > > 
> > > > > > > > > To summarize, these are the new requirements:
> > > > > > > > > 
> > > > > > > > > REQ 1) Any AP or AC vendor or any person can
> > > implement the
> > > > > > > > > CAPWAP protocol from the spec itself and by that it
> > > > > is required
> > > > > > > > > that all such implementations do interoperate.
> > > > > > > > > REQ 2) An AP Vendor can make modifications to HW
> > > > > without any AC
> > > > > > > > > vendor involvement.
> > > > > > > > > REQ 3) AP Vendors must not be bound to a specific MAC.
> > > > > > > > > REQ 4) AP vendors should not have to share technical
> > > > > > > specifications
> > > > > > > > > for hardware and software to AC vendors in order for 
> > > > > > > > > interoperability to be achieved.
> > > > > > > > > 
> > > > > > > > > WGLC for
> > > > > > > > > 
> > > http://www.ietf.org/internet-drafts/draft-ietf-capwap-object
> > > > > > > > > iv es-01.txt  for the IEEE experts Review 
> ends Monday, 
> > > > > > > > > 4/11/05.
> > > > > > > > > 
> > > > > > > > > Regards,
> > > > > > > > > Dorothy
> > > > > > > > _______________________________________________
> > > > > > > > Capwap mailing list
> > > > > > > > [email-masked]
> > > > > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > > > > > _______________________________________________
> > > > > > > > Capwap mailing list
> > > > > > > > [email-masked]
> > > > > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > > > > > 
> > > > > > > _______________________________________________
> > > > > > > Capwap mailing list
> > > > > > > [email-masked]
> > > > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > 
> > 
> 
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: Dan Harkins <[email-masked]>
Date: Mon, 11 Apr 2005 21:02:17 -0700

No it didn't and I'm sorry if my wording implied that it had. Due
to the arbitrariness of delay between mail sent to a list and its
posting from that list as well as delays due to trans-continental
delivery of email it is most likely that you responded to an email
on REQ 4 prior to seeing the subsequent email (from the list) 
mentioning its status of "rejected".

  I did not preceive your email as saying that the proposals were
mandatory. It was a different, and subsequent, email in which that
designation was applied to your posts. And it is the genesis of that
email which I am trying to find.

  Your work as editor is appreciated and understood. I thank you
for your posts suggesting text for REQ 1-4. My questions regarding
the status of REQ 4 (above and beyond your suggested text on it)
remain though.

  thanks,

  Dan.

On Tue, 12 Apr 2005 11:47:39 +0800 you wrote