Subject: RE: [Capwap] Proposed new requirements

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 11 Apr 2005 18:39:46 -0600

Dan,

If any such side-band discussions not within scope of CAPWAP list occur
we can't control it.

However, if the discussions refer to the cause of REQ1-4; I can trace it
on the list to the one from Dorothy Gellert - where she references and
infers prior observations from Bert Wijnen and Jim Kempf on the list.

I take all allegations of this nature seriously. If there are
conversations of official CAPWAP nature - that should be happening on
the list in all fairness.

That said - I think we are drawing about to draw to a close on the
Objectives WG Last Call. I do welcome providing comments in other areas
quickly by 'tonight' - although interpretation of interoperable
implementation and invariant state machines have figured as the main
issues hitherto.

Regards,
-mani
======
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Dan Harkins
Sent: Monday, April 11, 2005 12:51 PM
To: Pat Calhoun
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Capwap] Proposed new requirements 

  You didn't object further? So after your original objection you did
not
further object. I agree. My point is that between your original
objection
and the retraction of that objection there were no discussions on the
topic
and there were no folks that stated it provided any value. There was
nothing for you to further object. 

  I saw an objection to duplicate requirements. A discussion of which of
the duplicates to reject. A statement that a particular one would be
rejected.
Then all of a sudden there is agreement that that particular one should
not be rejected. If there are no other places where CAPWAP business is
discussed (note that I didn't specifically ask about lists but more
generally about, oh say, ad-hoc meetings, conference calls, etc) then I
don't understand how this agreement to resurrect REQ 4 came about.

  Who are these "folks", why did their statements not show up on the
list, and how can any agreement on a topic be arrived at if discussion
of
it does not take place on this list?

  Dan.

On Mon, 11 Apr 2005 12:11:50 PDT you wrote
> I did initially. My point below was that some folks thought it
provided some
> value, and I didn't object further. 
> 
> No, there are no additional mailing lists that I am aware of.
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
>  
> 
> > -----Original Message-----
> > From: Dan Harkins [mailto:[email-masked]] 
> > Sent: Monday, April 11, 2005 10:45 AM
> > To: Pat Calhoun
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked]
> > Subject: Re: [Capwap] Proposed new requirements 
> > 
> >   Really? You were the one who brought up the idea of 
> > removing it in the first place! You said,
> > 
> > "Dorothy, I think that (1) and (4) are one and the same. We 
> > could trim down to 3."
> > 
> > Dorothy and I then discussed which one made sense to reject 
> > culminating in her statement below that REQ4 would be the one 
> > to reject. I was unable to find any others who subsequently 
> > stated that it was beneficial to include it. Who are these 
> > others? And why did you change your mind?
> > 
> >   I get the distinct feeling that not all CAPWAP-related 
> > discussion are happening on this list. Is there some other 
> > place where discussions are held that result in people 
> > changing opinions they had previously stated in this forum?
> > 
> >   Dan.
> > 
> > On Mon, 11 Apr 2005 10:25:49 PDT you wrote
> > > But others felt that it was beneficial to include, which is 
> > probably 
> > > why Saravanan included it. I am ok with leaving it in, as 
> > were others.
> > > 
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > > 
> > >  
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]] On Behalf Of Dan Harkins
> > > > Sent: Monday, April 11, 2005 10:00 AM
> > > > To: [email-masked]
> > > > Cc: [email-masked]; [email-masked]
> > > > Subject: Re: [Capwap] Proposed new requirements
> > > > 
> > > >   You previously said, "I agree to move REQ 4 to the rejected 
> > > > category in the Objectives draft, since its been pointed out
that 
> > > > this is a duplicate of REQ 1."
> > > > 
> > > >   Dan.
> > > > 
> > > > On Mon, 11 Apr 2005 05:51:36 PDT you wrote
> > > > > My opinion on this is that these are mandatory since
> > > > interoperability
> > > > > is specified in the charter.
> > > > > 
> > > > > -Dorothy
> > > > > 
> > > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked] 
> > > > > [mailto:[email-masked]]On
> > > > > Behalf Of ext Saravanan Govindan
> > > > > Sent: Saturday, April 09, 2005 11:07 PM
> > > > > To: [email-masked]
> > > > > Subject: [Capwap] Proposed new requirements
> > > > > 
> > > > > 
> > > > > Following Dorothy's summary of the new requirements, 
> > the following 
> > > > > posts contain text for them corresponding to the format of the

> > > > > Objectives draft. The requirements have been classified as
> > > > 'General'. 
> > > > > We now need to confirm priorities for them (Mandatory,
> > > > Desirable or Rejected).
> > > > > 
> > > > > Please advise if there are any changes to be made to 
> > the proposed 
> > > > > formats.
> > > > > 
> > > > > Saravanan
> > > > > 
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: [email-masked]
> > > > > > [mailto:[email-masked]] On Behalf Of 
> > > > > > [email-masked]
> > > > > > Sent: Friday, April 08, 2005 5:19 AM
> > > > > > To: [email-masked]; [email-masked]; 
> > > > > > [email-masked]
> > > > > > Cc: [email-masked]; [email-masked]; 
> > > > > > [email-masked]
> > > > > > Subject: [Capwap] Interoperability reqs into Objectives
draft
> > > > > > (was: Comments on objectives draft)
> > > > > > 
> > > > > > 
> > > > > > I agree with James and Bert's proposal for Interoperability 
> > > > > > requirements in the CAPWAP Objectives draft.
> > > > > > 
> > > > > > We have some modest consensus on this point, and I'd like
> > > > to close
> > > > > > this issue in order to incorporate these requirements 
> > into the 
> > > > > > Objectives draft.
> > > > > > 
> > > > > > To summarize, these are the new requirements:
> > > > > > 
> > > > > > REQ 1) Any AP or AC vendor or any person can implement the 
> > > > > > CAPWAP protocol from the spec itself and by that it 
> > is required 
> > > > > > that all such implementations do interoperate.
> > > > > > REQ 2) An AP Vendor can make modifications to HW 
> > without any AC 
> > > > > > vendor involvement.
> > > > > > REQ 3) AP Vendors must not be bound to a specific MAC.
> > > > > > REQ 4) AP vendors should not have to share technical
> > > > specifications
> > > > > > for hardware and software to AC vendors in order for 
> > > > > > interoperability to be achieved.
> > > > > > 
> > > > > > WGLC for
> > > > > >
http://www.ietf.org/internet-drafts/draft-ietf-capwap-objectiv
> > > > > > es-01.txt  for the IEEE experts Review ends Monday, 4/11/05.
> > > > > > 
> > > > > > Regards,
> > > > > > Dorothy
> > > > > _______________________________________________
> > > > > Capwap mailing list
> > > > > [email-masked]
> > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > > _______________________________________________
> > > > > Capwap mailing list
> > > > > [email-masked]
> > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > > 
> > > > _______________________________________________
> > > > Capwap mailing list
> > > > [email-masked]
> > > > http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: Dan Harkins <[email-masked]>
Date: Mon, 11 Apr 2005 18:09:46 -0700

Mani,

  I understand that unofficial side-band discussions cannot, and really
should not, be controlled. It's just that "approval" seemed to be
derived from some just such a side-band discussion since the alleged
discussion did not happen on the list. That is something that can,
and should, be controlled. If discussion on the list seems to reach
some state then a declaration that it's really some different state
should be questioned.

  With that in mind I can trace REQ 4 to Dorothy from her post with
message id [email-masked]
but there was a subsequent discussion on the list ending with message id
[email-masked] which
closed with her saying, "I agree to move REQ 4 to the rejected category
in the Objectives draft, since it s been pointed out that this is a
duplicate of REQ 1." There were no other discussions on this requirement.
Just a post on how this requirement might appear in the objectives
draft followed by 2 "I agree with this requirement" posts (from James
and Pat), and then Dorothy's statement, with message id of,
[email-masked] that
all posts by Saravanan of the proposed text for REQ1-4 "are mandatory
since interoperability is specified in the charter."

  I took that to be an honest mistake on Dorothy's part and asked her
about it. That's when Pat declared that "others" had opined that
REQ 4 provided some value and that he now supported its inclusion
as mandatory (he had formerly stated that 1 and 4 were duplicates
and supported removing one of them).

  So where are these "others" and in which forum did they express
their opinions?

  Is REQ 4 rejected since it is a duplicate of REQ 1 or not? If it is
now mandatory then what discussion happened that caused it to change
from rejected to mandatory and how come I didn't see any of it on
the list?

  thanks,

  Dan.

On Mon, 11 Apr 2005 18:39:46 MDT you wrote

---

From: "Pat Calhoun" <[email-masked]>
Date: Tue, 12 Apr 2005 06:09:04 -0700

>   So where are these "others" and in which forum did they 
> express their opinions?
I went through the archives and apparently I dreamed up an
e-mail. I was quite certain someone had replied back that they
felt requirement 4 provided some added value. That said, when I 
read Saravanan's requirements, I thought requirement 4 did in 
fact add value.

Sorry for the confusion,

PatC