Subject: RE: [Capwap] REQ3: WTP MAC independence

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 11 Apr 2005 18:45:39 -0600

The objective should, still, reference the architecture taxonomy's
guideline; normative though it may not be as an informational; to
provide near-close interpretation to what constitutes split-MAC. I am
still inclined to think split-AP would have been a better terminology
(in an attempt to replace energetically the use of AP term from the
draft to WTP - we have lost out on AP terminology - equating AP to
local-MAC WTP) to provide a less schizophrenic interpretation of split.

-mani
======

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Saravanan Govindan
Sent: Saturday, April 09, 2005 11:09 PM
To: [email-masked]
Subject: [Capwap] REQ3: WTP MAC independence

Classification: General

Description:
The CAPWAP protocol must not be specified for a particular MAC. It
should be compatible with both local-MAC and split-MAC WTPs. 

Protocol Requirement:
WTP vendors must not be bound to a specific MAC.

Motivation and Protocol Benefits:
This requirement is to ensure that WTP vendors have sufficient
flexibility in selecting the type of MAC that they consider best for
deployments. 

Relation to Problem Statement:
This requirement is based on WG discussions that have determined to be
important for CAPWAP.
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 11 Apr 2005 20:32:25 -0600

I maintaining the original text. It is more of an observation than to
ask for change of terminology going deep into the taxonomy draft (though
I sought it in the first place).

-mani
======

-----Original Message-----
From: Inderpreet Singh [mailto:[email-masked]] 
Sent: Monday, April 11, 2005 7:27 PM
To: Saravanan Govindan
Cc: Mani, Mahalingam (Mahalingam); [email-masked]
Subject: Re: [Capwap] REQ3: WTP MAC independence

I prefer the previous wording.  Furthermore, if I am not mistaken, the
intent of the requirement as initially suggested by Pat was more
regarding the MAC implementation vendor, rather than the MAC
functional type as defined in the Taxonomy.

Section 5.1.11 of draft-ietf-capwap-objectives-01.txt already
specifies that the protocol must support a negotiation of capabilities
with regard to MAC type, namely split or local and already references
the Taxonomy document.

Thanks

Inderpreet

On Apr 11, 2005 9:42 PM, Saravanan Govindan <[email-masked]>
wrote:
> Hi Mani,
> 
> Just for my understanding, this objective should highlight that
> 'split-MAC' refers to designs where both MAC and other AP functions
> (data aggregation, STA state information etc.) are split across AC and
> WTPs.
> 
> So would the following text cover this?
> 
> ----XXXX----
> Classification: General
> 
> Description:
> The CAPWAP protocol must not be specified for a particular MAC or WTP
> design. It should be compatible with the major designs detailed in the
> Architecture  Taxonomy, namely local-MAC and split-MAC WTPs.
> 
> Protocol Requirement:
> WTP vendors must not be bound to a specific MAC or WTP design.
> 
> flexibility in selecting the type of MAC or WTP design that they
> consider best for  deployments.
> 
> ----XXXX----
> Cheers,
> Saravanan
> > From: Mani, Mahalingam (Mahalingam) [mailto:[email-masked]]
> > Sent: Tuesday, April 12, 2005 8:46 AM
> > To: Saravanan Govindan; [email-masked]
> > Subject: RE: [Capwap] REQ3: WTP MAC independence
> >
> > The objective should, still, reference the architecture
> > taxonomy's guideline; normative though it may not be as an
> > informational; to provide near-close interpretation to what
> > constitutes split-MAC. I am still inclined to think split-AP
> > would have been a better terminology (in an attempt to
> > replace energetically the use of AP term from the draft to
> > WTP - we have lost out on AP terminology - equating AP to
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of Saravanan Govindan
> > The CAPWAP protocol must not be specified for a particular
> > MAC. It should be compatible with both local-MAC and split-MAC WTPs.
> >
> > Protocol Requirement:
> > This requirement is to ensure that WTP vendors have
> > sufficient flexibility in selecting the type of MAC that they
> > consider best for deployments.
> >
> > This requirement is based on WG discussions that have
> > determined to be important for CAPWAP.