Subject: [Capwap] comment about LWAPP and other wireless technologies

From: Tal Anker <[email-masked]>
Date: Tue, 2 Aug 2005 17:46:40 +0300 (IDT)

Resending this (it seems the first attempt fails... appologies if you
receive duplicate copies...).

Hi,
while going over the LWAPP draft and on the objecives of CAPWAP there
seems to be a CAPWAP objective that may not be fully achieved with
the current LWAPP spec.
The LWAPP specification requires that the 802.11 frames would be
encapsulated by the WTP and sent to the AC for processing. The benefit
from doing this is having the original info carried in the .11 frame
available to the AC.
However, this requires the AC to process the native 802.11 frames; an
operation that will probably be done in some HW component. My concern is
that one of the CAPWAP objectives was to be applicable not only to 802.11
but for various wireless technologies. As a result the LWAPP should also
be applicable no only for 802.11... (as it indeed states in the beginning
of the LWAPP draft). However mandating that the wireless media frames
would be sent to the AC in their original format would make this objective
harder to achieve... When a new wireless media type would be introduced,
the AC would have to be somehow adapted to process the data frames (not
only the control frames that can obviously be processed in the AC cpu...).
This means either a HW change (or if the AC is using NP then an NP SW
upgrade).
What seems reasonable to do is to add the OPTION for sending the
data frames to the AC using the media type tha tthe WTP is connected to
the AC with. Meaning - to convert the frame in the WTP and to send it to
the AC for instance using 802.3 ethernet frames... This way when a new
wireless technology is inroduced to the AC all that needs to be done is
updating the SW of the AC.

As for loosing the specific media information that was in the 802.11
header - this info can be collected by the WTP and be sent to the AC using
LWAPP protocol messages...

Supporting both the current LWAPP suggestion (sending the original 802.11
frames to the AC) AND the option to convert to the AC media type will
allow LWAPP to comply to the "future wireless technologies" objective...

- Tal

=====================================================================
Tal Anker, PhD.
DANSS - Distributed Algorithms, Networking and Secure Systems Group.
The School of Engineering and Computer Science,
The hebrew University of Jerusalem,
Israel.

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 2 Aug 2005 14:16:24 -0700

Tal,

Thanks for the e-mail.

I believe that I understand your point, but I would argue that the AC
will have to be modified to support a new technology, and that upgrading
the code in the data path is really no more difficult than the control
path. If an implementation exists that does not allow for upgrade, then
it is limiting its market.

I would argue that include "technology specific" information piggy
backed within the LWAPP data frame would be hard to achieve, because we
cannot predict what this information would end up being. For instance,
802.11 has the concept of a BSSID, while 802.16 has something different
(and has additional information). So how would you map 802.11 QoS field
into a field that may not match with 802.16s?

If one were to need to extend the piggy backed header, then this would
require changes to the data path anyhow. Further, certain features will
require changes to the data path, for instance the introduction of
802.11i centralized encryption requires that the data path perform
AES-CCMP, and 802.11e requires specific quality of service queuing and
policing.

So while I understand the point raised, I firmly believe that
transporting the native frame provides the AC with all of the
information for the specific technology, and allows it to provide
differentiated services based on the information present - vs. limiting
it to what generic information would be in this piggy backed header.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Tal Anker
> Sent: Tuesday, August 02, 2005 7:47 AM
> To: [email-masked]
> Subject: [Capwap] comment about LWAPP and other wireless technologies
> 
> Resending this (it seems the first attempt fails... 
> appologies if you receive duplicate copies...).
> 
> Hi,
> while going over the LWAPP draft and on the objecives of 
> CAPWAP there seems to be a CAPWAP objective that may not be 
> fully achieved with the current LWAPP spec.
> The LWAPP specification requires that the 802.11 frames would 
> be encapsulated by the WTP and sent to the AC for processing. 
> The benefit from doing this is having the original info 
> carried in the .11 frame available to the AC.
> However, this requires the AC to process the native 802.11 
> frames; an operation that will probably be done in some HW 
> component. My concern is that one of the CAPWAP objectives 
> was to be applicable not only to 802.11 but for various 
> wireless technologies. As a result the LWAPP should also be 
> applicable no only for 802.11... (as it indeed states in the 
> beginning of the LWAPP draft). However mandating that the 
> wireless media frames would be sent to the AC in their 
> original format would make this objective harder to 
> achieve... When a new wireless media type would be 
> introduced, the AC would have to be somehow adapted to 
> process the data frames (not only the control frames that can 
> obviously be processed in the AC cpu...).
> This means either a HW change (or if the AC is using NP then 
> an NP SW upgrade).
> What seems reasonable to do is to add the OPTION for sending 
> the data frames to the AC using the media type tha tthe WTP 
> is connected to the AC with. Meaning - to convert the frame 
> in the WTP and to send it to the AC for instance using 802.3 
> ethernet frames... This way when a new wireless technology is 
> inroduced to the AC all that needs to be done is updating the 
> SW of the AC.
> 
> As for loosing the specific media information that was in the 
> 802.11 header - this info can be collected by the WTP and be 
> sent to the AC using LWAPP protocol messages...
> 
> Supporting both the current LWAPP suggestion (sending the 
> original 802.11 frames to the AC) AND the option to convert 
> to the AC media type will allow LWAPP to comply to the 
> "future wireless technologies" objective...
> 
> - Tal
> 
> The School of Engineering and Computer Science, The hebrew 
> University of Jerusalem, Israel.
> 
> 
>

---

From: "Tal Anker" <[email-masked]>
Date: Wed, 3 Aug 2005 01:06:10 +0300

Hi Pat.
Upgrading the data path is possible if you have, for example, a network processor performing the data path task. If your AC is based on regular ethernet switch built with ASICs for the data path packet processing (common practice), then you can easily upgrade the control plane but not the forwarding plane....(assuming that all the ACs will be based on HW that allows to easily upgrade to various L2 packet formats seems to me like assuming to have some NP-like capabilities in the AC....).
 
As for the piggybacking of the "technology specific" data... My intention was to extract this info and send some summary periodically to the AC using the LWAPP control messages and NOT to piggyback the data packets of the 802.3 with this info... Otherwise you would be correct of course that this would not give much benefit. However doing this in the control path and not the data path allows you to define new LWAPP protocol messages/fields for summarizing "technology specific" data as new technologies are introduced...
 
As for differentiated services - the QoS portfolio that the AC can provide, is usualy at least as good as what 802.11 can provide... for instance if you use ethernet 802.3 framing from the WTP to the AC you can mark whatever you need on the frame (not to mention if the traffic is IP traffic and you have additional DSCP field). Also if the packet is suppose to traverse another switch on the way to its destination then anyway it will get the QoS that the switch can assign it to the next link towards the destination... Thus I dont see a real benefit in keeping the wireless media original framing... 
 
IMHO extending the LWAPP protocol to support the OPTION for using the AC specific link layer format (in most cases it would be 802.3) would be beneficial in the future and would give LWAPP the flexability that it needs in order to comply to the "applicablity to future wireless technologies"...

- Tal

________________________________

From: [email-masked] on behalf of Pat Calhoun (pacalhou)
Sent: Tue 8/2/2005 11:16 PM
To: Tal Anker; [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Tal,

Thanks for the e-mail.

Pat Calhoun

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 2 Aug 2005 22:40:59 -0700

Well, obviously the WG needs to decide, but frankly I see this as being
no different than say IPv6 or even 802.1q (for those IEEE heads).
Changes in protocols require hardware/firmware changes. I believe that
sending "periodic" information about data frames is not useful and that
in order for the AC to act as an AP, it needs the data on each and every
frame. Such things as signal strength, for instance, allows the AC to
make predictive mobility decisions and cannot be represented in 802.3
frames.

Pat Calhoun

	From: Tal Anker [mailto:[email-masked]] 
	Sent: Tuesday, August 02, 2005 3:06 PM
	To: Pat Calhoun (pacalhou); Tal Anker; [email-masked]
	Subject: RE: [Capwap] comment about LWAPP and other wireless
technologies

	Hi Pat.
	Upgrading the data path is possible if you have, for example, a
network processor performing the data path task. If your AC is based on
regular ethernet switch built with ASICs for the data path packet
processing (common practice), then you can easily upgrade the control
plane but not the forwarding plane....(assuming that all the ACs will be
based on HW that allows to easily upgrade to various L2 packet formats
seems to me like assuming to have some NP-like capabilities in the
AC....).
	 
	As for the piggybacking of the "technology specific" data... My
intention was to extract this info and send some summary periodically to
the AC using the LWAPP control messages and NOT to piggyback the data
packets of the 802.3 with this info... Otherwise you would be correct of
course that this would not give much benefit. However doing this in the
control path and not the data path allows you to define new LWAPP
protocol messages/fields for summarizing "technology specific" data as
new technologies are introduced...
	 
	As for differentiated services - the QoS portfolio that the AC
can provide, is usualy at least as good as what 802.11 can provide...
for instance if you use ethernet 802.3 framing from the WTP to the AC
you can mark whatever you need on the frame (not to mention if the
traffic is IP traffic and you have additional DSCP field). Also if the
packet is suppose to traverse another switch on the way to its
destination then anyway it will get the QoS that the switch can assign
it to the next link towards the destination... Thus I dont see a real
benefit in keeping the wireless media original framing... 
	 
	IMHO extending the LWAPP protocol to support the OPTION for
using the AC specific link layer format (in most cases it would be
802.3) would be beneficial in the future and would give LWAPP the
flexability that it needs in order to comply to the "applicablity to
future wireless technologies"...

	- Tal

	From: [email-masked] on behalf of Pat Calhoun
(pacalhou)
	Sent: Tue 8/2/2005 11:16 PM
	To: Tal Anker; [email-masked]
	Subject: RE: [Capwap] comment about LWAPP and other wireless
technologies

	Tal,
	
	Thanks for the e-mail.
	
	I believe that I understand your point, but I would argue that
the AC
	will have to be modified to support a new technology, and that
upgrading
	the code in the data path is really no more difficult than the
control
	path. If an implementation exists that does not allow for
upgrade, then
	it is limiting its market.
	
	I would argue that include "technology specific" information
piggy
	backed within the LWAPP data frame would be hard to achieve,
because we
	cannot predict what this information would end up being. For
instance,
	802.11 has the concept of a BSSID, while 802.16 has something
different
	(and has additional information). So how would you map 802.11
QoS field
	into a field that may not match with 802.16s?
	
	If one were to need to extend the piggy backed header, then this
would
	require changes to the data path anyhow. Further, certain
features will
	require changes to the data path, for instance the introduction
of
	802.11i centralized encryption requires that the data path
perform
	AES-CCMP, and 802.11e requires specific quality of service
queuing and
	policing.
	
	So while I understand the point raised, I firmly believe that
	transporting the native frame provides the AC with all of the
	information for the specific technology, and allows it to
provide
	differentiated services based on the information present - vs.
limiting
	it to what generic information would be in this piggy backed
header.
	
	Pat Calhoun

---

From: "Yuval Cohen" <[email-masked]>
Date: Wed, 3 Aug 2005 11:14:17 +0300

Pat,
As I indicated below, there are cases where local AP is implemented and in addition there is small deployment scenarios, will not really burden the CPU. Also, a packet doesn’t need to be sent per each data packet but rather only when a threshold is met

But regardless, 802.3 frames seems to me to be the more generic case, while 802.11 is a specific media, not related to the AC technology which is usually Ethernet. And as indicated on a different mail thread, seems that with the 802.11 frame format, LWAPP is not fully compliant with the CAPWAP objectives (supporting all wireless formats) 

(And one correction to a typo I made below: LDAP should read LWAPP)

Yuval

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pat Calhoun (pacalhou)
Sent: Wednesday, August 03, 2005 8:47 AM
To: Yuval Cohen
Cc: Tal Anker; [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Yuval,

I'd like to comment on your point about having the WTP process the
information, and provide a digested version of the information. How
would you propose that the WTP represent the changes in signal strength
(which occur in real time) to the AC - and how frequent would you
propose these updates be made? Would this be a packet that hits the
control processor, because if so, then I have some serious scaling
concerns.

That said, I think that in the end we need the evaluation team to make a
recommendation on a protocol, and then let the WG decide. If the WG
decides that two separate protocol formats would be better than one,
then we can go down that path (and make sure that we make one mandatory
to implement).

Pat Calhoun

> From: Yuval Cohen [mailto:[email-masked]] 
> Sent: Tuesday, August 02, 2005 3:18 PM
> To: Pat Calhoun (pacalhou)
> Cc: Tal Anker; [email-masked]
> Pat,
> While the control path is usually implemented in CPU, the 
> data path in some cases is realized in silicon. Processing 
> 802.11 frames may add to complexity and cost.
> 
> I agree that in some cases, there is a need for the WTP to 
> send the 802.11 frame, as in the case of centralized crypto 
> (although that may conflict with HCCA) but for those 
> implementations not requiring that and in particular local AP 
> case, there is no real need for 802.11 frame reaching the AC.
> The extra info within the 802.11 frame can be processed 
> within the WTP and provided to the AC if needed via the 
> control plane, possibly after some digestion. 
> Using 802.3 frames only, will keep the implementation simple 
> and will enable a large install base of existing switches to 
> become AC with just software upgrade. This will aid wide 
> adoption of LDAP.
> 
> 
> My recommendation is that LWAPP will not limit the frame 
> format to 802.11 only but rather allow two formats, either 
> 802.11 or 802.3. 
> 
> Yuval
>  
> 
> 
> [mailto:[email-masked]] On Behalf Of Pat Calhoun (pacalhou)
> Sent: Wednesday, August 03, 2005 12:16 AM
> I believe that I understand your point, but I would argue 
> that the AC will have to be modified to support a new 
> technology, and that upgrading the code in the data path is 
> really no more difficult than the control path. If an 
> implementation exists that does not allow for upgrade, then 
> piggy backed within the LWAPP data frame would be hard to 
> achieve, because we cannot predict what this information 
> would end up being. For instance,
> different (and has additional information). So how would you 
> map 802.11 QoS field into a field that may not match with 802.16s?
> 
> If one were to need to extend the piggy backed header, then 
> this would require changes to the data path anyhow. Further, 
> certain features will require changes to the data path, for 
> instance the introduction of 802.11i centralized encryption 
> requires that the data path perform AES-CCMP, and 802.11e 
> requires specific quality of service queuing and policing.
> 
> provide differentiated services based on the information 
> present - vs. limiting it to what generic information would 
> be in this piggy backed header.
> 
> Pat Calhoun
> CAPWAP there 
> > seems to be a CAPWAP objective that may not be fully 
> achieved with the 
> > current LWAPP spec.
> > encapsulated by the WTP and sent to the AC for processing.
> frames; an 
> > operation that will probably be done in some HW component. 
> My concern 
> > is that one of the CAPWAP objectives was to be applicable 
> not only to 
> > 802.11 but for various wireless technologies. As a result the LWAPP 
> > should also be applicable no only for 802.11... (as it 
> indeed states 
> > in the beginning of the LWAPP draft). However mandating that the 
> original format 
> > would make this objective harder to achieve... When a new wireless 
> > media type would be introduced, the AC would have to be somehow 
> > adapted to process the data frames (not only the control 
> frames that 
> > can obviously be processed in the AC cpu...).
> > What seems reasonable to do is to add the OPTION for 
> sending the data 
> > frames to the AC using the media type tha tthe WTP is 
> connected to the 
> > AC with. Meaning - to convert the frame in the WTP and to 
> send it to 
> > wireless technology is inroduced to the AC all that needs 
> to be done 
> > is updating the SW of the AC.
> > 
> > 802.11 header - this info can be collected by the WTP and 
> be sent to 
> > the AC using LWAPP protocol messages...
> > 
> > Supporting both the current LWAPP suggestion (sending the original 
> > 802.11 frames to the AC) AND the option to convert to the AC media 
> > type will allow LWAPP to comply to the "future wireless 
> technologies" 
> > objective...
> > 
> > - Tal
> > 
> > 
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap
j��f��)��+-	�pj��j�(��(�m���j)_���w��o�j)fj��b��?q�pj

---

From: Michael Montemurro <[email-masked]>
Date: Wed, 3 Aug 2005 05:12:00 -0400

In the CTP draft, which is likely more aligned with what I would call a
Local MAC implementation rather than an split MAC implementation, we tunnel
802.3 frames. In the case of local MAC, you are bridging data to 802.3 at
the WTP so it makes sense to tunnel 802.3 frames.

Practically speaking, the only additional information in an 802.11 frame
(MSDU) is a BSSID. In most  implementations, the BSSID maps to a VLAN tag in
802.3. However we found for fast data plane processing we mapped the BSSID
to a Network ID in the CTP header. We have also provided the option for the
WTP to send the RSSI and RATE as part of the CTP header.

In the split MAC case, I could see the value in the WTP passing the 802.xx
frame to the AC in a tunnel. I still think you would want to for adding the
network ID (representation of the SSID/BSSID) as part of the CAPWAP protocol
header to aid in data plane processing.

On the QoS side, I think you definitely need to apply the equivalent
priority from the data frame to the tunnel header.

I would say from a requirements perspective, the tunnelled data packet must
include:
1) A data frame indicator in the header.
2) A Network ID in the header.
3) The SRC MAC, DEST MAC, and PAYLOAD
4) QoS information in the tunnel header. 

The open issue is what additional information could be given:
1) PHY specific information. For example, RSSI and RATE in 802.11.
2) MAC-specific information.

I think in the split-MAC case, you could make an argument for using either
type of data frame in the tunnel header. A 802.xx MAC header may involve
slightly less processing than an 802.3 header at the WTP. But I really don't
think there's much of a difference.

In a local-MAC case if you tunnel data to the AC, then it would make more
sense to use an 802.3 format for the data.

Cheers,

	Mike
  
> [mailto:[email-masked]] On Behalf Of Michael Vakulenko
> Sent: August 3, 2005 3:27 AM
> Cc: Yuval Cohen; Tal Anker; [email-masked]
> Your question is independent of whether CAPWAP tunnels 802.3 or
> 802.11 frame. Signal strength field does not present in 
> 802.11 frame headers. Having tunnel 802.11 frames doesn't 
> solve the problem.
> 
> Thanks,
> 
> -- Michael V.
> 
> At 08:46 AM 8/3/2005, Pat Calhoun \(pacalhou\) wrote:
> >Yuval,
> >
> >That said, I think that in the end we need the evaluation 
> team to make 
> >a recommendation on a protocol, and then let the WG decide. 
> If the WG 
> data path 
> > > in some cases is realized in silicon. Processing
> > > I agree that in some cases, there is a need for the WTP 
> to send the 
> > > 802.11 frame, as in the case of centralized crypto (although that 
> > > may conflict with HCCA) but for those implementations not 
> requiring 
> > > that and in particular local AP case, there is no real need for 
> > > 802.11 frame reaching the AC.
> within the 
> > > WTP and provided to the AC if needed via the control 
> plane, possibly 
> > > after some digestion.
> > > Using 802.3 frames only, will keep the implementation simple and 
> > > will enable a large install base of existing switches to 
> become AC 
> > > with just software upgrade. This will aid wide adoption of LDAP.
> > >
> > >
> format to 
> > > 802.11 only but rather allow two formats, either
> > > 802.11 or 802.3.
> > >
> > > Yuval
> > >
> > >
> > >
> that the 
> > > AC will have to be modified to support a new technology, and that 
> > > upgrading the code in the data path is really no more 
> difficult than 
> > > the control path. If an implementation exists that does not allow 
> > > for upgrade, then it is limiting its market.
> > >
> > > backed within the LWAPP data frame would be hard to 
> achieve, because 
> > > we cannot predict what this information would end up being. For 
> > > instance,
> > > different (and has additional information). So how would you map 
> > > 802.11 QoS field into a field that may not match with 802.16s?
> > >
> > > would require changes to the data path anyhow. Further, certain 
> > > features will require changes to the data path, for instance the 
> > > introduction of 802.11i centralized encryption requires that the 
> > > data path perform AES-CCMP, and 802.11e requires specific 
> quality of 
> > > service queuing and policing.
> > >
> > > limiting it to what generic information would be in this piggy 
> > > backed header.
> > >
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > >
> > >
> > >

---

From: "Yuval Cohen" <[email-masked]>
Date: Wed, 3 Aug 2005 12:55:22 +0300

Bob,
the discussion is not only about local MAC but also about split MAC. The local MAC was given just as an example.
For reasons provided before, I see also a lot of sense in using 802.3 frames also in the split MAC case, where you do the distribution function (based on 802.3 frame switching) within the AC
Since in any case you need to add the 802.11 specific info (like RSSI), I'd rather see it within the LWAPP tunnel header so I can choose if to take it from there or not and keep the frame 802.3. This will give the most flexibility for those implementations that need the extra info and for those looking into simple implementations not requiring processing the extra info or allowing processing in the WTP 

I would like to hear more opinions on the WG mailing list as to how important it is to support this also in split MAC case

Yuval

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob O'Hara (boohara)
Sent: Wednesday, August 03, 2005 11:49 AM
To: [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

I guess I fail to see what this controversy is all about.  If you want
to forward 802.3 frames from the WTP, you are using the local MAC
variant supported by LWAPP.  In fact, that is what the taxonomy draft
specifies.  

If all you have in your AC is Ethernet switch silicon on the data path,
this is the only reasonable implementation.  To say that another option
is necessary to support conversion of 802.11 frames to 802.3 frames in
the WTP in split MAC mode, separate the 802.11-specific information and
forward the 802.3 frames and separated 802.11 information about those
forwarded 802.3 frames in LWAPP packets is ridiculous.  Just because you
have a hammer, doesn't mean that everything else in the world is a nail.

It seems that this is a tremendous complication to the AC, which now
needs to correlate this separated information.  This correlation
operation was not necessary when the 802.11 frames were forwarded
directly, since the frames and their information arrived whole and
together. 

In order to reduce the computing load on the AC to correlate the
separated information, the WTP could send only summarized information.
Of course, this reduces the amount of information available to the AC,
without justification.

 -Bob
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Michael Vakulenko
Sent: Wednesday, August 03, 2005 12:27 AM
To: Pat Calhoun (pacalhou)
Cc: Yuval Cohen; Tal Anker; [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless
technologies

Pat,

Your question is independent of whether CAPWAP tunnels 802.3 or 
802.11 frame. Signal strength field does not present in 802.11 frame 
headers. Having tunnel 802.11 frames doesn't solve the problem.

Thanks,

-- Michael V.

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap
	�pj���X��X��&���_���w��hm������~��r��r���������+-�w��Ʃ��

---

From: "Nehru Bhandaru" <[email-masked]>
Date: Wed, 3 Aug 2005 06:39:09 -0600

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_______________________________________________Capwap mailing [email-masked]://mail.frascone.com/mailman/listinfo/capwap

---

From: "Yuval Cohen" <[email-masked]>
Date: Wed, 3 Aug 2005 16:28:10 +0300

> Pat,
> As I indicated below, there are cases where local AP is 
> implemented and in addition there is small deployment 
> scenarios, will not really burden the CPU. Also, a packet 
> doesn't need to be sent per each data packet but rather only 
> when a threshold is met

How do you define an RF threshold, and given the wide variations that
can exist between packets in most environments, how do you guarantee
that this doesn't negatively impact the WTP/AC performance?

[YC] this is definitely not the scope of CAPWAP to define the exact thresholds. 

> 
> But regardless, 802.3 frames seems to me to be the more 
> generic case, while 802.11 is a specific media, not related 
> to the AC technology which is usually Ethernet. And as 
> indicated on a different mail thread, seems that with the 
> 802.11 frame format, LWAPP is not fully compliant with the 
> CAPWAP objectives (supporting all wireless formats) 
Respectfully disagree. We haven't decided how 802.16 is mapped onto the
CAPWAP protocol. Therefore the LWAPP protocol allows it by being
flexible in allow the native frames to be tunneled. So it does in fact
comply with the standard.

[YC] with the cost of having different frame format for each wireless media...

Pat Calhoun

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 3 Aug 2005 06:57:03 -0700

So this would be an argument for local bridging and tunneling of 802.3 frames in local mode. I think that would be a good compromise. I believe that changing the basic fundamentals of Split MAC, which means *all* AP functions are performed in the AC (possibly including encryption), would be a mistake.

The taxonomy recommendation already recommends that Local MAC be the "mandatory" mode, but if the WG agrees, we could make changes to allow for tunneling of traffic in an 802.3 mode.

Pat Calhoun

> [mailto:[email-masked]] On Behalf Of Nehru Bhandaru
> Sent: Wednesday, August 03, 2005 5:39 AM
> To: Yuval Cohen; Bob O'Hara (boohara); [email-masked]
> All,
> IMHO supporting the case where 802.11 <-> 802.3 conversion is 
> done at the WTP and 802.3 is transported to AC is important 
> to leverage existing silicon in the data path at the AC. This 
> can be accomplished in many ways in CAPWAP - one option that 
> seems to be under debate is to consider this as a mode of Split MAC. 
> 
> Another, something I like better and not very complicated, is 
> to consider this an Local MAC option where the 
> integration/portal function of 802.11 AP is at the AC. With 
> this model, LWAPP control protocol (in the Local MAC case) 
> could negotiate the encapsulation for the data path to the 
> portal. This could be GRE, LWAPP(L2/L3) or whatever - with 
> inner payload of 802.3. RSSI/SNR/etc values can be obtained 
> from the encapsulation header...
> 
> Split MAC could carry 802.11 only in the data path.
> 
> - Nehru
> 
> [mailto:[email-masked]] On
>     Behalf Of Yuval Cohen
>     Sent: Wednesday, August 03, 2005 5:55 AM
>     To: Bob O'Hara (boohara); [email-masked]
>     the discussion is not only about local MAC but also about 
> split MAC. The
>     local MAC was given just as an example.
>     For reasons provided before, I see also a lot of sense in 
> using 802.3
>     frames also in the split MAC case, where you do the distribution
>     function (based on 802.3 frame switching) within the AC
>     Since in any case you need to add the 802.11 specific 
> info (like RSSI),
>     I'd rather see it within the LWAPP tunnel header so I can 
> choose if to
>     take it from there or not and keep the frame 802.3. This 
> will give the
>     most flexibility for those implementations that need the 
> extra info and
>     for those looking into simple implementations not 
> requiring processing
>     the extra info or allowing processing in the WTP
>     
>     I would like to hear more opinions on the WG mailing list 
> as to how
>     important it is to support this also in split MAC case
>     
>     Yuval
>     
>     
>     
>     
>     
> [mailto:[email-masked]] On
>     Behalf Of Bob O'Hara (boohara)
> 802.11 frame
>     >That said, I think that in the end we need the 
> evaluation team to make
>     a
>     > > > 802.11 but for various wireless technologies. As a 
> result the
>     LWAPP
>     > > > DANSS - Distributed Algorithms, Networking and 
> Secure Systems
>     Group.
>     	pjXX&_whm~rr+-wƩ
> 	j~rr

---

From: "Nehru Bhandaru" <[email-masked]>
Date: Wed, 3 Aug 2005 13:36:03 -0600

In reviewing the taxonomy document (v6) in the light of this discussion, it seems that this option does not allow, for example, 802.11 mgmt frames to terminate at AC with 802.3 in the data plane. As I understand only Split MAC allows 802.11 mgmt frames to terminate on the AC. Such a combination would be useful because 802.11 frame can easily be processed in software in the control path.

Another way to think about this issue, without changing the semantics of Split/Local MAC terminology, is to treat control and data planes separately, in line with the CAPWAP separation of control/data objective, and allow Split MAC or Local MAC to be negotiated independently for control & data via the CAPWAP protocol. Current usage of Split MAC and Local MAC each of which have requirements on the data and control planes is causing some confusion ( at least for me).

- Nehru

    -----Original Message-----
    From: Pat Calhoun (pacalhou) [mailto:[email-masked]]
    Sent: Wednesday, August 03, 2005 9:57 AM
    To: Nehru Bhandaru; Yuval Cohen; Bob O'Hara (boohara);
    [email-masked]
    Subject: RE: [Capwap] comment about LWAPP and other wireless
    technologies
    
    So this would be an argument for local bridging and tunneling of 802.3
    frames in local mode. I think that would be a good compromise. I believe
    that changing the basic fundamentals of Split MAC, which means *all* AP
    functions are performed in the AC (possibly including encryption), would
    be a mistake.
    
    The taxonomy recommendation already recommends that Local MAC be the
    "mandatory" mode, but if the WG agrees, we could make changes to allow
    for tunneling of traffic in an 802.3 mode.
    
    Pat Calhoun

---

From: "Yuval Cohen" <[email-masked]>
Date: Thu, 4 Aug 2005 01:31:09 +0300

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_______________________________________________Capwap mailing [email-masked]://mail.frascone.com/mailman/listinfo/capwap

---

From: "Nehru Bhandaru" <[email-masked]>
Date: Thu, 4 Aug 2005 06:23:16 -0600

I think the only assumption is - if local MAC then integration service may be performed on WTP.

Also according to my read of Fig 9 - arch taxonomoy draft (v6) 802.1x authenticator may be on WTP for local MAC

- Nehru

    -----Original Message-----
    From: Dan Harkins [mailto:[email-masked]]
    Sent: Thursday, August 04, 2005 3:44 AM
    To: Michael Montemurro
    Cc: Pat Calhoun (pacalhou); Nehru Bhandaru; Yuval Cohen; Bob O'Hara
    (boohara); [email-masked]
    Subject: Re: [Capwap] comment about LWAPP and other wireless
    technologies
    
      So are we saying that if the integration service is performed on the
    WTP
    then you're "local MAC" regardless of any of the other non-real time
    functions that may be done on the AC? I'm not sure I agree with that.
    
      By the way, if the 802.1x authenticator is on the AC then I think you
    are by definition a split MAC. No?
    
      Dan.
    
    On Wed, 03 Aug 2005 16:42:32 EDT you wrote
    > I would agree with this using 802.3 for local MAC and 802.xx for split
    MAC
    > would be a reasonable compromise to this issue.
    >
    > Mike
    >
    > Michael Montemurro
    > Director, Advanced Technology and Standards
    > Chantry Networks, A Siemens Company
    > 1900 Minnesota Ct, Suite 125
    > Mississauga, ON, CANADA.
    > T: 905-363-6413
    > F: 905-567-9900
    > E: [email-masked]
    >
    > > Sent: August 3, 2005 9:57 AM
    > > So this would be an argument for local bridging and tunneling
    > > of 802.3 frames in local mode. I think that would be a good
    > > compromise. I believe that changing the basic fundamentals of
    > > Split MAC, which means *all* AP functions are performed in
    > > the AC (possibly including encryption), would be a mistake.
    > >
    > > The taxonomy recommendation already recommends that Local MAC
    > > be the "mandatory" mode, but if the WG agrees, we could make
    > > changes to allow for tunneling of traffic in an 802.3 mode.
    > >
    > > Pat Calhoun
    > > > IMHO supporting the case where 802.11 <-> 802.3 conversion
    > > is done at
    > > > the WTP and 802.3 is transported to AC is important to leverage
    > > > existing silicon in the data path at the AC. This can be
    > > accomplished
    > > > in many ways in CAPWAP - one option that seems to be under
    > > debate is
    > > > to consider this as a mode of Split MAC.
    > > >
    > > > Another, something I like better and not very complicated, is to
    > > > consider this an Local MAC option where the integration/portal
    > > > function of 802.11 AP is at the AC. With this model, LWAPP control
    > > > protocol (in the Local MAC case) could negotiate the
    > > encapsulation for
    > > > the data path to the portal. This could be GRE, LWAPP(L2/L3) or
    > > > whatever - with inner payload of 802.3. RSSI/SNR/etc values can be
    > > > obtained from the encapsulation header...
    > > >
    split
    > > > MAC. The
    using
    > > > 802.3
    > > info (like
    > > > RSSI),
    > > >     I'd rather see it within the LWAPP tunnel header so I
    > > can choose
    > > > if to
    > > >     take it from there or not and keep the frame 802.3.
    > > This will give
    > > > the
    > > >     most flexibility for those implementations that need the extra
    > > > info and
    > > >     for those looking into simple implementations not requiring
    > > > processing
    > > >     I would like to hear more opinions on the WG mailing list as
    to
    > > > how
    > > >     variant supported by LWAPP.  In fact, that is what the
    taxonomy
    > > > draft
    > > >     specifies.
    > > >
    > > >     If all you have in your AC is Ethernet switch silicon
    > > on the data
    > > > path,
    > > >     this is the only reasonable implementation.  To say
    > > that another
    > > > option
    > > >     forward the 802.3 frames and separated 802.11 information
    about
    > > > those
    > > >     have a hammer, doesn't mean that everything else in the
    > > world is a
    > > > nail.
    > > >
    > > >     It seems that this is a tremendous complication to the
    > > AC, which
    > > > now
    > > >     Of course, this reduces the amount of information
    > > available to the
    > > > AC,
    > > >     without justification.
    > > >
    > > >      -Bob
    > > >
    > > >     >I'd like to comment on your point about having the WTP
    process
    > > > the
    > > >     >information, and provide a digested version of the
    > > information.
    > > > How
    > > >     >would you propose that the WTP represent the changes in
    signal
    > > > strength
    > > >     >propose these updates be made? Would this be a packet
    > > that hits
    > > > the
    > > evaluation team to
    > > > make
    > > >     >recommendation on a protocol, and then let the WG
    > > decide. If the
    > > > WG
    > > >     >decides that two separate protocol formats would be
    > > better than
    > > > one,
    > > >     > > [mailto:[email-masked]] On Behalf Of Pat
    Calhoun
    > > >     > > > 802.11 but for various wireless technologies. As a
    result
    > > > the
    > > >     > > > in the beginning of the LWAPP draft). However
    > > mandating that
    > > > the
    > > >     > > > would make this objective harder to achieve... When a
    new
    > > > wireless
    > > >     > > > the AC for instance using 802.3 ethernet
    > > frames... This way
    > > >     > > when a new
    > > >     > > > As for loosing the specific media information that was
    in
    > > > the
    > > > original
    > > >     > > > 802.11 frames to the AC) AND the option to
    > > convert to the AC
    > > > media
    > > >     > > > Tal Anker, PhD.
    > > >     > > > DANSS - Distributed Algorithms, Networking and Secure
    > > > Systems
    > > >     Group.
    > > >     	pjXX&_whm~rr+-wÆ©
    > > 	pjXX&_whm~rr+-wÆ©

---

From: "Sadot, Emek (Emek)" <[email-masked]>
Date: Fri, 5 Aug 2005 02:11:57 -0400

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_______________________________________________Capwap mailing [email-masked]://mail.frascone.com/mailman/listinfo/capwap

---

From: "Sadot, Emek (Emek)" <[email-masked]>
Date: Fri, 5 Aug 2005 02:11:57 -0400

I respectfully disagree with the assumption that Split MAC is define as *all* AP functions in the AC, and in particular the DS. This issue was exhausted in the list. If my memory server me right the key arguments in favor of offload the DS to the WTP were:
- CAPWAP is a control protocol, has nothing to do with data flow
- Avoid hammering the AC with data traffic
- Shortest path for data packets

Regards,
Emek

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pat Calhoun (pacalhou)
Sent: Wednesday, August 03, 2005 9:57 AM
To: Nehru Bhandaru; Yuval Cohen; Bob O'Hara (boohara); [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Pat Calhoun

> IMHO supporting the case where 802.11 <-> 802.3 conversion is done at 
> existing silicon in the data path at the AC. This can be accomplished 
> in many ways in CAPWAP - one option that seems to be under debate is 
> protocol (in the Local MAC case) could negotiate the encapsulation for 
>     the discussion is not only about local MAC but also about split 
> MAC. The
>     For reasons provided before, I see also a lot of sense in using 
> 802.3
>     Since in any case you need to add the 802.11 specific info (like 
> RSSI),
>     I'd rather see it within the LWAPP tunnel header so I can choose 
> if to
>     take it from there or not and keep the frame 802.3. This will give 
> the
>     I would like to hear more opinions on the WG mailing list as to 
> how
>     >That said, I think that in the end we need the evaluation team to 
> make
>     a
>     > > > 802.11 but for various wireless technologies. As a result 
> the
>     LWAPP
	pjXX&_whm~rr+-wƩ

---

From: "Yuval Cohen" <[email-masked]>
Date: Fri, 5 Aug 2005 11:09:46 +0300

The claim was not to demand translation to 802.3 but rather to the applicable media. If the media is 802.3 LAN than translate to 802.3 if it is frame relay, translate to it etc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sadot, Emek (Emek)
Sent: Friday, August 05, 2005 9:12 AM
To: Yuval Cohen; Bob O'Hara (boohara); [email-masked]
Subject: [BULK] RE: [Capwap] comment about LWAPP and other wireless technologies
Importance: Low

As terminating 802.11 at the WTP, converting to 802.3 and sending to the AC may be a good idea, I would argue against specifying this embodiment as mandatory. It border impossible to ensure that WTP to AC communication will always travel over 802.3 network. Although I concur it's the common practice in LAN environment, I would challenge its applicability to the WiMAX, or for that matter to other wireless technologies.

Regards,
Emek

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yuval Cohen
Sent: Wednesday, August 03, 2005 5:55 AM
To: Bob O'Hara (boohara); [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Bob,
the discussion is not only about local MAC but also about split MAC. The local MAC was given just as an example.
For reasons provided before, I see also a lot of sense in using 802.3 frames also in the split MAC case, where you do the distribution function (based on 802.3 frame switching) within the AC Since in any case you need to add the 802.11 specific info (like RSSI), I'd rather see it within the LWAPP tunnel header so I can choose if to take it from there or not and keep the frame 802.3. This will give the most flexibility for those implementations that need the extra info and for those looking into simple implementations not requiring processing the extra info or allowing processing in the WTP 

Yuval

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob O'Hara (boohara)
Sent: Wednesday, August 03, 2005 11:49 AM
To: [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

I guess I fail to see what this controversy is all about.  If you want to forward 802.3 frames from the WTP, you are using the local MAC variant supported by LWAPP.  In fact, that is what the taxonomy draft specifies.  

If all you have in your AC is Ethernet switch silicon on the data path, this is the only reasonable implementation.  To say that another option is necessary to support conversion of 802.11 frames to 802.3 frames in the WTP in split MAC mode, separate the 802.11-specific information and forward the 802.3 frames and separated 802.11 information about those forwarded 802.3 frames in LWAPP packets is ridiculous.  Just because you have a hammer, doesn't mean that everything else in the world is a nail.

It seems that this is a tremendous complication to the AC, which now needs to correlate this separated information.  This correlation operation was not necessary when the 802.11 frames were forwarded directly, since the frames and their information arrived whole and together. 

In order to reduce the computing load on the AC to correlate the separated information, the WTP could send only summarized information.
Of course, this reduces the amount of information available to the AC, without justification.

 -Bob
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Vakulenko
Sent: Wednesday, August 03, 2005 12:27 AM
To: Pat Calhoun (pacalhou)
Cc: Yuval Cohen; Tal Anker; [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Pat,

Your question is independent of whether CAPWAP tunnels 802.3 or
802.11 frame. Signal strength field does not present in 802.11 frame headers. Having tunnel 802.11 frames doesn't solve the problem.

Thanks,

-- Michael V.

At 08:46 AM 8/3/2005, Pat Calhoun \(pacalhou\) wrote:
> > While the control path is usually implemented in CPU, the data path 
> > I agree that in some cases, there is a need for the WTP to send the 
> > may conflict with HCCA) but for those implementations not requiring 
> > The extra info within the 802.11 frame can be processed within the 
> > WTP and provided to the AC if needed via the control plane, possibly 
> > after some digestion.
> > will enable a large install base of existing switches to become AC 
> > My recommendation is that LWAPP will not limit the frame format to 
> > I believe that I understand your point, but I would argue that the 
> > upgrading the code in the data path is really no more difficult than 
> > backed within the LWAPP data frame would be hard to achieve, because 
> > data path perform AES-CCMP, and 802.11e requires specific quality of 

	j~rr

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 8 Aug 2005 07:02:11 -0700

I will point you to figure 12 in the taxonomy document. In ALL six cases the Split MAC architectures handle both the DS and the IS functions in the AC. So I wonder why we should consider creating a protocol for which no products would use? 

Let's keep this simple and focus on market need.

Pat Calhoun

> [mailto:[email-masked]] On Behalf Of Sadot, Emek (Emek)
> Sent: Thursday, August 04, 2005 11:12 PM
> To: Pat Calhoun (pacalhou); Nehru Bhandaru; Yuval Cohen; Bob 
> O'Hara (boohara); [email-masked]
> I respectfully disagree with the assumption that Split MAC is 
> define as *all* AP functions in the AC, and in particular the 
> DS. This issue was exhausted in the list. If my memory server 
> me right the key arguments in favor of offload the DS to the WTP were:
> 	jXX&wh~rr+w

---

From: "Sadot, Emek (Emek)" <[email-masked]>
Date: Mon, 8 Aug 2005 15:44:30 -0400

Pat,

Thanks pointing it out. However, I think that the fact that, at time, all Split arch. vendors incorporated the DS at the AC shouldn't discourage the group from structuring a protocol that can comprehensively support various applications.

The IETF mandate working group to satisfy market requirements not to create a protocol to support existent products, that at time may not have been mature enough.

Regards,
Emek

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: Monday, August 08, 2005 10:02 AM
To: Sadot, Emek (Emek); Nehru Bhandaru; Yuval Cohen; Bob O'Hara (boohara); [email-masked]
Subject: RE: [Capwap] comment about LWAPP and other wireless technologies

Pat Calhoun

> To: Pat Calhoun (pacalhou); Nehru Bhandaru; Yuval Cohen; Bob O'Hara 
> I respectfully disagree with the assumption that Split MAC is define 
> as *all* AP functions in the AC, and in particular the DS. This issue 
> was exhausted in the list. If my memory server me right the key 
> arguments in favor of offload the DS to the WTP were:
> frames in local mode. I think that would be a good compromise. I 
> believe that changing the basic fundamentals of Split MAC, which means 
> *all* AP functions are performed in the AC (possibly including 
> encryption), would be a mistake.
>