Subject: [Capwap] In-band/out-of-band firmware download

From: Michael Montemurro <[email-masked]>
Date: Tue, 6 Sep 2005 09:46:18 -0400

One implicit technical issue that I believe has come out of the regulatory
discussion is regading firmware download. There seems to be two different
mechanisms that are proposed for firmware download to the WTP: one uses the
control channel between the AC and the WTP (I call that an in-band
mechanism) and the other uses a separate protocol, independent of the
control channel. 

An in-band mechanism provides a simpler mechanism for monitoring the
progress of the firmware download and simplified state management. An
out-of-band mechanism relies on other protocols (sftp, ftp, tftp), which
would likely provide a more robust mechanism for download, but perhaps a
slightly more compicated state machine.

What is the feeling of the group on how firmware download should work?

Cheers,

	Mike
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Nehru Bhandaru" <[email-masked]>
Date: Tue, 6 Sep 2005 09:05:06 -0600

Robustness provided by out-of-band mechanism is probably useful.
However, the out-of-band dowloaded firmware must be authenticated -
perhaps using the mechanism used by the control channel - so that
appropriate policy can be enforced.

One questions comes to mind - why not make the in-band mechanism robust?

- Nehru

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]
On
    Behalf Of Michael Montemurro
    Sent: Tuesday, September 06, 2005 9:46 AM
    To: [email-masked]
    Subject: [Capwap] In-band/out-of-band firmware download
    
    One implicit technical issue that I believe has come out of the
    regulatory
    discussion is regading firmware download. There seems to be two
    different
    mechanisms that are proposed for firmware download to the WTP: one
uses
    the
    control channel between the AC and the WTP (I call that an in-band
    mechanism) and the other uses a separate protocol, independent of
the
    control channel.
    
    An in-band mechanism provides a simpler mechanism for monitoring the
    progress of the firmware download and simplified state management.
An
    out-of-band mechanism relies on other protocols (sftp, ftp, tftp),
which
    would likely provide a more robust mechanism for download, but
perhaps a
    slightly more compicated state machine.
    
    What is the feeling of the group on how firmware download should
work?
    
    Cheers,
    
    	Mike

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 7 Sep 2005 08:57:36 -0700

Not clear to me why you state that out of band is more robust.

I think that being able to piggy back from the existing security
association, and encryption channel, between the WTP and the AC has lots
of value.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Michael Montemurro
> Sent: Tuesday, September 06, 2005 6:46 AM
> To: [email-masked]
> One implicit technical issue that I believe has come out of 
> the regulatory discussion is regading firmware download. 
> There seems to be two different mechanisms that are proposed 
> for firmware download to the WTP: one uses the control 
> channel between the AC and the WTP (I call that an in-band
> mechanism) and the other uses a separate protocol, 
> independent of the control channel. 
> 
> An in-band mechanism provides a simpler mechanism for 
> monitoring the progress of the firmware download and 
> simplified state management. An out-of-band mechanism relies 
> on other protocols (sftp, ftp, tftp), which would likely 
> provide a more robust mechanism for download, but perhaps a

---

From: Michael Montemurro <[email-masked]>
Date: Wed, 7 Sep 2005 15:47:11 -0400

Protocols such as ftp and sftp have built-in mechanisms to recover from
errors.

It's true that if you use an in-band mechanism, you can piggyback off the
existing security association and encryption. However, you would have to
build capability into the protocol to ensure that you could recover
efficiently from errors. This work has already been done for out-of-band
protocols.

Cheers,

	Mike

> From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
> Sent: September 7, 2005 11:58 AM
> To: Michael Montemurro; [email-masked]
> Subject: RE: [Capwap] In-band/out-of-band firmware download
> 
> I think that being able to piggy back from the existing 
> security association, and encryption channel, between the WTP 
> and the AC has lots of value.
> 
> Pat Calhoun
> > regulatory discussion is regading firmware download.
> > There seems to be two different mechanisms that are proposed for 
> > firmware download to the WTP: one uses the control channel 
> between the 
> > AC and the WTP (I call that an in-band
> monitoring the 
> > which would likely provide a more robust mechanism for 
> download, but 
> > perhaps a slightly more compicated state machine.
> >