Subject: [Capwap] Simple and complete proposal for CAPWAP

From: "Richard Gwee" <[email-masked]>
Date: Mon, 5 Sep 2005 16:13:07 +0800

Hi,

I do agree in a way that the CAPWAP protocol should be simple and
complete. From my perspective, rather than considering which proposed
protocol would best represent the basis for CAPWAP, I feel that each
CAPWAP proposal does have its unique strength in certain areas. It will
be best if the WG can look at combining all of these individual
strengths of the four protocols for CAPWAP.

Thanks and Regards
Richard Gwee

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Partha Narasimhan
Sent: Sunday, September 04, 2005 2:20 AM
To: Dan Harkins
Cc: [email-masked]; [email-masked]
Subject: Re: [Capwap] this is not the thread on expanded discussion on
regulatory certification which has now officially ended

I concur with Dan regarding IPR and SLAPP. Our goal was to come up with 
a proposal that re-used existing protocols as much as possible resulting

in a simple, yet complete proposal.
Thanks
partha

Dan Harkins wrote:

>  Troy,
>
>  There is no IPR claim on SLAPP to remove. 
>
>  Dan.
>
>On Sat, 03 Sep 2005 08:28:56 CDT you wrote
>  
>
>>Guys,
>>
>>I've been watching the argument on this thread and feel that it's time
to
>>make a statement as a working group member.  There are two very
separate
>>arguments going on here.  One is related to IPR claims and the other
around
>>image download and FCC violations.  I am not making this comment
around the
>>image download portion but believe it's essential to discuss the IPR
issue.
>>
>>I've seen the IPR game getting out of hand within the IETF for way too
long.
>>There are way too many drafts that are coming into the IETF standards
>>process claiming IPR.  
>>
>>The purpose for the CAPWAP working group is to create an OPEN standard
that
>>all vendors can implement and show interoperability.  Regardless of
the
>>image download argument, before I'll stand up and back the LWAPP or
SLAPP
>>contribution, I want Cisco as well as Trapeze to remove any notion of
owing
>>IPR where they can go after other vendors that implement an IETF
standard.
>>That simply does not wash.  
>>
>>If the IPR comment stands then we as a working group must engineer
around
>>any/all requirements and come up with a standard that does not allow
one
>>vendor to have that type of power.  
>>
>>I do not buy into any comments such as "we would never do it" or "we
want to
>>contribute to this moving forward" etc. If that is the case, drop the
IPR
>>claim and then we can go back to considering what protocol would best
>>represent the basis for CAPWAP.
>>
>>The notion of trying to move on from this topic and even consider
using a
>>protocol that has this type of IPR claim is ridiculous (IMHO).  I want
an
>>IPR free protocol standard out of this group.
>>
>>So there are two questions.  Will both the main authors of each of the
specs
>>remove any/all IPR claims for consideration of being in the spec? It's
a
>>simple question of yes or no. Please do not present a long reply
without
>>answering it as a binary decision.
>>
>>-Troy
>>
>>
>>    
>>
>>>-----Original Message-----
>>>From: [email-masked] [mailto:[email-masked]] On
>>>Behalf Of Dan Harkins
>>>Sent: Saturday, September 03, 2005 12:53 AM
>>>To: Bob O'Hara (boohara)
>>>Cc: [email-masked]
>>>Subject: Re: [Capwap] Expanded discussion on regulatory certification
>>>
>>>  Bob,
>>>
>>>On Fri, 02 Sep 2005 13:15:10 PDT you wrote
>>>[snip]
>>>      
>>>
>>>>Both the SLAPP and LWAPP protocol proposals include the ability to
>>>>        
>>>>
>>>download c
>>>      
>>>
>>>>ode to an AP/WTP.  The difference between the two is that CAPWAP
requires
>>>>        
>>>>
>>>an a
>>>      
>>>
>>>>uthentication signature must be validated before a download can be
used,
>>>>        
>>>>
>>>while
>>>      
>>>
>>>>SLAPP has no such mechanism and specifically allows download of code
>>>>        
>>>>
>>>from sou
>>>      
>>>
>>>>rces other than the manufacturer or an authorized delegate of the
>>>>        
>>>>
>>>manufacturer
>>>      
>>>
>>>>.  This is a significant difference between the two protocols and
needs
>>>>        
>>>>
>>>to be
>>>      
>>>
>>>>considered when evaluating the protocols during this phase of
selecting
>>>>        
>>>>
>>>the ba
>>>      
>>>
>>>>sis for CAPWAP standardization.
>>>>        
>>>>
>>>"Both the SLAPP and LWAPP protocol proposals.... The difference
between
>>>the
>>>two is that CAPWAP requires an authentication signature must be
validated
>>>before a download can be used, while SLAPP has no such mechanism...."
>>>
>>>LWAPP = CAPWAP? I think you're getting a little excited here Bob.
Either
>>>that or you know something that has not been made public yet.
>>>
>>>What you don't know is how SLAPP works. Please go read the spec.
There is
>>>an authentication step PRIOR to the AC and WTP deciding whether to
proceed
>>>to the full-fledged control and provisioning protocol or to do image
>>>download.
>>>
>>>      
>>>
>>>>Going back to one of my first statements on this topic and to bring
this
>>>>        
>>>>
>>>arou
>>>      
>>>
>>>>nd again to why this discussion is important to the working group
while
>>>>        
>>>>
>>>evalua
>>>      
>>>
>>>>ting protocols, independent implementations of LWAPP can be built
from
>>>>        
>>>>
>>>the pro
>>>      
>>>
>>>>tocol specification, alone.  That same statement cannot be made
about
>>>>        
>>>>
>>>SLAPP.
>>>
>>>Wrong! SLAPP includes a complete provisioning and control protocol.
>>>
>>>  Dan.
>>>
>>>_______________________________________________
>>>Capwap mailing list
>>>[email-masked]
>>>http://mail.frascone.com/mailman/listinfo/capwap
>>>      
>>>
>>_______________________________________________
>>Capwap mailing list
>>[email-masked]
>>http://mail.frascone.com/mailman/listinfo/capwap
>>    
>>
>_______________________________________________
>Capwap mailing list
>[email-masked]
>http://mail.frascone.com/mailman/listinfo/capwap
>  
>
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

Republic Polytechnic, Tanglin Campus, 1 Kay Siang Road, Singapore 248922  Website: www.rp.sg . Fax: +65 6415-1310 .

From April 2006, we will be located in our new home at 9 Woodlands Avenue 9,Singapore 738964 
Republic Polytechnic, the first Institute of Higher Learning to fully adopt the Problem-Based Learning approach in Singapore, continues to strive towards best practices and maintain excellence in service standards with the following certifications: Singapore Quality Class (SQC) certification, People Developer Standards and QEHS standards (ISO 9001, 14001 and OHSAS 18001 certifications).
---------------------------------------------------------------------
CONFIDENTIALITY CAUTION: This message is intended only for the use of the individual or entity to whom it is addressed and contains information that is privileged and confidential. If you, the reader of this message, are not the intended recipient, you should not disseminate, distribute or copy this communication. If you have received this communication in error, please notify us immediately by return email and delete the original message. Thank you.

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 5 Sep 2005 22:35:54 -0600

Richard,

At the outset of evaluation - we have not  ruled out (for evaluation) to
recommend and WG to agree on best collective aspects of the protocols -
should they make sense.

So it is within scope for such a protocol to emerge; the objective being
to arrive at one consensus version to be refined further as needed to
fit any new discoveries of requirements.

-mani
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Richard Gwee
Sent: Monday, September 05, 2005 1:13 AM
To: Partha Narasimhan; Dan Harkins
Cc: [email-masked]; [email-masked]
Subject: [Capwap] Simple and complete proposal for CAPWAP

Hi,

Thanks and Regards
Richard Gwee

-----Original Message-----

to
separate
around
around the
issue.
long.
that
the
SLAPP
owing
standard.
around
one
want to
IPR
using a
an
specs
a
without
requires
used,
needs
selecting
between
validated
Either
There is
proceed
this
while
from
about

Republic Polytechnic, Tanglin Campus, 1 Kay Siang Road, Singapore 248922
Website: www.rp.sg . Fax: +65 6415-1310 .

From April 2006, we will be located in our new home at 9 Woodlands
Avenue 9,Singapore 738964 
Republic Polytechnic, the first Institute of Higher Learning to fully
adopt the Problem-Based Learning approach in Singapore, continues to
strive towards best practices and maintain excellence in service
standards with the following certifications: Singapore Quality Class
(SQC) certification, People Developer Standards and QEHS standards (ISO
9001, 14001 and OHSAS 18001 certifications).
---------------------------------------------------------------------
CONFIDENTIALITY CAUTION: This message is intended only for the use of
the individual or entity to whom it is addressed and contains
information that is privileged and confidential. If you, the reader of
this message, are not the intended recipient, you should not
disseminate, distribute or copy this communication. If you have received
this communication in error, please notify us immediately by return
email and delete the original message. Thank you.