Subject: [Capwap] A note on IPR issues

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Tue, 20 Sep 2005 16:11:04 -0600

The AD has pointed out the need to and usefulness of disclosing all IPR
that there may be or known to be existing out there.

In addition - the chairs would urge the disclosures to be as detailed as
can be in order to facilitate the WG to decide its course of action
among the

many options this may lead to in terms of adoption of a protocol that
the WG can come to a consensus on - an acceptable base protocol and work
further

to get to an interoperable CAPWAP protocol.

An example of a clear (detailed) one is the ID#144 that points to
related enough information for WG to review and form an opinion.

So - whether it is being expansive in scope - it will be indeed useful
to the WG which has appeared to approach getting to a CAPWAP protocol
based on

work done so far in the WG & evaluation exercise and WG's review of it.

-mani

---

From: "Paul Lambert" <[email-masked]>
Date: Wed, 21 Sep 2005 11:33:33 -0700

>   - does the WG want to try to change course and define a 
> CAPWAP protocol
>     from scratch, trying to avoid any IPR claims

There might be some interesting 'non-scratch' approaches that reuse
existing IETF protocols.

Paul

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun [[email-masked]]" <[email-masked]>
Date: Wed, 21 Sep 2005 11:54:15 -0700

Oh, I realize your question was generic. I was just trying to get your
take on the LWAPP comparison.

Thanks for your view,

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James Kempf
> Sent: Wednesday, September 21, 2005 11:51 AM
> To: Pat Calhoun [[email-masked]]; Wijnen, Bert (Bert); 
> [email-masked]
> Subject: Re: [Capwap] A note on IPR issues
> 
> Pat,
> 
> If you read my note, I did not say that the LWAPP disclosure 
> did not match RFC 1822. I just said that any IPR the WG 
> accepted should be released in that manner.
> 
> But if you want my opinion about LWAPP...
> 
> <amateur lawyer hat on>
> Looking at RFC 1822 and the Cisco disclosure for LWAPP,  they 
> look substantially the same.
> <amateur lawyer hat off>
> 
> However, since I'm not a lawyer, take this for what it is 
> worth.There might be some subtle points to the difference in 
> wording that I'm missing which make a big difference.
> 
>             jak
> 
> 
> ----- Original Message -----
> From: "Pat Calhoun [[email-masked]]" <[email-masked]>
> To: "James Kempf" <[email-masked]>; "Wijnen, Bert (Bert)" 
> <[email-masked]>; <[email-masked]>
> Sent: Wednesday, September 21, 2005 11:26 AM
> Subject: RE: [Capwap] A note on IPR issues
> 
> 
> > >  - does the WG want to continue work on a CAPWAP protocol
> > that probably
> > >    will have IPR claims against it>
> >
> > Yes, provided the release to IETF follows RFC 1822 (royalty free)
> 
> James,
> 
> Out of curiosity, could you help me understand what you believe the
> differences are between the LWAPP IPR disclosure and RFC 1822?
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
>

---

From: "Pat Calhoun [[email-masked]]" <[email-masked]>
Date: Wed, 21 Sep 2005 14:24:28 -0700

> I also support James' recommendation of following RFC1822.  I 
> think the main difference is there aren't any exceptions to 
> the unlimited, royalty free grant of rights in RFC 1822, 
> compared to LWAPP IPR disclosure.  In addition, the LWAPP 
> disclosure appears to require the implementor obtain a 
> license from Cisco in order to receive royalty free 
> treatment. RFC1822 does not have this restriction.
Darren,

I understand your concern, but realistically Cisco does not
go after people or companies just because they do not go through
the formalities of getting a license.

Pat Calhoun

---

From: "Darren Loher" <[email-masked]>
Date: Thu, 22 Sep 2005 10:53:27 -0700

Thanks for pointing that out Dan.  That is also desirable.  Perhaps 
if this represents Cisco's intent, they would be willing to 
limit the scope of the IPR claim to:
1. claims and rights limitation scope to LWAPP 
2. specifically state an unlimited, "no license required" stance 
both of these being similar to the precedent set in RFC1822.  

Pat, what do you think?  These constraints seem compatible with
the intent you've been describing. Would you feel comfortable taking
these two constraints to Cisco?

Also, I know there have been several appeals already, but can you
also find out for us if Cisco will allow you to release to specific
claims that the disclosures are referring to?  I think this would
help the working group feel more comfortable dealing with this.

-Darren

-----Original Message-----
From: Dan Harkins [mailto:[email-masked]]
Sent: Wed 9/21/2005 3:26 PM
To: Darren Loher
Cc: Pat Calhoun [[email-masked]]; James Kempf; Wijnen,    Bert (Bert); [email-masked]
Subject: Re: [Capwap] A note on IPR issues 
 
  Derren,

  Another significant difference is that RFC1822 has a specific field
of use that applies when the grant of rights terminate ("Photuris or any
derivative"), while the LWAPP IPR disclosure has no field of use that
applies when the grant of rights terminate.

  Dan.

On Wed, 21 Sep 2005 13:01:50 PDT you wrote
> I also support James' recommendation of following RFC1822.  I think the
> main difference is there aren't any exceptions to the unlimited, royalty
> free grant of rights in RFC 1822, compared to LWAPP IPR disclosure.  In
> addition, the LWAPP disclosure appears to require the implementor obtain
> a license from Cisco in order to receive royalty free treatment. RFC1822
> does not have this restriction.

---

From: "Pat Calhoun [[email-masked]]" <[email-masked]>
Date: Thu, 22 Sep 2005 13:45:48 -0700

Folks, I'm working this in real time, but it is a complex issue and my
hectic travel schedule makes it slightly harder. That said, I will
provide a statement soon.

Pat Calhoun

> From: Darren Loher [mailto:[email-masked]] 
> Sent: Thursday, September 22, 2005 10:53 AM
> To: Dan Harkins
> Thanks for pointing that out Dan.  That is also desirable.  
> Perhaps if this represents Cisco's intent, they would be 
> willing to limit the scope of the IPR claim to:
> 1. claims and rights limitation scope to LWAPP 2. 
> specifically state an unlimited, "no license required" stance 
> Pat, what do you think?  These constraints seem compatible 
> with the intent you've been describing. Would you feel 
> comfortable taking these two constraints to Cisco?
> 
> Also, I know there have been several appeals already, but can 
> you also find out for us if Cisco will allow you to release 
> to specific claims that the disclosures are referring to?  I 
> think this would help the working group feel more comfortable 
> dealing with this.
> 
> -Darren
> 
> 
>   Another significant difference is that RFC1822 has a 
> specific field of use that applies when the grant of rights 
> terminate ("Photuris or any derivative"), while the LWAPP IPR 
> disclosure has no field of use that applies when the grant of 
> rights terminate.
> 
>   Dan.
> 
> > I also support James' recommendation of following RFC1822.  I think 
> > the main difference is there aren't any exceptions to the 
> unlimited, 
> > royalty free grant of rights in RFC 1822, compared to LWAPP IPR 
> > disclosure.  In addition, the LWAPP disclosure appears to 
> require the 
> > implementor obtain a license from Cisco in order to receive royalty 
> > free treatment. RFC1822 does not have this restriction.
>