Subject: [Capwap] RE: IPR issues

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 13 Sep 2005 20:44:02 +0200

Well, you guys were debating potential IPR concerns, and
so I figured I had to be clear that in accordance with the
IETF IPR rules and the NOTE WELL statements, anyone who
know about a patent needs to report on it if they participate.

Best of course is if there are no IPR claims at all, but
if they do exist, then we (as a WG) better know about
them early. 

Bert

> -----Original Message-----
> From: Dan Harkins [mailto:[email-masked]]
> Sent: Tuesday, September 13, 2005 18:24
> To: Wijnen, Bert (Bert)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: IPR issues 
> 
> 
>   Bert,
> 
>   You overturned a rock and some nastly things crawled out. I 
> refer to:
> 
> 	
> http://www.ietf.org/ietf/IPR/cisco-ipr-draft-singh-capwap-ctp.txt
> 
> So now Cisco is claiming IPR ON ALL SUBMISSIONS TO THIS 
> WORKING GROUP!!!
> 
>   How pathetic. And how utterly baseless.
> 
>   Dan.
> 
> On Sat, 03 Sep 2005 23:06:28 +0200 you wrote
> > All,
> > 
> > I changed the subject line. 
> > This is not about FCC certification but about IPR.
> > 
> > The question to be asked is:
> > 
> >    does anyone know if there is any IPR anywhere. 
> > 
> > According to the NOTE WELL, if anyone who contributes to
> > or participates in this WG, then they MUST disclose if they know
> > about any IPR of the technology being discussed in the WG.  
> > Even if it is IPR that they know someone else is holding.
> > 
> > And so that includes all submitted technologies.
> > Pls also read RFC 3978 and RFC 3979
> > 
> > Bert
> > 
> > > -----Original Message-----
> > > From: [email-masked] 
> [mailto:[email-masked]]On
> > > Behalf Of Dan Harkins
> > > Sent: Saturday, September 03, 2005 13:47
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Subject: [Capwap] this is not the thread on expanded discussion on
> > > regulatory certification which has now officially ended
> > > 
> > > 
> > >   Troy,
> > > 
> > >   There is no IPR claim on SLAPP to remove. 
> > > 
> > >   Dan.
> > > 
> > > On Sat, 03 Sep 2005 08:28:56 CDT you wrote
> > > > Guys,
> > > > 
> > > > I've been watching the argument on this thread and feel 
> > > that it's time to
> > > > make a statement as a working group member.  There are two 
> > > very separate
> > > > arguments going on here.  One is related to IPR claims and 
> > > the other around
> > > > image download and FCC violations.  I am not making this 
> > > comment around the
> > > > image download portion but believe it's essential to 
> > > discuss the IPR issue.
> > > > 
> > > > I've seen the IPR game getting out of hand within the IETF 
> > > for way too long.
> > > > There are way too many drafts that are coming into the IETF 
> > > standards
> > > > process claiming IPR.  
> > > > 
> > > > The purpose for the CAPWAP working group is to create an 
> > > OPEN standard that
> > > > all vendors can implement and show interoperability.  
> > > Regardless of the
> > > > image download argument, before I'll stand up and back the 
> > > LWAPP or SLAPP
> > > > contribution, I want Cisco as well as Trapeze to remove any 
> > > notion of owing
> > > > IPR where they can go after other vendors that implement an 
> > > IETF standard.
> > > > That simply does not wash.  
> > > > 
> > > > If the IPR comment stands then we as a working group must 
> > > engineer around
> > > > any/all requirements and come up with a standard that does 
> > > not allow one
> > > > vendor to have that type of power.  
> > > > 
> > > > I do not buy into any comments such as "we would never do 
> > > it" or "we want to
> > > > contribute to this moving forward" etc. If that is the 
> > > case, drop the IPR
> > > > claim and then we can go back to considering what protocol 
> > > would best
> > > > represent the basis for CAPWAP.
> > > > 
> > > > The notion of trying to move on from this topic and even 
> > > consider using a
> > > > protocol that has this type of IPR claim is ridiculous 
> > > (IMHO).  I want an
> > > > IPR free protocol standard out of this group.
> > > > 
> > > > So there are two questions.  Will both the main authors of 
> > > each of the specs
> > > > remove any/all IPR claims for consideration of being in the 
> > > spec? It's a
> > > > simple question of yes or no. Please do not present a long 
> > > reply without
> > > > answering it as a binary decision.
> > > > 
> > > > -Troy
> > > > 
> > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked] 
> > > [mailto:[email-masked]] On
> > > > > Behalf Of Dan Harkins
> > > > > Sent: Saturday, September 03, 2005 12:53 AM
> > > > > To: Bob O'Hara (boohara)
> > > > > Cc: [email-masked]
> > > > > Subject: Re: [Capwap] Expanded discussion on regulatory 
> > > certification
> > > > > 
> > > > >   Bob,
> > > > > 
> > > > > On Fri, 02 Sep 2005 13:15:10 PDT you wrote
> > > > > [snip]
> > > > > >
> > > > > > Both the SLAPP and LWAPP protocol proposals include the 
> > > ability to
> > > > > download c
> > > > > >ode to an AP/WTP.  The difference between the two is 
> > > that CAPWAP requires
> > > > > an a
> > > > > >uthentication signature must be validated before a 
> > > download can be used,
> > > > > while
> > > > > > SLAPP has no such mechanism and specifically allows 
> > > download of code
> > > > > from sou
> > > > > >rces other than the manufacturer or an authorized 
> delegate of the
> > > > > manufacturer
> > > > > >.  This is a significant difference between the two 
> > > protocols and needs
> > > > > to be
> > > > > >considered when evaluating the protocols during this 
> > > phase of selecting
> > > > > the ba
> > > > > >sis for CAPWAP standardization.
> > > > > 
> > > > > "Both the SLAPP and LWAPP protocol proposals.... The 
> > > difference between
> > > > > the
> > > > > two is that CAPWAP requires an authentication signature 
> > > must be validated
> > > > > before a download can be used, while SLAPP has no such 
> > > mechanism...."
> > > > > 
> > > > > LWAPP = CAPWAP? I think you're getting a little excited 
> > > here Bob. Either
> > > > > that or you know something that has not been made public yet.
> > > > > 
> > > > > What you don't know is how SLAPP works. Please go read 
> > > the spec. There is
> > > > > an authentication step PRIOR to the AC and WTP deciding 
> > > whether to proceed
> > > > > to the full-fledged control and provisioning protocol or 
> > > to do image
> > > > > download.
> > > > > 
> > > > > > Going back to one of my first statements on this topic 
> > > and to bring this
> > > > > arou
> > > > > >nd again to why this discussion is important to the 
> > > working group while
> > > > > evalua
> > > > > >ting protocols, independent implementations of LWAPP can 
> > > be built from
> > > > > the pro
> > > > > >tocol specification, alone.  That same statement cannot 
> > > be made about
> > > > > SLAPP.
> > > > > 
> > > > > Wrong! SLAPP includes a complete provisioning and control 
> > > protocol.
> > > > > 
> > > > >   Dan.
> > > > > 
> > > > > _______________________________________________
> > > > > Capwap mailing list
> > > > > [email-masked]
> > > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > 
> > > > _______________________________________________
> > > > Capwap mailing list
> > > > [email-masked]
> > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > _______________________________________________
> > > Capwap mailing list
> > > [email-masked]
> > > http://mail.frascone.com/mailman/listinfo/capwap
> > > 
> 
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Troy Dixler" <[email-masked]>
Date: Wed, 14 Sep 2005 06:16:52 -0500

Guys,

I think that we have a major problem with this type of tactic. Clearly the
working group has to move forward with submissions that are free from Cisco
IPR claims.  This type of hijacking of the working group simply cannot be
permitted to take place. The IETF is an open standards working group. Talk
about capitalism taken off the deep end.

-Troy

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Tuesday, September 13, 2005 1:44 PM
> To: Dan Harkins
> Subject: RE: IPR issues