Subject: [Capwap] How to handle sequence numbers with LWAPP

From: "Peter Nilsson J (LI/EAB)" <[email-masked]>
Date: Fri, 16 Sep 2005 08:00:26 +0200

Hi,

When the AC perform a 802.11i Group Key Handshake it is supposed to provide the Key RSC (last transmit sequence number) to the supplicant in message 1.
But since the sequence counter is maintained in the MAC in the WTP I wonder how this is supposed to work?

Regards
Peter Nilsson
Ericsson
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Saravanan Govindan" <[email-masked]>
Date: Fri, 16 Sep 2005 14:09:27 +0800

Peter,

I think this is a good case you point out. It is covered by the IEEE
802.11i Considerations objective. 

I am not sure of LWAPP but in WiCoP, a Key Config message is used to
transport the group key handshake message from AC to the WTP. The KeyRSC
fields are left unassigned by the AC. Then after receiving the Key
Config message, the WTP assings the Key RSC field with the prevailing
counter value. The handshake message is then sent to the terminal. 

Cheers,

Saravanan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Peter Nilsson 
> J (LI/EAB)
> Sent: Friday, September 16, 2005 2:00 PM
> To: [email-masked]
> Subject: [Capwap] How to handle sequence numbers with LWAPP
> 
> Hi,
> 
> When the AC perform a 802.11i Group Key Handshake it is 
> supposed to provide the Key RSC (last transmit sequence 
> number) to the supplicant in message 1.
> But since the sequence counter is maintained in the MAC in 
> the WTP I wonder how this is supposed to work?
> 
> Regards
> Peter Nilsson
> Ericsson