Subject: RE: [Capwap] In-band/out-of-band firmware download

From: "Sood, Kapil" <[email-masked]>
Date: Wed, 7 Sep 2005 14:28:24 -0700

The difference may lie in the "purpose" and properties of the existing
SA, and the implicit/explicit Access Control that goes with that
protected channel.

Best Regards,
 
Kapil.
503.264.3759

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of
> Pat Calhoun (pacalhou)
> Sent: Wednesday, September 07, 2005 8:58 AM
> To: Michael Montemurro; [email-masked]
> Subject: RE: [Capwap] In-band/out-of-band firmware download
> 
> Not clear to me why you state that out of band is more robust.
> 
> I think that being able to piggy back from the existing security
> association, and encryption channel, between the WTP and the AC has
lots
> of value.
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of Michael Montemurro
> > Sent: Tuesday, September 06, 2005 6:46 AM
> > To: [email-masked]
> > Subject: [Capwap] In-band/out-of-band firmware download
> >
> > One implicit technical issue that I believe has come out of
> > the regulatory discussion is regading firmware download.
> > There seems to be two different mechanisms that are proposed
> > for firmware download to the WTP: one uses the control
> > channel between the AC and the WTP (I call that an in-band
> > mechanism) and the other uses a separate protocol,
> > independent of the control channel.
> >
> > An in-band mechanism provides a simpler mechanism for
> > monitoring the progress of the firmware download and
> > simplified state management. An out-of-band mechanism relies
> > on other protocols (sftp, ftp, tftp), which would likely
> > provide a more robust mechanism for download, but perhaps a
> > slightly more compicated state machine.
> >
> > What is the feeling of the group on how firmware download should
work?
> >
> > Cheers,
> >
> > 	Mike
> > _______________________________________________
> > Capwap mailing list
> > [email-masked]
> > http://mail.frascone.com/mailman/listinfo/capwap
> >
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: sujay <[email-masked]>
Date: Mon, 12 Sep 2005 15:34:59 +0530

Group,
Coming back to this thread.
Given the issues between in-band and out-band, will the capwap
working group have a say or should it be left implementation specific???

Regards,
Sujay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sood, Kapil
Sent: Thursday, September 08, 2005 2:58 AM
To: Pat Calhoun (pacalhou); Michael Montemurro; [email-masked]
Subject: RE: [Capwap] In-band/out-of-band firmware download

Best Regards,
 
Kapil.
503.264.3759

Behalf Of
lots
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of Michael Montemurro
> > One implicit technical issue that I believe has come out of the 
> > regulatory discussion is regading firmware download. There seems to 
> > be two different mechanisms that are proposed for firmware download 
> > to the WTP: one uses the control channel between the AC and the WTP 
> > (I call that an in-band
> > mechanism) and the other uses a separate protocol, independent of 
> > the control channel.
> >
> > An in-band mechanism provides a simpler mechanism for monitoring the

> > progress of the firmware download and simplified state management. 
> > An out-of-band mechanism relies on other protocols (sftp, ftp, 
> > tftp), which would likely provide a more robust mechanism for 
> > download, but perhaps a slightly more compicated state machine.
> >
work?
> > [email-masked] http://mail.frascone.com/mailman/listinfo/capwap
> >
> [email-masked] http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked] http://mail.frascone.com/mailman/listinfo/capwap