Subject: RE: [Capwap] CAPWAP evaluation draft complete

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 26 Sep 2005 10:17:47 -0600

Charles,

Evaluation team acts on behalf of (and essentially represents a
task-force of) the WG. This is a team picked out of the
call-for-volunteers and agreed to by the WG.

In spirit of above - it is more than a recommendation: expected to
represent the collective assessment of the WG.

The evaluation team has termed their conclusions as recommendations.

The WG has to ratify the recommendations - given the consensus-based
approach of IETF - confirming the WG is in sync with the conclusions
drawn by the evaluation team that did the focused work. 

-mani
======
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of T. Charles Clancy
Sent: Monday, September 26, 2005 7:14 AM
To: [email-masked]
Subject: RE: [Capwap] CAPWAP evaluation draft complete

On Mon, 26 Sep 2005, Wijnen, Bert (Bert) wrote:

> The evaluation team made a "decision" if you like for itself, but they

> reported that decision as a RECOMMENDATION to the WG.

Well if we don't take it as more than a RECOMMENDATION, I wonder what
the 
point of an evaluation team was.

> So James has stated that he supports the recommendation of the team.
You 
> seem to not support that. So what do the other WG members think and 
> opine?

I support the recommendation.  I agree with the idea of trying to reuse 
more standarized protocols within LWAPP, for example some sort of 
TLS-based authentication.

[ t. charles clancy ]--[ [email-masked] ]--[ www.cs.umd.edu/~clancy ]
[ computer science ]-----[ university of maryland | college park ]
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Mani, Mahalingam (Mahalingam)" <[email-masked]>
Date: Mon, 26 Sep 2005 11:33:57 -0600

A further clarification note:

I had a question whether the 'ratification' leaves no choice for the WG.

Let me correct the interpretation: it is upto WG to ratify, i.e., accept

the recommendations.

The WG consensus may be to choose not to ratify.

Regards,

-mani

> > The evaluation team made a "decision" if you like for itself, but 

> > they

> the point of an evaluation team was.

> I support the recommendation.  I agree with the idea of trying to 

> reuse more standarized protocols within LWAPP, for example some sort 

> of TLS-based authentication.

> [ t. charles clancy ]--[ [email-masked] ]--[ www.cs.umd.edu/~clancy ] [ 

> computer science ]-----[ university of maryland | college park ] 

 

Regards,

-mani

======

---

From: "Saravanan Govindan" <[email-masked]>
Date: Tue, 27 Sep 2005 18:02:57 +0800

Troy,

I like your suggestion of highlighting protocol attributes. I think
doing so would help in developing a solid CAPWAP protocol. 

The CAPWAP Comparative Analysis document seems to be in line with this.
It highlights specific mechanisms in the candidate protocols that best
address the requirements. 

The WG can consider incorporating some of the specifics of the
Comparative Analysis in the Evaluation draft. 

Saravanan

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Troy Dixler
> Sent: Tuesday, September 27, 2005 8:30 AM
> To: [email-masked]
> I guess I'm not following the logic behind the 
> recommendation.  It seems to me that rather than the group 
> focusing in on what draft, they should be focusing in on what 
> attributes they want in the CAPWAP protocol.  There are 
> clearly pieces of both base protocols that bring value to the 
> working group.
> In the end the best pieces will become the basis we work from 
> to become a standard.
> 
> To pick a "side" when clearly there were attributes that were 
> not within LWAPP just stirs up politics.
> 
> Why not revise the draft to state the clear attributes and 
> recommendations that the protocol should contain and not 
> start with either base draft but start it fresh and call it 
> by its rightful name CAPWAP.
> 
> -Troy
> 
> 
> > Behalf Of Wijnen, Bert (Bert)
> > Sent: Monday, September 26, 2005 4:01 PM
> > To: T. Charles Clancy; [email-masked]
> > Inline
> > > From: [email-masked] 
> [mailto:[email-masked]]On
> > > Sent: Monday, September 26, 2005 16:14
> > > To: [email-masked]
> > > Well if we don't take it as more than a RECOMMENDATION, I wonder 
> > > what the point of an evaluation team was.
> > >
> > 
> > I believe the value was en is that we had a dedicated team 
> of people 
> > who have meticoulously studied the objectives and the 
> submission and 
> > who have after that documented their findings precisely and at then 
> > end even gave a recommendation.
> > 
> > That is a very useful piece of input for the WG based on which they 
> > can try to come to a decision as what to do. This in 
> addition to any 
> > other input (like your own evaluation etc).
> > 
> > Bert

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 27 Sep 2005 06:34:48 -0700

> by its rightful name CAPWAP.

I don't think the name is germane. There is no hard and fast rule that a
WG's name must match the protocol (or the other way around). For
instance, AAA is working on Diameter. There are plenty of other examples
in the IETF.

That said, I believe that the motivation for starting with a base draft
is to get to the finish line quicker than starting from a blank piece of
paper.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Richard Gwee" <[email-masked]>
Date: Wed, 28 Sep 2005 09:46:30 +0800

Hi,

I also agree with this suggestion. I believe too that having clear
protocol attributes will help in developing the CAPWAP protocol. I will
be willing to work with the evaluation team in this area.

Regards
Richard Gwee

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Saravanan Govindan
Sent: Tuesday, September 27, 2005 6:03 PM
To: [email-masked]; [email-masked]
Subject: RE: [Capwap] CAPWAP evaluation draft complete

Troy,

Saravanan

> [mailto:[email-masked]] On 

Republic Polytechnic, Tanglin Campus, 1 Kay Siang Road, Singapore 248922 . Website: www.rp.sg . Fax: +65 6415-1310 .

From April 2006, we will be located in our new home at 9 Woodlands Avenue 9,Singapore 738964 
Republic Polytechnic, the first Institute of Higher Learning to fully adopt the Problem-Based Learning approach in Singapore, continues to strive towards best practices and maintain excellence in service standards with the following certifications: Singapore Quality Class (SQC) certification, People Developer Standards and QEHS standards (ISO 9001, 14001 and OHSAS 18001 certifications).
---------------------------------------------------------------------
CONFIDENTIALITY CAUTION: This message is intended only for the use of the individual or entity to whom it is addressed and contains information that is privileged and confidential. If you, the reader of this message, are not the intended recipient, you should not disseminate, distribute or copy this communication. If you have received this communication in error, please notify us immediately by return email and delete the original message. Thank you.

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 28 Sep 2005 14:32:14 -0700

> I understand your theory that starting with one of the drafts 
> would have you believe it would speed up the process, but I 
> do not agree or see how you can arrive at a conclusion that 
> it would take "another year".  

Of course the WG is free to take the direction it believes is right for
the Internet Community, but my experience at IETF (13 years now) has
proven to me that it is unrealistic to create a protocol from scratch in
less than a year. In fact, RFC 3012 actually took well over a year from
inception to RFC, and it is about as simple as an RFC can get - let
alone a whole protocol. I won't even get into how long Diameter took,
and it started from a base protocol (and, yes, we had plenty of interim
meetings) ...

Many additional examples available upon request... :)

I think it is equally important to note that there is additional value
in starting with a base draft, and ideally one that has been implemented
and demonstrated that it works and solves the requirements. From my
experience, up until a protocol has seen real world deployment, there
are many gotchas that can go unnoticed during the specification phase. 

Pat Calhoun

> Sent: Tuesday, September 27, 2005 7:39 PM
> To: 'Darren Loher'; [email-masked]
> > We did consider an approach of a new proposal with the best 
> features 
> > of all the good and interesting capabilities presented.  
> However, as a 
> > team we agreed this would be akin to "starting over" and 
> would likely 
> > extend the standards process by another year, if not 
> longer.  I am not 
> > in favor of this, but it is up to working group consensus 
> to decide if 
> > a delay like that is desirable.
> 
> 
> With the impending IPR claims as well as the fact that both 
> protocols exhibit attributes that would benefit the working 
> group I think we can turn it around rather quickly.  The two 
> drafts are simply not that complex.
> 
> I believe there have been a few voices that have responded to 
> this thread stating that they would like to revisit the draft 
> and define the attributes rather than one or the other for a 
> base draft.  I would equally be willing to work on the 
> revised recommendation draft to define the core set of 
> attributes that make up the CAPWAP standard.  I believe 
> others on the list would equally be willing to assist.
> 
> -Troy
> 
>