Subject: [Capwap] CAPWAP Objectives - Logical Groups

From: "Saravanan Govindan" <[email-masked]>
Date: Tue, 27 Sep 2005 15:16:42 +0800

All,

Regarding the Objectives document, it was last suggested that the
Protocol Requirement for the Logical Groups objective (Section 5.1.1) be
updated to reflect needs for local-MAC architectures. 

The current requirement is;

"The CAPWAP protocol MUST be capable of controlling and managing
physical WTPs in terms of logical groups including BSSID-based groups."

Then it was suggested by Pat to extend with;

"The CAPWAP protocol MUST be capable of controlling and managing
physical WTPs in terms of logical groups including BSSID-based groups.

For non-tunneled mode, the protocols MUST also provide the provisions 
to configure the associated VLAN (or subnet) which is to be used by 
the WTP in bridging traffic for the logical group."

Since the Objectives draft does not define "non-tunneled mode", I'm
thinking of rewording for a more clear requirement. Consider the
following;

"The CAPWAP protocol MUST be capable of controlling and managing
physical WTPs in terms of logical groups including BSSID-based groups.

For all operating modes, including those in which the WTP performs local
bridging and those in which the AC performs centralized bridging, the
protocol MUST provide provisions for configuring logical groups across
the AC-WTP interface."          

I look forward to any further suggestions on this. 

Saravanan            
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 27 Sep 2005 06:36:16 -0700

You say:

> For all operating modes, including those in which the WTP performs
local bridging and 
> those in which the AC performs centralized bridging, the protocol MUST
provide provisions 
> for configuring logical groups across
> the AC-WTP interface.

But what does the AC-WTP interface mean when data is locally bridged? 

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Saravanan Govindan
> Sent: Tuesday, September 27, 2005 12:17 AM
> To: [email-masked]
> Subject: [Capwap] CAPWAP Objectives - Logical Groups
> 
> All,
> 
> Regarding the Objectives document, it was last suggested that 
> the Protocol Requirement for the Logical Groups objective 
> (Section 5.1.1) be updated to reflect needs for local-MAC 
> architectures. 
> 
> "The CAPWAP protocol MUST be capable of controlling and 
> managing physical WTPs in terms of logical groups including 
> BSSID-based groups."
> 
> 
> 
> "The CAPWAP protocol MUST be capable of controlling and 
> managing physical WTPs in terms of logical groups including 
> BSSID-based groups.
> 
> For non-tunneled mode, the protocols MUST also provide the 
> provisions to configure the associated VLAN (or subnet) which 
> is to be used by the WTP in bridging traffic for the logical group."
> 
> 
> 
> Since the Objectives draft does not define "non-tunneled 
> mode", I'm thinking of rewording for a more clear 
> requirement. Consider the following;
> 
> "The CAPWAP protocol MUST be capable of controlling and 
> managing physical WTPs in terms of logical groups including 
> BSSID-based groups.
> 
> For all operating modes, including those in which the WTP 
> performs local bridging and those in which the AC performs 
> centralized bridging, the protocol MUST provide provisions 
> for configuring logical groups across
> the AC-WTP interface."          
>

---

From: "Darren Loher" <[email-masked]>
Date: Tue, 27 Sep 2005 16:41:09 -0700

Perhaps this wording would work:

"For all operating modes, including those in which the WTP
performs local bridging and those in which the AC performs
centralized bridging, the protocol MUST provide provisions
for configuring logical groups at the WTP."

This avoids using "tunneled mode" and "non-tunneled mode" 
which are not currently defined in the objectives.

-Darren

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Pat Calhoun (pacalhou)
> Sent: Tuesday, September 27, 2005 7:36 AM
> To: Saravanan Govindan; [email-masked]
> Subject: RE: [Capwap] CAPWAP Objectives - Logical Groups
> 
> You say:
>

---

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 28 Sep 2005 09:08:32 +0800

Darren,

I think your suggestion rightly reflects the objective's intent. 

If this is fine with the rest of the WG, we can move forward on the
Objectives.

Saravanan

> From: Darren Loher [mailto:[email-masked]] 
> Sent: Wednesday, September 28, 2005 7:41 AM
> To: Pat Calhoun (pacalhou); Saravanan Govindan; [email-masked]
> [mailto:[email-masked]] On 
> > > for configuring logical groups across the AC-WTP interface.
> > 
> > CTO, Wireless Networking Business Unit Cisco Systems
> > 
> > 
> > 
> > > Protocol Requirement for the Logical Groups objective (Section 
> > > 5.1.1) be updated to reflect needs for local-MAC architectures.
> > >
> > > provisions to configure the associated VLAN (or subnet) 
> which is to 
> > > be used by the WTP in bridging traffic for the logical group."
> > >
> > >
> > >
> mode", I'm 
> performs 
> > > local bridging and those in which the AC performs centralized 
> > > bridging, the protocol MUST provide provisions for configuring 
> > > logical groups across the AC-WTP interface."
> > >

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 28 Sep 2005 14:32:13 -0700

Works for me.

Pat Calhoun

> [mailto:[email-masked]] On Behalf Of Darren Loher
> Sent: Tuesday, September 27, 2005 4:41 PM