Subject: 回复:RE: RE: [Capwap] Re: In-band/out-of-band about the firmware download

From: zhaoyujin 00919 <[email-masked]>
Date: Fri, 16 Sep 2005 09:56:31 +0500

I think if we have known the problem, we maybe give a solution for the problem.
Only for example we can define mechanism which type is equal to 0x00000001 is common download mechanism (In-band download mechanism). If an AP can support the in-band download, the AC may choose the in-band download for the AP.

Best regards
Michael

> But once more this introduces optional download mechanisms, which 
> means interoperability issues.
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
> 
> 
> > -----Original Message-----
> > From: zhaoyujin 00919 [[email-masked]] 
> > Sent: Wednesday, September 14, 2005 2:46 AM
> > To: Pat Calhoun (pacalhou)
> > Cc: [email-masked]
> > Subject: 回复:RE: [Capwap] Re: In-band/out-of-band about the 
> > firmware download
> > 
> > I think capwap wants to define a control management of AP. 
> > And I think the WG has give some firmware download mechinasm 
> > which is enough for the capwap.
> > 
> > But the firmware download is only a small part of the control 
> > management. And at present there are many file transimission 
> > protocol, capwap may think about using those protocol.
> > 
> > If the vendor has not support any file transimission 
> > protocol, it can use the in-band firmware download. Otherwise 
> > the vendor may choose to negotiate which type download mechinasm.
> > 
> > 
> > 
> > > Vendors should always be free to make changes to protocols, 
> > as long as 
> > > the protocol allows for vendor extensions. That said, the 
> > WG needs to 
> > > define a mandatory to implement mode - and if that is the 
> case, I 
> > > wonderwhy a vendor would feel compelled to support multiple 
> > methods. 
> > > If the concern is that the mechanism defined by the WG is 
> > > insufficient, then they should try to address that problem 
> > in the WG.
> > > 
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > > 
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [[email-masked]] On Behalf Of zhaoyujin 00919
> > > > Sent: Monday, September 12, 2005 9:24 PM
> > > > To: [email-masked]
> > > > Cc: [email-masked]
> > > > Subject: [Capwap] Re: In-band/out-of-band about the firmware
> > > download> 
> > > > CAPWAP defines an architecture of WLAN. At present there are 
> may 
> > > > realization protocols--LWAPP,SLAPP,CTP, and so on.
> > > > 
> > > > All those protocols use control tunnel and data tunnel. 
> > In one mail 
> > > > the next information is mentionned:"in-band 
> mechanism(Download 
> > > > firmware with control tunnel)" and "out-of-band 
> > mechanism(Download 
> > > > firmware with other protocol like ftp,tftp)". And the mail 
> give 
> > > > another mention--"perhaps a slightly more compicated 
> > state machine."
> > > > 
> > > > But in fact the out-of-band mechanism is not very 
> compicated. 
> > > > If the capwap uses the out-of-band mechanism, the 
> > function will be 
> > > > clarified.
> > > > 
> > > > Can we add a payload in the version negotiation packet. 
> > This payload 
> > > > can decide the firmware download mechanism. For example the 
> > > > mechanism can use OUI+type. If the OUI is equal to 
> > 0x000000, capwap 
> > > > should think the download mechanism is common. Otherwise the 
> > > > mechanise is private for vendor.
> > > > 
> > > > 
> > > > Best regards
> > > > Michael
> > > > 
> > > > 
> > > > _______________________________________________
> > > > Capwap mailing list
> > > > [email-masked]
> > > > http://mail.frascone.com/mailman/listinfo/capwap
> > > > 
> > > _______________________________________________
> > > Capwap mailing list
> > > [email-masked]
> > > http://mail.frascone.com/mailman/listinfo/capwap
> > > 
> > 
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
> 

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: sujay <[email-masked]>
Date: Fri, 16 Sep 2005 13:21:44 +0530

Even if the negotiation capability is added about the download mechanism,
For multi-vendor AP interoperability, the AC should support both
In-band and Out-band mechanism.
Else opt for a single protocol confirmity and either In-band or Out-band mechanism !

~Sujay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhaoyujin 00919
Sent: Friday, September 16, 2005 10:27 AM
To: Pat Calhoun [[email-masked]]
Cc: [email-masked]
Subject: 回复:RE: RE: [Capwap] Re: In-band/out-of-band about the firmware download

I think if we have known the problem, we maybe give a solution for the problem. Only for example we can define mechanism which type is equal to 0x00000001 is common download mechanism (In-band download mechanism). If an AP can support the in-band download, the AC may choose the in-band download for the AP.

Best regards
Michael

> > > > From: [email-masked] [[email-masked]] On 
> > > > Behalf Of zhaoyujin 00919
> [email-masked] http://mail.frascone.com/mailman/listinfo/capwap
> 

_______________________________________________
Capwap mailing list
[email-masked] http://mail.frascone.com/mailman/listinfo/capwap