Subject: RE: RE: [Capwap] Issue 61: Justification Required

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 7 Apr 2006 08:42:31 -0700

To get closure on this issue, the general sentiment that I've 
seen is that it would be a "nice to have" to allow the WTP to
manage its own MAC Addresses. I heard about "possible implementations"
Bbut no one that said this would be a problem for them.

One example that was provided in the thread where it could be
required is the one where an existing WTP is enabled to support
multiple BSSIDs by loading MAC addresses after it has been 
deployed. In this scenario, we can simply require that a contiguous
range of n MAC addresses be loaded on the WTP (where 'n' is the
number of BSSIDs desired), as opposed to n-1 (in order to keep the
original MAC address).

Thoughts?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: Pat Calhoun (pacalhou) 
> Sent: Friday, March 31, 2006 7:05 AM
> To: zhaoyujin 31390; Saravanan Govindan
> Cc: [email-masked]; [email-masked]
> Subject: RE: RE: [Capwap] Issue 61: Justification Required
> 
> Unfortunately, radios have BSSIDs, not the ACs.
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
>  
> 
> > -----Original Message-----
> > From: zhaoyujin 31390 [mailto:[email-masked]]
> > Sent: Thursday, March 30, 2006 5:07 AM
> > To: Saravanan Govindan
> > Cc: Pat Calhoun (pacalhou);
> > [email-masked]; [email-masked]
> > Subject: RE:RE: [Capwap] Issue 61: Justification Required
> > 
> > Hi all:
> > 
> >   I think current protocol mechanism is ok. 
> > 
> >   The map of WLAN ID and BSSID is very simple, and it is only an 
> > offset from based BSSID.
> > 
> >   The WLAN ID length is shorter than BSSID, and easy to used than 
> > BSSID (It is a MAC address).
> > 
> >   Another if keep BSSID on AC is based on vendor, and it is out of 
> > protocol scope.
> > 
> > Best regard
> > Michael
> > 
> > 
> > 
> > > Yes, Pat.
> > > 
> > > 
> > > 
> > > ----Original Message Follows----
> > > From: "Pat Calhoun (pacalhou)" <[email-masked]>
> > > To: "Saravanan Govindan" 
> > > <[email-masked]>,"capwap" 
> > > <[email-masked]>
> > > Subject: RE: [Capwap] Issue 61: Justification Required
> > > Date: Wed, 29 Mar 2006 10:36:22 -0800
> > > 
> > > So if I understand properly, you'd like the AC to also 
> include the 
> > > BSSID the WTP should use, in addition to the WLAN ID?
> > > 
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems
> > > 
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: Saravanan Govindan [[email-masked]]
> > > > Sent: Tuesday, March 28, 2006 5:21 PM
> > > > To: Pat Calhoun (pacalhou); capwap
> > > > Subject: RE: [Capwap] Issue 61: Justification Required
> > > >
> > > > Pat,
> > > >
> > > > I like the idea of specifying a default mode for WLAN
> > configuration
> > > > because it helps implementers with an exact spec. In a
> > slight change
> > > > from the request below, I would like to see the AC decide
> > the WLAN
> > > > ID and its corresponding BSSID (for the WTP) and notify
> > this mapping
> > > > within the Configuration Response.
> > > >
> > > > Saravanan
> > > >
> > > >
> > > >
> > > >
> > > > -----Original Message-----
> > > > From: Pat Calhoun (pacalhou) [[email-masked]]
> > > > Sent: Wednesday, March 29, 2006 2:06 AM
> > > > To: capwap
> > > > Subject: [Capwap] Issue 61: Justification Required
> > > >
> > > > The original request stated:
> > > > > Page 108, Section 11.8.1.1. I would like to suggest a 
> slightly 
> > > > > different behavior for configuring a WLAN on a WTP.
> > > > > The AC would send a WLAN ID as part of the Configuration
> > > > Request and
> > > > > the WTP would respond with the BSSID that would be used for
> > > > the WLAN
> > > > > as part of the Configuration Response.
> > > > > In that way, the WTP is responsible for maintaining BSSID
> > > > to WLAN ID
> > > > > mappings.
> > > >
> > > > I'd like to better understand the justification for 
> making such a 
> > > > change. Anyone have strong feelings, and reasons, for
> > this feature?
> > > >
> > > >
> > > > Pat Calhoun
> > > > CTO, Wireless Networking Business Unit Cisco Systems 
> > > > 
> _________________________________________________________________
> > > > To unsubscribe or modify your subscription options, 
> please visit:
> > > > http://lists.frascone.com/mailman/listinfo/capwap
> > > >
> > > > Archives: http://lists.frascone.com/pipermail/capwap
> > > >
> > > _________________________________________________________________
> > > To unsubscribe or modify your subscription options, please visit:
> > > http://lists.frascone.com/mailman/listinfo/capwap
> > > 
> > > Archives: http://lists.frascone.com/pipermail/capwap
> > > 
> > > _________________________________________________________________
> > > Get an advanced look at the new version of MSN Messenger. 
> > > http://messenger.msn.com.sg/Beta/Default.aspx
> > > 
> > > _________________________________________________________________
> > > To unsubscribe or modify your subscription options, please visit:
> > > http://lists.frascone.com/mailman/listinfo/capwap
> > > 
> > > Archives: http://lists.frascone.com/pipermail/capwap
> > > 
> > 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Partha Narasimhan" <[email-masked]>
Date: Mon, 10 Apr 2006 07:23:23 -0700

While many existing implementations are probably not affected as it
stands today, I do sense ugliness in the current mechanism that can be
easily addressed with a few lines of text. I have no trouble with using
a shorter WLAN-ID, but would prefer to have the WTP choose the BSSID to
WLAN-ID mapping. This way we do not have to make assumptions on how WTPs
manage their MAC addresses.

I plan to submit text to address this the cleaner way, unless there are
serious objections to my doing so.

Thanks
partha

> From: Pat Calhoun (pacalhou) [mailto:[email-masked]]
> Sent: Friday, April 07, 2006 8:43 AM
> To: Pat Calhoun (pacalhou); zhaoyujin 31390; Saravanan Govindan

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 10 Apr 2006 09:57:35 -0700

No objections on my end, but I'd like a sense for the group on
whether they feel this is needed. My current feeling is that this
level of complexity is not required as the alternative is clearly 
there, and works fine with most manufacturing environments that I 
am aware of.

I guess I'm still looking for the driving application that makes this
necessary...

Pat Calhoun

> From: Partha Narasimhan [mailto:[email-masked]] 
> Sent: Monday, April 10, 2006 7:23 AM
> While many existing implementations are probably not affected 
> as it stands today, I do sense ugliness in the current 
> mechanism that can be easily addressed with a few lines of 
> text. I have no trouble with using a shorter WLAN-ID, but 
> would prefer to have the WTP choose the BSSID to WLAN-ID 
> mapping. This way we do not have to make assumptions on how 
> WTPs manage their MAC addresses.
> 
> I plan to submit text to address this the cleaner way, unless 
> there are serious objections to my doing so.
> 
> Thanks
> partha
> 
> > To get closure on this issue, the general sentiment that 
> I've seen is 
> > that it would be a "nice to have" to allow the WTP to 
> manage its own 
> > MAC Addresses. I heard about "possible implementations"
> > One example that was provided in the thread where it could 
> be required 
> > is the one where an existing WTP is enabled to support 
> multiple BSSIDs 
> > by loading MAC addresses after it has been deployed. In 
> this scenario, 
> > we can simply require that a contiguous range of n MAC addresses be 
> > loaded on the WTP (where 'n' is the number of BSSIDs desired), as 
> > opposed to n-1 (in order to keep the original MAC address).
> > 
> > Thoughts?
> > 
> > Pat Calhoun