Subject: [Capwap] Use of "Status/WLANs" field in ctrl msgs

From: "David T. Perkins" <[email-masked]>
Date: Fri, 7 Apr 2006 11:22:27 -0700 (PDT)

HI,

Presently, the "Status/WLANs" field in the CAPWAP header
is not used (always has a value of zero) in CAPWAP
control messages. I suggest that this contain a
timestamp sent in a request and echoed back in
a response to help determine retransmission 
timeout (RTO). The details for how to use this
and the motivations are described in
"UNIX Network Programming, vol 1, 3rd Ed" by
Stevens, section 22.5 (starts on page 597).

Regards,
/david t. perkins

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Sat, 29 Apr 2006 13:13:26 -0700

I think this is a good proposal. I am in the process of changing this
section as per discussions on the list - and the request to add the Data
Rate to the frame. I've created issue 111 to track this request.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Friday, April 07, 2006 11:22 AM
> To: capwap
> Subject: [Capwap] Use of "Status/WLANs" field in ctrl msgs
> 
> HI,
> 
> Presently, the "Status/WLANs" field in the CAPWAP header is 
> not used (always has a value of zero) in CAPWAP control 
> messages. I suggest that this contain a timestamp sent in a 
> request and echoed back in a response to help determine 
> retransmission timeout (RTO). The details for how to use this 
> and the motivations are described in "UNIX Network 
> Programming, vol 1, 3rd Ed" by Stevens, section 22.5 (starts 
> on page 597).
> 
> Regards,
> /david t. perkins
>