Subject: [Capwap] RE: WTP Mac Type negotiation.

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 13 Apr 2006 06:18:22 -0700

Could you please define these new modes of operation?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: sujay [mailto:[email-masked]] 
	Sent: Tuesday, April 11, 2006 4:32 AM
	To: 'Saravanan Govindan'; [email-masked]; Pat Calhoun
(pacalhou)
	Subject: RE: WTP Mac Type negotiation.

	Saravanan,
	I suggest not to limit the AC's mode of operation,
	by classifying modes of operation viz Control - bias 
	and Load-bias mode.
	 
	Keeping it simple;
	 
	5.2.6.   Operating Mode

	   The Operating Mode message element specifies the mode of
operation for a WTP capable of  

	   operating in both Local-MAC and Split-MAC modes. 

	      0
	      0 1 2 3 4 5 6 7
	     +-+-+-+-+-+-+-+-+
	     |Operating Mode |
	     +-+-+-+-+-+-+-+-+
	 
	   Type:  TBD
	 
	   Length:  1
	 
	   Operating Mode:  The selected mode for WTP operation
	 
	<
	        0: Control-bias mode, WTP operates in Split-MAC mode
	 
	        1: Load-bias mode, WTP operates in Local-MAC mode 
	/>
	change to;
	
	<
	        0: Split-MAC mode, WTP operates in Split-MAC mode
	 
	        1: Local-MAC mode, WTP operates in Local-MAC mode 
	/>

	Any suggestions?
	Sujay

		-----Original Message-----
		From: Saravanan Govindan
[mailto:[email-masked]] 
		Sent: Friday, March 31, 2006 8:14 AM
		To: sujay; [email-masked]
		Subject: RE: WTP Mac Type negotiation.

		Dear All,

		Following from Sujay G's suggestion, this is text for
mode selection in the case where a WTP supports both split-MAC and
local-MAC modes and can also support the different tunnel options. 

		Cheers,
		
		Saravanan

		 

		----oooo----

		<NOTE> 

		Introduce how operational mode is selected in Section 2
(Protocol Overview) [Paragraph 3, after 2nd sentence]

		<END NOTE>

		"The WTPs specify their operational modes in their
Discovery Request message, to which the responding AC selects particular
operational modes and specifies them in the Discovery Response message."

		<NOTE> 

		Then in Section 5.2 (Discovery Response) [After
Paragraph 2, include following paragraph]

		<END NOTE>

		" In the case where a requesting WTP is capable of both
Local-MAC and Split-MAC operations (MAC Type [Section 5.1.4] value "2")
or where a WTP is capable of all types of bridging (Frame Type [Section
5.1.5] value "7"), AC determines the particular operating mode based on
the following;

		i. Control-bias Mode

		In this mode, the AC has greater control of WTP
operations. So the AC instructs the requesting WTP to operate in
Split-MAC mode. 

		ii. Load-bias Mode

		In this mode, the AC reduces processing load of WTP
operations. So the AC instructs the requesting WTP to operate in
Local-MAC mode. "

		<NOTE>

		Introduce Operation Mode message element as Section
5.2.6 (Operating Mode).

		<END NOTE>

		5.2.6.   Operating Mode

		   The Operating Mode message element specifies the mode
of operation for a WTP capable of  

		   operating in both Local-MAC and Split-MAC modes. 

		      0
		      0 1 2 3 4 5 6 7
		     +-+-+-+-+-+-+-+-+
		     |Operating Mode |
		     +-+-+-+-+-+-+-+-+
		 
		   Type:  TBD
		 
		   Length:  1
		 
		   Operating Mode:  The selected mode for WTP operation
		 
		        0: Control-bias mode, WTP operates in Split-MAC
mode
		 
		        1: Load-bias mode, WTP operates in Local-MAC
mode 

		----XXXX----

		 

		 

		-----Original Message-----
		From: sujay [mailto:[email-masked]] 
		Sent: Friday, March 17, 2006 2:32 PM
		To: [email-masked]
		Cc: Saravanan Govindan
		Subject: WTP Mac Type negotiation.

		Importance: Normal

		X-Priority: 3 (Normal)

		X-MSMail-priority: Normal

		The CAPWAP does not specify as to how the selection is
made if the WTP 

		Can support both Modes Split and Local and Frame (Tunnel
) type.

		The WTP specifies MAC Type and Frame Type  in Discovery
Request message,

		but if it supports 

		both modes , there is no provision for the AC to select
the working

		mode.

		Recommendation :

		1. Add the WTP mode and WTP tunnel type messages  in the

		configure response ? Which  makes it binding 

		agnostic.

		2. The logic for choosing WTP mode type on the AC could
depend on the

		load, and user policy.

		Solicit comments.

		Regds,

		Sujay

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Saravanan Govindan" <[email-masked]>
Date: Thu, 13 Apr 2006 22:49:40 +0800

Pat,

>From an earlier post,

" In the case where a requesting WTP is capable of both Local-MAC and 
Split-MAC operations (MAC Type [Section 5.1.4] value "2") or where a WTP is 
capable of all types of bridging (Frame Type [Section 5.1.5] value "7"), AC 
determines the particular operating mode based on the following;

i. Control-bias Mode

In this mode, the AC has greater control of WTP operations. So the AC 
instructs the requesting WTP to operate in Split-MAC mode.

ii. Load-bias Mode

In this mode, the AC reduces processing load of WTP operations. So the AC 
instructs the requesting WTP to operate in Local-MAC mode. "

Saravanan

----Original Message Follows----
From: "Pat Calhoun (pacalhou)" <[email-masked]>
To: "sujay" <[email-masked]>,"Saravanan Govindan" 
<[email-masked]>,<[email-masked]>
Subject: [Capwap] RE: WTP Mac Type negotiation.
Date: Thu, 13 Apr 2006 06:18:22 -0700

Pat Calhoun

	Saravanan,

	Keeping it simple;

	5.2.6.   Operating Mode

	      0
	      0 1 2 3 4 5 6 7
	     +-+-+-+-+-+-+-+-+
	     |Operating Mode |
	     +-+-+-+-+-+-+-+-+

	   Type:  TBD

	   Length:  1

	<

	<

	Any suggestions?
	Sujay

		-----Original Message-----
		From: Saravanan Govindan

		Dear All,

		Cheers,

		Saravanan

		----oooo----

		<NOTE>

		<END NOTE>

		<NOTE>

		<END NOTE>

		i. Control-bias Mode

		ii. Load-bias Mode

		<NOTE>

		<END NOTE>

		5.2.6.   Operating Mode

		      0
		      0 1 2 3 4 5 6 7
		     +-+-+-+-+-+-+-+-+
		     |Operating Mode |
		     +-+-+-+-+-+-+-+-+

		   Type:  TBD

		   Length:  1

		----XXXX----

		-----Original Message-----
		From: sujay [mailto:[email-masked]]
		Sent: Friday, March 17, 2006 2:32 PM
		To: [email-masked]
		Cc: Saravanan Govindan
		Subject: WTP Mac Type negotiation.

		Importance: Normal

		X-Priority: 3 (Normal)

		but if it supports

		mode.

		Recommendation :

		agnostic.

		load, and user policy.

		Solicit comments.

		Regds,

		Sujay

_________________________________________________________________
Find love on MSN Personals http://personals.msn.com.sg/