Subject: [Capwap] New Question/Issue - 5.1.1 Discovery type definition inconsistencies

From: "Dorothy Stanley" <[email-masked]>
Date: Tue, 11 Apr 2006 08:53:14 -0700

All,

Section 5.1.1 Defines the Discovery Type message element. This message
element is included in the
Discovery Request message, sent by WTPs to discover potential ACs.

The current definition is below:

The Discovery message element is used to configure a WTP to operate in a
specific mode.
 0
 0 1 2 3 4 5 6 7
+-+-+-+-+-+-+-+-+
 | Discovery Type|
 +-+-+-+-+-+-+-+-+

Type: 58 for Discovery Type

 Length: 1
Discovery Type: An 8-bit value indicating how the AC was discovered.
The following values are supported:
 0 - Broadcast
1 - Configured

Comments:
1. The statement that " The Discovery message element is used to configure a
WTP to operate in a specific mode." seems inconsistent
with its inclusion in the Discovery Request message.
2. Discovery Type: An 8-bit value indicating how the AC was discovered. -
The AC hasn't been discovered yet. Does this mean the mode - unicast,
broadcast/multi-cast
in which the discovery request message was sent? Must the WTP be either
configured with the AC address, or find the address on its own? Seems like
this
would be part of WTP configuration, rather than being included in the
discovery request message.
3. What is the purpose/value of including "Discovery Type"? Either define
consistently, or delete it

Do we mean the following?

The Discovery Type message element is used to indicate that the WTP has been
configured with the AC address
to which the corresponding Discovery Request message is sent.
 0
 0 1 2 3 4 5 6 7
+-+-+-+-+-+-+-+-+
 | Discovery Type|
 +-+-+-+-+-+-+-+-+

Type: 58 for Discovery Type

 Length: 1
Discovery Type: An 8-bit value indicating WTP knowledge of the AC
The following values are supported:
 0 - Unknown
1 -  Configured

Comments please.

Thanks,

Dorothy
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 11 Apr 2006 09:30:57 -0700 (PDT)

HI,

I started work on a document that described the CAPWAP boot model.
I sent Scott and Charles a copy, but didn't send one to you
or the WG mailing list, since it is not yet done. I'll try
to get it wrapped up, but realy need some clarification on
the previous question (on image transfer) plus the state
diagram update.

In general, the boot model as described in the LWAPP-03 and
CAPWAP-00 leaves out a lot of details.

In trying to address one part, with the question below,
I believe you are possibly making detailed choices
that may not fit with the overall "boot model".
The "boot model" is the process that is used to
get a WTP to the run state.

Even though it is not well described (and the text may be
inconsistent in places), the current CAPWAP-00 document
describes the following:

A WTP can be configured to be managed by an ordered list
of ACs (which is stored in persistent storage). The first
is the "primary". A WTP may also get AC addresses via
DHCP option 43 or a "well known" DNS name. And finally,
a WTP may broadcast or multicast when an IP address is
unknown.
The details of how the list is used is not specified
in the CAPWAP-00 document. For example, does the WTP
send Discovery messages to all ACs in the list, or
just the first? And only send mcast/bcast if the
list is empty or no response is received from any
AC on the list?

I believe that the boot model should be worked out
before the details of messages used in the boot process
are worked out.

However, for the below, I suggest that the values
for "Discovery type" be modified to be an enum
that has values:
  0 - bcast/mcast
  1 - last AC (the AC used last time the WTP booted)
  2 - AC address from DHCP
  3 - AC address from DNS
  4-127 reserved
  128 - first configured AC
  129 - second configured AC
  130 - third configured AC
  131-255 reserved
  
> The Discovery message element is used to configure a WTP to operate in a
Regards,
/david t. perkins

---

From: "Dorothy Stanley" <[email-masked]>
Date: Tue, 11 Apr 2006 13:39:54 -0700

David,

Clarifying the boot model is helpful. Note that there are also two
in-run-state discovery
messages that are also currently defined, the Primary Discovery Request and
Primary Discovery Response. So you might need to look at what happens in the
run state, in addtion to getting there. The contents of these messages are
identical to the
Discovery Request and Response.  In this extended Discovery Type list, there
may be a way to
indicate "primary discovery" and eliminate two messages.

Thanks,

Dorothy