Subject: Re: [Capwap] Editorial question - Location of Message elements

From: "Dorothy Stanley" <[email-masked]>
Date: Mon, 3 Apr 2006 12:30:15 -0700

Bob,

Here is a list of the message elements that would be in the new section,
(tentatively 4.4) and their current location.
These are all base protocol message elements.  The 802.11 specific message
elements would stay in section 11.

Dorothy

Vendor Specific 4.3.2.1.1
Discovery Type 5.1.1
WTP Descriptor 5.1.2
WTP Radio Information 5.1.3
WTP MAC Type 5.1.4
WTP Frame Type 5.1.5
AC Address 5.2.1
AC Descriptor 5.2.2
AC Name 5.2.3
WTP Manager Control IPv4 Address 5.2.4
WTP Manager Control IPv6 Address 5.2.5
Administrative State 7.2.1 - Suggest modifying the name to the Radio
Administrative State, to provide a more specific name
WTP Board Data 7.2.4
Statistics Timer 7.2.5
WTP Static IP Address Information 7.2.6
WTP Re-boot Statistics
Decryption Error Report Period 7.3.1
Change State 7.3.2
CAPWAP Timers 7.3.3
AC IPv4 List 7.3.4
AC IPv6 List 7.3.5
WTP Fallback 7.3.6
Idle Timeout 7.3.7
WTP Name 7.4.1
Location Data 7.4.5
Add MAC ALC Entry 7.4.9
Delete MAC ACL Entry 7.4.10
Add Static MAC ACL Entry 7.4.11
Delete Static MAC ACL Entry 7.4.12
Timestamp 7.4.17 - Suggest modifying the name to AC Timestamp, to provide a
more specific name
Result Code 7.5.1 - Is this only the "Configuration Update Result Code" or
used more generally?
Image Download 8.1.1
Image Data 8.1.2
Decryption Error Report 8.5.1
Duplicate IPv4 Address 8.5.2
Duplicate IPv6 Address 8.5.3
Data Transfer Mode 8.71
Data Transfer Data 8.7.2
Add Mobile 9.1.1 - Suggest modifying the name to "Add Mobile Station", to
align with the descriptive text
Delete Mobile 9.1.2 - Suggest modifying the name to "Delete Mobile Station"
to align with the descriptive text

On 3/27/06, Bob O'Hara (boohara) <[email-masked]> wrote:
>
>  Well, we shouldn't consolidate ALL the message elements in one section.
> I think that the elements used in the base protocol should be consolidated
> in one section and those for the 802.11 binding in another.
>
>  -Bob
>
>
>
>  ------------------------------
> *From:* Saravanan Govindan [mailto:[email-masked]]
> *Sent:* Monday, March 27, 2006 4:52 PM
> *To:* Dorothy Stanley; [email-masked]
> *Subject:* RE: [Capwap] Editorial question - Location of Message elements
>
>  Dorothy,
>
>
>
> I think structuring all the message elements in a single section is very
> useful. It helps make reading easier.
>
>
>
> Saravanan
>
>
>
>
>
>
>
>
>  ------------------------------
>
> *From:* Dorothy Stanley [mailto:[email-masked]]
> *Sent:* Thursday, March 23, 2006 1:41 AM
> *To:* [email-masked]
> *Subject:* [Capwap] Editorial question - Location of Message elements
>
>
>
> All,
>
> In the -00 draft, the CAPWAP message elements are defined in multiple
> sections, specifically the section defining
> the first message in which a particular message element appears.
>
> I propose to collect all of the message element definitions in a single
> section, so that there is
> one place where they are all defined, and can easily be found.
>
> Is there any objection to proceeding with this editorial change?
>
> At the CAPWAP meeting on Monday, there seemed to be support for this
> approach, with
> Pat noting that he LWAPP draft at one point was organized this way, but
> was then changed, due to
> comments received. So, comments please on this proposed editorial change
> to the CAPWAP  draft specification.
>
> Thanks,
>
> Dorothy
>
> -----------------
> Dorothy Stanley
> Aruba Networks
> 630-363-1389 (cell) 630-836-9734 (office)
>
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
>
> Archives: http://lists.frascone.com/pipermail/capwap
>
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Tue, 4 Apr 2006 11:54:08 -0700

Dorothy,
 
Thanks.  this list of base message elements looks good to me.

 -Bob

________________________________

From: Dorothy Stanley [mailto:[email-masked]] 
Sent: Monday, April 03, 2006 12:30 PM
To: Bob O'Hara (boohara)
Cc: [email-masked]
Subject: Re: [Capwap] Editorial question - Location of Message elements

Bob,

Here is a list of the message elements that would be in the new section,
(tentatively 4.4) and their current location.
These are all base protocol message elements.  The 802.11 specific
message elements would stay in section 11.

Dorothy

Vendor Specific 4.3.2.1.1
Discovery Type 5.1.1
WTP Descriptor 5.1.2
WTP Radio Information 5.1.3
WTP MAC Type 5.1.4
WTP Frame Type 5.1.5
AC Address 5.2.1
AC Descriptor 5.2.2
AC Name 5.2.3
WTP Manager Control IPv4 Address 5.2.4
WTP Manager Control IPv6 Address 5.2.5
Administrative State 7.2.1 - Suggest modifying the name to the Radio
Administrative State, to provide a more specific name
WTP Board Data 7.2.4
Statistics Timer 7.2.5
WTP Static IP Address Information 7.2.6
WTP Re-boot Statistics
Decryption Error Report Period 7.3.1
Change State 7.3.2
CAPWAP Timers 7.3.3
AC IPv4 List 7.3.4
AC IPv6 List 7.3.5
WTP Fallback 7.3.6
Idle Timeout 7.3.7
WTP Name 7.4.1
Location Data 7.4.5
Add MAC ALC Entry 7.4.9
Delete MAC ACL Entry 7.4.10
Add Static MAC ACL Entry 7.4.11
Delete Static MAC ACL Entry 7.4.12
Timestamp 7.4.17 - Suggest modifying the name to AC Timestamp, to
provide a more specific name
Result Code 7.5.1 - Is this only the "Configuration Update Result Code"
or used more generally?
Image Download 8.1.1
Image Data 8.1.2
Decryption Error Report 8.5.1
Duplicate IPv4 Address 8.5.2
Duplicate IPv6 Address 8.5.3
Data Transfer Mode 8.71
Data Transfer Data 8.7.2
Add Mobile 9.1.1 - Suggest modifying the name to "Add Mobile Station",
to align with the descriptive text
Delete Mobile 9.1.2 - Suggest modifying the name to "Delete Mobile
Station" to align with the descriptive text

On 3/27/06, Bob O'Hara (boohara) <[email-masked] > wrote: 

	Well, we shouldn't consolidate ALL the message elements in one
section.  I think that the elements used in the base protocol should be
consolidated in one section and those for the 802.11 binding in another.

	 -Bob

________________________________

	From: Saravanan Govindan
[mailto:[email-masked]] 
	Sent: Monday, March 27, 2006 4:52 PM
	To: Dorothy Stanley; [email-masked]
	Subject: RE: [Capwap] Editorial question - Location of Message
elements

	Dorothy,

	I think structuring all the message elements in a single section
is very useful. It helps make reading easier. 

	Saravanan

	 

________________________________

	From: Dorothy Stanley [mailto:[email-masked]] 
	Sent: Thursday, March 23, 2006 1:41 AM
	To: [email-masked]
	Subject: [Capwap] Editorial question - Location of Message
elements

	All,
	
	In the -00 draft, the CAPWAP message elements are defined in
multiple sections, specifically the section defining
	the first message in which a particular message element appears.

	I propose to collect all of the message element definitions in a
single section, so that there is
	one place where they are all defined, and can easily be found.

	At the CAPWAP meeting on Monday, there seemed to be support for
this approach, with
	Pat noting that he LWAPP draft at one point was organized this
way, but was then changed, due to 
	comments received. So, comments please on this proposed
editorial change to the CAPWAP  draft specification.

	Thanks,

	Dorothy

	-----------------
	Dorothy Stanley
	Aruba Networks

_________________________________________________________________
	To unsubscribe or modify your subscription options, please
visit:
	http://lists.frascone.com/mailman/listinfo/capwap