Subject: RE: [Capwap] Proposed Resolution to Issue 45 -Issueoncombiningmessages

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 28 Apr 2006 21:18:24 -0700

I'm saying you restart the echo timer everytime you send a control
packet. However, some implementation, for whatever reason, may opt to
simply send the echo request after the expiration of the timer, and
never reset it. One cannot penalize an implementation for doing so,
since it is not technically breaking anything. My point was that the
receiver must abide by the idle timer, and accept unexpected echos, and
consider the link dead as per the rules.

Be conservative in what you send, liberal in what you receive.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: Friday, April 28, 2006 5:14 PM
> To: Pat Calhoun (pacalhou)
> Cc: Scott G Kelly; Saravanan Govindan; capwap
> Subject: RE: [Capwap] Proposed Resolution to Issue 45 
> -Issueoncombiningmessages
> 
> HI
> 
> I'm having some problems understanding the "MAY only", which 
> seems much more restrictive than needs be.
> 
> Are you saying that an AC or WTP can only seen an ECHO 
> request when it hasn't seen any control traffic after X 
> amount of time?
> 
> For example, if an AC sends, say, a config update request, 
> then it cannot send an echo request before X ammount of time 
> has elapsed?
> 
> On Fri, 28 Apr 2006, Pat Calhoun (pacalhou) wrote:
> > I will summarize my thoughts here and not try to inject in 
> the various 
> > threads, but I agree that the echo remains, does not include any 
> > statistics, and MAY only be sent in the absence of any 
> control packets.
> > I say MAY because an implementation could send them if it 
> wishes, but 
> > the receiver must take into account control packets in 
> addition to the 
> > echo prior to declaring a link dead.
> > 
> > Pat Calhoun
> > CTO, Wireless Networking Business Unit Cisco Systems
> 
> Regards,
> /david t. perkins
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Sat, 29 Apr 2006 07:28:54 -0700 (PDT)

HI,

Thanks for the clarification. I also believe what you describe
is the most appropriate behavior.

Regards,
/david t. perkins