Subject: Re: [Capwap] Some question on CAPWAP protocol implementation

From: "Wenhui Zhou" <[email-masked]>
Date: Tue, 4 Jul 2006 10:13:55 +0800

Dear CAPWAP guys,

i am sorry i missed much previous related topics, so i have some questions about CAPWAP protocol implementation.

1. Whether it has been decided that LWAPP will be the protocol implementing CAPWAP?
2. Whether all of the traffic of the control plane, management plane,  as well as data plane will be encapsulated in the tunnel between WTP and the AC by the CAPWAP protocol imple?
3. Due to the hot and diverse discussions on CAPWAP protocol implementation here, can some kind of summary of agreement  of CAPWAP protocol implementation  be presented periodically?

thanks.

Wenhui Zhou

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Monday, July 03, 2006 6:16 PM
Subject: Capwap Digest, Vol 9, Issue 3

> Send Capwap mailing list submissions to
> [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> http://lists.frascone.com/mailman/listinfo/capwap
> or, via email, send a message with subject or body 'help' to
> [email-masked]
> 
> You can reach the person managing the list at
> [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Capwap digest..."
> 
> 
> Today's Topics:
> 
>   1. Re: Clarification of Issue 43: IEEE 802.11i Considerations
>      (Saravanan Govindan)
>   2. Editorial - WTP Event Request (Saravanan Govindan)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Mon, 3 Jul 2006 13:54:04 +0800
> From: "Saravanan Govindan" <[email-masked]>
> Subject: Re: [Capwap] Clarification of Issue 43: IEEE 802.11i
> Considerations
> To: "Michael Montemurro" <[email-masked]>
> Cc: capwap <[email-masked]>
> Message-ID:
> <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> Hi Mike,
> 
> 
> 
> I had a chance to review the new draft. 
> 
> 
> 
> With regard to Issue 43, my understanding is that updates were made in
> Section 11.9.1 (IEEE 802.11 Add WLAN). In particular, the IEEE 802.11
> Add WLAN message element now allows the AC to send sequence counter
> values to the WTP. So now, CAPWAP can support designs where the KeyRSC
> is maintained by the AC. 
> 
> 
> 
> My initial concern was with supporting designs where the KeyRSC is
> maintained by the WTP. This is particularly important to manage the
> 4-Way and Group-key handshakes. 
> 
> 
> 
> With this in mind, I think the protocol still requires support for
> designs where the KeyRSC is maintained by the WTP. Based on the current
> draft, this support can be included by adding another field to the IEEE
> 802.11 Add WLAN message element. This field would contain Message-3
> EAPoL frame (for 4-Way handshake) or Message-1 EAPoL frame (for
> Group-key handshake). These EAPoL frames would have unassigned fields
> for KeyRSC (since the value is maintained by the WTP). 
> 
> 
> 
> I am also open to any alternatives to support this. 
> 
> 
> 
> Cheers,
> 
> 
> Saravanan
> 
> 
> 
> 
> 
> 
> 
> 
> 
> ________________________________
> 
> From: Michael Montemurro [mailto:[email-masked]] 
> Sent: Tuesday, June 20, 2006 10:01 PM
> To: Saravanan Govindan
> Cc: Bob O'Hara (boohara); capwap
> Subject: Re: [Capwap] Clarification of Issue 43: IEEE 802.11i
> Considerations
> 
> 
> 
> Saravanan,
> 
> 
> 
> I've updated section 11.3 to deal with the GTK exchange and the handling
> of the KeyRSC in draft -02 to address your comments. I also provided a
> mechanism for the AC to transmit the keyRSC to the WTP using the
> updateWLAN message element as part of the Group Key exchange. 
> 
> 
> 
> We're finalizing the -02 draft this week and you should be able to look
> at it when we post it later this week.
> 
> 
> 
> Cheers,
> 
> 
> 
> Mike
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: http://lists.frascone.com/pipermail/capwap/attachments/20060703/7806c36e/attachment.htm 
> 
> ------------------------------
> 
> Message: 2
> Date: Mon, 3 Jul 2006 15:02:10 +0800
> From: "Saravanan Govindan" <[email-masked]>
> Subject: [Capwap] Editorial - WTP Event Request
> To: "capwap" <[email-masked]>
> Message-ID:
> <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> All,
> 
> 
> 
> I would like to suggest an editorial update to Section 9.5 (WTP Event
> Request). 
> 
> 
> 
> This is based on earlier discussions of how WTP Event Request serves as
> an implicit keep alive mechanism for the WTP. I believe this observation
> can be made explicit in this section.
> 
> 
> 
> I suggest the following after the 1st paragraph of Section 9.5;
> 
> 
> 
> "The exchange of WTP Event Request serves as an implicit keep alive
> mechanism for the WTP. The arrival of a WTP Event Request message at the
> AC indicates the WTP is operational. In cases where WTP Event Request is
> not exchanged, explicit keep alive is used (see Section 7)."
> 
> 
> 
> The current text in Section 7 refers to maintaining the control
> communication channel, whereas the suggestion above refers to the WTP as
> a whole. 
> 
> 
> 
> Comments?
> 
> 
> 
> Saravanan
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: http://lists.frascone.com/pipermail/capwap/attachments/20060703/b987e7b1/attachment.htm 
> 
> ------------------------------
> 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 
> End of Capwap Digest, Vol 9, Issue 3
> ************************************
>
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 4 Jul 2006 23:19:06 -0700 (PDT)

HI,

See answers inline below...

On Tue, 4 Jul 2006, Wenhui Zhou wrote:
> Dear CAPWAP guys,
> 
> i am sorry i missed much previous related topics, so i have
> some questions about CAPWAP protocol implementation.
This wasn't a question, but an untrue statement.
CAPWAP is a protocol that is in development. There have
been development of prototypes of early drafts of the
CAPWAP protocol specification, but no compleat developments
nor deployments of the latest draft of the protocol
specification (that is CAPWAP-02) have been reported.
> 1. Whether it has been decided that LWAPP will be the protocol
The starting specification for the CAPWAP protocol specification
was LWAPP. However, the current CAPWAP specification is
"on the wire" different from LWAPP, and the final CAPWAP
specification will, I'm guessing be radically different
from LWAPP. This is because there are many other good ideas
and requirements that are not part of LWAPP, plus the
learning that has occured from deployment of LWAPP.
I recently saw some cisco literature that said something
to the effect that CAPWAP was LWAPP. This is just not
the case. CAPWAP is a new protocol that uses a lot
of ideas from LWAPP, but is not LWAPP.

> 2. Whether all of the traffic of the control plane, management
> plane,  as well as data plane will be encapsulated in the tunnel
> between WTP and the AC by the CAPWAP protocol imple?
CAPWAP is in development, and so far all of the control
traffic (including mangement - configuration, status,
statistics, and event reporting) are via operations
usings a protected session that provides data integrety
and encryption. The data traffic to and from devices
with a wireless interface between a WTP and AC over a
protected tunnel. However, CAPWAP supported a local-MAC
operation of a WTP where data traffic is not tunneled
tbetween a WTP and AC.

> 3. Due to the hot and diverse discussions on CAPWAP 
> protocol implementation here, can some kind of summary
> of agreement  of CAPWAP protocol implementation  
> be presented periodically?
Wellm just folllow the WG minutes and look for
new versions of the CAPWAP protocol specification.
NOTE: the ther "implementation" has several meaning.
Please be more specific. DO you mean completion of
a version of A draft of the CAPWAP protocol specification?
Or do you mean writing the code and creating and
executabler for a WTP or AC? Or do you mean
deployment of a wireless network that uses the CAPWAP
protocol?

> Wenhui Zhou
Regards,
/david t. perkins