Subject: [Capwap] Issue 209: Dealing with Reserved Bits

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 31 Aug 2006 06:39:24 -0700

Here is the proposed new text:

4.1.  CAPWAP Transport Header
[...]
   Flags:  A set of reserved bits for future flags in the CAPWAP header.
      All implementations complying with version zero of this protocol
      MUST set these bits to zero.  Receivers MUST ignore all bits not
      defined for the version of the protocol they support
[...]
   Reserved:  The 3-bit Reserved field is reserved and set to 0 in this
      version of the CAPWAP protocol.  Receivers MUST ignore all bits
      not defined for the version of the protocol they support 
 
Comments?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Bob O'Hara (boohara)" <[email-masked]>
Date: Thu, 31 Aug 2006 09:24:26 -0700

Pat,  

This is good, as far as it goes.  There are many more reserved fields in
the message elements.

 -Bob
 
-----Original Message-----
From: Pat Calhoun (pacalhou) 
Sent: Thursday, August 31, 2006 6:39 AM
To: [email-masked]
Subject: [Capwap] Issue 209: Dealing with Reserved Bits

 
Comments?

Pat Calhoun

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 31 Aug 2006 09:55:15 -0700

Yes, I've taken care of all of those as well.

Thanks,

Pat Calhoun

> From: Bob O'Hara (boohara) 
> Sent: Thursday, August 31, 2006 9:24 AM
> To: Pat Calhoun (pacalhou); [email-masked]
> Subject: RE: [Capwap] Issue 209: Dealing with Reserved Bits
> 
> Pat,  
> 
> This is good, as far as it goes.  There are many more 
> reserved fields in the message elements.
> 
>  -Bob
>  
>       defined for the version of the protocol they support [...]

---

From: "Nelson, David" <[email-masked]>
Date: Thu, 31 Aug 2006 17:16:33 -0400

For the sake of symmetry, may I suggest a different revision to the
text:

OLD (Pat C. as of 8/31/06):

NEW:

4.1.  CAPWAP Transport Header
[...]
   Flags:  A set of reserved bits for future flags in the CAPWAP header.
      All implementations complying with this protocol MUST set to zero
      any bits that are reserved in the version of the protocol
supported
      by that implementation.  Receivers MUST ignore all bits not
defined
      for the version of the protocol they support
[...]

This places a symmetric requirement on senders to zero, and receivers to
ignore, any bits that are still reserved in the version of the protocol
supported in that implementation.

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 31 Aug 2006 14:24:24 -0700

I'm ok with this as well.

Pat Calhoun

> From: Nelson, David [mailto:[email-masked]] 
> Sent: Thursday, August 31, 2006 2:17 PM
>       any bits that are reserved in the version of the 
> protocol supported
>       by that implementation.  Receivers MUST ignore all bits 
> not defined
>       for the version of the protocol they support [...]
> 
> This places a symmetric requirement on senders to zero, and 
> receivers to ignore, any bits that are still reserved in the 
> version of the protocol supported in that implementation.
>