Subject: Re: [Capwap] Ver 4 or CAPWAP packet syntax

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 4 Aug 2006 06:46:32 -0700

> In looking at the CAPWAP data header, the first question is 
> why does this need to be present in every packet? If the 
> format is determined at by the configuration, isn't it enough 
> the know the WTP and RadioID, or do you also need to know the 
> BSSID? The second question is can encoding of the CAPWAP data 
> header be made simplier?
> There are dependencies between the values of the "WBID" and 
> "T" fields (and "W" field). Also, what is valid depends on 
> the direction of the CAPWAP data PDU (certainly the data 
> going to a WTP should not specify "wireless specific info" 
> (which is  RSSI, SNR, and Data rate)). It does appear to me 
> that the "T" field could be removed, and that a value of, say 
> 0, for the WBID mean 802.3 frame format.

David,

We went through this on the list, and it was absent in -00/-01, and
then due to requests from the list, it was added. I am reluctant to
go back to the previous version at this point.

If something is specifically broken in the protocol, then we need to
address it. At this point, I don't see anything broken, just a desire
to make it look different. My take is that the WG has plenty of issues
to deal with, and should instead focus on issues that are in fact
broken.

PatC
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 4 Aug 2006 07:30:29 -0700 (PDT)

HI,

Since the IETF meeting, I haven't had a chance to
check in with you. I hope all is fine.

There are quite a few outstanding issues to
resolve to go forward with CAPWAP. What process
would you like to propose to make progress?

Regards,
/david t. perkins