Subject: [Capwap] Issue 193: Issues with Reset request and response

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 15 Aug 2006 15:45:28 -0700

My apologies for the format below, but xml.resource.org appears to be
down, so I cannot reformat the XML into txt.

Below is my proposed change:

x.x Reset Request
   The Reset Request message is used to cause a WTP to reboot.

   A Reset Request message is sent by an AC to cause a WTP to
reinitialize its 
   operation.

   The Reset Request message carries no message elements.

   When a WTP receives a Reset Request it will respond with a
   Reset Response indicating success and then reinitialize itself. In
the
   event the WTP is unable to reset, including a hardware reset, it can
   respond with a Reset Response whose Result-Code message element
indicates
   failure.

x.y Reset Response
   The Reset Response message acknowledges the Reset Request message.

   A Reset Response message is sent by the WTP after receiving a Reset
Request message.

   The following message elements MAY be included in the Image Data
Request Message.

       Result Code, see <xref>

   When an AC receives a successful Reset Response message, it is
   notified that the WTP will reinitialize its operation. An AC that 
   receives a Reset Response indicating failure may opt to no longer
   provide service to the WTP in question.

I've also added a new enum value to Result-Code, which indicates failure
to reset

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 31 Aug 2006 15:50:38 -0700

Based on the lack of comments, I will assume acceptance of the proposed
text and close the issue.

Pat Calhoun

> -----Original Message-----
> From: Pat Calhoun (pacalhou) 
> Sent: Tuesday, August 15, 2006 3:45 PM
> To: capwap
> Subject: [Capwap] Issue 193: Issues with Reset request and response
> 
> My apologies for the format below, but xml.resource.org 
> appears to be down, so I cannot reformat the XML into txt.
> 
>    Reset Response indicating success and then reinitialize 
> itself. In the
>    respond with a Reset Response whose Result-Code message 
> element indicates
>    failure.
> 
> x.y Reset Response
>    A Reset Response message is sent by the WTP after 
> receiving a Reset Request message.
> 
>    The following message elements MAY be included in the 
> Image Data Request Message.
> 
>        Result Code, see <xref>
> 
> I've also added a new enum value to Result-Code, which 
> indicates failure to reset
> 
> 
> Pat Calhoun