Subject: [Capwap] Issue 166: Is AC Name text?

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 15 Aug 2006 15:48:04 -0700

I was originally inclined to reject this issue, since the text is pretty
clear already in the format of the message element. It states:
   The AC name message element contains an ASCII representation of the
AC's 
   identity. The value is a variable length byte string.  The string is
NOT 
   zero terminated.

However, after careful consideration, I am wondering if I should just
abuse the existence of this issue to change the format from ASCII to
UTF-8. So the new text would look like (and a similar change would exist
for WTP name).

x.x AC-Name
   The AC name message element contains an UTF-8 representation of the
AC's 
   identity. The value is a variable length byte string.  The string is
NOT 
   zero terminated.

   0               
   0 1 2 3 4 5 6 7 
  +-+-+-+-+-+-+-+-+
  | Name ...
  +-+-+-+-+-+-+-+-+

     Type:
       4 for AC Name

     Length:
        > 0

     Name:
        A variable length UTF-8 string containing the AC's name

Comments?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 31 Aug 2006 15:51:17 -0700

Given no comments on the proposed text, I will assume acceptance and
close the issue

Pat Calhoun

> -----Original Message-----
> From: Pat Calhoun (pacalhou) 
> Sent: Tuesday, August 15, 2006 3:48 PM
> To: capwap
> Subject: [Capwap] Issue 166: Is AC Name text?
> 
> I was originally inclined to reject this issue, since the 
> text is pretty clear already in the format of the message 
> element. It states:
>    The AC name message element contains an ASCII 
> representation of the AC's 
>    identity. The value is a variable length byte string.  The 
> string is NOT 
>    zero terminated.
> 
> However, after careful consideration, I am wondering if I 
> should just abuse the existence of this issue to change the 
> format from ASCII to UTF-8. So the new text would look like 
> (and a similar change would exist for WTP name).
> 
> x.x AC-Name
>    The AC name message element contains an UTF-8 
> representation of the AC's 
>    identity. The value is a variable length byte string.  The 
> string is NOT 
>    zero terminated.
> 
>    0               
>    0 1 2 3 4 5 6 7
>   +-+-+-+-+-+-+-+-+
>   | Name ...
>   +-+-+-+-+-+-+-+-+
> 
>      Type:
>        4 for AC Name
> 
>      Length:
>         > 0
> 
>      Name: