Subject: Re: [Capwap] Regarding next version of draft and packet formats(resend)

From: "Nelson, David" <[email-masked]>
Date: Tue, 22 Aug 2006 16:44:17 -0400

David T. Perkins writes...

> I'm surprise and distrubed to say the least about the
> statement "We are working out the details..."!
> 
> Why? Because such work is being done without WG visibility.
> 
> It would be proper, and I believe would result in a much better
> outcome if this was done via an open interim meeting.

The appropriate way to make such decisions in the IETF is for someone to
propose a resolution to each issue (from the tracker tool) to the WG
mailing list and call for consensus.   I've seen a series of such
messages from the document editors in the last week or so.  It looks as
if the process is working.

Interim meetings are great for high-bandwidth, low-latency
communication.  However, in the final analysis, the I-D Editor(s) MUST
post the proposed changes to WG work items to the list and the chairs
declare that consensus is achieved before the changes are incorporated
into a revised draft.

If your complaint is that you expect to first see the resolutions in the
text of a revised I-D, before those changes have been proposed and
discussed on the WG mailing list, you have a valid process issue.

Is that your concern?  If not, I think your concerns are premature.

Regards,

Dave

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 22 Aug 2006 13:13:01 -0700 (PDT)

HI,

I didn't see this show up on the mailing list.
Sorry if you get it twice.

Regards,
/david t. perkins

---------- Forwarded message ----------
Date: Tue, 22 Aug 2006 09:52:35 -0700 (PDT)
From: David T. Perkins <[email-masked]>
To: "Pat Calhoun (pacalhou)" <[email-masked]>
Cc: Josh Peterson <[email-masked]>, [email-masked]
Subject: Re: [Capwap] Regarding next version of draft and packet formats

HI,

Regards,
/david t. perkins

On Tue, 22 Aug 2006, Pat Calhoun (pacalhou) wrote:
> We are working out the details of MUX vs. UDP port. Once we've ironed
> out the details of the protocol the editors will be putting out the -03
> document. It is too early to tell what the packet format will look like,
> so I can't answer your question right now.
>  
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
> 
>  
> 
> 
> ________________________________
> 
> 	From: Josh Peterson [mailto:[email-masked]] 
> 	Sent: Sunday, August 20, 2006 7:43 PM
> 	To: [email-masked]
> 	Subject: [Capwap] Regarding next version of draft and packet
> formats
> 	
> 	
> 	Hi all
> 	    When is the next version of the draft expected to be out?
> 	
> 	    Also, is the packet format as outlined in
> http://lists.frascone.com/pipermail/capwap/msg03250.html expected to be
> the new packet format in that draft?
> 	
> 	Thanks
> 	Josh
> 	
> 
>

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 22 Aug 2006 16:00:38 -0700 (PDT)

HI,

See inline below...

On Tue, 22 Aug 2006, Nelson, David wrote:
> mailing list and call for consensus.
This is only appropriate at specific places in a document
life cycle. I don't believe the CAPWAP document is there yet.

> I've seen a series of such
Yes, the process is working, but the results are useless in many cases!
Having process that works can get in the way of any real forward
progress. That is what I believe is happening here.
We need to throw out the bug tracker.
 
> declare that consensus is achieved before the changes are incorporated
I believe there is a lot of "talking past each other". Email has
made this much worse. 

> Is that your concern?  If not, I think your concerns are premature.
The above seemed stated backwards. Is this what you meant?

The issue is that fundamentals have not yet been defined in
technically sound and complete descriptions. Some believe that
the LWAPP document and the CAPWAP docs have met this test
because there is "working product". That has been the
ultimate answer to all hard questions. However, there are
two holes with this logic. The first is that it has not
been demonstrated that anyone has taken the LWAPP documentation
and write code that interoperates with the airespace
products (showing that the code and documents match,
and the LWAPP docs are sufficient to do an implementation).
Secondly, that the same assumptions from LWAPP transfer
to CAPWAP. An example of this is that using DTLS (which
encapsulates (and encrypts) the complete payload) causes
problems not found in LWAPP (which encrypts only a
portion of the message. 

Regards,
/david t. perkins