Subject: [Capwap] Clarification on DTLSRehandshake/DTLSPeerAuthorize/DTLSIncomingSession

From: "Anu Varughese (avarughe)" <[email-masked]>
Date: Tue, 13 Mar 2007 12:02:25 +0530

All,
 
There are some confusions existing with draft-05
 
1)Section 4.6.5.  DTLSRehandshake  
Is this timer needed or will it be removed ?

2) DTLSPeerAuthorize notification is specified in state transition. 
 
DTLS Setup to Authorize (h):
 
     WTP:  This state transition occurs when the WTP receives the
         DTLSPeerAuthorize notification (see Section 2.3.2.2).  Upon
         entering this state, the WTP performs an authorization check
         against the AC credentials.  See Section 2.4.4 for more
         information on AC authorization.

      AC:  This state transition occurs when the AC receives the
         DTLSPeerAuthorize notification (see Section 2.3.2.2).  Upon
         entering this state, the AC performs an authorization check
         against the WTP credentials.  See Section 2.4.4 for more
         information on WTP authorization.
 
But there is no definition for DTLSPeerAuthorize in Section 2.3.2.2.
 
3) DTLSIncomingSession is defined in Section 2.3.2.2
But there is no mention of when this notification is used in state
transition.
 
Regards,
Anu Varughese.

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 13 Mar 2007 07:44:58 -0700

> Is this timer needed or will it be removed ?
Yes, it needs to be removed.	 

>	But there is no definition for DTLSPeerAuthorize in Section
2.3.2.2.
You are correct that DTLSPeerAuthorize is missing
	 
> But there is no mention of when this notification is used in state
transition.
Correct, the state transition is there, but the text does not refer to
the notification.

Very good catches, thanks for your careful review of the state machine. 

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

________________________________

	From: Anu Varughese (avarughe) 
	Sent: Monday, March 12, 2007 11:32 PM
	To: [email-masked]
	Subject: [Capwap] Clarification
onDTLSRehandshake/DTLSPeerAuthorize/DTLSIncomingSession

	All,

	2) DTLSPeerAuthorize notification is specified in state
transition. 

	     WTP:  This state transition occurs when the WTP receives
the
	         DTLSPeerAuthorize notification (see Section 2.3.2.2).
Upon
	         entering this state, the WTP performs an authorization
check
	         against the AC credentials.  See Section 2.4.4 for more
	         information on AC authorization.
	
	      AC:  This state transition occurs when the AC receives the
	         DTLSPeerAuthorize notification (see Section 2.3.2.2).
Upon
	         entering this state, the AC performs an authorization
check
	         against the WTP credentials.  See Section 2.4.4 for
more
	         information on WTP authorization.
	 
	But there is no definition for DTLSPeerAuthorize in Section
2.3.2.2.
	 
		3) DTLSIncomingSession is defined in Section 2.3.2.2
	But there is no mention of when this notification is used in
state transition.
	 
	Regards,
	Anu Varughese.

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 13 Mar 2007 07:45:38 -0700

Created issue 250.

Pat Calhoun

	All,

	 

	 

	Regards,
	Anu Varughese.

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Mon, 19 Mar 2007 01:20:43 -0700

I've gone through the spec, and here is my proposed resolution:
1. Remove DTLSRehandshake timer
2. Rename DTLSIncomingSession to DTLSPeerAuthorize. It appears as if the
change was not completely applied.

Comments?

Pat Calhoun

> -----Original Message-----
> From: Pat Calhoun (pacalhou) 
> Sent: Tuesday, March 13, 2007 7:45 AM
> To: Anu Varughese (avarughe); [email-masked]
> Subject: Re: [Capwap] 
> ClarificationonDTLSRehandshake/DTLSPeerAuthorize/DTLSIncomingSession
> 
> > 3) DTLSIncomingSession is defined in Section 2.3.2.2 But 
> there is no 
> > mention of when this notification is used in state
> transition.
> Correct, the state transition is there, but the text does not 
> refer to the notification.
> 
> 	But there is no mention of when this notification is 
> used in state transition.
> 	 
> 	Regards,
> 	Anu Varughese.
> 			
> 	
> 	
>