Subject: Re: [Capwap] Question about IANA UDP Port Request

From: "Scott G. Kelly" <[email-masked]>
Date: Thu, 10 Apr 2008 16:57:48 -0400 (EDT)

By "at the system level", do you mean <= 1024?

-----Original Message-----
>From: "Pat Calhoun (pacalhou)" <[email-masked]>
>Sent: Apr 10, 2008 4:52 PM
>To: [email-masked]
>Subject: [Capwap] Question about IANA UDP Port Request
>
>All,
> 
>IANA has come back to me after I requested two UDP ports asking whether
>these ports really need to be at the system level. I believe they need
>to, but thought I'd solicit thoughts from the rest of the working group.
> 
>PatC
>_________________________________________________________________
>To unsubscribe or modify your subscription options, please visit:
>http://lists.frascone.com/mailman/listinfo/capwap
>
>Archives: http://lists.frascone.com/pipermail/capwap

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Thu, 10 Apr 2008 14:24:36 -0700

yes

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 11 Apr 2008 10:36:31 +0200

I would like to note that you actually will need to provide a motivation 
for port in the range 0-1023 is needed. What, benefit is there really 
compared to be using one in the range 1024-49151?

Cheers

Magnus

-- 

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Färögatan 6                | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 11 Apr 2008 09:46:25 -0700

That's a good question. The primary difference, as I understand it, is whether a non-root based application could access the port. I suppose that since CAPWAP is likely to be implemented on embedded systems, and not on multi-purpose computers, then perhaps a reserved port is fine.

Further, since authentication is mandatory to establish the control plane, perhaps the actual port number matters less.

Thoughts?

PatC 

-----Original Message-----
From: Magnus Westerlund [mailto:[email-masked]] 
Sent: Friday, April 11, 2008 1:37 AM
To: Pat Calhoun (pacalhou)
Cc: [email-masked]
Subject: Re: [Capwap] Question about IANA UDP Port Request

I would like to note that you actually will need to provide a motivation for port in the range 0-1023 is needed. What, benefit is there really compared to be using one in the range 1024-49151?

Cheers

Magnus

Pat Calhoun (pacalhou) skrev:
>> these ports really need to be at the system level. I believe they 
>> need to, but thought I'd solicit thoughts from the rest of the 
>> working
> group.
>> PatC

-- 

Magnus Westerlund

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 11 Apr 2008 12:59:06 -0400

I don't know of any reason why CAPWAP needs a system port.  I think a  
reserved port would be fine.

Margaret

On Apr 11, 2008, at 12:46 PM, Pat Calhoun (pacalhou) wrote:
> That's a good question. The primary difference, as I understand it,  
> is whether a non-root based application could access the port. I  
> suppose that since CAPWAP is likely to be implemented on embedded  
> systems, and not on multi-purpose computers, then perhaps a  
> reserved port is fine.
>
> Further, since authentication is mandatory to establish the control  
> plane, perhaps the actual port number matters less.
>
> Thoughts?
>
> PatC
>
> I would like to note that you actually will need to provide a  
> motivation for port in the range 0-1023 is needed. What, benefit is  
> there really compared to be using one in the range 1024-49151?
>
> Cheers
>
> Magnus
>