Subject: Re: Java GSS bindings

From: Michael Smith <[email-masked]>
Date: Wed, 09 Dec 1998 11:03:35 -0500

At 10:53 AM 12/9/98 -0500, you wrote:
>[Not speaking ex-cathedra as Security co-AD]
>
>My preference would be for interfaces and providers. 
[....]
>It isn't that hard to use Interfaces.

Another data point, possibly relevant: I've found 
in my own implementation efforts where I work that 
having the GSS-API consist of interfaces greatly 
increases my flexibility as a programmer, due to 
the prohibition in Java of multiple inheritance
of classes (but of course no such restriction on 
interfaces). In my particular case, I needed to 
make some server-side CORBA objects which implemented
the GSS-API. To make a long story short, the easiest 
way to do this was to have them extend some classes
generated by the IDL compiler. But of course then 
they couldn't also extend GSS classes; whereas they 
could implement GSS interfaces.

--Michael Smith
  [email-masked]

==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: "Jeffrey I. Schiller" <[email-masked]>
Date: Thu, 10 Dec 1998 00:07:47 -0500

Sounds like a pretty powerful argument to me...

                -Jeff

---

From: [email-masked]
Date: Thu, 10 Dec 1998 09:53:48 -0800

From an implementation point of view I definitely favor interfaces.  
     
     From the applications point of view you need two things (at least)
     
     1) Description of how to use the classes (interfaces).
     2) An instance of an object that supports those interfaces.
     
     1 is definitely within the scope of this document. The exact details 
     on how to get 2 may vary from implementation to implementation, 
     although having a standard interface to get an instance may be 
     helpful.  
     
Concrete classes will probably force implementations to be more complicated than
they need to be.

     Also in implementing GSSAPI in a COM (ugh) environment we found interfaces 
to provide more flexibility due to the similar restrictions it imposes on 
multiple inheritance.

-Joe

______________________________ Reply Separator _________________________________
Subject: Re: Java GSS bindings
Author:  jis ([email-masked]) at internet
Date:    12/9/98 9:07 PM

                -Jeff