Subject: RE: Java-GSS bindings document(s)

From: "Linn, John" <[email-masked]>
Date: Mon, 29 Mar 1999 08:47:24 -0500

Does anyone have any comments to offer re Michael's proposal that the Java
interfaces and concrete classes should be split into separate documents?
I'd like to clarify where the group stands on this, so that our delivery
plans are clear.

--jl

-----Original Message-----
From: Michael Smith [mailto:[email-masked]]
Sent: Tuesday, March 23, 1999 10:15 AM
To: [email-masked]
Subject: Java-GSS bindings document(s)

The impression I took away from the CAT WG 
meeting in Minneapolis was that Java GSS bindings
should be based on an interface-based specification, but 
that a set of concrete classes should also be specified
(and presumably written) which would spare the application 
programmer the onus of finding and instantiating the 
local implementing classes. If I got it wrong, somebody 
please let me know, since as the lady says in the Henry 
James novel, when I'm misinformed I'm as dangerous as a 
poisoned rat.

Sounds like we need two documents: one specifying
the interfaces, and one specifying the concrete classes
(and referencing the former). Since the implementation
I have here is interface-based, I'm volunteering to 
produce an I-D defining that part of the work. 

I've gone through my mapping and the one produced 
by Jack Kabat in the existing I-D; the differences 
are really very minor (not surprising, since Jack 
and I corresponded extensively while he was writing
his draft and I was producing my implementation). 
What I propose to do is bring all the method and field
names in my version into line with the ones Jack 
defined. There are one or two areas of functional 
difference which I think might benefit from a bit of 
discussion; I'll sent another note to the list soon
about those. 

And oh, by the way: my command of ?roff is very 
primitive; if anybody has a ?roff source for an 
I-D (particularly if it has a table of contents)
I would be very grateful to have a look at it. 

--Michael Smith
  [email-masked]

==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]
==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Mike Eisler <[email-masked]>
Date: Mon, 29 Mar 1999 06:43:45 -0800 (PST)

> I'd like to clarify where the group stands on this, so that our delivery

This was certainly an idea that I was mentioning after the WG meeting had
concluded. My rationale was to limit the size of the document that
a novice jGSS programmer would have to absorb. On the other hand, as
I mentioned to Jack Kabat earlier this week, if as doc editor he feels he
can present both approaches in one document, and if it the end document
is still somewhat concise, then that is fine too.

	-mre

---

From: [email-masked]
Date: Mon, 29 Mar 1999 09:58:40 -0800

It seems that the interfaces and concrete classes are closely 
     connected.  If there are two separate documents they have to be 
     tightly linked.  It would be very, very bad to have different bindings 
     for interfaces and concrete classes.  I do not think two documents 
     would simplify things.  I would prefer a well organised single 
     document over two separate documents.  
     
     I think it is desirable to have a separate document for an SPI layer.
     
     Joe

______________________________ Reply Separator _________________________________
Subject: RE: Java-GSS bindings document(s)
Author:  mre ([email-masked]) at internet
Date:    3/29/99 6:43 AM

     
        -mre