Subject: Java-GSS bindings document(s)

From: Michael Smith <[email-masked]>
Date: Tue, 23 Mar 1999 10:14:47 -0500

The impression I took away from the CAT WG 
meeting in Minneapolis was that Java GSS bindings
should be based on an interface-based specification, but 
that a set of concrete classes should also be specified
(and presumably written) which would spare the application 
programmer the onus of finding and instantiating the 
local implementing classes. If I got it wrong, somebody 
please let me know, since as the lady says in the Henry 
James novel, when I'm misinformed I'm as dangerous as a 
poisoned rat.

Sounds like we need two documents: one specifying
the interfaces, and one specifying the concrete classes
(and referencing the former). Since the implementation
I have here is interface-based, I'm volunteering to 
produce an I-D defining that part of the work. 

I've gone through my mapping and the one produced 
by Jack Kabat in the existing I-D; the differences 
are really very minor (not surprising, since Jack 
and I corresponded extensively while he was writing
his draft and I was producing my implementation). 
What I propose to do is bring all the method and field
names in my version into line with the ones Jack 
defined. There are one or two areas of functional 
difference which I think might benefit from a bit of 
discussion; I'll sent another note to the list soon
about those. 

And oh, by the way: my command of ?roff is very 
primitive; if anybody has a ?roff source for an 
I-D (particularly if it has a table of contents)
I would be very grateful to have a look at it. 

--Michael Smith
  [email-masked]

==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Michael Smith <[email-masked]>
Date: Mon, 29 Mar 1999 11:12:28 -0500

At 06:43 AM 3/29/99 -0800, Mike Eisler <[email-masked]> wrote:

>This was certainly an idea that I was mentioning after the WG meeting had
>concluded. My rationale was to limit the size of the document that
>a novice jGSS programmer would have to absorb. On the other hand, as
>I mentioned to Jack Kabat earlier this week, if as doc editor he feels he
>can present both approaches in one document, and if it the end document
>is still somewhat concise, then that is fine too.

At the time, I thought Mike's idea was a good one. 
What seemed to emerge from the WG discussion was the 
idea that programmers might want to keep their lives
simple (and write to the concrete classes) or use the 
extra power of writing to the interfaces; with a split
document, each group would have a smaller spec to master,
and less irrelevant material to sift through. 

This is not a life-or-death issue, but the split 
document approach seems slightly preferable to me. 
My offer to write one of the halves stands. 

I'll be out of the office, though perhaps not 
entirely incommunicado, all this week; back on 
Saturday (the 3d).  

--Michael Smith
  [email-masked]