Subject: Re: GGF's extensions to GSS in Public Comment

From: "Douglas E. Engert" <[email-masked]>
Date: Thu, 01 Apr 2004 09:37:38 -0600

Brian E Carpenter wrote:
> 
> Security ADs,
> 
> With my IETF-GGF liaison hat on... please note that the GGF's extensions
> to the GSS-API are open for Public Comment (roughly the equivalent of an IETF
> Last Call). So far, I hear that the GGF has not got any response from
> attempts to get IETF comment (despite draft-engert-ggf-gss-extensions-00.txt).
> This looks like the last chance. Can you kindly pass this on to some
> competent reviewers?

Last week I did send the note below [email-masked] (and am cc'ing them 
on this note.) There was one comment logged from an IETF member, Tim Alsop, which says:
"This document (in my opinion) looks ready, but needs to be reviewed
 by IETF CAT (or KITTEN) working group to see if there are any
 concerns from IETF community."

The consencus as far as I can tell is to talk about it at the proposed 
CAT BOF at the next IETF. This may not be the time fram that the GGF was looking for. 

"Douglas E. Engert" wrote:
> 
> The Global Grid Forum is proceeding with their GSS extensions
> document. If anyone would like to comment on it.
> 
> -------- Original Message --------
> Subject: [security-area] GSS Extensions document needs comments
> Date: Thu, 25 Mar 2004 13:46:58 -0600
> From: Von Welch <[email-masked]>
> Reply-To: Von Welch <[email-masked]>
> To: [email-masked]
> 
> Folks,
> 
>  The GSS Extensions document is in public last call (for a second
> time, after changes made to remove the key argument from the
> export/import credential calls). GGF is now requiring some amount of
> public comment before they will allow a document to pass public
> comment.
> 
>  So please comment, even if it's nothing more to say you've read the
> document.
> 
> You can find WS-Word and PDF versions of the document at the url
> below. The version for comment is version 11.
> 
> https://forge.gridforum.org/docman2/ViewCategory.php?group_id=58&category_id=0
> 
> You can comment at:
> http://forge.gridforum.org/tracker/index.php?aid=482
> 
> Thanks,
> 
> Von
> 
> Thanks
>     Brian
> 
> -------- Original Message --------
> Subject: Public Comment Documents and Tutorial Update
> Date: Fri, 26 Mar 2004 17:48:35 -0500
> From: "Steve Crumb" <[email-masked]>
> Reply-To: <[email-masked]>
> To: <[email-masked]>
> 
> -----------------------------------------------------------------------
> 1. Documents: 9 Documents in Public Comment
> 2. Call for GGF11 Tutorials and GGF11 Tutorial Survey
> 3. GGF11 Semantic Grid Applications Workshop Call for Papers
> -----------------------------------------------------------------------
> 
> 1. Documents in Public Comment
> GGF process encourages community comment on all documents that have
> passed the GGF Editor's initial review.  The absence of public comments
> may hinder the document's progress through the GGF Editorial process.
> Your participation in the comment period is critical.
> 
> There are two ways you may chose to make your comments:
> - Visit GGF's SourceForge.net site
> (http://sourceforge.net/projects/ggf/). Download the document by
> selecting the title of the document you wish to review.  You can post
> comments using the associated "Forum" (discussion thread) for each
> document. These forums can be found by clicking the "Forums" link near
> the top of the Sourceforge project page and clicking the forum named
> similarly to the document.
> - Use the GridForge tracker in the GGF Editor project
> (http://forge.gridforum.org/tracker/index.php?func=browse&group_id=90&at
> id=414) Visit the provided link and click on the title of document to
> open a comment form. You may choose to login to GridForge to submit
> comments or make your comments anonymously. After typing your comments
> into the form, press the "Save" button and your comments will be posted.
> 
> Documents currently in Public Comment:
> - Usage Record-XML (SRM) 60 day
> - Persistent Archive Capabilities (DATA) 30 day
> - NM-WG Hierarchy (ISP) 60 day
> - GSS Extensions (SEC) 60 day
> - An Analysis of "Top N" Event Descriptions (ISP) 30 day
> - Peer To Peer and Grid: Synergies and Opportunities (P2P) 30 day
> - Distributed Resource Management Application API Specification 1.0
> (SRM) 60 day
> - GIR-WG Requirements (ISP) 30 day
> - Certificates for Automated Clients (SEC) 60 day
> 
> <snip>

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444
-++**==--++**==--++**==--++**==--++**==--++**==--++**==
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Nicolas Williams <[email-masked]>
Date: Thu, 1 Apr 2004 11:23:12 -0600

> > This looks like the last chance. Can you kindly pass this on to some

I'm not sure when Mr. Carpenter wrote this since Doug did not include a
date in the log line, but I assume it was written long after I posted
draft-williams-gssapi-store-deleg-creds-00.txt to the I-D repository and
subsequent comments to GGF and IETF lists.

Neither my comments (made long ago on _both_, GGF and IETF lists) nor
Sam Hartman's (made on IETF lists; I don't know if he's posted on GGF
lists) seem to be appreciated by the GGF.

If I hear no replies anytime soon to my comments then I will give up
trying to comment on this proposal.  I can't say that my employer would
never implement it, but certainly I think there are serious flaws in
this proposal and I certainly would not want to implement it as it
stands.

>  concerns from IETF community."

I hate to say this Doug but Tim's comment on the CAT WG list was the
least significant of all comments made recently.  Issues were raised,
particularly with respect to the way that the GGF has failed to address
comments raised on its and IETF's lists.  To quote the lone voice in
favor of the proposal as it stands and leave out the others is, well,
not useful.

> CAT BOF at the next IETF. This may not be the time fram that the GGF was looking for. 

I don't quite agree with this.

The GGF could have responded to Sam's or my comments months ago.  It
still can.

And I would still welcome replies from the GGF and give them serious
consideration, and I'm sure Sam might be amenable also -- there's no
need to wait until August to discuss this.

No, there is no CAT WG (or successor), yet, but this does not mean that
an IETF document on GSS-API extensions can't be published, discussed and
progressed, if only the authors would deign to pursue it.

Let's not forget either that we (by which I mean Doug, myself and
others) have discussed some of these issues in hallway conversations at
IETF meetings and at KRB WG interim meetings, not just discussions on
some mailing lists; it's not as though the GGF published an IETF-related
proposal that the IETF then proceeded to ignore.

Cheers,

Nico

---

From: "Douglas E. Engert" <[email-masked]>
Date: Thu, 01 Apr 2004 13:19:55 -0600

> subsequent comments to GGF and IETF lists.

No, I got his note today.   Thu, 01 Apr 2004 17:16:24 +0200

> lists) seem to be appreciated by the GGF.

Yes that is a problem that the GGF needs to address. 

> least significant of all comments made recently. 

The point was that Tim sent the comment to the GGF in response to the 
request to make comments on the web site. Sort of encougaging others,
such as yourself, to add your own comment on the GGF web page.  If nothing else,
that you feel that the GGF has failed to address your previous comments. 

> Issues were raised,

I was not quoting him as in favor, but rather that it needed reviewing by the IETF. 
(He said both.)

> need to wait until August to discuss this.

That is my intention here as well, to get some dialog going between
the GGF and IETF not between myself and other ITEF members. 

> progressed, if only the authors would deign to pursue it.

I know I am listed as an author, but I am not on this project any longer.
and don't attend the GGF. But I do have an interest in GSSAPI being
a single standard fromthe IETF. So it is up to others in GGF to respond. 

--