Subject: Re: [Cbor] [Technical Errata Reported] RFC7049 (5434)

From: Carsten Bormann <[email-masked]>
Date: Sun, 22 Jul 2018 19:15:37 +0200

Hi David,

thank you for this report!

It appears “UBJSON” is now a specification completely different from what it was in 2013, sharing only the name.  The peril of referencing a website for a specification.  If you have more information about what happened to “UBJSON" in the last five years, this could be quite interesting.

I would propose classifying this as “hold for document update”, with a view of removing UBJSON from the illustrative appendix: the use will create confusion and the example is not at all necessary for making use of CBOR.  (The updated text of RFC 7049 is being actively worked on by the CBOR WG, draft at https://github.com/cbor-wg/CBORbis — comments on this document are very welcome!)

(As a separate observation, I will note that the Experimental RFC 8060 references UBJSON without specifying whether the old or the new specification is intended.)

Grüße, Carsten

> On Jul 22, 2018, at 18:16, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC7049,
> "Concise Binary Object Representation (CBOR)".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5434
> 
> --------------------------------------
> Type: Technical
> Reported by: LAMBERT David <[email-masked]>
> 
> Section: E.6
> 
> Original Text
> -------------
>   |               |                         |                         |
>   | UBJSON        | 61 02 42 01 61 02 42 02 | 61 ff 42 01 61 02 42 02 |
>   |               | 42 03                   | 42 03 45                |
>   |               |                         |                         |
> 
> 
> Corrected Text
> --------------
>   |               |                         |                         |
>   | UBJSON        | 5B 23 55 02 55 01 5B 23 | 5B 55 01 5B 55 02 55 03 |
>   |               | 55 02 55 02 55 03       | 5D 5D                   |
>   |               |                         |                         |
> 
> 
> Notes
> -----
> According to UBJSON type specification available at
> http://ubjson.org/type-reference/ arrays are encoded with square-brackets '[' and ']', or with '[' followed by '#' to specify the element count.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC7049 (draft-bormann-cbor-09)
> --------------------------------------
> Title               : Concise Binary Object Representation (CBOR)
> Publication Date    : October 2013
> Author(s)           : C. Bormann, P. Hoffman
> Category            : PROPOSED STANDARD
> Source              : IETF - NON WORKING GROUP
> Area                : N/A
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Lambert DAVID <[email-masked]>
Date: Mon, 23 Jul 2018 18:52:49 +0200 (CEST)

Hi Carsten,

thank you for the answer.

Effectively, UBJSON seems to have changed recently. The specification history is not present on the official website.

It is difficult to use a specification that can change and do not preserve previous versions of the specification for references.

The UBJSON specification seems to have been modified in 2013 :

2013-01-11  https://web.archive.org/web/20130111190558/http://ubjson.org:80/type-reference/

2013-06-04  https://web.archive.org/web/20130604130935/http://ubjson.org/type-reference/

UBJSON was quite new in 2013 and its specification may have not been mature or not a final version.

I think the specification could have changed because there was no much UBJSON implementations.

But 5 years later in 2018, the UBJSON has not changed since this version.

Changing the UBJSON specification in 2018 would have great impact on existing implementations.

About RFC 8060, as it has been created in 2017, 4 years after the change, we can assume it refers to the new specification.

About CBOR, I found it to be a very good serialization format, comparing it against MessagePack because CBOR encoding is similar for all data types, and allows extending the data types that can be encoded via Tags, with a very wide range for tag numbers.

Best regards,

David

> Message du 22/07/18 19:15
> De : "Carsten Bormann" 
> A : "RFC Errata System" 
> Copie à : "Paul Hoffman" 
, "The IESG" , [email-masked], [email-masked]
> Objet : Re: [Technical Errata Reported] RFC7049 (5434)
> 
> Hi David,
> 
> > On Jul 22, 2018, at 18:16, RFC Errata System  wrote:
> > 
> > Reported by: LAMBERT David 
> > 
> > Section: E.6
> > 
> > Original Text
> > -------------
> > | | | |